Update to 0.4
- Add Epoch to fix versioning.
This commit is contained in:
parent
b6e3b8873b
commit
86e8aa2973
1
.gitignore
vendored
1
.gitignore
vendored
@ -3,3 +3,4 @@
|
|||||||
/nftables-20140426.tar.bz2
|
/nftables-20140426.tar.bz2
|
||||||
/nftables-20140704.tar.bz2
|
/nftables-20140704.tar.bz2
|
||||||
/nftables-20140903.tar.bz2
|
/nftables-20140903.tar.bz2
|
||||||
|
/nftables-0.4.tar.bz2
|
||||||
|
@ -1,53 +0,0 @@
|
|||||||
diff -Nur nftables-20140118.orig/configure nftables-20140118/configure
|
|
||||||
--- nftables-20140118.orig/configure 2014-01-17 22:28:04.000000000 -0700
|
|
||||||
+++ nftables-20140118/configure 2014-01-18 15:42:10.427000000 -0700
|
|
||||||
@@ -3310,8 +3310,8 @@
|
|
||||||
rm -f conftest.sed
|
|
||||||
|
|
||||||
|
|
||||||
-# Extract the first word of "docbook2x-man", so it can be a program name with args.
|
|
||||||
-set dummy docbook2x-man; ac_word=$2
|
|
||||||
+# Extract the first word of "db2x_docbook2man", so it can be a program name with args.
|
|
||||||
+set dummy db2x_docbook2man; ac_word=$2
|
|
||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
|
|
||||||
$as_echo_n "checking for $ac_word... " >&6; }
|
|
||||||
if test "${ac_cv_prog_CONFIG_MAN+set}" = set; then :
|
|
||||||
@@ -3350,8 +3350,8 @@
|
|
||||||
|
|
||||||
if test "$CONFIG_MAN" != "y"
|
|
||||||
then
|
|
||||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: docbookx2-man not found, no manpages will be built" >&5
|
|
||||||
-$as_echo "$as_me: WARNING: docbookx2-man not found, no manpages will be built" >&2;}
|
|
||||||
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: db2x_docbook2man not found, no manpages will be built" >&5
|
|
||||||
+$as_echo "$as_me: WARNING: db2x_docbook2man not found, no manpages will be built" >&2;}
|
|
||||||
fi
|
|
||||||
|
|
||||||
# Extract the first word of "db2pdf", so it can be a program name with args.
|
|
||||||
diff -Nur nftables-20140118.orig/configure.ac nftables-20140118/configure.ac
|
|
||||||
--- nftables-20140118.orig/configure.ac 2014-01-17 22:28:00.000000000 -0700
|
|
||||||
+++ nftables-20140118/configure.ac 2014-01-18 15:42:24.483000000 -0700
|
|
||||||
@@ -25,10 +25,10 @@
|
|
||||||
AC_PROG_INSTALL
|
|
||||||
AC_PROG_SED
|
|
||||||
|
|
||||||
-AC_CHECK_PROG(CONFIG_MAN, docbook2x-man, y, n)
|
|
||||||
+AC_CHECK_PROG(CONFIG_MAN, db2x_docbook2man, y, n)
|
|
||||||
if test "$CONFIG_MAN" != "y"
|
|
||||||
then
|
|
||||||
- AC_MSG_WARN([docbookx2-man not found, no manpages will be built])
|
|
||||||
+ AC_MSG_WARN([db2x_docbook2man not found, no manpages will be built])
|
|
||||||
fi
|
|
||||||
|
|
||||||
AC_CHECK_PROG(CONFIG_PDF, db2pdf, y, n)
|
|
||||||
diff -Nur nftables-20140118.orig/Makefile.rules.in nftables-20140118/Makefile.rules.in
|
|
||||||
--- nftables-20140118.orig/Makefile.rules.in 2014-01-17 22:28:00.000000000 -0700
|
|
||||||
+++ nftables-20140118/Makefile.rules.in 2014-01-18 15:27:45.759000000 -0700
|
|
||||||
@@ -37,7 +37,7 @@
|
|
||||||
|
|
||||||
%.8: %.xml $(makedeps)
|
|
||||||
@echo -e " MAN\t\t$@"
|
|
||||||
- (cd $(SUBDIR); docbook2x-man ../$<)
|
|
||||||
+ (cd $(SUBDIR); db2x_docbook2man ../$<)
|
|
||||||
|
|
||||||
%.pdf: %.xml $(makedeps)
|
|
||||||
@echo -e " PDF\t\t$@"
|
|
@ -1,9 +0,0 @@
|
|||||||
diff -Nur nftables-20140118.orig/Makefile.rules.in nftables-20140118/Makefile.rules.in
|
|
||||||
--- nftables-20140118.orig/Makefile.rules.in 2014-01-17 22:28:00.000000000 -0700
|
|
||||||
+++ nftables-20140118/Makefile.rules.in 2014-01-18 14:43:35.889000000 -0700
|
|
||||||
@@ -93,4 +93,4 @@
|
|
||||||
.PHONY: $(SUBDIRS)
|
|
||||||
$(SUBDIRS):
|
|
||||||
@echo -e " SUBDIR\t$@/"
|
|
||||||
- @$(MAKE) -s -f Makefile.rules $(MAKECMDGOALS) SUBDIR="$@/" SUBDIRS=""
|
|
||||||
+ @$(MAKE) -f Makefile.rules $(MAKECMDGOALS) SUBDIR="$@/" SUBDIRS=""
|
|
@ -1,11 +0,0 @@
|
|||||||
diff -Nur nftables-20140118.orig/doc/nftables.xml nftables-20140118/doc/nftables.xml
|
|
||||||
--- nftables-20140118.orig/doc/nftables.xml 2014-01-17 22:28:00.000000000 -0700
|
|
||||||
+++ nftables-20140118/doc/nftables.xml 2014-01-18 14:42:47.941000000 -0700
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
<?xml version="1.0" encoding="UTF-8" ?>
|
|
||||||
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
|
|
||||||
- "/usr/share/xml/docbook/schema/dtd/4.5/docbookx.dtd">
|
|
||||||
+ "/usr/share/sgml/docbook/xml-dtd-4.5/docbookx.dtd">
|
|
||||||
|
|
||||||
<refentry>
|
|
||||||
<refentryinfo>
|
|
@ -1,23 +1,22 @@
|
|||||||
%global snapdate 20140903
|
#global snapdate 20140903
|
||||||
|
|
||||||
Name: nftables
|
Name: nftables
|
||||||
Version: 0.100
|
Version: 0.4
|
||||||
Release: 4.%{snapdate}git%{?dist}
|
#Release: 0.1.%{snapdate}git%{?dist}
|
||||||
|
Release: 1%{?dist}
|
||||||
|
# Upstream released a 0.100 version, then 0.4. Need Epoch to get back on track.
|
||||||
|
Epoch: 1
|
||||||
Summary: Netfilter Tables userspace utillites
|
Summary: Netfilter Tables userspace utillites
|
||||||
|
|
||||||
License: GPLv2
|
License: GPLv2
|
||||||
URL: http://netfilter.org/projects/nftables/
|
URL: http://netfilter.org/projects/nftables/
|
||||||
Source0: http://ftp.netfilter.org/pub/nftables/snapshot/nftables-%{snapdate}.tar.bz2
|
#Source0: http://ftp.netfilter.org/pub/nftables/snapshot/nftables-%{snapdate}.tar.bz2
|
||||||
|
Source0: http://ftp.netfilter.org/pub/nftables/nftables-%{version}.tar.bz2
|
||||||
|
|
||||||
#
|
#BuildRequires: autogen
|
||||||
# Disable silent make so we can see compiler flags and such
|
#BuildRequires: autoconf
|
||||||
#
|
#BuildRequires: automake
|
||||||
Patch1: nftables-20140118-disable-silent-make.patch
|
#BuildRequires: libtool
|
||||||
|
|
||||||
BuildRequires: autogen
|
|
||||||
BuildRequires: autoconf
|
|
||||||
BuildRequires: automake
|
|
||||||
BuildRequires: libtool
|
|
||||||
BuildRequires: flex
|
BuildRequires: flex
|
||||||
BuildRequires: bison
|
BuildRequires: bison
|
||||||
BuildRequires: libmnl-devel
|
BuildRequires: libmnl-devel
|
||||||
@ -30,13 +29,12 @@ BuildRequires: docbook2X
|
|||||||
Netfilter Tables userspace utilities.
|
Netfilter Tables userspace utilities.
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n nftables-%{snapdate}
|
#setup -q -n nftables-%{snapdate}
|
||||||
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./autogen.sh
|
#./autogen.sh
|
||||||
%configure
|
%configure --disable-silent-rules
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -51,6 +49,10 @@ chmod 644 $RPM_BUILD_ROOT/%{_mandir}/man8/nft*
|
|||||||
%{_mandir}/man8/nft*
|
%{_mandir}/man8/nft*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 26 2014 Kevin Fenzi <kevin@scrye.com> 0.4-1
|
||||||
|
- Update to 0.4
|
||||||
|
- Add Epoch to fix versioning.
|
||||||
|
|
||||||
* Wed Sep 03 2014 Kevin Fenzi <kevin@scrye.com> 0.100-4.20140903git
|
* Wed Sep 03 2014 Kevin Fenzi <kevin@scrye.com> 0.100-4.20140903git
|
||||||
- Update to 20140903 snapshot
|
- Update to 20140903 snapshot
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user