Update to 20140326 snapshot

- Fix permissions on man pages.
This commit is contained in:
Kevin Fenzi 2014-03-26 14:11:00 -06:00
parent 4b64c04757
commit 692351e699
6 changed files with 167 additions and 0 deletions

1
.gitignore vendored
View File

@ -0,0 +1 @@
/nftables-20140326.tar.bz2

View File

@ -0,0 +1,53 @@
diff -Nur nftables-20140118.orig/configure nftables-20140118/configure
--- nftables-20140118.orig/configure 2014-01-17 22:28:04.000000000 -0700
+++ nftables-20140118/configure 2014-01-18 15:42:10.427000000 -0700
@@ -3310,8 +3310,8 @@
rm -f conftest.sed
-# Extract the first word of "docbook2x-man", so it can be a program name with args.
-set dummy docbook2x-man; ac_word=$2
+# Extract the first word of "db2x_docbook2man", so it can be a program name with args.
+set dummy db2x_docbook2man; ac_word=$2
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
$as_echo_n "checking for $ac_word... " >&6; }
if test "${ac_cv_prog_CONFIG_MAN+set}" = set; then :
@@ -3350,8 +3350,8 @@
if test "$CONFIG_MAN" != "y"
then
- { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: docbookx2-man not found, no manpages will be built" >&5
-$as_echo "$as_me: WARNING: docbookx2-man not found, no manpages will be built" >&2;}
+ { $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: db2x_docbook2man not found, no manpages will be built" >&5
+$as_echo "$as_me: WARNING: db2x_docbook2man not found, no manpages will be built" >&2;}
fi
# Extract the first word of "db2pdf", so it can be a program name with args.
diff -Nur nftables-20140118.orig/configure.ac nftables-20140118/configure.ac
--- nftables-20140118.orig/configure.ac 2014-01-17 22:28:00.000000000 -0700
+++ nftables-20140118/configure.ac 2014-01-18 15:42:24.483000000 -0700
@@ -25,10 +25,10 @@
AC_PROG_INSTALL
AC_PROG_SED
-AC_CHECK_PROG(CONFIG_MAN, docbook2x-man, y, n)
+AC_CHECK_PROG(CONFIG_MAN, db2x_docbook2man, y, n)
if test "$CONFIG_MAN" != "y"
then
- AC_MSG_WARN([docbookx2-man not found, no manpages will be built])
+ AC_MSG_WARN([db2x_docbook2man not found, no manpages will be built])
fi
AC_CHECK_PROG(CONFIG_PDF, db2pdf, y, n)
diff -Nur nftables-20140118.orig/Makefile.rules.in nftables-20140118/Makefile.rules.in
--- nftables-20140118.orig/Makefile.rules.in 2014-01-17 22:28:00.000000000 -0700
+++ nftables-20140118/Makefile.rules.in 2014-01-18 15:27:45.759000000 -0700
@@ -37,7 +37,7 @@
%.8: %.xml $(makedeps)
@echo -e " MAN\t\t$@"
- (cd $(SUBDIR); docbook2x-man ../$<)
+ (cd $(SUBDIR); db2x_docbook2man ../$<)
%.pdf: %.xml $(makedeps)
@echo -e " PDF\t\t$@"

View File

@ -0,0 +1,9 @@
diff -Nur nftables-20140118.orig/Makefile.rules.in nftables-20140118/Makefile.rules.in
--- nftables-20140118.orig/Makefile.rules.in 2014-01-17 22:28:00.000000000 -0700
+++ nftables-20140118/Makefile.rules.in 2014-01-18 14:43:35.889000000 -0700
@@ -93,4 +93,4 @@
.PHONY: $(SUBDIRS)
$(SUBDIRS):
@echo -e " SUBDIR\t$@/"
- @$(MAKE) -s -f Makefile.rules $(MAKECMDGOALS) SUBDIR="$@/" SUBDIRS=""
+ @$(MAKE) -f Makefile.rules $(MAKECMDGOALS) SUBDIR="$@/" SUBDIRS=""

View File

@ -0,0 +1,11 @@
diff -Nur nftables-20140118.orig/doc/nftables.xml nftables-20140118/doc/nftables.xml
--- nftables-20140118.orig/doc/nftables.xml 2014-01-17 22:28:00.000000000 -0700
+++ nftables-20140118/doc/nftables.xml 2014-01-18 14:42:47.941000000 -0700
@@ -1,6 +1,6 @@
<?xml version="1.0" encoding="UTF-8" ?>
<!DOCTYPE refentry PUBLIC "-//OASIS//DTD DocBook XML V4.5//EN"
- "/usr/share/xml/docbook/schema/dtd/4.5/docbookx.dtd">
+ "/usr/share/sgml/docbook/xml-dtd-4.5/docbookx.dtd">
<refentry>
<refentryinfo>

92
nftables.spec Normal file
View File

@ -0,0 +1,92 @@
%global snapdate 20140326
Name: nftables
Version: 0
Release: 0.7.%{snapdate}git%{?dist}
Summary: Netfilter Tables userspace utillites
License: GPLv2
URL: http://netfilter.org/projects/nftables/
Source0: http://ftp.netfilter.org/pub/nftables/snapshot/nftables-%{snapdate}.tar.bz2
#
# Disable silent make so we can see compiler flags and such
#
Patch1: nftables-20140118-disable-silent-make.patch
#
# Point to the Fedora provided dtd for docbook to man/pdf conversion.
#
Patch2: nftables-20140118-dtdpath.patch
#
# use the Fedora version of docbook2man
#
Patch3: nftables-20140118-db2x_docbook2man.patch
BuildRequires: autogen
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
BuildRequires: flex
BuildRequires: bison
BuildRequires: libmnl-devel
BuildRequires: gmp-devel
BuildRequires: readline-devel
BuildRequires: libnftnl-devel
BuildRequires: docbook2X
BuildRequires: docbook-dtds
%description
Netfilter Tables userspace utilities.
%prep
%setup -q -n nftables-%{snapdate}
%patch1 -p1
%patch2 -p1
%patch3 -p1
%build
./autogen.sh
%configure
make %{?_smp_mflags}
%install
%make_install
find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
chmod 644 $RPM_BUILD_ROOT/%{_mandir}/man8/nft*
%files
%doc COPYING TODO
%config(noreplace) %{_sysconfdir}/nftables/
%{_sbindir}/nft
%{_mandir}/man8/nft*
%changelog
* Wed Mar 26 2014 Kevin Fenzi <kevin@scrye.com> 0-0.7.20140326git
- Update to 20140326 snapshot
- Fix permissions on man pages.
* Mon Mar 24 2014 Kevin Fenzi <kevin@scrye.com> 0-0.6.20140324git
- Update to 20140324 snapshot
* Fri Mar 07 2014 Kevin Fenzi <kevin@scrye.com> 0-0.5.20140307git
- Update to 20140307
* Sat Jan 25 2014 Kevin Fenzi <kevin@scrye.com> 0-0.4.20140125git
- Update to 20140125 snapshot
* Sat Jan 18 2014 Kevin Fenzi <kevin@scrye.com> 0-0.3.20140118git
- Update to 20140118 snapshot
- Fixed License tag to be correct
- Fixed changelog
- nft scripts now use full path for nft
- Fixed man page building
- Dropped unneeded rm in install
- Patched build to not be silent.
* Tue Dec 03 2013 Kevin Fenzi <kevin@scrye.com> 0-0.2.20131202git
- Use upstream snapshots for source.
- Use 0 for version.
* Sat Nov 30 2013 Kevin Fenzi <kevin@scrye.com> 0-0.1
- initial version for Fedora review

View File

@ -0,0 +1 @@
0b891bb8463e3a12c2e01dc38406d0ee nftables-20140326.tar.bz2