nfs4-acl-tools/nfs4acl-0.2.0-compile.patch
2008-10-29 19:12:56 +00:00

36 lines
1.4 KiB
Diff

diff -up nfs4-acl-tools-0.3.2/configure.ac.orig nfs4-acl-tools-0.3.2/configure.ac
--- nfs4-acl-tools-0.3.2/configure.ac.orig 2007-10-22 15:46:09.000000000 -0400
+++ nfs4-acl-tools-0.3.2/configure.ac 2008-10-29 14:42:02.427246000 -0400
@@ -32,5 +32,6 @@ AC_PACKAGE_NEED_GETXATTR_LIBATTR
AC_MANUAL_FORMAT
AC_FUNC_GCC_VISIBILITY
+AC_DEFINE(HAVE_VISIBILITY_ATTRIBUTE, [], [GCC supports visibility attributes])
AC_OUTPUT(include/builddefs)
diff -up nfs4-acl-tools-0.3.2/include/buildmacros.orig nfs4-acl-tools-0.3.2/include/buildmacros
--- nfs4-acl-tools-0.3.2/include/buildmacros.orig 2007-03-08 13:32:15.000000000 -0500
+++ nfs4-acl-tools-0.3.2/include/buildmacros 2008-10-29 14:42:02.431244000 -0400
@@ -54,7 +54,8 @@ OBJECTS = $(ASFILES:.s=.o) \
$(LFILES:.l=.o) \
$(YFILES:%.y=%.tab.o)
-INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
+#INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
+INSTALL = $(TOPDIR)/install-sh
SHELL = /bin/sh
IMAGES_DIR = $(TOPDIR)/all-images
diff -up nfs4-acl-tools-0.3.2/Makefile.orig nfs4-acl-tools-0.3.2/Makefile
--- nfs4-acl-tools-0.3.2/Makefile.orig 2007-02-27 18:58:58.000000000 -0500
+++ nfs4-acl-tools-0.3.2/Makefile 2008-10-29 14:42:02.413258000 -0400
@@ -46,7 +46,7 @@ LDIRT = config.log .dep config.status co
SUBDIRS = include libnfs4acl nfs4_getfacl nfs4_setfacl man
-default: $(CONFIGURE)
+default:
ifeq ($(HAVE_BUILDDEFS), no)
$(MAKE) -C . $@
else