Updated to the latest upstream release: 0.3.5
Signed-off-by: Steve Dickson <steved@redhat.com>
This commit is contained in:
parent
3179585066
commit
9b2bcd2bf3
6
.gitignore
vendored
6
.gitignore
vendored
@ -1,2 +1,4 @@
|
||||
/nfs4-acl-tools-0.3.4.tar.gz
|
||||
nfs4-acl-tools-0.3.4
|
||||
Makefile
|
||||
x86_64/
|
||||
/nfs4-acl-tools-0.3.5.tar.gz
|
||||
nfs4-acl-tools-0.3.5
|
||||
|
@ -1,48 +1,32 @@
|
||||
Name: nfs4-acl-tools
|
||||
Version: 0.3.4
|
||||
Version: 0.3.5
|
||||
Release: 0%{?dist}
|
||||
Summary: The nfs4 ACL tools
|
||||
Group: Applications/System
|
||||
License: BSD
|
||||
URL: http://www.citi.umich.edu/projects/nfsv4/linux/
|
||||
|
||||
Source0: http://www.citi.umich.edu/projects/nfsv4/linux/nfs4-acl-tools/%{name}-%{version}.tar.gz
|
||||
URL: http://git.linux-nfs.org/?p=bfields/nfs4-acl-tools.git;a=summary
|
||||
Source0: http://linux-nfs.org/~bfields/nfs4-acl-tools/nfs4-acl-tools-%{name}-%{version}.tar.gz
|
||||
|
||||
BuildRequires: libtool
|
||||
BuildRequires: libattr-devel
|
||||
BuildRequires: qt-devel
|
||||
|
||||
Patch100: nfs4acl-0.2.0-compile.patch
|
||||
|
||||
%description
|
||||
This package contains commandline and GUI ACL utilities for the Linux
|
||||
This package contains commandline ACL utilities for the Linux
|
||||
NFSv4 client.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch100 -p1
|
||||
|
||||
%build
|
||||
%ifarch s390 s390x sparc
|
||||
PIE="-fPIE"
|
||||
%else
|
||||
PIE="-fpie"
|
||||
%endif
|
||||
CFLAGS="`echo $RPM_OPT_FLAGS $PIE`"
|
||||
export LDFLAGS="-pie"
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
%configure \
|
||||
CFLAGS="%{build_cflags} -D_FILE_OFFSET_BITS=64" \
|
||||
LDFLAGS="%{build_ldflags}"
|
||||
|
||||
pushd GUI/nfs4-acl-editor
|
||||
%{qmake_qt4} nfs4-acl-editor.pro
|
||||
make %{?_smp_mflags}
|
||||
popd
|
||||
%make_build
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make DESTDIR=%{buildroot} install
|
||||
install -m 0755 GUI/nfs4-acl-editor/nfs4-acl-editor %{buildroot}/usr/bin/nfs4-acl-editor
|
||||
|
||||
%files
|
||||
%doc COPYING INSTALL README TODO VERSION
|
||||
@ -52,16 +36,10 @@ install -m 0755 GUI/nfs4-acl-editor/nfs4-acl-editor %{buildroot}/usr/bin/nfs4-ac
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man5/*
|
||||
|
||||
%package gui
|
||||
Summary: The nfs4 ACL editing GUI
|
||||
|
||||
%description gui
|
||||
This package contains GUI ACL utilities for the Linux NFSv4 client.
|
||||
|
||||
%files gui
|
||||
%{_bindir}/nfs4-acl-editor
|
||||
|
||||
%changelog
|
||||
* Sat Oct 6 2018 Steve Dickson <steved@redhat.com> - 0.3.5-0
|
||||
- Updated to the latest upstream release: 0.3.5
|
||||
|
||||
* Sat Aug 4 2018 Steve Dickson <steved@redhat.com> - 0.3.4-0
|
||||
- Updated to latest upstream release: 0.3.4
|
||||
|
||||
|
@ -1,35 +0,0 @@
|
||||
diff -up nfs4-acl-tools-0.3.2/configure.ac.orig nfs4-acl-tools-0.3.2/configure.ac
|
||||
--- nfs4-acl-tools-0.3.2/configure.ac.orig 2007-10-22 15:46:09.000000000 -0400
|
||||
+++ nfs4-acl-tools-0.3.2/configure.ac 2008-10-29 14:42:02.427246000 -0400
|
||||
@@ -32,5 +32,6 @@ AC_PACKAGE_NEED_GETXATTR_LIBATTR
|
||||
AC_MANUAL_FORMAT
|
||||
|
||||
AC_FUNC_GCC_VISIBILITY
|
||||
+AC_DEFINE(HAVE_VISIBILITY_ATTRIBUTE, [], [GCC supports visibility attributes])
|
||||
|
||||
AC_OUTPUT(include/builddefs)
|
||||
diff -up nfs4-acl-tools-0.3.2/include/buildmacros.orig nfs4-acl-tools-0.3.2/include/buildmacros
|
||||
--- nfs4-acl-tools-0.3.2/include/buildmacros.orig 2007-03-08 13:32:15.000000000 -0500
|
||||
+++ nfs4-acl-tools-0.3.2/include/buildmacros 2008-10-29 14:42:02.431244000 -0400
|
||||
@@ -54,7 +54,8 @@ OBJECTS = $(ASFILES:.s=.o) \
|
||||
$(LFILES:.l=.o) \
|
||||
$(YFILES:%.y=%.tab.o)
|
||||
|
||||
-INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
|
||||
+#INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
|
||||
+INSTALL = $(TOPDIR)/install-sh
|
||||
|
||||
SHELL = /bin/sh
|
||||
IMAGES_DIR = $(TOPDIR)/all-images
|
||||
diff -up nfs4-acl-tools-0.3.2/Makefile.orig nfs4-acl-tools-0.3.2/Makefile
|
||||
--- nfs4-acl-tools-0.3.2/Makefile.orig 2007-02-27 18:58:58.000000000 -0500
|
||||
+++ nfs4-acl-tools-0.3.2/Makefile 2008-10-29 14:42:02.413258000 -0400
|
||||
@@ -46,7 +46,7 @@ LDIRT = config.log .dep config.status co
|
||||
|
||||
SUBDIRS = include libnfs4acl nfs4_getfacl nfs4_setfacl man
|
||||
|
||||
-default: $(CONFIGURE)
|
||||
+default:
|
||||
ifeq ($(HAVE_BUILDDEFS), no)
|
||||
$(MAKE) -C . $@
|
||||
else
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (nfs4-acl-tools-0.3.4.tar.gz) = 4727c930249c32ae310b5d25784792b29611f546c6636e708aab4a4b175ca7af985232d27380dcc59d8b6e322ef8805d3add10eb90e598530249bfa93dd91246
|
||||
SHA512 (nfs4-acl-tools-0.3.5.tar.gz) = c23d5c5c676c03cbb8016de32e384086525df6f181c85b36331f42b9bab023ab5158c4e01096f837da5d59c64d8a247cc7e92c9d37bd6bb38fc2aed960705618
|
||||
|
Loading…
Reference in New Issue
Block a user