inital commit
This commit is contained in:
parent
65b850a2fc
commit
56598c5d17
@ -0,0 +1 @@
|
||||
nfs4-acl-tools-0.3.1.tar.gz
|
133
nfs4-acl-tools-0.3.0-destdir.patch
Normal file
133
nfs4-acl-tools-0.3.0-destdir.patch
Normal file
@ -0,0 +1,133 @@
|
||||
--- nfs4-acl-tools/man/man1/Makefile.destdir 2007-03-06 13:24:31.000000000 -0600
|
||||
+++ nfs4-acl-tools/man/man1/Makefile 2007-03-06 13:25:58.000000000 -0600
|
||||
@@ -36,7 +36,7 @@
|
||||
MAN_SECTION = 1
|
||||
|
||||
MAN_PAGES = $(shell echo *.$(MAN_SECTION))
|
||||
-MAN_DEST = $(PKG_MAN_DIR)/man$(MAN_SECTION)
|
||||
+MAN_DEST = $(DESTDIR)$(PKG_MAN_DIR)/man$(MAN_SECTION)
|
||||
LSRCFILES = $(MAN_PAGES)
|
||||
|
||||
default : $(MAN_PAGES)
|
||||
--- nfs4-acl-tools/man/man5/Makefile.destdir 2007-03-06 13:26:32.000000000 -0600
|
||||
+++ nfs4-acl-tools/man/man5/Makefile 2007-03-06 13:26:20.000000000 -0600
|
||||
@@ -36,7 +36,7 @@
|
||||
MAN_SECTION = 5
|
||||
|
||||
MAN_PAGES = $(shell echo *.$(MAN_SECTION))
|
||||
-MAN_DEST = $(PKG_MAN_DIR)/man$(MAN_SECTION)
|
||||
+MAN_DEST = $(DESTDIR)$(PKG_MAN_DIR)/man$(MAN_SECTION)
|
||||
LSRCFILES = $(MAN_PAGES)
|
||||
|
||||
default : $(MAN_PAGES)
|
||||
--- nfs4-acl-tools/nfs4_setfacl/Makefile.destdir 2007-02-27 14:32:46.000000000 -0600
|
||||
+++ nfs4-acl-tools/nfs4_setfacl/Makefile 2007-03-06 13:22:58.000000000 -0600
|
||||
@@ -44,12 +44,12 @@
|
||||
include $(BUILDRULES)
|
||||
|
||||
install: default
|
||||
- $(INSTALL) -m 755 -d $(PKG_BIN_DIR)
|
||||
- $(LTINSTALL) -m 755 $(LTCOMMAND) $(PKG_BIN_DIR)
|
||||
- if [ -f $(PKG_BIN_DIR)/nfs4_editfacl ]; then \
|
||||
+ $(INSTALL) -m 755 -d $(DESTDIR)$(PKG_BIN_DIR)
|
||||
+ $(LTINSTALL) -m 755 $(LTCOMMAND) $(DESTDIR)$(PKG_BIN_DIR)
|
||||
+ if [ -f $(DESTDIR)$(PKG_BIN_DIR)/nfs4_editfacl ]; then \
|
||||
: ; \
|
||||
else \
|
||||
- ln -s $(PKG_BIN_DIR)/nfs4_setfacl $(PKG_BIN_DIR)/nfs4_editfacl ; \
|
||||
+ ln -s nfs4_setfacl $(DESTDIR)$(PKG_BIN_DIR)/nfs4_editfacl ; \
|
||||
fi
|
||||
|
||||
install-dev install-lib:
|
||||
--- nfs4-acl-tools/nfs4_getfacl/Makefile.destdir 2006-08-21 12:05:23.000000000 -0500
|
||||
+++ nfs4-acl-tools/nfs4_getfacl/Makefile 2007-03-06 13:22:58.000000000 -0600
|
||||
@@ -45,7 +45,7 @@
|
||||
include $(BUILDRULES)
|
||||
|
||||
install: default
|
||||
- $(INSTALL) -m 755 -d $(PKG_BIN_DIR)
|
||||
- $(LTINSTALL) -m 755 $(LTCOMMAND) $(PKG_BIN_DIR)
|
||||
+ $(INSTALL) -m 755 -d $(DESTDIR)$(PKG_BIN_DIR)
|
||||
+ $(LTINSTALL) -m 755 $(LTCOMMAND) $(DESTDIR)$(PKG_BIN_DIR)
|
||||
|
||||
install-dev install-lib:
|
||||
--- nfs4-acl-tools/include/builddefs.destdir 2007-02-27 23:49:27.000000000 -0600
|
||||
+++ nfs4-acl-tools/include/builddefs 2007-03-06 13:23:02.000000000 -0600
|
||||
@@ -45,6 +45,8 @@
|
||||
prefix = /usr/local
|
||||
exec_prefix = ${prefix}
|
||||
|
||||
+DESTDIR =
|
||||
+
|
||||
PKG_NAME = nfs4acl
|
||||
PKG_USER = root
|
||||
PKG_GROUP = root
|
||||
--- nfs4-acl-tools/include/builddefs.in.destdir 2006-10-24 15:26:13.000000000 -0500
|
||||
+++ nfs4-acl-tools/include/builddefs.in 2007-03-06 13:22:58.000000000 -0600
|
||||
@@ -45,6 +45,8 @@
|
||||
prefix = @prefix@
|
||||
exec_prefix = @exec_prefix@
|
||||
|
||||
+DESTDIR =
|
||||
+
|
||||
PKG_NAME = @pkg_name@
|
||||
PKG_USER = @pkg_user@
|
||||
PKG_GROUP = @pkg_group@
|
||||
--- nfs4-acl-tools/include/buildmacros.destdir 2007-03-06 13:22:58.000000000 -0600
|
||||
+++ nfs4-acl-tools/include/buildmacros 2007-03-06 13:25:10.000000000 -0600
|
||||
@@ -83,10 +83,10 @@
|
||||
ifeq ($(ENABLE_SHARED),yes)
|
||||
INSTALL_LTLIB = \
|
||||
cd $(TOPDIR)/$(LIBNAME)/.libs; \
|
||||
- ../$(INSTALL) -m 755 -d $(PKG_LIB_DIR); \
|
||||
- ../$(INSTALL) -m 644 -T so_dot_version $(LIBNAME).lai $(PKG_LIB_DIR); \
|
||||
+ ../$(INSTALL) -m 755 -d $(DESTDIR)$(PKG_LIB_DIR); \
|
||||
+ ../$(INSTALL) -m 644 -T so_dot_version $(LIBNAME).lai $(DESTDIR)$(PKG_LIB_DIR); \
|
||||
test "$(PKG_DISTRIBUTION)" = debian || \
|
||||
- ../$(INSTALL) -T so_dot_current $(LIBNAME).lai $(PKG_LIB_DIR)
|
||||
+ ../$(INSTALL) -T so_dot_current $(LIBNAME).lai $(DESTDIR)$(PKG_LIB_DIR)
|
||||
endif
|
||||
|
||||
# Libtool thinks the static and shared libs should be in the same dir, so
|
||||
@@ -98,22 +98,22 @@
|
||||
ifeq ($(ENABLE_SHARED),yes)
|
||||
INSTALL_LTLIB_DEV = \
|
||||
cd $(TOPDIR)/$(LIBNAME)/.libs; \
|
||||
- ../$(INSTALL) -m 755 -d $(PKG_DEVLIB_DIR); \
|
||||
- ../$(INSTALL) -m 644 -T old_lib $(LIBNAME).lai $(PKG_DEVLIB_DIR); \
|
||||
- ../$(INSTALL) -m 644 $(LIBNAME).lai $(PKG_DEVLIB_DIR)/$(LIBNAME).la ; \
|
||||
- ../$(INSTALL) -m 755 -d $(PKG_LIB_DIR); \
|
||||
- ../$(INSTALL) -T so_base $(LIBNAME).lai $(PKG_LIB_DIR); \
|
||||
- ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).a $(PKG_LIB_DIR)/$(LIBNAME).a; \
|
||||
- ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).la $(PKG_LIB_DIR)/$(LIBNAME).la; \
|
||||
- ../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).so $(PKG_DEVLIB_DIR)/$(LIBNAME).so
|
||||
+ ../$(INSTALL) -m 755 -d $(DESTDIR)$(PKG_DEVLIB_DIR); \
|
||||
+ ../$(INSTALL) -m 644 -T old_lib $(LIBNAME).lai $(DESTDIR)$(PKG_DEVLIB_DIR); \
|
||||
+ ../$(INSTALL) -m 644 $(LIBNAME).lai $(DESTDIR)$(PKG_DEVLIB_DIR)/$(LIBNAME).la ; \
|
||||
+ ../$(INSTALL) -m 755 -d $(DESTDIR)$(PKG_LIB_DIR); \
|
||||
+ ../$(INSTALL) -T so_base $(LIBNAME).lai $(DESTDIR)$(PKG_LIB_DIR); \
|
||||
+ ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).a $(DESTDIR)$(PKG_LIB_DIR)/$(LIBNAME).a; \
|
||||
+ ../$(INSTALL) -S $(PKG_DEVLIB_DIR)/$(LIBNAME).la $(DESTDIR)$(PKG_LIB_DIR)/$(LIBNAME).la; \
|
||||
+ ../$(INSTALL) -S $(PKG_LIB_DIR)/$(LIBNAME).so $(DESTDIR)$(PKG_DEVLIB_DIR)/$(LIBNAME).so
|
||||
else
|
||||
INSTALL_LTLIB_DEV = $(INSTALL_LTLIB_STATIC)
|
||||
endif
|
||||
|
||||
INSTALL_LTLIB_STATIC = \
|
||||
cd $(TOPDIR)/$(LIBNAME)/.libs; \
|
||||
- ../$(INSTALL) -m 755 -d $(PKG_DEVLIB_DIR); \
|
||||
- ../$(INSTALL) -m 644 -T old_lib $(LIBNAME).lai $(PKG_DEVLIB_DIR)
|
||||
+ ../$(INSTALL) -m 755 -d $(DESTDIR)$(PKG_DEVLIB_DIR); \
|
||||
+ ../$(INSTALL) -m 644 -T old_lib $(LIBNAME).lai $(DESTDIR)$(PKG_DEVLIB_DIR)
|
||||
|
||||
INSTALL_MAN = \
|
||||
@for d in $(MAN_PAGES); do \
|
||||
@@ -145,7 +145,7 @@
|
||||
INSTALL_LINGUAS = \
|
||||
@for l in $(LINGUAS) ""; do \
|
||||
if test -f "$$l.mo" ; then \
|
||||
- ldir=$(PKG_LOCALE_DIR)/$$l/LC_MESSAGES; \
|
||||
+ ldir=$(DESTDIR)$(PKG_LOCALE_DIR)/$$l/LC_MESSAGES; \
|
||||
$(INSTALL) -m 755 -d $$ldir; \
|
||||
$(INSTALL) -m 644 $$l.mo $$ldir/$(PKG_NAME).mo; \
|
||||
fi; \
|
11
nfs4-acl-tools-0.3.0-usepassedLDFLAGS.patch
Normal file
11
nfs4-acl-tools-0.3.0-usepassedLDFLAGS.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- nfs4-acl-tools/include/buildmacros.BAD 2007-03-06 14:30:22.000000000 -0600
|
||||
+++ nfs4-acl-tools/include/buildmacros 2007-03-06 14:30:27.000000000 -0600
|
||||
@@ -37,7 +37,7 @@
|
||||
# $(CXXFILES), or $(HFILES) and is used to construct the manifest list
|
||||
# during the "dist" phase (packaging).
|
||||
|
||||
-LDFLAGS = $(LLDFLAGS)
|
||||
+LDFLAGS += $(LLDFLAGS)
|
||||
LDLIBS = $(LLDLIBS) $(PLDLIBS) $(MALLOCLIB)
|
||||
|
||||
MAKEOPTS = --no-print-directory
|
75
nfs4-acl-tools.spec
Normal file
75
nfs4-acl-tools.spec
Normal file
@ -0,0 +1,75 @@
|
||||
Name: nfs4-acl-tools
|
||||
Version: 0.3.1
|
||||
Release: 1%{?dist}.2
|
||||
Summary: The nfs4 ACL tools
|
||||
Group: System Environment/Tools
|
||||
License: BSD
|
||||
URL: http://www.citi.umich.edu/projects/nfsv4/linux/
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root-%(%{__id_u} -n)
|
||||
Source0: http://www.citi.umich.edu/projects/nfsv4/linux/nfs4-acl-tools/%{name}-%{version}.tar.gz
|
||||
|
||||
BuildRequires: libtool
|
||||
BuildRequires: libattr-devel
|
||||
|
||||
Patch100: nfs4acl-0.2.0-compile.patch
|
||||
|
||||
%description
|
||||
This package contains commandline and GUI ACL utilities for the Linux
|
||||
NFSv4 client.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%patch100 -p1
|
||||
|
||||
%build
|
||||
%ifarch s390 s390x sparc
|
||||
PIE="-fPIE"
|
||||
%else
|
||||
PIE="-fpie"
|
||||
%endif
|
||||
CFLAGS="`echo $RPM_OPT_FLAGS $PIE`"
|
||||
export LDFLAGS="-pie"
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
rm -rf %{buildroot}
|
||||
make DESTDIR=%{buildroot} install
|
||||
|
||||
%clean
|
||||
rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc CHANGELOG COPYING INSTALL README TODO VERSION
|
||||
%{_bindir}/nfs4_editfacl
|
||||
%{_bindir}/nfs4_getfacl
|
||||
%{_bindir}/nfs4_setfacl
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man5/*
|
||||
|
||||
%changelog
|
||||
* Tue Mar 27 2007 Steve Dickson <steved@redhat.com> - 0.3.1-1.2
|
||||
- Checked in to Fedora CVS
|
||||
|
||||
* Thu Mar 8 2007 Steve Dickson <steved@redhat.com> - 0.3.1-1.1
|
||||
- Updated to latest upstream version 0.3.1 which eliminated the
|
||||
need for the patches introduced in the previous commit.
|
||||
|
||||
* Tue Mar 6 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.3.0-1.1
|
||||
- lose the BR for autotools
|
||||
- Patch in support for destdir
|
||||
- use %%configure macro, make DESTDIR= install
|
||||
- add sparc to -fPIE (trivial, but correct)
|
||||
- destdir revealed missing/poorly created symlink, patch fixes it, add nfs4_editfacl to files
|
||||
- LDFLAGS passed to configure/exported were being blindly overwritten, patch fixes
|
||||
|
||||
* Fri Mar 2 2007 Steve Dickson <steved@redhat.com> - 0.3.0-1
|
||||
- Updated to latest upstream version 0.3.0
|
||||
- Fixed minor issues in spec file from the package review
|
||||
|
||||
* Fri Feb 16 2007 Steve Dickson <steved@redhat.com> - 0.2.0-1
|
||||
- Initial commit
|
32
nfs4acl-0.2.0-compile.patch
Normal file
32
nfs4acl-0.2.0-compile.patch
Normal file
@ -0,0 +1,32 @@
|
||||
--- nfs4-acl-tools/Makefile.orig 2006-10-24 17:52:48.000000000 -0400
|
||||
+++ nfs4-acl-tools/Makefile 2007-02-16 14:33:09.000000000 -0500
|
||||
@@ -46,7 +46,7 @@ LDIRT = config.log .dep config.status co
|
||||
|
||||
SUBDIRS = include libnfs4acl nfs4_getfacl nfs4_setfacl
|
||||
|
||||
-default: $(CONFIGURE)
|
||||
+default:
|
||||
ifeq ($(HAVE_BUILDDEFS), no)
|
||||
$(MAKE) -C . $@
|
||||
else
|
||||
--- nfs4-acl-tools/configure.ac.orig 2006-10-25 13:34:00.000000000 -0400
|
||||
+++ nfs4-acl-tools/configure.ac 2007-02-16 14:33:09.000000000 -0500
|
||||
@@ -32,5 +32,6 @@ AC_PACKAGE_NEED_GETXATTR_LIBATTR
|
||||
AC_MANUAL_FORMAT
|
||||
|
||||
AC_FUNC_GCC_VISIBILITY
|
||||
+AC_DEFINE(HAVE_VISIBILITY_ATTRIBUTE, [], [GCC supports visibility attributes])
|
||||
|
||||
AC_OUTPUT(include/builddefs)
|
||||
--- nfs4-acl-tools/include/buildmacros.orig 2006-08-21 13:05:23.000000000 -0400
|
||||
+++ nfs4-acl-tools/include/buildmacros 2007-02-16 14:35:40.000000000 -0500
|
||||
@@ -54,7 +54,8 @@ OBJECTS = $(ASFILES:.s=.o) \
|
||||
$(LFILES:.l=.o) \
|
||||
$(YFILES:%.y=%.tab.o)
|
||||
|
||||
-INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
|
||||
+#INSTALL = $(TOPDIR)/install-sh -o $(PKG_USER) -g $(PKG_GROUP)
|
||||
+INSTALL = $(TOPDIR)/install-sh
|
||||
|
||||
SHELL = /bin/sh
|
||||
IMAGES_DIR = $(TOPDIR)/all-images
|
Loading…
Reference in New Issue
Block a user