Updated to the latest pseudo root release (rel8).
This commit is contained in:
parent
c1ec542e87
commit
e9aa86337b
@ -1,6 +1,6 @@
|
|||||||
diff -up nfs-utils-1.2.0/support/export/xtab.c.save nfs-utils-1.2.0/support/export/xtab.c
|
diff -up nfs-utils-1.2.1/support/export/xtab.c.orig nfs-utils-1.2.1/support/export/xtab.c
|
||||||
--- nfs-utils-1.2.0/support/export/xtab.c.save 2009-10-20 08:46:50.000000000 -0400
|
--- nfs-utils-1.2.1/support/export/xtab.c.orig 2009-11-04 06:13:56.000000000 -0500
|
||||||
+++ nfs-utils-1.2.0/support/export/xtab.c 2009-10-20 08:47:26.000000000 -0400
|
+++ nfs-utils-1.2.1/support/export/xtab.c 2009-11-11 14:01:56.370963000 -0500
|
||||||
@@ -19,7 +19,9 @@
|
@@ -19,7 +19,9 @@
|
||||||
#include "exportfs.h"
|
#include "exportfs.h"
|
||||||
#include "xio.h"
|
#include "xio.h"
|
||||||
@ -29,9 +29,9 @@ diff -up nfs-utils-1.2.0/support/export/xtab.c.save nfs-utils-1.2.0/support/expo
|
|||||||
break;
|
break;
|
||||||
case 2:
|
case 2:
|
||||||
exp->m_exported = -1;/* may be exported */
|
exp->m_exported = -1;/* may be exported */
|
||||||
diff -up nfs-utils-1.2.0/support/include/exportfs.h.save nfs-utils-1.2.0/support/include/exportfs.h
|
diff -up nfs-utils-1.2.1/support/include/exportfs.h.orig nfs-utils-1.2.1/support/include/exportfs.h
|
||||||
--- nfs-utils-1.2.0/support/include/exportfs.h.save 2009-10-20 08:46:50.000000000 -0400
|
--- nfs-utils-1.2.1/support/include/exportfs.h.orig 2009-11-04 06:13:56.000000000 -0500
|
||||||
+++ nfs-utils-1.2.0/support/include/exportfs.h 2009-10-20 08:47:07.000000000 -0400
|
+++ nfs-utils-1.2.1/support/include/exportfs.h 2009-11-11 14:01:56.377960000 -0500
|
||||||
@@ -12,6 +12,17 @@
|
@@ -12,6 +12,17 @@
|
||||||
#include <netdb.h>
|
#include <netdb.h>
|
||||||
#include "nfslib.h"
|
#include "nfslib.h"
|
||||||
@ -50,9 +50,9 @@ diff -up nfs-utils-1.2.0/support/include/exportfs.h.save nfs-utils-1.2.0/support
|
|||||||
enum {
|
enum {
|
||||||
MCL_FQDN = 0,
|
MCL_FQDN = 0,
|
||||||
MCL_SUBNETWORK,
|
MCL_SUBNETWORK,
|
||||||
diff -up nfs-utils-1.2.0/support/include/nfs/export.h.save nfs-utils-1.2.0/support/include/nfs/export.h
|
diff -up nfs-utils-1.2.1/support/include/nfs/export.h.orig nfs-utils-1.2.1/support/include/nfs/export.h
|
||||||
--- nfs-utils-1.2.0/support/include/nfs/export.h.save 2009-10-20 08:46:50.000000000 -0400
|
--- nfs-utils-1.2.1/support/include/nfs/export.h.orig 2009-11-04 06:13:56.000000000 -0500
|
||||||
+++ nfs-utils-1.2.0/support/include/nfs/export.h 2009-10-20 08:47:07.000000000 -0400
|
+++ nfs-utils-1.2.1/support/include/nfs/export.h 2009-11-11 14:01:56.383967000 -0500
|
||||||
@@ -24,6 +24,7 @@
|
@@ -24,6 +24,7 @@
|
||||||
#define NFSEXP_FSID 0x2000
|
#define NFSEXP_FSID 0x2000
|
||||||
#define NFSEXP_CROSSMOUNT 0x4000
|
#define NFSEXP_CROSSMOUNT 0x4000
|
||||||
@ -62,9 +62,9 @@ diff -up nfs-utils-1.2.0/support/include/nfs/export.h.save nfs-utils-1.2.0/suppo
|
|||||||
+#define NFSEXP_ALLFLAGS 0x1FFFF
|
+#define NFSEXP_ALLFLAGS 0x1FFFF
|
||||||
|
|
||||||
#endif /* _NSF_EXPORT_H */
|
#endif /* _NSF_EXPORT_H */
|
||||||
diff -up nfs-utils-1.2.0/support/include/nfslib.h.save nfs-utils-1.2.0/support/include/nfslib.h
|
diff -up nfs-utils-1.2.1/support/include/nfslib.h.orig nfs-utils-1.2.1/support/include/nfslib.h
|
||||||
--- nfs-utils-1.2.0/support/include/nfslib.h.save 2009-10-20 08:46:50.000000000 -0400
|
--- nfs-utils-1.2.1/support/include/nfslib.h.orig 2009-11-04 06:13:56.000000000 -0500
|
||||||
+++ nfs-utils-1.2.0/support/include/nfslib.h 2009-10-20 08:47:07.000000000 -0400
|
+++ nfs-utils-1.2.1/support/include/nfslib.h 2009-11-11 14:01:56.390963000 -0500
|
||||||
@@ -88,6 +88,7 @@ struct exportent {
|
@@ -88,6 +88,7 @@ struct exportent {
|
||||||
int e_fslocmethod;
|
int e_fslocmethod;
|
||||||
char * e_fslocdata;
|
char * e_fslocdata;
|
||||||
@ -73,9 +73,9 @@ diff -up nfs-utils-1.2.0/support/include/nfslib.h.save nfs-utils-1.2.0/support/i
|
|||||||
struct sec_entry e_secinfo[SECFLAVOR_COUNT+1];
|
struct sec_entry e_secinfo[SECFLAVOR_COUNT+1];
|
||||||
};
|
};
|
||||||
|
|
||||||
diff -up /dev/null nfs-utils-1.2.0/support/include/v4root.h
|
diff -up /dev/null nfs-utils-1.2.1/support/include/v4root.h
|
||||||
--- /dev/null 2009-10-15 16:13:05.251004788 -0400
|
--- /dev/null 2009-11-11 11:00:17.075766506 -0500
|
||||||
+++ nfs-utils-1.2.0/support/include/v4root.h 2009-10-20 08:47:16.000000000 -0400
|
+++ nfs-utils-1.2.1/support/include/v4root.h 2009-11-11 14:01:56.399965000 -0500
|
||||||
@@ -0,0 +1,20 @@
|
@@ -0,0 +1,20 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Copyright (C) 2009 Red Hat <nfs@redhat.com>
|
+ * Copyright (C) 2009 Red Hat <nfs@redhat.com>
|
||||||
@ -97,9 +97,9 @@ diff -up /dev/null nfs-utils-1.2.0/support/include/v4root.h
|
|||||||
+extern void v4root_unset(void), v4root_set(void);
|
+extern void v4root_unset(void), v4root_set(void);
|
||||||
+
|
+
|
||||||
+#endif /* V4ROOT_H */
|
+#endif /* V4ROOT_H */
|
||||||
diff -up nfs-utils-1.2.0/utils/mountd/auth.c.save nfs-utils-1.2.0/utils/mountd/auth.c
|
diff -up nfs-utils-1.2.1/utils/mountd/auth.c.orig nfs-utils-1.2.1/utils/mountd/auth.c
|
||||||
--- nfs-utils-1.2.0/utils/mountd/auth.c.save 2009-10-20 08:46:50.000000000 -0400
|
--- nfs-utils-1.2.1/utils/mountd/auth.c.orig 2009-11-04 06:13:56.000000000 -0500
|
||||||
+++ nfs-utils-1.2.0/utils/mountd/auth.c 2009-10-20 08:47:26.000000000 -0400
|
+++ nfs-utils-1.2.1/utils/mountd/auth.c 2009-11-11 14:01:56.405963000 -0500
|
||||||
@@ -20,6 +20,7 @@
|
@@ -20,6 +20,7 @@
|
||||||
#include "exportfs.h"
|
#include "exportfs.h"
|
||||||
#include "mountd.h"
|
#include "mountd.h"
|
||||||
@ -122,9 +122,9 @@ diff -up nfs-utils-1.2.0/utils/mountd/auth.c.save nfs-utils-1.2.0/utils/mountd/a
|
|||||||
++counter;
|
++counter;
|
||||||
|
|
||||||
return counter;
|
return counter;
|
||||||
diff -up nfs-utils-1.2.0/utils/mountd/cache.c.save nfs-utils-1.2.0/utils/mountd/cache.c
|
diff -up nfs-utils-1.2.1/utils/mountd/cache.c.orig nfs-utils-1.2.1/utils/mountd/cache.c
|
||||||
--- nfs-utils-1.2.0/utils/mountd/cache.c.save 2009-10-20 08:46:50.000000000 -0400
|
--- nfs-utils-1.2.1/utils/mountd/cache.c.orig 2009-11-04 06:13:56.000000000 -0500
|
||||||
+++ nfs-utils-1.2.0/utils/mountd/cache.c 2009-10-20 08:47:21.000000000 -0400
|
+++ nfs-utils-1.2.1/utils/mountd/cache.c 2009-11-11 14:01:56.414960000 -0500
|
||||||
@@ -32,23 +32,12 @@
|
@@ -32,23 +32,12 @@
|
||||||
#include "xmalloc.h"
|
#include "xmalloc.h"
|
||||||
#include "fsloc.h"
|
#include "fsloc.h"
|
||||||
@ -267,9 +267,9 @@ diff -up nfs-utils-1.2.0/utils/mountd/cache.c.save nfs-utils-1.2.0/utils/mountd/
|
|||||||
}
|
}
|
||||||
}
|
}
|
||||||
|
|
||||||
diff -up nfs-utils-1.2.0/utils/mountd/Makefile.am.save nfs-utils-1.2.0/utils/mountd/Makefile.am
|
diff -up nfs-utils-1.2.1/utils/mountd/Makefile.am.orig nfs-utils-1.2.1/utils/mountd/Makefile.am
|
||||||
--- nfs-utils-1.2.0/utils/mountd/Makefile.am.save 2009-10-20 08:46:50.000000000 -0400
|
--- nfs-utils-1.2.1/utils/mountd/Makefile.am.orig 2009-11-04 06:13:56.000000000 -0500
|
||||||
+++ nfs-utils-1.2.0/utils/mountd/Makefile.am 2009-10-20 08:47:16.000000000 -0400
|
+++ nfs-utils-1.2.1/utils/mountd/Makefile.am 2009-11-11 14:01:56.421960000 -0500
|
||||||
@@ -8,7 +8,7 @@ KPREFIX = @kprefix@
|
@@ -8,7 +8,7 @@ KPREFIX = @kprefix@
|
||||||
sbin_PROGRAMS = mountd
|
sbin_PROGRAMS = mountd
|
||||||
|
|
||||||
@ -279,10 +279,10 @@ diff -up nfs-utils-1.2.0/utils/mountd/Makefile.am.save nfs-utils-1.2.0/utils/mou
|
|||||||
mountd_LDADD = ../../support/export/libexport.a \
|
mountd_LDADD = ../../support/export/libexport.a \
|
||||||
../../support/nfs/libnfs.a \
|
../../support/nfs/libnfs.a \
|
||||||
../../support/misc/libmisc.a \
|
../../support/misc/libmisc.a \
|
||||||
diff -up /dev/null nfs-utils-1.2.0/utils/mountd/v4root.c
|
diff -up /dev/null nfs-utils-1.2.1/utils/mountd/v4root.c
|
||||||
--- /dev/null 2009-10-15 16:13:05.251004788 -0400
|
--- /dev/null 2009-11-11 11:00:17.075766506 -0500
|
||||||
+++ nfs-utils-1.2.0/utils/mountd/v4root.c 2009-10-20 08:47:33.000000000 -0400
|
+++ nfs-utils-1.2.1/utils/mountd/v4root.c 2009-11-11 14:02:39.699100000 -0500
|
||||||
@@ -0,0 +1,414 @@
|
@@ -0,0 +1,432 @@
|
||||||
+/*
|
+/*
|
||||||
+ * Copyright (C) 2009 Red Hat <nfs@redhat.com>
|
+ * Copyright (C) 2009 Red Hat <nfs@redhat.com>
|
||||||
+ *
|
+ *
|
||||||
@ -459,7 +459,8 @@ diff -up /dev/null nfs-utils-1.2.0/utils/mountd/v4root.c
|
|||||||
+v4root_set()
|
+v4root_set()
|
||||||
+{
|
+{
|
||||||
+ nfs_export *exp, *nxt;
|
+ nfs_export *exp, *nxt;
|
||||||
+ int i;
|
+ struct exportent *proot;
|
||||||
|
+ int i, insecure = 0;
|
||||||
+ char *path, *ptr;
|
+ char *path, *ptr;
|
||||||
+ char *hostname;
|
+ char *hostname;
|
||||||
+
|
+
|
||||||
@ -470,6 +471,12 @@ diff -up /dev/null nfs-utils-1.2.0/utils/mountd/v4root.c
|
|||||||
+ return;
|
+ return;
|
||||||
+
|
+
|
||||||
+ pseudo_root = &pr_export;
|
+ pseudo_root = &pr_export;
|
||||||
|
+ if ((proot = v4root_create(_PATH_PSEUDO_ROOT, pseudo_root)) == NULL) {
|
||||||
|
+ xlog(L_WARNING, "v4root_set: Unable to create"
|
||||||
|
+ "pseudo export for '%s'", _PATH_PSEUDO_ROOT);
|
||||||
|
+ pseudo_root = NULL;
|
||||||
|
+ return;
|
||||||
|
+ }
|
||||||
+
|
+
|
||||||
+ for (i = 0; i < MCL_MAXTYPES; i++) {
|
+ for (i = 0; i < MCL_MAXTYPES; i++) {
|
||||||
+ for (exp = exportlist[i].p_head; exp; exp = nxt) {
|
+ for (exp = exportlist[i].p_head; exp; exp = nxt) {
|
||||||
@ -489,10 +496,21 @@ diff -up /dev/null nfs-utils-1.2.0/utils/mountd/v4root.c
|
|||||||
+ *ptr = '/';
|
+ *ptr = '/';
|
||||||
+ ptr++;
|
+ ptr++;
|
||||||
+ }
|
+ }
|
||||||
|
+ /* Make note of insecure exports */
|
||||||
|
+ if (!insecure)
|
||||||
|
+ insecure = (exp->m_export.e_flags & NFSEXP_INSECURE_PORT);
|
||||||
+
|
+
|
||||||
+ free(path);
|
+ free(path);
|
||||||
+ }
|
+ }
|
||||||
+ }
|
+ }
|
||||||
|
+ /*
|
||||||
|
+ * If there are any insecure exports, the pseudo root
|
||||||
|
+ * also has to be insecure
|
||||||
|
+ */
|
||||||
|
+ if (insecure) {
|
||||||
|
+ pseudo_root->m_export.e_flags |= NFSEXP_INSECURE_PORT;
|
||||||
|
+ proot->e_flags |= NFSEXP_INSECURE_PORT;
|
||||||
|
+ }
|
||||||
+}
|
+}
|
||||||
+
|
+
|
||||||
+/*
|
+/*
|
@ -2,7 +2,7 @@ Summary: NFS utilities and supporting clients and daemons for the kernel NFS ser
|
|||||||
Name: nfs-utils
|
Name: nfs-utils
|
||||||
URL: http://sourceforge.net/projects/nfs
|
URL: http://sourceforge.net/projects/nfs
|
||||||
Version: 1.2.1
|
Version: 1.2.1
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
# group all 32bit related archs
|
# group all 32bit related archs
|
||||||
@ -22,7 +22,7 @@ Patch00: nfs-utils-1.0.5-statdpath.patch
|
|||||||
Patch01: nfs-utils-1.1.0-smnotify-path.patch
|
Patch01: nfs-utils-1.1.0-smnotify-path.patch
|
||||||
Patch02: nfs-utils-1.1.0-exp-subtree-warn-off.patch
|
Patch02: nfs-utils-1.1.0-exp-subtree-warn-off.patch
|
||||||
|
|
||||||
Patch200: nfs-utils-1.2.0-v4root-rel7.patch
|
Patch200: nfs-utils-1.2.0-v4root-rel8.patch
|
||||||
|
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
Provides: exportfs = %{epoch}:%{version}-%{release}
|
Provides: exportfs = %{epoch}:%{version}-%{release}
|
||||||
@ -246,6 +246,9 @@ fi
|
|||||||
%attr(4755,root,root) /sbin/umount.nfs4
|
%attr(4755,root,root) /sbin/umount.nfs4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 11 2009 Steve Dickson <steved@redhat.com> 1.2.1-2
|
||||||
|
- Updated to the latest pseudo root release (rel8).
|
||||||
|
|
||||||
* Wed Nov 4 2009 Steve Dickson <steved@redhat.com> 1.2.1-1
|
* Wed Nov 4 2009 Steve Dickson <steved@redhat.com> 1.2.1-1
|
||||||
- Updated to latest upstream release: 1.2.0
|
- Updated to latest upstream release: 1.2.0
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user