Fixed typo in nfs man page (bz 210864)
This commit is contained in:
parent
264f0b36ba
commit
e6e33fa3aa
@ -1,6 +1,6 @@
|
|||||||
--- nfs-utils-1.0.9/utils/mount/nfs4mount.c.orig 2006-07-07 20:04:32.000000000 -0400
|
--- nfs-utils-1.0.9/utils/mount/nfs4mount.c.orig 2006-10-16 08:32:53.789617000 -0400
|
||||||
+++ nfs-utils-1.0.9/utils/mount/nfs4mount.c 2006-07-28 13:08:10.000000000 -0400
|
+++ nfs-utils-1.0.9/utils/mount/nfs4mount.c 2006-10-16 08:33:53.098133000 -0400
|
||||||
@@ -200,7 +200,7 @@ int nfs4mount(const char *spec, const ch
|
@@ -201,7 +201,7 @@ int nfs4mount(const char *spec, const ch
|
||||||
char *s;
|
char *s;
|
||||||
int val;
|
int val;
|
||||||
int bg, soft, intr;
|
int bg, soft, intr;
|
||||||
@ -9,7 +9,7 @@
|
|||||||
int retry;
|
int retry;
|
||||||
int retval;
|
int retval;
|
||||||
time_t timeout, t;
|
time_t timeout, t;
|
||||||
@@ -251,6 +251,7 @@ int nfs4mount(const char *spec, const ch
|
@@ -252,6 +252,7 @@ int nfs4mount(const char *spec, const ch
|
||||||
intr = NFS4_MOUNT_INTR;
|
intr = NFS4_MOUNT_INTR;
|
||||||
nocto = 0;
|
nocto = 0;
|
||||||
noac = 0;
|
noac = 0;
|
||||||
@ -17,7 +17,7 @@
|
|||||||
retry = 10000; /* 10000 minutes ~ 1 week */
|
retry = 10000; /* 10000 minutes ~ 1 week */
|
||||||
|
|
||||||
/*
|
/*
|
||||||
@@ -331,6 +332,8 @@ int nfs4mount(const char *spec, const ch
|
@@ -332,6 +333,8 @@ int nfs4mount(const char *spec, const ch
|
||||||
soft = !val;
|
soft = !val;
|
||||||
else if (!strcmp(opt, "intr"))
|
else if (!strcmp(opt, "intr"))
|
||||||
intr = val;
|
intr = val;
|
||||||
@ -26,7 +26,7 @@
|
|||||||
else if (!strcmp(opt, "cto"))
|
else if (!strcmp(opt, "cto"))
|
||||||
nocto = !val;
|
nocto = !val;
|
||||||
else if (!strcmp(opt, "ac"))
|
else if (!strcmp(opt, "ac"))
|
||||||
@@ -346,7 +349,8 @@ int nfs4mount(const char *spec, const ch
|
@@ -347,7 +350,8 @@ int nfs4mount(const char *spec, const ch
|
||||||
data.flags = (soft ? NFS4_MOUNT_SOFT : 0)
|
data.flags = (soft ? NFS4_MOUNT_SOFT : 0)
|
||||||
| (intr ? NFS4_MOUNT_INTR : 0)
|
| (intr ? NFS4_MOUNT_INTR : 0)
|
||||||
| (nocto ? NFS4_MOUNT_NOCTO : 0)
|
| (nocto ? NFS4_MOUNT_NOCTO : 0)
|
||||||
@ -36,8 +36,8 @@
|
|||||||
|
|
||||||
/*
|
/*
|
||||||
* Give a warning if the rpc.idmapd daemon is not running
|
* Give a warning if the rpc.idmapd daemon is not running
|
||||||
--- nfs-utils-1.0.9/utils/mount/nfs_mount.h.orig 2006-07-28 12:52:43.000000000 -0400
|
--- nfs-utils-1.0.9/utils/mount/nfs_mount.h.orig 2006-10-16 08:32:53.763643000 -0400
|
||||||
+++ nfs-utils-1.0.9/utils/mount/nfs_mount.h 2006-07-28 12:58:07.000000000 -0400
|
+++ nfs-utils-1.0.9/utils/mount/nfs_mount.h 2006-10-16 08:33:53.113133000 -0400
|
||||||
@@ -63,6 +63,7 @@ struct nfs_mount_data {
|
@@ -63,6 +63,7 @@ struct nfs_mount_data {
|
||||||
#define NFS_MOUNT_BROKEN_SUID 0x0400 /* 4 */
|
#define NFS_MOUNT_BROKEN_SUID 0x0400 /* 4 */
|
||||||
#define NFS_MOUNT_NOACL 0x0800 /* 4 */
|
#define NFS_MOUNT_NOACL 0x0800 /* 4 */
|
||||||
@ -46,9 +46,9 @@
|
|||||||
|
|
||||||
/* security pseudoflavors */
|
/* security pseudoflavors */
|
||||||
|
|
||||||
--- nfs-utils-1.0.9/utils/mount/nfsmount.c.orig 2006-07-28 13:02:55.000000000 -0400
|
--- nfs-utils-1.0.9/utils/mount/nfsmount.c.orig 2006-10-16 08:32:53.853553000 -0400
|
||||||
+++ nfs-utils-1.0.9/utils/mount/nfsmount.c 2006-07-28 13:03:11.000000000 -0400
|
+++ nfs-utils-1.0.9/utils/mount/nfsmount.c 2006-10-16 08:33:53.128133000 -0400
|
||||||
@@ -694,6 +694,10 @@ parse_options(char *old_opts, struct nfs
|
@@ -695,6 +695,10 @@ parse_options(char *old_opts, struct nfs
|
||||||
data->flags &= ~NFS_MOUNT_SOFT;
|
data->flags &= ~NFS_MOUNT_SOFT;
|
||||||
if (val)
|
if (val)
|
||||||
data->flags |= NFS_MOUNT_SOFT;
|
data->flags |= NFS_MOUNT_SOFT;
|
||||||
@ -60,7 +60,7 @@
|
|||||||
data->flags &= ~NFS_MOUNT_SOFT;
|
data->flags &= ~NFS_MOUNT_SOFT;
|
||||||
if (!val)
|
if (!val)
|
||||||
--- nfs-utils-1.0.9/utils/mount/nfs4_mount.h.orig 2006-07-07 20:04:32.000000000 -0400
|
--- nfs-utils-1.0.9/utils/mount/nfs4_mount.h.orig 2006-07-07 20:04:32.000000000 -0400
|
||||||
+++ nfs-utils-1.0.9/utils/mount/nfs4_mount.h 2006-07-28 13:07:27.000000000 -0400
|
+++ nfs-utils-1.0.9/utils/mount/nfs4_mount.h 2006-10-16 08:33:53.143133000 -0400
|
||||||
@@ -65,6 +65,7 @@ struct nfs4_mount_data {
|
@@ -65,6 +65,7 @@ struct nfs4_mount_data {
|
||||||
#define NFS4_MOUNT_NOCTO 0x0010 /* 1 */
|
#define NFS4_MOUNT_NOCTO 0x0010 /* 1 */
|
||||||
#define NFS4_MOUNT_NOAC 0x0020 /* 1 */
|
#define NFS4_MOUNT_NOAC 0x0020 /* 1 */
|
||||||
@ -69,3 +69,27 @@
|
|||||||
#define NFS4_MOUNT_FLAGMASK 0xFFFF
|
#define NFS4_MOUNT_FLAGMASK 0xFFFF
|
||||||
|
|
||||||
/* pseudoflavors: */
|
/* pseudoflavors: */
|
||||||
|
--- nfs-utils-1.0.9/utils/mount/nfs.man.orig 2006-10-16 08:32:53.825581000 -0400
|
||||||
|
+++ nfs-utils-1.0.9/utils/mount/nfs.man 2006-10-16 08:36:39.503163000 -0400
|
||||||
|
@@ -272,6 +272,10 @@ default UDP protocol. Many NFS servers
|
||||||
|
.I udp
|
||||||
|
Mount the NFS filesystem using the UDP protocol. This
|
||||||
|
is the default.
|
||||||
|
+.TP 1.5i
|
||||||
|
+.I fsc
|
||||||
|
+Enable the use of persistent caching to the local disk using
|
||||||
|
+the FS-Cache facility for the given mount point.
|
||||||
|
.P
|
||||||
|
All of the non-value options have corresponding nooption forms.
|
||||||
|
For example, nointr means don't allow file operations to be
|
||||||
|
@@ -428,6 +432,10 @@ This extracts a
|
||||||
|
server performance penalty but it allows two different NFS clients
|
||||||
|
to get reasonable good results when both clients are actively
|
||||||
|
writing to common filesystem on the server.
|
||||||
|
+.TP 1.5i
|
||||||
|
+.I fsc
|
||||||
|
+Enable the use of persistent caching to the local disk using
|
||||||
|
+the FS-Cache facility for the given mount point.
|
||||||
|
.P
|
||||||
|
All of the non-value options have corresponding nooption forms.
|
||||||
|
For example, nointr means don't allow file operations to be
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- nfs-utils-1.0.9/utils/mount/nfs.man.kzak 2006-09-20 13:47:50.000000000 +0200
|
--- /dev/null 2006-10-11 11:03:58.566320005 -0400
|
||||||
+++ nfs-utils-1.0.9/utils/mount/nfs.man 2006-09-20 13:47:50.000000000 +0200
|
+++ nfs-utils-1.0.9/utils/mount/nfs.man 2006-10-16 08:31:02.204578000 -0400
|
||||||
@@ -0,0 +1,464 @@
|
@@ -0,0 +1,456 @@
|
||||||
+.\" nfs.5 "Rick Sladkey" <jrs@world.std.com>
|
+.\" nfs.5 "Rick Sladkey" <jrs@world.std.com>
|
||||||
+.\" Wed Feb 8 12:52:42 1995, faith@cs.unc.edu: updates for Ross Biro's
|
+.\" Wed Feb 8 12:52:42 1995, faith@cs.unc.edu: updates for Ross Biro's
|
||||||
+.\" patches. "
|
+.\" patches. "
|
||||||
@ -275,10 +275,6 @@
|
|||||||
+.I udp
|
+.I udp
|
||||||
+Mount the NFS filesystem using the UDP protocol. This
|
+Mount the NFS filesystem using the UDP protocol. This
|
||||||
+is the default.
|
+is the default.
|
||||||
+.TP 1.5i
|
|
||||||
+.I fsc
|
|
||||||
+Unable the use of persistent caching to the local disk using
|
|
||||||
+the FS-Cache facility for the given mount point.
|
|
||||||
+.P
|
+.P
|
||||||
+All of the non-value options have corresponding nooption forms.
|
+All of the non-value options have corresponding nooption forms.
|
||||||
+For example, nointr means don't allow file operations to be
|
+For example, nointr means don't allow file operations to be
|
||||||
@ -435,10 +431,6 @@
|
|||||||
+server performance penalty but it allows two different NFS clients
|
+server performance penalty but it allows two different NFS clients
|
||||||
+to get reasonable good results when both clients are actively
|
+to get reasonable good results when both clients are actively
|
||||||
+writing to common filesystem on the server.
|
+writing to common filesystem on the server.
|
||||||
+.TP 1.5i
|
|
||||||
+.I fsc
|
|
||||||
+Unable the use of persistent caching to the local disk using
|
|
||||||
+the FS-Cache facility for the given mount point.
|
|
||||||
+.P
|
+.P
|
||||||
+All of the non-value options have corresponding nooption forms.
|
+All of the non-value options have corresponding nooption forms.
|
||||||
+For example, nointr means don't allow file operations to be
|
+For example, nointr means don't allow file operations to be
|
||||||
@ -465,8 +457,8 @@
|
|||||||
+.BR ioctl
|
+.BR ioctl
|
||||||
+families of functions) may lead to inconsistent result due to the lack of
|
+families of functions) may lead to inconsistent result due to the lack of
|
||||||
+consistency check in kernel even if noac is used.
|
+consistency check in kernel even if noac is used.
|
||||||
--- nfs-utils-1.0.9/utils/mount/Makefile.am.kzak 2006-09-20 13:47:57.000000000 +0200
|
--- nfs-utils-1.0.9/utils/mount/Makefile.am.orig 2006-10-16 08:29:34.790243000 -0400
|
||||||
+++ nfs-utils-1.0.9/utils/mount/Makefile.am 2006-09-20 13:51:36.000000000 +0200
|
+++ nfs-utils-1.0.9/utils/mount/Makefile.am 2006-10-16 08:30:32.594308000 -0400
|
||||||
@@ -1,9 +1,10 @@
|
@@ -1,9 +1,10 @@
|
||||||
## Process this file with automake to produce Makefile.in
|
## Process this file with automake to produce Makefile.in
|
||||||
|
|
||||||
@ -479,7 +471,7 @@
|
|||||||
mount_nfs_SOURCES = mount.c nfsmount.c nfs4mount.c nfsumount.c \
|
mount_nfs_SOURCES = mount.c nfsmount.c nfs4mount.c nfsumount.c \
|
||||||
mount_constants.h nfs4_mount.h nfs_mount4.h
|
mount_constants.h nfs4_mount.h nfs_mount4.h
|
||||||
|
|
||||||
@@ -29,6 +30,11 @@
|
@@ -29,6 +30,11 @@ install-man-links:
|
||||||
inst=`echo $$m | sed -e 's/man$$/8/'`; \
|
inst=`echo $$m | sed -e 's/man$$/8/'`; \
|
||||||
rm -f $$inst ; \
|
rm -f $$inst ; \
|
||||||
done)
|
done)
|
||||||
@ -491,7 +483,7 @@
|
|||||||
|
|
||||||
uninstall-man-links:
|
uninstall-man-links:
|
||||||
(cd $(DESTDIR)$(man8dir) && \
|
(cd $(DESTDIR)$(man8dir) && \
|
||||||
@@ -36,4 +42,9 @@
|
@@ -36,4 +42,9 @@ uninstall-man-links:
|
||||||
inst=`echo $$m | sed -e 's/man$$/8/'`; \
|
inst=`echo $$m | sed -e 's/man$$/8/'`; \
|
||||||
rm -f $$inst ; \
|
rm -f $$inst ; \
|
||||||
done)
|
done)
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: NFS utlilities and supporting clients and daemons for the kernel NFS server.
|
Summary: NFS utlilities and supporting clients and daemons for the kernel NFS server.
|
||||||
Name: nfs-utils
|
Name: nfs-utils
|
||||||
Version: 1.0.9
|
Version: 1.0.9
|
||||||
Release: 9%{?dist}
|
Release: 10%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
# group all 32bit related archs
|
# group all 32bit related archs
|
||||||
@ -12,6 +12,10 @@ Epoch: 1
|
|||||||
# both NFS and NFS4 filesystems.
|
# both NFS and NFS4 filesystems.
|
||||||
%define enablemount 1
|
%define enablemount 1
|
||||||
|
|
||||||
|
# Enable the ability to set the 'fsc' mount flag which
|
||||||
|
# will allow NFS to use FS-Cache.
|
||||||
|
%define enablefscache 1
|
||||||
|
|
||||||
Source0: http://www.kernel.org/pub/linux/utils/nfs/nfs-utils-1.0.9.tar.bz2
|
Source0: http://www.kernel.org/pub/linux/utils/nfs/nfs-utils-1.0.9.tar.bz2
|
||||||
Source1: ftp://nfs.sourceforge.net/pub/nfs/nfs.doc.tar.gz
|
Source1: ftp://nfs.sourceforge.net/pub/nfs/nfs.doc.tar.gz
|
||||||
|
|
||||||
@ -26,14 +30,21 @@ Patch51: nfs-utils-1.0.6-mountd.patch
|
|||||||
Patch52: nfs-utils-1.0.6-idmap.conf.patch
|
Patch52: nfs-utils-1.0.6-idmap.conf.patch
|
||||||
Patch53: nfs-utils-1.0.6-gssd_mixed_case.patch
|
Patch53: nfs-utils-1.0.6-gssd_mixed_case.patch
|
||||||
Patch54: nfs-utils-1.0.8-privports.patch
|
Patch54: nfs-utils-1.0.8-privports.patch
|
||||||
Patch55: nfs-utils-1.0.9-mount-options-v3.patch
|
Patch55: nfs-utils-1.0.9-krb5-memory.patch
|
||||||
Patch56: nfs-utils-1.0.9-lazy-umount.patch
|
|
||||||
Patch57: nfs-utils-1.0.9-mount-fsc.patch
|
%if %{enablemount}
|
||||||
Patch58: nfs-utils-1.0.9-krb5-memory.patch
|
Patch70: nfs-utils-1.0.9-mount-options-v3.patch
|
||||||
Patch59: nfs-utils-1.0.9-mount-sloppy.patch
|
Patch71: nfs-utils-1.0.9-lazy-umount.patch
|
||||||
Patch60: nfs-utils-1.0.9-mount-man-nfs.patch
|
Patch72: nfs-utils-1.0.9-mount-sloppy.patch
|
||||||
Patch61: nfs-utils-1.0.9-return-mount-error.patch
|
Patch73: nfs-utils-1.0.9-mount-man-nfs.patch
|
||||||
Patch62: nfs-utils-1.0.9-nfsmount-authnone.patch
|
Patch74: nfs-utils-1.0.9-return-mount-error.patch
|
||||||
|
Patch75: nfs-utils-1.0.9-nfsmount-authnone.patch
|
||||||
|
|
||||||
|
%if %{enablefscache}
|
||||||
|
Patch90: nfs-utils-1.0.9-mount-fsc.patch
|
||||||
|
%endif
|
||||||
|
|
||||||
|
%endif
|
||||||
|
|
||||||
Patch100: nfs-utils-1.0.9-compile.patch
|
Patch100: nfs-utils-1.0.9-compile.patch
|
||||||
|
|
||||||
@ -81,13 +92,17 @@ This package also contains the mount.nfs and umount.nfs program.
|
|||||||
%patch53 -p1
|
%patch53 -p1
|
||||||
%patch54 -p1
|
%patch54 -p1
|
||||||
%patch55 -p1
|
%patch55 -p1
|
||||||
%patch56 -p1
|
%if %{enablemount}
|
||||||
%patch57 -p1
|
%patch70 -p1
|
||||||
%patch58 -p1
|
%patch71 -p1
|
||||||
%patch59 -p1
|
%patch72 -p1
|
||||||
%patch60 -p1
|
%patch73 -p1
|
||||||
%patch61 -p1
|
%patch74 -p1
|
||||||
%patch62 -p1
|
%patch75 -p1
|
||||||
|
%if %{enablefscache}
|
||||||
|
%patch90 -p1
|
||||||
|
%endif
|
||||||
|
%endif
|
||||||
|
|
||||||
# Do the magic to get things to compile
|
# Do the magic to get things to compile
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
@ -261,6 +276,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 16 2006 Steve Dickson <steved@redhat.com> 1.0.9-10
|
||||||
|
- Fixed typo in nfs man page (bz 210864).
|
||||||
|
|
||||||
* Fri Oct 13 2006 Steve Dickson <steved@redhat.com> 1.0.9-9
|
* Fri Oct 13 2006 Steve Dickson <steved@redhat.com> 1.0.9-9
|
||||||
- Unable to mount NFS V3 share where sec=none is specified (bz 210644)
|
- Unable to mount NFS V3 share where sec=none is specified (bz 210644)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user