Updated to the latest RC release: nfs-utils-2-6-3-rc2 (bz 2126545)
Signed-off-by: Steve Dickson <steved@redhat.com>
This commit is contained in:
parent
dd16fad70d
commit
d068404e96
174
nfs-utils.2.6.3-rc2.patch
Normal file
174
nfs-utils.2.6.3-rc2.patch
Normal file
@ -0,0 +1,174 @@
|
|||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index f1c46c5..5d9cbf3 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -249,6 +249,16 @@ AC_ARG_ENABLE(nfsdcld,
|
||||||
|
enable_nfsdcld=$enableval,
|
||||||
|
enable_nfsdcld="yes")
|
||||||
|
|
||||||
|
+AC_ARG_ENABLE(nfsrahead,
|
||||||
|
+ [AS_HELP_STRING([--disable-nfsrahead],[disable nfsrahead command @<:@default=no@:>@])],
|
||||||
|
+ enable_nfsrahead=$enableval,
|
||||||
|
+ enable_nfsrahead="yes")
|
||||||
|
+ AM_CONDITIONAL(CONFIG_NFSRAHEAD, [test "$enable_nfsrahead" = "yes" ])
|
||||||
|
+ if test "$enable_nfsrahead" = yes; then
|
||||||
|
+ dnl Check for -lmount
|
||||||
|
+ PKG_CHECK_MODULES([LIBMOUNT], [mount])
|
||||||
|
+ fi
|
||||||
|
+
|
||||||
|
AC_ARG_ENABLE(nfsdcltrack,
|
||||||
|
[AS_HELP_STRING([--disable-nfsdcltrack],[disable NFSv4 clientid tracking programs @<:@default=no@:>@])],
|
||||||
|
enable_nfsdcltrack=$enableval,
|
||||||
|
diff --git a/support/export/auth.c b/support/export/auth.c
|
||||||
|
index 03ce4b8..2d7960f 100644
|
||||||
|
--- a/support/export/auth.c
|
||||||
|
+++ b/support/export/auth.c
|
||||||
|
@@ -82,7 +82,7 @@ check_useipaddr(void)
|
||||||
|
}
|
||||||
|
|
||||||
|
unsigned int
|
||||||
|
-auth_reload()
|
||||||
|
+auth_reload(void)
|
||||||
|
{
|
||||||
|
struct stat stb;
|
||||||
|
static ino_t last_inode;
|
||||||
|
diff --git a/support/export/v4clients.c b/support/export/v4clients.c
|
||||||
|
index 5f15b61..3230251 100644
|
||||||
|
--- a/support/export/v4clients.c
|
||||||
|
+++ b/support/export/v4clients.c
|
||||||
|
@@ -26,7 +26,7 @@ void v4clients_init(void)
|
||||||
|
{
|
||||||
|
struct stat sb;
|
||||||
|
|
||||||
|
- if (!stat("/proc/fs/nfsd/clients", &sb) == 0 ||
|
||||||
|
+ if (stat("/proc/fs/nfsd/clients", &sb) != 0 ||
|
||||||
|
!S_ISDIR(sb.st_mode))
|
||||||
|
return;
|
||||||
|
if (clients_fd >= 0)
|
||||||
|
diff --git a/support/export/v4root.c b/support/export/v4root.c
|
||||||
|
index c12a7d8..fbb0ad5 100644
|
||||||
|
--- a/support/export/v4root.c
|
||||||
|
+++ b/support/export/v4root.c
|
||||||
|
@@ -198,7 +198,7 @@ static int v4root_add_parents(nfs_export *exp)
|
||||||
|
* looking for components of the v4 mount.
|
||||||
|
*/
|
||||||
|
void
|
||||||
|
-v4root_set()
|
||||||
|
+v4root_set(void)
|
||||||
|
{
|
||||||
|
nfs_export *exp;
|
||||||
|
int i;
|
||||||
|
diff --git a/support/export/xtab.c b/support/export/xtab.c
|
||||||
|
index c888a80..e210ca9 100644
|
||||||
|
--- a/support/export/xtab.c
|
||||||
|
+++ b/support/export/xtab.c
|
||||||
|
@@ -135,7 +135,7 @@ xtab_write(char *xtab, char *xtabtmp, char *lockfn, int is_export)
|
||||||
|
}
|
||||||
|
|
||||||
|
int
|
||||||
|
-xtab_export_write()
|
||||||
|
+xtab_export_write(void)
|
||||||
|
{
|
||||||
|
return xtab_write(etab.statefn, etab.tmpfn, etab.lockfn, 1);
|
||||||
|
}
|
||||||
|
diff --git a/support/nfsidmap/regex.c b/support/nfsidmap/regex.c
|
||||||
|
index 958b4ac..8424179 100644
|
||||||
|
--- a/support/nfsidmap/regex.c
|
||||||
|
+++ b/support/nfsidmap/regex.c
|
||||||
|
@@ -542,7 +542,7 @@ struct trans_func regex_trans = {
|
||||||
|
.gss_princ_to_grouplist = regex_gss_princ_to_grouplist,
|
||||||
|
};
|
||||||
|
|
||||||
|
-struct trans_func *libnfsidmap_plugin_init()
|
||||||
|
+struct trans_func *libnfsidmap_plugin_init(void)
|
||||||
|
{
|
||||||
|
return (®ex_trans);
|
||||||
|
}
|
||||||
|
diff --git a/tools/Makefile.am b/tools/Makefile.am
|
||||||
|
index 40c17c3..48fd0cd 100644
|
||||||
|
--- a/tools/Makefile.am
|
||||||
|
+++ b/tools/Makefile.am
|
||||||
|
@@ -12,6 +12,10 @@ if CONFIG_NFSDCLD
|
||||||
|
OPTDIRS += nfsdclddb
|
||||||
|
endif
|
||||||
|
|
||||||
|
-SUBDIRS = locktest rpcdebug nlmtest mountstats nfs-iostat rpcctl nfsdclnts nfsrahead $(OPTDIRS)
|
||||||
|
+if CONFIG_NFSRAHEAD
|
||||||
|
+OPTDIRS += nfsrahead
|
||||||
|
+endif
|
||||||
|
+
|
||||||
|
+SUBDIRS = locktest rpcdebug nlmtest mountstats nfs-iostat rpcctl nfsdclnts $(OPTDIRS)
|
||||||
|
|
||||||
|
MAINTAINERCLEANFILES = Makefile.in
|
||||||
|
diff --git a/tools/nfsrahead/Makefile.am b/tools/nfsrahead/Makefile.am
|
||||||
|
index 845ea0d..7e08233 100644
|
||||||
|
--- a/tools/nfsrahead/Makefile.am
|
||||||
|
+++ b/tools/nfsrahead/Makefile.am
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
libexec_PROGRAMS = nfsrahead
|
||||||
|
nfsrahead_SOURCES = main.c
|
||||||
|
-nfsrahead_LDFLAGS= -lmount
|
||||||
|
+nfsrahead_LDFLAGS= $(LIBMOUNT_LIBS)
|
||||||
|
nfsrahead_LDADD = ../../support/nfs/libnfsconf.la
|
||||||
|
|
||||||
|
man5_MANS = nfsrahead.man
|
||||||
|
diff --git a/utils/blkmapd/device-discovery.c b/utils/blkmapd/device-discovery.c
|
||||||
|
index 2736ac8..49935c2 100644
|
||||||
|
--- a/utils/blkmapd/device-discovery.c
|
||||||
|
+++ b/utils/blkmapd/device-discovery.c
|
||||||
|
@@ -462,7 +462,7 @@ static void sig_die(int signal)
|
||||||
|
unlink(PID_FILE);
|
||||||
|
}
|
||||||
|
BL_LOG_ERR("exit on signal(%d)\n", signal);
|
||||||
|
- exit(1);
|
||||||
|
+ exit(0);
|
||||||
|
}
|
||||||
|
static void usage(void)
|
||||||
|
{
|
||||||
|
diff --git a/utils/exportfs/exportfs.c b/utils/exportfs/exportfs.c
|
||||||
|
index 6ba615d..0897b22 100644
|
||||||
|
--- a/utils/exportfs/exportfs.c
|
||||||
|
+++ b/utils/exportfs/exportfs.c
|
||||||
|
@@ -69,14 +69,14 @@ static int _lockfd = -1;
|
||||||
|
* need these additional lockfile() routines.
|
||||||
|
*/
|
||||||
|
static void
|
||||||
|
-grab_lockfile()
|
||||||
|
+grab_lockfile(void)
|
||||||
|
{
|
||||||
|
_lockfd = open(lockfile, O_CREAT|O_RDWR, 0666);
|
||||||
|
if (_lockfd != -1)
|
||||||
|
lockf(_lockfd, F_LOCK, 0);
|
||||||
|
}
|
||||||
|
static void
|
||||||
|
-release_lockfile()
|
||||||
|
+release_lockfile(void)
|
||||||
|
{
|
||||||
|
if (_lockfd != -1) {
|
||||||
|
lockf(_lockfd, F_ULOCK, 0);
|
||||||
|
diff --git a/utils/idmapd/idmapd.c b/utils/idmapd/idmapd.c
|
||||||
|
index e79c124..cd9a965 100644
|
||||||
|
--- a/utils/idmapd/idmapd.c
|
||||||
|
+++ b/utils/idmapd/idmapd.c
|
||||||
|
@@ -867,7 +867,7 @@ nfsdreopen_one(struct idmap_client *ic)
|
||||||
|
}
|
||||||
|
|
||||||
|
static void
|
||||||
|
-nfsdreopen()
|
||||||
|
+nfsdreopen(void)
|
||||||
|
{
|
||||||
|
nfsdreopen_one(&nfsd_ic[IC_NAMEID]);
|
||||||
|
nfsdreopen_one(&nfsd_ic[IC_IDNAME]);
|
||||||
|
diff --git a/utils/mount/network.c b/utils/mount/network.c
|
||||||
|
index ed2f825..01ead49 100644
|
||||||
|
--- a/utils/mount/network.c
|
||||||
|
+++ b/utils/mount/network.c
|
||||||
|
@@ -179,7 +179,7 @@ static const unsigned long probe_mnt3_only[] = {
|
||||||
|
|
||||||
|
static const unsigned int *nfs_default_proto(void);
|
||||||
|
#ifdef MOUNT_CONFIG
|
||||||
|
-static const unsigned int *nfs_default_proto()
|
||||||
|
+static const unsigned int *nfs_default_proto(void)
|
||||||
|
{
|
||||||
|
extern unsigned long config_default_proto;
|
||||||
|
/*
|
@ -2,7 +2,7 @@ Summary: NFS utilities and supporting clients and daemons for the kernel NFS ser
|
|||||||
Name: nfs-utils
|
Name: nfs-utils
|
||||||
URL: http://linux-nfs.org/
|
URL: http://linux-nfs.org/
|
||||||
Version: 2.6.2
|
Version: 2.6.2
|
||||||
Release: 1%{?dist}
|
Release: 1.rc2%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
# group all 32bit related archs
|
# group all 32bit related archs
|
||||||
@ -14,6 +14,8 @@ Source2: lockd.conf
|
|||||||
Source3: 24-nfs-server.conf
|
Source3: 24-nfs-server.conf
|
||||||
Source4: 10-nfsv4.conf
|
Source4: 10-nfsv4.conf
|
||||||
|
|
||||||
|
Patch001: nfs-utils.2.6.3-rc2.patch
|
||||||
|
|
||||||
Patch100: nfs-utils-1.2.1-statdpath-man.patch
|
Patch100: nfs-utils-1.2.1-statdpath-man.patch
|
||||||
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
|
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
|
||||||
Patch102: nfs-utils-1.2.5-idmap-errmsg.patch
|
Patch102: nfs-utils-1.2.5-idmap-errmsg.patch
|
||||||
@ -451,6 +453,9 @@ fi
|
|||||||
%{_mandir}/*/nfsiostat.8.gz
|
%{_mandir}/*/nfsiostat.8.gz
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 27 2022 Steve Dickson <steved@redhat.com> 2.6.2-1.rc2
|
||||||
|
- Updated to the latest RC release: nfs-utils-2-6-3-rc2 (bz 2126545)
|
||||||
|
|
||||||
* Tue Aug 23 2022 Steve Dickson <steved@redhat.com> 2.6.2-1
|
* Tue Aug 23 2022 Steve Dickson <steved@redhat.com> 2.6.2-1
|
||||||
- Removed the nfsconvert scripts, no longer needed.
|
- Removed the nfsconvert scripts, no longer needed.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user