- Update to upstream RC release: nfs-utils-1.2.6-rc1
- Added named.service to After list in nfs-server.service (bz 742746) Signed-off-by: Steve Dickson <steved@redhat.com>
This commit is contained in:
parent
09c97ac38f
commit
b6a5bfc39f
@ -1,7 +1,7 @@
|
||||
[Unit]
|
||||
Description=NFS Server
|
||||
Requires=proc-fs-nfsd.mount
|
||||
After=network.target rpcbind.service proc-fs-nfsd.mount
|
||||
After=network.target rpcbind.service proc-fs-nfsd.mount named.service
|
||||
|
||||
[Service]
|
||||
Type=forking
|
||||
|
48
nfs-utils-1.2.6-rc1.patch
Normal file
48
nfs-utils-1.2.6-rc1.patch
Normal file
@ -0,0 +1,48 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 80fb39d..f101b86 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -265,6 +265,12 @@ if test "$enable_nfsv4" = yes; then
|
||||
AC_RPCSEC_VERSION
|
||||
fi
|
||||
fi
|
||||
+
|
||||
+if test "$enable_nfsv41" = yes; then
|
||||
+ AC_CHECK_LIB([devmapper], [dm_task_create], [LIBDEVMAPPER="-ldevmapper"], AC_MSG_ERROR([libdevmapper needed]))
|
||||
+ AC_CHECK_HEADER(libdevmapper.h, , AC_MSG_ERROR([Cannot find devmapper header file libdevmapper.h]))
|
||||
+fi
|
||||
+
|
||||
dnl enable nfsidmap when its support by libnfsidmap
|
||||
AM_CONDITIONAL(CONFIG_NFSIDMAP, [test "$ac_cv_header_keyutils_h$ac_cv_lib_nfsidmap_nfs4_owner_to_uid" = "yesyes"])
|
||||
|
||||
diff --git a/utils/blkmapd/device-process.c b/utils/blkmapd/device-process.c
|
||||
index 27ff374..652a7a8 100644
|
||||
--- a/utils/blkmapd/device-process.c
|
||||
+++ b/utils/blkmapd/device-process.c
|
||||
@@ -296,7 +296,7 @@ decode_blk_volume(uint32_t **pp, uint32_t *end, struct bl_volume *vols, int voln
|
||||
off_t stripe_unit = vol->param.bv_stripe_unit;
|
||||
/* Check limitations imposed by device-mapper */
|
||||
if ((stripe_unit & (stripe_unit - 1)) != 0
|
||||
- || stripe_unit < (off_t) (PAGE_SIZE >> 9))
|
||||
+ || stripe_unit < (off_t) (sysconf(_SC_PAGE_SIZE) >> 9))
|
||||
return -EIO;
|
||||
BLK_READBUF(p, end, 4);
|
||||
READ32(vol->bv_vol_n);
|
||||
diff --git a/utils/mount/nfs.man b/utils/mount/nfs.man
|
||||
index ce40933..2ad92d1 100644
|
||||
--- a/utils/mount/nfs.man
|
||||
+++ b/utils/mount/nfs.man
|
||||
@@ -1561,10 +1561,10 @@ To ensure that the saved mount options are not erased during a remount,
|
||||
specify either the local mount directory, or the server hostname and
|
||||
export pathname, but not both, during a remount. For example,
|
||||
.P
|
||||
-.NF
|
||||
-.TA 2.5i
|
||||
+.nf
|
||||
+.ta 8n
|
||||
mount -o remount,ro /mnt
|
||||
-.FI
|
||||
+.fi
|
||||
.P
|
||||
merges the mount option
|
||||
.B ro
|
@ -2,7 +2,7 @@ Summary: NFS utilities and supporting clients and daemons for the kernel NFS ser
|
||||
Name: nfs-utils
|
||||
URL: http://sourceforge.net/projects/nfs
|
||||
Version: 1.2.5
|
||||
Release: 0%{?dist}
|
||||
Release: 1%{?dist}
|
||||
Epoch: 1
|
||||
|
||||
# group all 32bit related archs
|
||||
@ -28,7 +28,8 @@ Source51: nfs-server.preconfig
|
||||
Source52: nfs-server.postconfig
|
||||
%define nfs_configs %{SOURCE50} %{SOURCE51} %{SOURCE52}
|
||||
|
||||
Patch001: nfs-utils-1.2.4-mountshortcut.patch
|
||||
Patch001: nfs-utils-1.2.6-rc1.patch
|
||||
Patch002: nfs-utils-1.2.4-mountshortcut.patch
|
||||
|
||||
Patch100: nfs-utils-1.2.1-statdpath-man.patch
|
||||
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
|
||||
@ -85,6 +86,7 @@ This package also contains the mount.nfs and umount.nfs program.
|
||||
%setup -q
|
||||
|
||||
%patch001 -p1
|
||||
%patch002 -p1
|
||||
|
||||
%patch100 -p1
|
||||
%patch101 -p1
|
||||
@ -272,6 +274,10 @@ fi
|
||||
%attr(4755,root,root) /sbin/umount.nfs4
|
||||
|
||||
%changelog
|
||||
* Mon Oct 3 2011 Steve Dickson <steved@redhat.com> 1.2.5-1
|
||||
- Update to upstream RC release: nfs-utils-1.2.6-rc1
|
||||
- Added named.service to After list in nfs-server.service (bz 742746)
|
||||
|
||||
* Tue Sep 27 2011 Steve Dickson <steved@redhat.com> 1.2.5-0
|
||||
- Update to upstream release: nfs-utils-1.2.5 (bz 717931)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user