- Updated to the latest pseudo root release (rel10) which containts the

upstream pseudo root release
This commit is contained in:
Steve Dickson 2010-01-14 09:27:25 +00:00
parent 67df246c34
commit a6589566ac
4 changed files with 1327 additions and 122 deletions

View File

@ -1,42 +0,0 @@
--- nfs-utils-1.1.0/utils/statd/statd.h.orig 2007-05-10 23:40:57.000000000 -0400
+++ nfs-utils-1.1.0/utils/statd/statd.h 2007-07-14 05:55:57.000000000 -0400
@@ -16,10 +16,11 @@
/*
* Paths and filenames.
*/
+#define STATD_PATH_XTN "statd/"
#if defined(NFS_STATEDIR)
-# define DEFAULT_DIR_BASE NFS_STATEDIR "/"
+# define DEFAULT_DIR_BASE NFS_STATEDIR "/" STATD_PATH_XTN
#else
-# define DEFAULT_DIR_BASE "/var/lib/nfs/"
+# define DEFAULT_DIR_BASE "/var/lib/nfs/" STATD_PATH_XTN
#endif
#define DEFAULT_SM_DIR DEFAULT_DIR_BASE "sm"
--- nfs-utils-1.1.0/utils/statd/statd.man.orig 2007-05-10 23:40:57.000000000 -0400
+++ nfs-utils-1.1.0/utils/statd/statd.man 2007-07-14 05:57:20.000000000 -0400
@@ -24,7 +24,7 @@ reboots.
For each NFS client or server machine to be monitored,
.B rpc.statd
creates a file in
-.BR /var/lib/nfs/sm .
+.BR /var/lib/nfs/statd/sm .
When starting, it normally runs
.B sm-notify
to iterate through these files and notify the
@@ -176,11 +176,11 @@ and send notifications to clients. This
of an NFS export from another server.
.SH FILES
-.BR /var/lib/nfs/state
+.BR /var/lib/nfs/statd/sm/state
.br
-.BR /var/lib/nfs/sm/*
+.BR /var/lib/nfs/statd/sm/*
.br
-.BR /var/lib/nfs/sm.bak/*
+.BR /var/lib/nfs/statd/sm.bak/*
.SH SEE ALSO
.BR rpc.nfsd(8),
.BR portmap(8)

View File

@ -0,0 +1,77 @@
diff -up nfs-utils-1.2.1/configure.ac.orig nfs-utils-1.2.1/configure.ac
--- nfs-utils-1.2.1/configure.ac.orig 2010-01-13 17:23:17.089961251 -0500
+++ nfs-utils-1.2.1/configure.ac 2010-01-13 17:24:00.144003829 -0500
@@ -22,6 +22,14 @@ AC_ARG_WITH(statedir,
statedir=$withval,
statedir=/var/lib/nfs)
AC_SUBST(statedir)
+AC_ARG_WITH(statdpath,
+ [AC_HELP_STRING([--with-statdpath=/foo],
+ [Causes statd put it's state file in /foo instead of statedir]
+ )],
+ statdpath=$withval,
+ statdpath=""
+ )
+ AC_SUBST(statdpath)
AC_ARG_WITH(statduser,
[AC_HELP_STRING([--with-statduser=rpcuser],
[statd to run under @<:@rpcuser or nobody@:>@]
@@ -347,6 +355,9 @@ dnl ************************************
dnl Export some path names to config.h
dnl *************************************************************
AC_DEFINE_UNQUOTED(NFS_STATEDIR, "$statedir", [This defines the location of the NFS state files. Warning: this must match definitions in config.mk!])
+if test "$statdpath" != ""; then
+ AC_DEFINE_UNQUOTED(NSM_STATD_PATH, "$statdpath", [Define this if you what statd file placed in somewhere other than NFS_STATEDIR])
+fi
if test "x$cross_compiling" = "xno"; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-"$CFLAGS"}
diff -up nfs-utils-1.2.1/support/nsm/file.c.orig nfs-utils-1.2.1/support/nsm/file.c
--- nfs-utils-1.2.1/support/nsm/file.c.orig 2010-01-13 17:23:17.099961228 -0500
+++ nfs-utils-1.2.1/support/nsm/file.c 2010-01-13 17:26:44.476815932 -0500
@@ -91,12 +91,13 @@
#define NSM_KERNEL_STATE_FILE "/proc/sys/fs/nfs/nsm_local_state"
/*
- * Some distributions place statd's files in a subdirectory
+ * Allow different places for statd's files
*/
-#define NSM_PATH_EXTENSION
-/* #define NSM_PATH_EXTENSION "/statd" */
-
-#define NSM_DEFAULT_STATEDIR NFS_STATEDIR NSM_PATH_EXTENSION
+#ifdef NSM_STATD_PATH
+#define NSM_DEFAULT_STATEDIR NSM_STATD_PATH
+#else
+#define NSM_DEFAULT_STATEDIR NFS_STATEDIR
+#endif
static char nsm_base_dirname[PATH_MAX] = NSM_DEFAULT_STATEDIR;
diff -up nfs-utils-1.2.1/utils/statd/statd.man.orig nfs-utils-1.2.1/utils/statd/statd.man
--- nfs-utils-1.2.1/utils/statd/statd.man.orig 2009-11-04 06:13:56.000000000 -0500
+++ nfs-utils-1.2.1/utils/statd/statd.man 2010-01-13 17:23:41.110003469 -0500
@@ -24,7 +24,7 @@ reboots.
For each NFS client or server machine to be monitored,
.B rpc.statd
creates a file in
-.BR /var/lib/nfs/sm .
+.BR /var/lib/nfs/statd/sm .
When starting, it normally runs
.B sm-notify
to iterate through these files and notify the
@@ -176,11 +176,11 @@ and send notifications to clients. This
of an NFS export from another server.
.SH FILES
-.BR /var/lib/nfs/state
+.BR /var/lib/nfs/statd/sm/state
.br
-.BR /var/lib/nfs/sm/*
+.BR /var/lib/nfs/statd/sm/*
.br
-.BR /var/lib/nfs/sm.bak/*
+.BR /var/lib/nfs/statd/sm.bak/*
.SH SEE ALSO
.BR rpc.nfsd(8),
.BR portmap(8)

File diff suppressed because it is too large Load Diff

View File

@ -2,7 +2,7 @@ Summary: NFS utilities and supporting clients and daemons for the kernel NFS ser
Name: nfs-utils
URL: http://sourceforge.net/projects/nfs
Version: 1.2.1
Release: 9%{?dist}
Release: 10%{?dist}
Epoch: 1
# group all 32bit related archs
@ -18,14 +18,13 @@ Source13: rpcgssd.init
Source14: rpcsvcgssd.init
Source15: nfs.sysconfig
Patch00: nfs-utils-1.0.5-statdpath.patch
Patch01: nfs-utils-1.1.0-smnotify-path.patch
Patch02: nfs-utils-1.1.0-exp-subtree-warn-off.patch
Patch100: nfs-utils-1.2.2-rc5.patch
Patch100: nfs-utils-1.2.2-rc6.patch
Patch101: nfs-utils-1.2.1-compile.patch
Patch200: nfs-utils-1.2.0-v4root-rel9.patch
Patch200: nfs-utils-1.2.1-statdpath.patch
Group: System Environment/Daemons
Provides: exportfs = %{epoch}:%{version}-%{release}
@ -73,7 +72,6 @@ This package also contains the mount.nfs and umount.nfs program.
%prep
%setup -q
%patch00 -p1
%patch01 -p1
%patch02 -p1
@ -102,7 +100,8 @@ CFLAGS="`echo $RPM_OPT_FLAGS $ARCH_OPT_FLAGS $PIE -D_FILE_OFFSET_BITS=64`"
CPPFLAGS="$DEFINES" \
LDFLAGS="-pie" \
--enable-mount \
--enable-mountconfig
--enable-mountconfig \
--with-statdpath=/var/lib/nfs/statd
make all
@ -252,6 +251,10 @@ fi
%attr(4755,root,root) /sbin/umount.nfs4
%changelog
* Thu Jan 14 2010 Steve Dickson <steved@redhat.com> 1.2.1-10
- Updated to the latest pseudo root release (rel10) which
containts the upstream pseudo root release
* Mon Jan 12 2010 Steve Dickson <steved@redhat.com> 1.2.1-9
- Updated to latest upstream RC release: nfs-utils-1-2-2-rc5