configure: fix AC_CACHE_VAL warnings
This commit is contained in:
parent
31083ffc0b
commit
a4989af149
64
nfs-utils-1.1.4-configure.patch
Normal file
64
nfs-utils-1.1.4-configure.patch
Normal file
@ -0,0 +1,64 @@
|
||||
commit 38667906c89d6944faaced7fbcda027643dc10ad
|
||||
Author: Chuck Lever <chuck.lever@oracle.com>
|
||||
Date: Wed Mar 4 15:54:39 2009 -0500
|
||||
|
||||
configure: fix AC_CACHE_VAL warnings on Fedora 10
|
||||
|
||||
Autoconf 2.63 (and maybe earlier releases) complains about the cache
|
||||
variable name used in aclocal/libblkid.m4:
|
||||
|
||||
configure.ac:217: warning: AC_CACHE_VAL(libblkid_is_recent, ...):
|
||||
suspicious cache-id, must contain _cv_ to be cached
|
||||
../../lib/autoconf/general.m4:1974: AC_CACHE_VAL is expanded from...
|
||||
aclocal/libblkid.m4:2: AC_BLKID_VERS is expanded from...
|
||||
configure.ac:217: the top level
|
||||
|
||||
This addresses
|
||||
https://bugzilla.redhat.com/attachment.cgi?bugid=481386 .
|
||||
|
||||
Signed-off-by: Chuck Lever <chuck.lever@oracle.com>
|
||||
Signed-off-by: Steve Dickson <steved@redhat.com>
|
||||
|
||||
diff --git a/aclocal/libblkid.m4 b/aclocal/libblkid.m4
|
||||
index d751a8c..10824e9 100644
|
||||
--- a/aclocal/libblkid.m4
|
||||
+++ b/aclocal/libblkid.m4
|
||||
@@ -1,7 +1,7 @@
|
||||
dnl *************************** libblkid needs version 1.40 or later ***********************
|
||||
AC_DEFUN([AC_BLKID_VERS], [
|
||||
AC_MSG_CHECKING(for suitable libblkid version)
|
||||
- AC_CACHE_VAL(libblkid_is_recent,
|
||||
+ AC_CACHE_VAL([libblkid_cv_is_recent],
|
||||
[
|
||||
saved_LIBS="$LIBS"
|
||||
LIBS=-lblkid
|
||||
@@ -12,9 +12,8 @@ AC_DEFUN([AC_BLKID_VERS], [
|
||||
int vers = blkid_get_library_version(0, 0);
|
||||
return vers >= 140 ? 0 : 1;
|
||||
}
|
||||
- ], libblkid_is_recent=yes, libblkid_is_recent=no,
|
||||
- libblkid_is_recent=unknown)
|
||||
- LIBS="$saved_LIBS"
|
||||
- ])dnl
|
||||
- AC_MSG_RESULT($libblkid_is_recent)
|
||||
+ ], [libblkid_cv_is_recent=yes], [libblkid_cv_is_recent=no],
|
||||
+ [libblkid_cv_is_recent=unknown])
|
||||
+ LIBS="$saved_LIBS"])
|
||||
+ AC_MSG_RESULT($libblkid_cv_is_recent)
|
||||
])dnl
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index c8508f1..4fd111f 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -219,9 +219,9 @@ if test "$choose_blkid" != no; then
|
||||
AC_BLKID_VERS
|
||||
if test $choose_blkid = yes; then
|
||||
use_blkid=1
|
||||
- test $libblkid_is_recent = no && AC_MSG_WARN([libblkid is old and may cause mountd to leak memory])
|
||||
+ test $libblkid_cv_is_recent = no && AC_MSG_WARN([libblkid is old and may cause mountd to leak memory])
|
||||
else
|
||||
- if test $libblkid_is_recent = yes
|
||||
+ if test $libblkid_cv_is_recent = yes
|
||||
then use_blkid=1
|
||||
else use_blkid=0
|
||||
AC_MSG_WARN([uuid support disabled as libblkid is too old])
|
@ -2,7 +2,7 @@ Summary: NFS utilities and supporting clients and daemons for the kernel NFS ser
|
||||
Name: nfs-utils
|
||||
URL: http://sourceforge.net/projects/nfs
|
||||
Version: 1.1.4
|
||||
Release: 20%{?dist}
|
||||
Release: 21%{?dist}
|
||||
Epoch: 1
|
||||
|
||||
# group all 32bit related archs
|
||||
@ -52,6 +52,7 @@ Patch122: nfs-utils-1.1.4-mount-nolock.patch
|
||||
Patch123: nfs-utils-1.1.4-mount-udponly.patch
|
||||
Patch124: nfs-utils-1.1.4-umount-ipv6.patch
|
||||
Patch125: nfs-utils-1.1.4-export-hash.patch
|
||||
Patch126: nfs-utils-1.1.4-configure.patch
|
||||
|
||||
%if %{enablefscache}
|
||||
Patch90: nfs-utils-1.1.0-mount-fsc.patch
|
||||
@ -132,6 +133,7 @@ This package also contains the mount.nfs and umount.nfs program.
|
||||
%patch123 -p1
|
||||
%patch124 -p1
|
||||
%patch125 -p1
|
||||
%patch126 -p1
|
||||
|
||||
%if %{enablefscache}
|
||||
%patch90 -p1
|
||||
@ -295,6 +297,9 @@ fi
|
||||
%attr(4755,root,root) /sbin/umount.nfs4
|
||||
|
||||
%changelog
|
||||
* Wed Mar 4 2009 Steve Dickson <steved@redhat.com> 1.1.4-21
|
||||
- configure: fix AC_CACHE_VAL warnings
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.1.4-20
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user