Updated to the latest upstream RC release: nfs-utils.1.2.9-rc1
Signed-off-by: Steve Dickson <steved@redhat.com>
This commit is contained in:
parent
a5859b22cf
commit
87701eca5f
229
nfs-utils-1-2-9-rc1.patch
Normal file
229
nfs-utils-1-2-9-rc1.patch
Normal file
@ -0,0 +1,229 @@
|
|||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index a594a7b..d3ad854 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
dnl Process this file with autoconf to produce a configure script.
|
||||||
|
dnl
|
||||||
|
-AC_INIT([linux nfs-utils],[1.2.7],[linux-nfs@vger.kernel.org],[nfs-utils])
|
||||||
|
+AC_INIT([linux nfs-utils],[1.2.8],[linux-nfs@vger.kernel.org],[nfs-utils])
|
||||||
|
AC_CANONICAL_BUILD([])
|
||||||
|
AC_CANONICAL_HOST([])
|
||||||
|
AC_CONFIG_MACRO_DIR(aclocal)
|
||||||
|
diff --git a/support/include/nfsrpc.h b/support/include/nfsrpc.h
|
||||||
|
index a0b80e1..1bfae7a 100644
|
||||||
|
--- a/support/include/nfsrpc.h
|
||||||
|
+++ b/support/include/nfsrpc.h
|
||||||
|
@@ -156,6 +156,11 @@ extern unsigned long nfs_pmap_getport(const struct sockaddr_in *,
|
||||||
|
const struct timeval *);
|
||||||
|
|
||||||
|
/*
|
||||||
|
+ * Use nfs_pmap_getport to see if statd is running locally
|
||||||
|
+ */
|
||||||
|
+extern int nfs_probe_statd(void);
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
* Contact a remote RPC service to discover whether it is responding
|
||||||
|
* to requests.
|
||||||
|
*/
|
||||||
|
diff --git a/support/nfs/getport.c b/support/nfs/getport.c
|
||||||
|
index 3331ad4..081594c 100644
|
||||||
|
--- a/support/nfs/getport.c
|
||||||
|
+++ b/support/nfs/getport.c
|
||||||
|
@@ -1102,3 +1102,25 @@ unsigned long nfs_pmap_getport(const struct sockaddr_in *sin,
|
||||||
|
|
||||||
|
return port;
|
||||||
|
}
|
||||||
|
+
|
||||||
|
+static const char *nfs_ns_pgmtbl[] = {
|
||||||
|
+ "status",
|
||||||
|
+ NULL,
|
||||||
|
+};
|
||||||
|
+
|
||||||
|
+/*
|
||||||
|
+ * nfs_probe_statd - use nfs_pmap_getport to see if statd is running locally
|
||||||
|
+ *
|
||||||
|
+ * Returns non-zero if statd is running locally.
|
||||||
|
+ */
|
||||||
|
+int nfs_probe_statd(void)
|
||||||
|
+{
|
||||||
|
+ struct sockaddr_in addr = {
|
||||||
|
+ .sin_family = AF_INET,
|
||||||
|
+ .sin_addr.s_addr = htonl(INADDR_LOOPBACK),
|
||||||
|
+ };
|
||||||
|
+ rpcprog_t program = nfs_getrpcbyname(NSMPROG, nfs_ns_pgmtbl);
|
||||||
|
+
|
||||||
|
+ return nfs_getport_ping((struct sockaddr *)(char *)&addr, sizeof(addr),
|
||||||
|
+ program, (rpcvers_t)1, IPPROTO_UDP);
|
||||||
|
+}
|
||||||
|
diff --git a/utils/gssd/gssd_proc.c b/utils/gssd/gssd_proc.c
|
||||||
|
index af1844c..6cd4276 100644
|
||||||
|
--- a/utils/gssd/gssd_proc.c
|
||||||
|
+++ b/utils/gssd/gssd_proc.c
|
||||||
|
@@ -67,7 +67,6 @@
|
||||||
|
#include <errno.h>
|
||||||
|
#include <gssapi/gssapi.h>
|
||||||
|
#include <netdb.h>
|
||||||
|
-#include <ctype.h>
|
||||||
|
|
||||||
|
#include "gssd.h"
|
||||||
|
#include "err_util.h"
|
||||||
|
diff --git a/utils/mount/network.c b/utils/mount/network.c
|
||||||
|
index 4be48cd..e2cdcaf 100644
|
||||||
|
--- a/utils/mount/network.c
|
||||||
|
+++ b/utils/mount/network.c
|
||||||
|
@@ -65,11 +65,6 @@ extern int nfs_mount_data_version;
|
||||||
|
extern char *progname;
|
||||||
|
extern int verbose;
|
||||||
|
|
||||||
|
-static const char *nfs_ns_pgmtbl[] = {
|
||||||
|
- "status",
|
||||||
|
- NULL,
|
||||||
|
-};
|
||||||
|
-
|
||||||
|
static const char *nfs_mnt_pgmtbl[] = {
|
||||||
|
"mount",
|
||||||
|
"mountd",
|
||||||
|
@@ -761,18 +756,6 @@ int probe_bothports(clnt_addr_t *mnt_server, clnt_addr_t *nfs_server)
|
||||||
|
&nfs_server->pmap);
|
||||||
|
}
|
||||||
|
|
||||||
|
-static int nfs_probe_statd(void)
|
||||||
|
-{
|
||||||
|
- struct sockaddr_in addr = {
|
||||||
|
- .sin_family = AF_INET,
|
||||||
|
- .sin_addr.s_addr = htonl(INADDR_LOOPBACK),
|
||||||
|
- };
|
||||||
|
- rpcprog_t program = nfs_getrpcbyname(NSMPROG, nfs_ns_pgmtbl);
|
||||||
|
-
|
||||||
|
- return nfs_getport_ping(SAFE_SOCKADDR(&addr), sizeof(addr),
|
||||||
|
- program, (rpcvers_t)1, IPPROTO_UDP);
|
||||||
|
-}
|
||||||
|
-
|
||||||
|
/**
|
||||||
|
* start_statd - attempt to start rpc.statd
|
||||||
|
*
|
||||||
|
diff --git a/utils/mount/nfs.man b/utils/mount/nfs.man
|
||||||
|
index a8ec46c..2a42b93 100644
|
||||||
|
--- a/utils/mount/nfs.man
|
||||||
|
+++ b/utils/mount/nfs.man
|
||||||
|
@@ -84,6 +84,20 @@ in
|
||||||
|
.SS "Options supported by all versions"
|
||||||
|
These options are valid to use with any NFS version.
|
||||||
|
.TP 1.5i
|
||||||
|
+.BI nfsvers= n
|
||||||
|
+The NFS protocol version number used to contact the server's NFS service.
|
||||||
|
+If the server does not support the requested version, the mount request
|
||||||
|
+fails.
|
||||||
|
+If this option is not specified, the client negotiates a suitable version
|
||||||
|
+with
|
||||||
|
+the server, trying version 4 first, version 3 second, and version 2 last.
|
||||||
|
+.TP 1.5i
|
||||||
|
+.BI vers= n
|
||||||
|
+This option is an alternative to the
|
||||||
|
+.B nfsvers
|
||||||
|
+option.
|
||||||
|
+It is included for compatibility with other operating systems
|
||||||
|
+.TP 1.5i
|
||||||
|
.BR soft " / " hard
|
||||||
|
Determines the recovery behavior of the NFS client
|
||||||
|
after an NFS request times out.
|
||||||
|
@@ -621,18 +635,6 @@ Using this option ensures that
|
||||||
|
reports the proper maximum component length to applications
|
||||||
|
in such cases.
|
||||||
|
.TP 1.5i
|
||||||
|
-.BI nfsvers= n
|
||||||
|
-The NFS protocol version number used to contact the server's NFS service.
|
||||||
|
-If the server does not support the requested version, the mount request fails.
|
||||||
|
-If this option is not specified, the client negotiates a suitable version with
|
||||||
|
-the server, trying version 4 first, version 3 second, and version 2 last.
|
||||||
|
-.TP 1.5i
|
||||||
|
-.BI vers= n
|
||||||
|
-This option is an alternative to the
|
||||||
|
-.B nfsvers
|
||||||
|
-option.
|
||||||
|
-It is included for compatibility with other operating systems.
|
||||||
|
-.TP 1.5i
|
||||||
|
.BR lock " / " nolock
|
||||||
|
Selects whether to use the NLM sideband protocol to lock files on the server.
|
||||||
|
If neither option is specified (or if
|
||||||
|
diff --git a/utils/mountd/cache.c b/utils/mountd/cache.c
|
||||||
|
index 737927c..517aa62 100644
|
||||||
|
--- a/utils/mountd/cache.c
|
||||||
|
+++ b/utils/mountd/cache.c
|
||||||
|
@@ -347,20 +347,26 @@ static char *next_mnt(void **v, char *p)
|
||||||
|
|
||||||
|
static int is_subdirectory(char *child, char *parent)
|
||||||
|
{
|
||||||
|
+ /* Check is child is strictly a subdirectory of
|
||||||
|
+ * parent or a more distant descendant.
|
||||||
|
+ */
|
||||||
|
size_t l = strlen(parent);
|
||||||
|
|
||||||
|
- if (strcmp(parent, "/") == 0)
|
||||||
|
+ if (strcmp(parent, "/") == 0 && child[1] != 0)
|
||||||
|
return 1;
|
||||||
|
|
||||||
|
- return strcmp(child, parent) == 0
|
||||||
|
- || (strncmp(child, parent, l) == 0 && child[l] == '/');
|
||||||
|
+ return (strncmp(child, parent, l) == 0 && child[l] == '/');
|
||||||
|
}
|
||||||
|
|
||||||
|
static int path_matches(nfs_export *exp, char *path)
|
||||||
|
{
|
||||||
|
- if (exp->m_export.e_flags & NFSEXP_CROSSMOUNT)
|
||||||
|
- return is_subdirectory(path, exp->m_export.e_path);
|
||||||
|
- return strcmp(path, exp->m_export.e_path) == 0;
|
||||||
|
+ /* Does the path match the export? I.e. is it an
|
||||||
|
+ * exact match, or does the export have CROSSMOUNT, and path
|
||||||
|
+ * is a descendant?
|
||||||
|
+ */
|
||||||
|
+ return strcmp(path, exp->m_export.e_path) == 0
|
||||||
|
+ || ((exp->m_export.e_flags & NFSEXP_CROSSMOUNT)
|
||||||
|
+ && is_subdirectory(path, exp->m_export.e_path));
|
||||||
|
}
|
||||||
|
|
||||||
|
static int
|
||||||
|
@@ -369,15 +375,13 @@ export_matches(nfs_export *exp, char *dom, char *path, struct addrinfo *ai)
|
||||||
|
return path_matches(exp, path) && client_matches(exp, dom, ai);
|
||||||
|
}
|
||||||
|
|
||||||
|
-/* True iff e1 is a child of e2 and e2 has crossmnt set: */
|
||||||
|
+/* True iff e1 is a child of e2 (or descendant) and e2 has crossmnt set: */
|
||||||
|
static bool subexport(struct exportent *e1, struct exportent *e2)
|
||||||
|
{
|
||||||
|
char *p1 = e1->e_path, *p2 = e2->e_path;
|
||||||
|
- size_t l2 = strlen(p2);
|
||||||
|
|
||||||
|
return e2->e_flags & NFSEXP_CROSSMOUNT
|
||||||
|
- && strncmp(p1, p2, l2) == 0
|
||||||
|
- && p1[l2] == '/';
|
||||||
|
+ && is_subdirectory(p1, p2);
|
||||||
|
}
|
||||||
|
|
||||||
|
struct parsed_fsid {
|
||||||
|
diff --git a/utils/statd/statd.c b/utils/statd/statd.c
|
||||||
|
index 652546c..8c51bcc 100644
|
||||||
|
--- a/utils/statd/statd.c
|
||||||
|
+++ b/utils/statd/statd.c
|
||||||
|
@@ -28,6 +28,7 @@
|
||||||
|
|
||||||
|
#include "statd.h"
|
||||||
|
#include "nfslib.h"
|
||||||
|
+#include "nfsrpc.h"
|
||||||
|
#include "nsm.h"
|
||||||
|
|
||||||
|
/* Socket operations */
|
||||||
|
@@ -237,6 +238,12 @@ int main (int argc, char **argv)
|
||||||
|
/* Set hostname */
|
||||||
|
MY_NAME = NULL;
|
||||||
|
|
||||||
|
+ /* Refuse to start if another statd is running */
|
||||||
|
+ if (nfs_probe_statd()) {
|
||||||
|
+ fprintf(stderr, "Statd service already running!\n");
|
||||||
|
+ exit(1);
|
||||||
|
+ }
|
||||||
|
+
|
||||||
|
/* Process command line switches */
|
||||||
|
while ((arg = getopt_long(argc, argv, "h?vVFNH:dn:p:o:P:L", longopts, NULL)) != EOF) {
|
||||||
|
switch (arg) {
|
@ -2,7 +2,7 @@ Summary: NFS utilities and supporting clients and daemons for the kernel NFS ser
|
|||||||
Name: nfs-utils
|
Name: nfs-utils
|
||||||
URL: http://sourceforge.net/projects/nfs
|
URL: http://sourceforge.net/projects/nfs
|
||||||
Version: 1.2.8
|
Version: 1.2.8
|
||||||
Release: 0%{?dist}
|
Release: 1%{?dist}
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
|
|
||||||
# group all 32bit related archs
|
# group all 32bit related archs
|
||||||
@ -36,6 +36,8 @@ Source51: nfs-server.preconfig
|
|||||||
Source52: nfs-server.postconfig
|
Source52: nfs-server.postconfig
|
||||||
%define nfs_configs %{SOURCE50} %{SOURCE51} %{SOURCE52}
|
%define nfs_configs %{SOURCE50} %{SOURCE51} %{SOURCE52}
|
||||||
|
|
||||||
|
Patch001: nfs-utils-1-2-9-rc1.patch
|
||||||
|
|
||||||
Patch100: nfs-utils-1.2.1-statdpath-man.patch
|
Patch100: nfs-utils-1.2.1-statdpath-man.patch
|
||||||
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
|
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
|
||||||
Patch102: nfs-utils-1.2.3-sm-notify-res_init.patch
|
Patch102: nfs-utils-1.2.3-sm-notify-res_init.patch
|
||||||
@ -91,6 +93,8 @@ This package also contains the mount.nfs and umount.nfs program.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
|
%patch001 -p1
|
||||||
|
|
||||||
%patch100 -p1
|
%patch100 -p1
|
||||||
%patch101 -p1
|
%patch101 -p1
|
||||||
%patch102 -p1
|
%patch102 -p1
|
||||||
@ -294,6 +298,9 @@ fi
|
|||||||
%attr(4755,root,root) /sbin/umount.nfs4
|
%attr(4755,root,root) /sbin/umount.nfs4
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue May 7 2013 Steve Dickson <steved@redhat.com> 1.2.8-1
|
||||||
|
- Updated to the latest upstream RC release: nfs-utils.1.2.9-rc1
|
||||||
|
|
||||||
* Tue Apr 23 2013 Steve Dickson <steved@redhat.com> 1.2.8-0
|
* Tue Apr 23 2013 Steve Dickson <steved@redhat.com> 1.2.8-0
|
||||||
- Updated to latest upstream release: 1.2.8
|
- Updated to latest upstream release: 1.2.8
|
||||||
- Removed the libgssglue dependency
|
- Removed the libgssglue dependency
|
||||||
|
Loading…
Reference in New Issue
Block a user