- Updated to latest upstream RC release: nfs-utils-1-2-2-rc7 which includes

Ipv6 support for statd (disabled by default).
This commit is contained in:
Steve Dickson 2010-01-16 12:32:42 +00:00
parent a6589566ac
commit 80be375668
7 changed files with 5769 additions and 1636 deletions

View File

@ -1,12 +0,0 @@
diff -up nfs-utils-1.1.1/support/nfs/exports.c.orig nfs-utils-1.1.1/support/nfs/exports.c
--- nfs-utils-1.1.1/support/nfs/exports.c.orig 2007-10-18 23:07:28.000000000 -0400
+++ nfs-utils-1.1.1/support/nfs/exports.c 2008-01-05 09:01:50.000000000 -0500
@@ -484,7 +484,7 @@ static int
parseopts(char *cp, struct exportent *ep, int warn, int *had_subtree_opt_ptr)
{
struct sec_entry *p;
- int had_subtree_opt = 0;
+ int had_subtree_opt = 1;
char *flname = efname?efname:"command line";
int flline = efp?efp->x_line:0;
unsigned int active = 0;

View File

@ -1,58 +0,0 @@
diff -up nfs-utils-1.1.4/utils/statd/sm-notify.c.orig nfs-utils-1.1.4/utils/statd/sm-notify.c
--- nfs-utils-1.1.4/utils/statd/sm-notify.c.orig 2008-10-17 10:20:09.000000000 -0400
+++ nfs-utils-1.1.4/utils/statd/sm-notify.c 2008-10-17 11:22:01.000000000 -0400
@@ -28,11 +28,13 @@
#include <errno.h>
#include <grp.h>
+#define STATD_PATH_XTN "statd/"
+
#ifndef BASEDIR
# ifdef NFS_STATEDIR
-# define BASEDIR NFS_STATEDIR
+# define BASEDIR NFS_STATEDIR "/" STATD_PATH_XTN
# else
-# define BASEDIR "/var/lib/nfs"
+# define BASEDIR "/var/lib/nfs" "/" STATD_PATH_XTN
# endif
#endif
diff -up nfs-utils-1.1.4/utils/statd/sm-notify.man.orig nfs-utils-1.1.4/utils/statd/sm-notify.man
--- nfs-utils-1.1.4/utils/statd/sm-notify.man.orig 2008-10-17 10:20:09.000000000 -0400
+++ nfs-utils-1.1.4/utils/statd/sm-notify.man 2008-10-17 11:22:01.000000000 -0400
@@ -33,7 +33,7 @@ but this is configurable.
For each NFS client or server machine to be monitored,
.B rpc.statd
creates a file in
-.BR /var/lib/nfs/sm ", "
+.BR /var/lib/nfs/statd/sm ", "
and removes the file if monitoring is no longer required.
.PP
When the machine is rebooted,
@@ -47,7 +47,7 @@ Each machine has an
which is basically an integer counter that is incremented
each time the machine reboots. This counter is stored
in
-.BR /var/lib/nfs/state ,
+.BR /var/lib/nfs/statd/state ,
and updated by
.BR sm-notify .
.SS Security
@@ -149,13 +149,13 @@ By default,
.B sm-notify
forks and puts itself in the background after obtaining the
list of hosts from
-.BR /var/lib/nfs/sm .
+.BR /var/lib/nfs/statd/sm .
.SH FILES
-.BR /var/lib/nfs/state
+.BR /var/lib/nfs/statd/state
.br
-.BR /var/lib/nfs/sm/*
+.BR /var/lib/nfs/statd/sm/*
.br
-.BR /var/lib/nfs/sm.bak/*
+.BR /var/lib/nfs/statd/sm.bak/*
.br
.BR /var/run/sm-notify.pid
.SH SEE ALSO

View File

@ -0,0 +1,12 @@
diff -up nfs-utils-1.2.1/support/nfs/exports.c.orig nfs-utils-1.2.1/support/nfs/exports.c
--- nfs-utils-1.2.1/support/nfs/exports.c.orig 2010-01-15 10:48:49.631894982 -0500
+++ nfs-utils-1.2.1/support/nfs/exports.c 2010-01-15 11:05:02.009874055 -0500
@@ -483,7 +483,7 @@ static void fix_pseudoflavor_flags(struc
static int
parseopts(char *cp, struct exportent *ep, int warn, int *had_subtree_opt_ptr)
{
- int had_subtree_opt = 0;
+ int had_subtree_opt = 1;
char *flname = efname?efname:"command line";
int flline = efp?efp->x_line:0;
unsigned int active = 0;

View File

@ -0,0 +1,58 @@
diff -up nfs-utils-1.2.1/utils/statd/sm-notify.man.save nfs-utils-1.2.1/utils/statd/sm-notify.man
--- nfs-utils-1.2.1/utils/statd/sm-notify.man.save 2010-01-15 11:10:25.096874609 -0500
+++ nfs-utils-1.2.1/utils/statd/sm-notify.man 2010-01-15 11:14:12.636873981 -0500
@@ -186,7 +186,7 @@ where NSM state information resides.
If this option is not specified,
.B sm-notify
uses
-.I /var/lib/nfs
+.I /var/lib/nfs/statd
by default.
.IP
After starting,
@@ -287,13 +287,13 @@ Currently, the
command supports sending notification only via datagram transport protocols.
.SH FILES
.TP 2.5i
-.I /var/lib/nfs/sm
+.I /var/lib/nfs/statd/sm
directory containing monitor list
.TP 2.5i
-.I /var/lib/nfs/sm.bak
+.I /var/lib/nfs/statd/sm.bak
directory containing notify list
.TP 2.5i
-.I /var/lib/nfs/state
+.I /var/lib/nfs/statd/state
NSM state number for this host
.TP 2.5i
.I /proc/sys/fs/nfs/nsm_local_state
diff -up nfs-utils-1.2.1/utils/statd/statd.man.save nfs-utils-1.2.1/utils/statd/statd.man
--- nfs-utils-1.2.1/utils/statd/statd.man.save 2010-01-15 11:10:25.098906325 -0500
+++ nfs-utils-1.2.1/utils/statd/statd.man 2010-01-15 11:11:03.874769717 -0500
@@ -232,7 +232,7 @@ where NSM state information resides.
If this option is not specified,
.B rpc.statd
uses
-.I /var/lib/nfs
+.I /var/lib/nfs/statd
by default.
.IP
After starting,
@@ -368,13 +368,13 @@ As long as at least one network transpor
will operate.
.SH FILES
.TP 2.5i
-.I /var/lib/nfs/sm
+.I /var/lib/nfs/statd/sm
directory containing monitor list
.TP 2.5i
-.I /var/lib/nfs/sm.bak
+.I /var/lib/nfs/statd/sm.bak
directory containing notify list
.TP 2.5i
-.I /var/lib/nfs/state
+.I /var/lib/nfs/statd/state
NSM state number for this host
.TP 2.5i
.I /var/run/run.statd.pid

View File

@ -1,6 +1,6 @@
diff -up nfs-utils-1.2.1/configure.ac.orig nfs-utils-1.2.1/configure.ac
--- nfs-utils-1.2.1/configure.ac.orig 2010-01-13 17:23:17.089961251 -0500
+++ nfs-utils-1.2.1/configure.ac 2010-01-13 17:24:00.144003829 -0500
--- nfs-utils-1.2.1/configure.ac.orig 2010-01-15 11:10:25.080854089 -0500
+++ nfs-utils-1.2.1/configure.ac 2010-01-15 11:11:03.872749424 -0500
@@ -22,6 +22,14 @@ AC_ARG_WITH(statedir,
statedir=$withval,
statedir=/var/lib/nfs)
@ -16,7 +16,7 @@ diff -up nfs-utils-1.2.1/configure.ac.orig nfs-utils-1.2.1/configure.ac
AC_ARG_WITH(statduser,
[AC_HELP_STRING([--with-statduser=rpcuser],
[statd to run under @<:@rpcuser or nobody@:>@]
@@ -347,6 +355,9 @@ dnl ************************************
@@ -350,6 +358,9 @@ dnl ************************************
dnl Export some path names to config.h
dnl *************************************************************
AC_DEFINE_UNQUOTED(NFS_STATEDIR, "$statedir", [This defines the location of the NFS state files. Warning: this must match definitions in config.mk!])
@ -27,9 +27,9 @@ diff -up nfs-utils-1.2.1/configure.ac.orig nfs-utils-1.2.1/configure.ac
if test "x$cross_compiling" = "xno"; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-"$CFLAGS"}
diff -up nfs-utils-1.2.1/support/nsm/file.c.orig nfs-utils-1.2.1/support/nsm/file.c
--- nfs-utils-1.2.1/support/nsm/file.c.orig 2010-01-13 17:23:17.099961228 -0500
+++ nfs-utils-1.2.1/support/nsm/file.c 2010-01-13 17:26:44.476815932 -0500
@@ -91,12 +91,13 @@
--- nfs-utils-1.2.1/support/nsm/file.c.orig 2010-01-15 11:10:25.086884939 -0500
+++ nfs-utils-1.2.1/support/nsm/file.c 2010-01-15 11:11:03.873769833 -0500
@@ -93,12 +93,13 @@
#define NSM_KERNEL_STATE_FILE "/proc/sys/fs/nfs/nsm_local_state"
/*
@ -48,30 +48,3 @@ diff -up nfs-utils-1.2.1/support/nsm/file.c.orig nfs-utils-1.2.1/support/nsm/fil
static char nsm_base_dirname[PATH_MAX] = NSM_DEFAULT_STATEDIR;
diff -up nfs-utils-1.2.1/utils/statd/statd.man.orig nfs-utils-1.2.1/utils/statd/statd.man
--- nfs-utils-1.2.1/utils/statd/statd.man.orig 2009-11-04 06:13:56.000000000 -0500
+++ nfs-utils-1.2.1/utils/statd/statd.man 2010-01-13 17:23:41.110003469 -0500
@@ -24,7 +24,7 @@ reboots.
For each NFS client or server machine to be monitored,
.B rpc.statd
creates a file in
-.BR /var/lib/nfs/sm .
+.BR /var/lib/nfs/statd/sm .
When starting, it normally runs
.B sm-notify
to iterate through these files and notify the
@@ -176,11 +176,11 @@ and send notifications to clients. This
of an NFS export from another server.
.SH FILES
-.BR /var/lib/nfs/state
+.BR /var/lib/nfs/statd/sm/state
.br
-.BR /var/lib/nfs/sm/*
+.BR /var/lib/nfs/statd/sm/*
.br
-.BR /var/lib/nfs/sm.bak/*
+.BR /var/lib/nfs/statd/sm.bak/*
.SH SEE ALSO
.BR rpc.nfsd(8),
.BR portmap(8)

File diff suppressed because it is too large Load Diff

View File

@ -2,7 +2,7 @@ Summary: NFS utilities and supporting clients and daemons for the kernel NFS ser
Name: nfs-utils
URL: http://sourceforge.net/projects/nfs
Version: 1.2.1
Release: 10%{?dist}
Release: 11%{?dist}
Epoch: 1
# group all 32bit related archs
@ -18,13 +18,12 @@ Source13: rpcgssd.init
Source14: rpcsvcgssd.init
Source15: nfs.sysconfig
Patch01: nfs-utils-1.1.0-smnotify-path.patch
Patch02: nfs-utils-1.1.0-exp-subtree-warn-off.patch
Patch000: nfs-utils-1.2.2-rc7.patch
Patch001: nfs-utils-1.2.1-compile.patch
Patch002: nfs-utils-1.2.1-statdpath.patch
Patch100: nfs-utils-1.2.2-rc6.patch
Patch101: nfs-utils-1.2.1-compile.patch
Patch200: nfs-utils-1.2.1-statdpath.patch
Patch100: nfs-utils-1.2.1-statdpath-man.patch
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
Group: System Environment/Daemons
Provides: exportfs = %{epoch}:%{version}-%{release}
@ -48,7 +47,7 @@ License: MIT and GPLv2 and GPLv2+ and BSD
Buildroot: %{_tmppath}/%{name}-%{version}-root
Requires: rpcbind, sed, gawk, sh-utils, fileutils, textutils, grep
Requires: modutils >= 2.4.26-9
BuildRequires: libgssglue-devel libevent-devel
BuildRequires: libgssglue-devel libevent-devel libcap-devel
BuildRequires: nfs-utils-lib-devel >= 1.1.0-3 libtirpc-devel libblkid-devel
BuildRequires: krb5-libs >= 1.4 autoconf >= 2.57 openldap-devel >= 2.2
BuildRequires: automake, libtool, glibc-headers
@ -56,7 +55,7 @@ BuildRequires: e2fsprogs-devel, krb5-devel, tcp_wrappers-devel
Requires(pre): shadow-utils >= 4.0.3-25
Requires(pre): /sbin/chkconfig /sbin/nologin
Requires: nfs-utils-lib >= 1.1.0-3 libgssglue libevent
Requires: libtirpc libblkid
Requires: libtirpc libblkid libcap
%description
The nfs-utils package provides a daemon for the kernel NFS server and
@ -72,14 +71,14 @@ This package also contains the mount.nfs and umount.nfs program.
%prep
%setup -q
%patch01 -p1
%patch02 -p1
%patch000 -p1
%patch001 -p1
%patch002 -p1
%patch100 -p1
%patch101 -p1
%patch200 -p1
# Remove .orig files
find . -name "*.orig" | xargs rm -f
@ -251,6 +250,10 @@ fi
%attr(4755,root,root) /sbin/umount.nfs4
%changelog
* Sat Jan 16 2010 Steve Dickson <steved@redhat.com> 1.2.1-11
- Updated to latest upstream RC release: nfs-utils-1-2-2-rc7
which includes Ipv6 support for statd (disabled by default).
* Thu Jan 14 2010 Steve Dickson <steved@redhat.com> 1.2.1-10
- Updated to the latest pseudo root release (rel10) which
containts the upstream pseudo root release