Updated to latest upstream version: 1.2.2

This commit is contained in:
Steve Dickson 2010-02-18 15:02:14 +00:00
parent 945d2bc769
commit 75c26a1be2
7 changed files with 18 additions and 12466 deletions

View File

@ -2,3 +2,4 @@ nfs.doc.tar.gz
nfs-utils-1.1.6.tar.bz2
nfs-utils-1.2.0.tar.bz2
nfs-utils-1.2.1.tar.bz2
nfs-utils-1.2.2.tar.bz2

View File

@ -1,76 +0,0 @@
diff -up nfs-utils-1.2.1/utils/mount/configfile.c.orig nfs-utils-1.2.1/utils/mount/configfile.c
--- nfs-utils-1.2.1/utils/mount/configfile.c.orig 2010-01-21 05:20:04.257284410 -0500
+++ nfs-utils-1.2.1/utils/mount/configfile.c 2010-01-21 05:20:49.616131234 -0500
@@ -222,6 +222,12 @@ int inline check_vers(char *mopt, char *
unsigned long config_default_vers;
unsigned long config_default_proto;
+#ifdef IPV6_SUPPORTED
+sa_family_t config_default_family = AF_UNSPEC;
+#else
+sa_family_t config_default_family = AF_INET;
+#endif
+
/*
* Check to see if a default value is being set.
* If so, set the appropriate global value which will
@@ -243,6 +249,12 @@ int inline default_value(char *mopt)
xlog_warn("Unable to set default protocol : %s",
strerror(errno));
}
+#ifdef IPV6_SUPPORTED
+ if (!nfs_nfs_proto_family(options, &config_default_family)) {
+ xlog_warn("Unable to set default family : %s",
+ strerror(errno));
+ }
+#endif
} else {
xlog_warn("Unable to alloc memory for default protocol");
}
diff -up nfs-utils-1.2.1/utils/mount/network.c.orig nfs-utils-1.2.1/utils/mount/network.c
--- nfs-utils-1.2.1/utils/mount/network.c.orig 2010-01-21 05:20:04.252304404 -0500
+++ nfs-utils-1.2.1/utils/mount/network.c 2010-01-21 05:20:49.617183039 -0500
@@ -54,6 +54,16 @@
#include "network.h"
#include "conffile.h"
+#ifdef MOUNT_CONFIG
+extern sa_family_t config_default_family;
+#else
+#ifdef IPV6_SUPPORTED
+sa_family_t config_default_family = AF_UNSPEC;
+#else
+sa_family_t config_default_family = AF_INET;
+#endif
+#endif
+
#define PMAP_TIMEOUT (10)
#define CONNECT_TIMEOUT (20)
#define MOUNT_TIMEOUT (30)
@@ -1342,12 +1352,7 @@ int nfs_nfs_proto_family(struct mount_op
unsigned long protocol;
char *option;
-#ifdef IPV6_SUPPORTED
- *family = AF_UNSPEC;
-#else
- *family = AF_INET;
-#endif
-
+ *family = config_default_family;
switch (po_rightmost(options, nfs_transport_opttbl)) {
case 0: /* udp */
return 1;
@@ -1489,11 +1494,7 @@ int nfs_mount_proto_family(struct mount_
unsigned long protocol;
char *option;
-#ifdef HAVE_LIBTIRPC
- *family = AF_UNSPEC;
-#else
- *family = AF_INET;
-#endif
+ *family = config_default_family;
option = po_get(options, "mountproto");
if (option != NULL)

View File

@ -1,31 +0,0 @@
commit 6318d601cf182d2848d397af323ca9c4fbdecb97
Author: Steve Dickson <steved@redhat.com>
Date: Mon Jan 25 13:09:04 2010 -0500
Teach nfs_compare_sockaddr() to handle NULL arguments.
Reviewed-by: Chuck Lever <chuck.lever@oracle.com>
Signed-off-by: Steve Dickson <steved@redhat.com>
diff --git a/support/include/sockaddr.h b/support/include/sockaddr.h
index 732514b..9af2543 100644
--- a/support/include/sockaddr.h
+++ b/support/include/sockaddr.h
@@ -20,6 +20,7 @@
#ifndef NFS_UTILS_SOCKADDR_H
#define NFS_UTILS_SOCKADDR_H
+#include <libio.h>
#include <stdbool.h>
#include <sys/socket.h>
#include <netinet/in.h>
@@ -223,6 +224,9 @@ compare_sockaddr6(__attribute__ ((unused)) const struct sockaddr *sa1,
static inline _Bool
nfs_compare_sockaddr(const struct sockaddr *sa1, const struct sockaddr *sa2)
{
+ if (sa1 == NULL || sa2 == NULL)
+ return false;
+
if (sa1->sa_family == sa2->sa_family)
switch (sa1->sa_family) {
case AF_INET:

File diff suppressed because it is too large Load Diff

View File

@ -1,6 +1,6 @@
diff -up nfs-utils-1.2.1/configure.ac.orig nfs-utils-1.2.1/configure.ac
--- nfs-utils-1.2.1/configure.ac.orig 2010-01-15 11:10:25.080854089 -0500
+++ nfs-utils-1.2.1/configure.ac 2010-01-15 11:11:03.872749424 -0500
diff -up nfs-utils-1.2.2/configure.ac.orig nfs-utils-1.2.2/configure.ac
--- nfs-utils-1.2.2/configure.ac.orig 2010-02-18 07:35:00.000000000 -0500
+++ nfs-utils-1.2.2/configure.ac 2010-02-18 09:15:24.710128679 -0500
@@ -22,6 +22,14 @@ AC_ARG_WITH(statedir,
statedir=$withval,
statedir=/var/lib/nfs)
@ -16,7 +16,7 @@ diff -up nfs-utils-1.2.1/configure.ac.orig nfs-utils-1.2.1/configure.ac
AC_ARG_WITH(statduser,
[AC_HELP_STRING([--with-statduser=rpcuser],
[statd to run under @<:@rpcuser or nobody@:>@]
@@ -350,6 +358,9 @@ dnl ************************************
@@ -364,6 +372,9 @@ dnl ************************************
dnl Export some path names to config.h
dnl *************************************************************
AC_DEFINE_UNQUOTED(NFS_STATEDIR, "$statedir", [This defines the location of the NFS state files. Warning: this must match definitions in config.mk!])
@ -26,9 +26,9 @@ diff -up nfs-utils-1.2.1/configure.ac.orig nfs-utils-1.2.1/configure.ac
if test "x$cross_compiling" = "xno"; then
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-"$CFLAGS"}
diff -up nfs-utils-1.2.1/support/nsm/file.c.orig nfs-utils-1.2.1/support/nsm/file.c
--- nfs-utils-1.2.1/support/nsm/file.c.orig 2010-01-15 11:10:25.086884939 -0500
+++ nfs-utils-1.2.1/support/nsm/file.c 2010-01-15 11:11:03.873769833 -0500
diff -up nfs-utils-1.2.2/support/nsm/file.c.orig nfs-utils-1.2.2/support/nsm/file.c
--- nfs-utils-1.2.2/support/nsm/file.c.orig 2010-02-18 07:35:00.000000000 -0500
+++ nfs-utils-1.2.2/support/nsm/file.c 2010-02-18 09:15:24.711128045 -0500
@@ -93,12 +93,13 @@
#define NSM_KERNEL_STATE_FILE "/proc/sys/fs/nfs/nsm_local_state"

View File

@ -1,8 +1,8 @@
Summary: NFS utilities and supporting clients and daemons for the kernel NFS server
Name: nfs-utils
URL: http://sourceforge.net/projects/nfs
Version: 1.2.1
Release: 17%{?dist}
Version: 1.2.2
Release: 1%{?dist}
Epoch: 1
# group all 32bit related archs
@ -18,13 +18,9 @@ Source13: rpcgssd.init
Source14: rpcsvcgssd.init
Source15: nfs.sysconfig
Patch000: nfs-utils-1.2.2-rc9.patch
Patch001: nfs-utils-1.2.1-statdpath.patch
Patch002: nfs-utils-1.2.1-default-family.patch
Patch003: nfs-utils-1.2.1-statd-null-addrs.patch
Patch100: nfs-utils-1.2.1-statdpath-man.patch
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
Patch101: nfs-utils-1.2.2-statdpath.patch
Patch102: nfs-utils-1.2.1-exp-subtree-warn-off.patch
Group: System Environment/Daemons
Provides: exportfs = %{epoch}:%{version}-%{release}
@ -73,13 +69,9 @@ This package also contains the mount.nfs and umount.nfs program.
%prep
%setup -q
%patch000 -p1
%patch001 -p1
%patch002 -p1
%patch003 -p1
%patch100 -p1
%patch101 -p1
%patch102 -p1
# Remove .orig files
find . -name "*.orig" | xargs rm -f
@ -100,9 +92,9 @@ CFLAGS="`echo $RPM_OPT_FLAGS $ARCH_OPT_FLAGS $PIE -D_FILE_OFFSET_BITS=64`"
CFLAGS="$CFLAGS" \
CPPFLAGS="$DEFINES" \
LDFLAGS="-pie" \
--enable-mount \
--enable-mountconfig \
--enable-ipv6 \
--enable-nfsv41 \
--with-statdpath=/var/lib/nfs/statd
make all
@ -253,6 +245,9 @@ fi
%attr(4755,root,root) /sbin/umount.nfs4
%changelog
* Thu Feb 18 2010 Steve Dickson <steved@redhat.com> 1.2.2-1
- Updated to latest upstream version: 1.2.2
* Thu Jan 28 2010 Steve Dickson <steved@redhat.com> 1.2.1-17
- Backed out the "Don't fail mounts when /etc/netconfig is
nonexistent" patch

View File

@ -1,2 +1,2 @@
ae7db9c61c5ad04f83bb99e5caed73da nfs.doc.tar.gz
c3ccd16c147befd49fe4541a506dd177 nfs-utils-1.2.1.tar.bz2
dad92f64db3266c7757f71bb53ee8f35 nfs-utils-1.2.2.tar.bz2