Updated to latest RC release: nfs-utils-2-3-4-rc2
Addeding libxml2-devel dependency Make sure /etc/sysconfig/nfs is immutable Added Requires: e2fsprogs (bz 1647727) nfsref: switch the way libraries are linked Signed-off-by: Steve Dickson <steved@redhat.com>
This commit is contained in:
parent
2a7dc21ee2
commit
684c60c247
29
nfs-utils-2.3.3-nfsref-linking.patch
Normal file
29
nfs-utils-2.3.3-nfsref-linking.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
commit 47aa0c9683e048eb325dc9779a5aff41250c2c68
|
||||||
|
Author: Steve Dickson <steved@redhat.com>
|
||||||
|
Date: Tue Dec 11 12:51:37 2018 -0500
|
||||||
|
|
||||||
|
nfsref: switch the way libraries are linked.
|
||||||
|
|
||||||
|
Link the static libs before the dynamic libs allowing
|
||||||
|
the routines in the static libs to be defined
|
||||||
|
by the dynamic libs
|
||||||
|
|
||||||
|
Signed-off-by: Steve Dickson <steved@redhat.com>
|
||||||
|
|
||||||
|
diff --git a/utils/nfsref/Makefile.am b/utils/nfsref/Makefile.am
|
||||||
|
index 44edc83..2409dd0 100644
|
||||||
|
--- a/utils/nfsref/Makefile.am
|
||||||
|
+++ b/utils/nfsref/Makefile.am
|
||||||
|
@@ -27,9 +27,9 @@ noinst_HEADERS = nfsref.h
|
||||||
|
|
||||||
|
sbin_PROGRAMS = nfsref
|
||||||
|
nfsref_SOURCES = add.c lookup.c nfsref.c remove.c
|
||||||
|
-LDADD = $(LIBXML2) $(LIBCAP) \
|
||||||
|
- ../../support/nfs/libnfs.la \
|
||||||
|
- ../../support/junction/libjunction.la
|
||||||
|
+LDADD = ../../support/nfs/libnfs.la \
|
||||||
|
+ ../../support/junction/libjunction.la \
|
||||||
|
+ $(LIBXML2) $(LIBCAP)
|
||||||
|
|
||||||
|
man8_MANS = nfsref.man
|
||||||
|
|
@ -18,6 +18,7 @@ Source6: nfsconvert.sh
|
|||||||
Source7: nfs-convert.service
|
Source7: nfs-convert.service
|
||||||
|
|
||||||
Patch001: nfs-utils.2.3.4-rc2.patch
|
Patch001: nfs-utils.2.3.4-rc2.patch
|
||||||
|
Patch002: nfs-utils-2.3.3-nfsref-linking.patch
|
||||||
|
|
||||||
Patch100: nfs-utils-1.2.1-statdpath-man.patch
|
Patch100: nfs-utils-1.2.1-statdpath-man.patch
|
||||||
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
|
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
|
||||||
@ -44,12 +45,12 @@ Provides: start-statd = %{epoch}:%{version}-%{release}
|
|||||||
|
|
||||||
License: MIT and GPLv2 and GPLv2+ and BSD
|
License: MIT and GPLv2 and GPLv2+ and BSD
|
||||||
Requires: rpcbind, sed, gawk, grep
|
Requires: rpcbind, sed, gawk, grep
|
||||||
Requires: kmod, keyutils, quota
|
Requires: kmod, keyutils, quota, e2fsprogs
|
||||||
BuildRequires: libevent-devel libcap-devel
|
BuildRequires: libevent-devel libcap-devel
|
||||||
BuildRequires: libtirpc-devel libblkid-devel
|
BuildRequires: libtirpc-devel libblkid-devel
|
||||||
BuildRequires: krb5-libs >= 1.4 autoconf >= 2.57 openldap-devel >= 2.2
|
BuildRequires: krb5-libs >= 1.4 autoconf >= 2.57 openldap-devel >= 2.2
|
||||||
BuildRequires: automake, libtool, gcc, device-mapper-devel
|
BuildRequires: automake, libtool, gcc, device-mapper-devel
|
||||||
BuildRequires: krb5-devel, libmount-devel
|
BuildRequires: krb5-devel, libmount-devel, libxml2-devel
|
||||||
BuildRequires: sqlite-devel
|
BuildRequires: sqlite-devel
|
||||||
BuildRequires: python3-devel
|
BuildRequires: python3-devel
|
||||||
BuildRequires: systemd
|
BuildRequires: systemd
|
||||||
@ -315,8 +316,12 @@ fi
|
|||||||
%{_libdir}/libnfsidmap.so
|
%{_libdir}/libnfsidmap.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Mon Dec 10 2018 Steve Dickson <steved@redhat.com> 2.3.3-3.rc2
|
* Tue Dec 11 2018 Steve Dickson <steved@redhat.com> 2.3.3-3.rc2
|
||||||
- Updated to latest RC release: nfs-utils-2-3-4-rc2
|
- Updated to latest RC release: nfs-utils-2-3-4-rc2
|
||||||
|
- Addeding libxml2-devel dependency
|
||||||
|
- Make sure /etc/sysconfig/nfs is immutable
|
||||||
|
- Added Requires: e2fsprogs (bz 1647727)
|
||||||
|
- nfsref: switch the way libraries are linked
|
||||||
|
|
||||||
* Fri Nov 9 2018 Steve Dickson <steved@redhat.com> 2.3.3-3.rc1
|
* Fri Nov 9 2018 Steve Dickson <steved@redhat.com> 2.3.3-3.rc1
|
||||||
- Fix typo in the spec file.
|
- Fix typo in the spec file.
|
||||||
|
@ -16,6 +16,10 @@ fi
|
|||||||
#
|
#
|
||||||
grep "nfs.conf" /etc/sysconfig/nfs > /dev/null
|
grep "nfs.conf" /etc/sysconfig/nfs > /dev/null
|
||||||
if [ $? -eq 0 ]; then
|
if [ $? -eq 0 ]; then
|
||||||
|
# Make sure the file is immutable.
|
||||||
|
if [ -w /etc/sysconfig/nfs ]; then
|
||||||
|
chattr +i /etc/sysconfig/nfs
|
||||||
|
fi
|
||||||
exit 0
|
exit 0
|
||||||
fi
|
fi
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user