Update to upstream RC release: nfs-utils-1.2.6-rc2
Signed-off-by: Steve Dickson <steved@redhat.com>
This commit is contained in:
parent
348eec39ed
commit
5987d19fcf
@ -1,30 +0,0 @@
|
||||
commit 8f065a26d49eabebc3995b8f6966b15ef7553b3e
|
||||
Author: Luca Giuzzi <luca.giuzzi@gmail.com>
|
||||
Date: Tue Oct 4 13:35:06 2011 -0400
|
||||
|
||||
rpc.idmapd: Dies with 'I/O possible'
|
||||
|
||||
We have had problems on some of our machines (all Fedora 14), where
|
||||
rpc.idmapd used to die with an `I/O possible' message at (basically)
|
||||
random times. A strace suggested the issue being in nfsopen() where a
|
||||
signal type is reset before notification is disabled; a signal at just
|
||||
the right time might be the cause of the problem; see
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=684308
|
||||
|
||||
Reviewed-by: Jeff Layton <jlayton@redhat.com>
|
||||
Signed-off-by: Steve Dickson <steved@redhat.com>
|
||||
|
||||
diff --git a/utils/idmapd/idmapd.c b/utils/idmapd/idmapd.c
|
||||
index 19d9114..e80efb4 100644
|
||||
--- a/utils/idmapd/idmapd.c
|
||||
+++ b/utils/idmapd/idmapd.c
|
||||
@@ -778,8 +778,8 @@ nfsopen(struct idmap_client *ic)
|
||||
} else {
|
||||
event_set(&ic->ic_event, ic->ic_fd, EV_READ, nfscb, ic);
|
||||
event_add(&ic->ic_event, NULL);
|
||||
- fcntl(ic->ic_dirfd, F_SETSIG, 0);
|
||||
fcntl(ic->ic_dirfd, F_NOTIFY, 0);
|
||||
+ fcntl(ic->ic_dirfd, F_SETSIG, 0);
|
||||
if (verbose > 0)
|
||||
xlog_warn("Opened %s", ic->ic_path);
|
||||
}
|
@ -1,65 +0,0 @@
|
||||
commit 079f3021929e002b2a59104de3af923fcb49cd9c
|
||||
Author: Steve Dickson <steved@redhat.com>
|
||||
Date: Tue Oct 4 12:39:08 2011 -0400
|
||||
|
||||
man pages: fixed a few typos in a couple man pages
|
||||
|
||||
Signed-off-by: Steve Dickson <steved@redhat.com>
|
||||
|
||||
diff --git a/utils/exportfs/exportfs.man b/utils/exportfs/exportfs.man
|
||||
index 364f247..8853486 100644
|
||||
--- a/utils/exportfs/exportfs.man
|
||||
+++ b/utils/exportfs/exportfs.man
|
||||
@@ -177,7 +177,7 @@ In this way
|
||||
.B exportfs
|
||||
can be used to modify the export options of an already exported directory.
|
||||
.SS Unexporting Directories
|
||||
-The third synopsis shows how to unexported a currently exported directory.
|
||||
+The third synopsis shows how to unexport a currently exported directory.
|
||||
When using
|
||||
.BR "exportfs -ua" ,
|
||||
all entries listed in
|
||||
diff --git a/utils/exportfs/nfsd.man b/utils/exportfs/nfsd.man
|
||||
index 7365a1b..47b73be 100644
|
||||
--- a/utils/exportfs/nfsd.man
|
||||
+++ b/utils/exportfs/nfsd.man
|
||||
@@ -12,7 +12,7 @@ nfsd \- special filesystem for controlling Linux NFS server
|
||||
.SH DESCRIPTION
|
||||
The
|
||||
.B nfsd
|
||||
-filesytem is a special filesystem which provides access to the Linux
|
||||
+filesystem is a special filesystem which provides access to the Linux
|
||||
NFS server. The filesystem consists of a single directory which
|
||||
contains a number of files. These files are actually gateways into
|
||||
the NFS server. Writing to them can affect the server. Reading from
|
||||
@@ -86,7 +86,7 @@ should be followed by a newline, with white-space separating the
|
||||
fields, and octal quoting of special characters.
|
||||
|
||||
On writing this, the program will be able to read back a filehandle
|
||||
-for that path as exported to the given client. The filehandles length
|
||||
+for that path as exported to the given client. The filehandle's length
|
||||
will be at most the number of bytes given.
|
||||
|
||||
The filehandle will be represented in hex with a leading '\ex'.
|
||||
@@ -165,7 +165,7 @@ file. The user-space program might then write
|
||||
.ti +5
|
||||
nfsd 127.0.0.1 1057206953 localhost
|
||||
.br
|
||||
-to indicate that 127.0.0.1 should map to localhost, atleast for now.
|
||||
+to indicate that 127.0.0.1 should map to localhost, at least for now.
|
||||
|
||||
If the program uses select(2) or poll(2) to discover if it can read
|
||||
from the
|
||||
diff --git a/utils/nfsd/nfsd.man b/utils/nfsd/nfsd.man
|
||||
index d8988d2..1cf9296 100644
|
||||
--- a/utils/nfsd/nfsd.man
|
||||
+++ b/utils/nfsd/nfsd.man
|
||||
@@ -38,7 +38,7 @@ request on all known network addresses. This may change in future
|
||||
releases of the Linux Kernel.
|
||||
.TP
|
||||
.B \-p " or " \-\-port port
|
||||
-specify a diferent port to listen on for NFS requests. By default,
|
||||
+specify a different port to listen on for NFS requests. By default,
|
||||
.B rpc.nfsd
|
||||
will listen on port 2049.
|
||||
.TP
|
File diff suppressed because it is too large
Load Diff
147
nfs-utils-1.2.6-rc2.patch
Normal file
147
nfs-utils-1.2.6-rc2.patch
Normal file
@ -0,0 +1,147 @@
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 80fb39d..f101b86 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -265,6 +265,12 @@ if test "$enable_nfsv4" = yes; then
|
||||
AC_RPCSEC_VERSION
|
||||
fi
|
||||
fi
|
||||
+
|
||||
+if test "$enable_nfsv41" = yes; then
|
||||
+ AC_CHECK_LIB([devmapper], [dm_task_create], [LIBDEVMAPPER="-ldevmapper"], AC_MSG_ERROR([libdevmapper needed]))
|
||||
+ AC_CHECK_HEADER(libdevmapper.h, , AC_MSG_ERROR([Cannot find devmapper header file libdevmapper.h]))
|
||||
+fi
|
||||
+
|
||||
dnl enable nfsidmap when its support by libnfsidmap
|
||||
AM_CONDITIONAL(CONFIG_NFSIDMAP, [test "$ac_cv_header_keyutils_h$ac_cv_lib_nfsidmap_nfs4_owner_to_uid" = "yesyes"])
|
||||
|
||||
diff --git a/utils/blkmapd/device-process.c b/utils/blkmapd/device-process.c
|
||||
index 27ff374..652a7a8 100644
|
||||
--- a/utils/blkmapd/device-process.c
|
||||
+++ b/utils/blkmapd/device-process.c
|
||||
@@ -296,7 +296,7 @@ decode_blk_volume(uint32_t **pp, uint32_t *end, struct bl_volume *vols, int voln
|
||||
off_t stripe_unit = vol->param.bv_stripe_unit;
|
||||
/* Check limitations imposed by device-mapper */
|
||||
if ((stripe_unit & (stripe_unit - 1)) != 0
|
||||
- || stripe_unit < (off_t) (PAGE_SIZE >> 9))
|
||||
+ || stripe_unit < (off_t) (sysconf(_SC_PAGE_SIZE) >> 9))
|
||||
return -EIO;
|
||||
BLK_READBUF(p, end, 4);
|
||||
READ32(vol->bv_vol_n);
|
||||
diff --git a/utils/exportfs/exportfs.man b/utils/exportfs/exportfs.man
|
||||
index 364f247..8853486 100644
|
||||
--- a/utils/exportfs/exportfs.man
|
||||
+++ b/utils/exportfs/exportfs.man
|
||||
@@ -177,7 +177,7 @@ In this way
|
||||
.B exportfs
|
||||
can be used to modify the export options of an already exported directory.
|
||||
.SS Unexporting Directories
|
||||
-The third synopsis shows how to unexported a currently exported directory.
|
||||
+The third synopsis shows how to unexport a currently exported directory.
|
||||
When using
|
||||
.BR "exportfs -ua" ,
|
||||
all entries listed in
|
||||
diff --git a/utils/exportfs/nfsd.man b/utils/exportfs/nfsd.man
|
||||
index 7365a1b..47b73be 100644
|
||||
--- a/utils/exportfs/nfsd.man
|
||||
+++ b/utils/exportfs/nfsd.man
|
||||
@@ -12,7 +12,7 @@ nfsd \- special filesystem for controlling Linux NFS server
|
||||
.SH DESCRIPTION
|
||||
The
|
||||
.B nfsd
|
||||
-filesytem is a special filesystem which provides access to the Linux
|
||||
+filesystem is a special filesystem which provides access to the Linux
|
||||
NFS server. The filesystem consists of a single directory which
|
||||
contains a number of files. These files are actually gateways into
|
||||
the NFS server. Writing to them can affect the server. Reading from
|
||||
@@ -86,7 +86,7 @@ should be followed by a newline, with white-space separating the
|
||||
fields, and octal quoting of special characters.
|
||||
|
||||
On writing this, the program will be able to read back a filehandle
|
||||
-for that path as exported to the given client. The filehandles length
|
||||
+for that path as exported to the given client. The filehandle's length
|
||||
will be at most the number of bytes given.
|
||||
|
||||
The filehandle will be represented in hex with a leading '\ex'.
|
||||
@@ -165,7 +165,7 @@ file. The user-space program might then write
|
||||
.ti +5
|
||||
nfsd 127.0.0.1 1057206953 localhost
|
||||
.br
|
||||
-to indicate that 127.0.0.1 should map to localhost, atleast for now.
|
||||
+to indicate that 127.0.0.1 should map to localhost, at least for now.
|
||||
|
||||
If the program uses select(2) or poll(2) to discover if it can read
|
||||
from the
|
||||
diff --git a/utils/idmapd/idmapd.c b/utils/idmapd/idmapd.c
|
||||
index 19d9114..e80efb4 100644
|
||||
--- a/utils/idmapd/idmapd.c
|
||||
+++ b/utils/idmapd/idmapd.c
|
||||
@@ -778,8 +778,8 @@ nfsopen(struct idmap_client *ic)
|
||||
} else {
|
||||
event_set(&ic->ic_event, ic->ic_fd, EV_READ, nfscb, ic);
|
||||
event_add(&ic->ic_event, NULL);
|
||||
- fcntl(ic->ic_dirfd, F_SETSIG, 0);
|
||||
fcntl(ic->ic_dirfd, F_NOTIFY, 0);
|
||||
+ fcntl(ic->ic_dirfd, F_SETSIG, 0);
|
||||
if (verbose > 0)
|
||||
xlog_warn("Opened %s", ic->ic_path);
|
||||
}
|
||||
diff --git a/utils/mount/nfs.man b/utils/mount/nfs.man
|
||||
index ce40933..2ad92d1 100644
|
||||
--- a/utils/mount/nfs.man
|
||||
+++ b/utils/mount/nfs.man
|
||||
@@ -1561,10 +1561,10 @@ To ensure that the saved mount options are not erased during a remount,
|
||||
specify either the local mount directory, or the server hostname and
|
||||
export pathname, but not both, during a remount. For example,
|
||||
.P
|
||||
-.NF
|
||||
-.TA 2.5i
|
||||
+.nf
|
||||
+.ta 8n
|
||||
mount -o remount,ro /mnt
|
||||
-.FI
|
||||
+.fi
|
||||
.P
|
||||
merges the mount option
|
||||
.B ro
|
||||
diff --git a/utils/mount/stropts.c b/utils/mount/stropts.c
|
||||
index 314a806..4032bf3 100644
|
||||
--- a/utils/mount/stropts.c
|
||||
+++ b/utils/mount/stropts.c
|
||||
@@ -665,9 +665,10 @@ static int nfs_try_mount_v3v2(struct nfsmount_info *mi)
|
||||
case EHOSTUNREACH:
|
||||
continue;
|
||||
default:
|
||||
- break;
|
||||
+ goto out;
|
||||
}
|
||||
}
|
||||
+out:
|
||||
return ret;
|
||||
}
|
||||
|
||||
@@ -751,9 +752,10 @@ static int nfs_try_mount_v4(struct nfsmount_info *mi)
|
||||
case EHOSTUNREACH:
|
||||
continue;
|
||||
default:
|
||||
- break;
|
||||
+ goto out;
|
||||
}
|
||||
}
|
||||
+out:
|
||||
return ret;
|
||||
}
|
||||
|
||||
diff --git a/utils/nfsd/nfsd.man b/utils/nfsd/nfsd.man
|
||||
index d8988d2..1cf9296 100644
|
||||
--- a/utils/nfsd/nfsd.man
|
||||
+++ b/utils/nfsd/nfsd.man
|
||||
@@ -38,7 +38,7 @@ request on all known network addresses. This may change in future
|
||||
releases of the Linux Kernel.
|
||||
.TP
|
||||
.B \-p " or " \-\-port port
|
||||
-specify a diferent port to listen on for NFS requests. By default,
|
||||
+specify a different port to listen on for NFS requests. By default,
|
||||
.B rpc.nfsd
|
||||
will listen on port 2049.
|
||||
.TP
|
@ -2,7 +2,7 @@ Summary: NFS utilities and supporting clients and daemons for the kernel NFS ser
|
||||
Name: nfs-utils
|
||||
URL: http://sourceforge.net/projects/nfs
|
||||
Version: 1.2.5
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Epoch: 1
|
||||
|
||||
# group all 32bit related archs
|
||||
@ -28,10 +28,8 @@ Source51: nfs-server.preconfig
|
||||
Source52: nfs-server.postconfig
|
||||
%define nfs_configs %{SOURCE50} %{SOURCE51} %{SOURCE52}
|
||||
|
||||
Patch001: nfs-utils-1.2.6-rc1.patch
|
||||
Patch001: nfs-utils-1.2.6-rc2.patch
|
||||
Patch002: nfs-utils-1.2.4-mountshortcut.patch
|
||||
Patch003: nfs-utils-1.2.5-manpage-typos.patch
|
||||
Patch004: nfs-utils-1.2.5-idmapd-ioerror.patch
|
||||
|
||||
Patch100: nfs-utils-1.2.1-statdpath-man.patch
|
||||
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
|
||||
@ -89,8 +87,6 @@ This package also contains the mount.nfs and umount.nfs program.
|
||||
|
||||
%patch001 -p1
|
||||
%patch002 -p1
|
||||
%patch003 -p1
|
||||
%patch004 -p1
|
||||
|
||||
%patch100 -p1
|
||||
%patch101 -p1
|
||||
@ -278,6 +274,9 @@ fi
|
||||
%attr(0755,root,root) /sbin/umount.nfs4
|
||||
|
||||
%changelog
|
||||
* Tue Oct 18 2011 Steve Dickson <steved@redhat.com> 1.2.5-3
|
||||
- Update to upstream RC release: nfs-utils-1.2.6-rc2
|
||||
|
||||
* Tue Oct 4 2011 Steve Dickson <steved@redhat.com> 1.2.5-2
|
||||
- Removed SUID bits on mount commands (bz 528498)
|
||||
- Fixed a few typos in a couple man pages (bz 668124, 673818, 664330)
|
||||
|
Loading…
Reference in New Issue
Block a user