mount.nfs: retry NFSv3 mount after NFSv4 failure in auto negotiation

(RHEL-68574)

Signed-off-by: Steve Dickson <steved@redhat.com>
Resolves: RHEL-68574
This commit is contained in:
Steve Dickson 2024-11-24 14:09:34 -05:00
parent dc0832eb24
commit 42ca37ba87
2 changed files with 14 additions and 0 deletions

View File

@ -0,0 +1,12 @@
diff -up nfs-utils-2.5.4/utils/mount/stropts.c.orig nfs-utils-2.5.4/utils/mount/stropts.c
--- nfs-utils-2.5.4/utils/mount/stropts.c.orig 2024-11-24 08:36:03.734689817 -0500
+++ nfs-utils-2.5.4/utils/mount/stropts.c 2024-11-24 08:37:52.541239493 -0500
@@ -973,7 +973,7 @@ fall_back:
if ((result = nfs_try_mount_v3v2(mi, FALSE)))
return result;
- if (errno != EBUSY && errno != EACCES)
+ if (errno != EBUSY && errno != EACCES && errno != ETIMEDOUT)
errno = olderrno;
return result;

View File

@ -70,6 +70,7 @@ Patch027: nfs-utils-2.5.4-gssd-segfault.patch
#
Patch028: nfs-utils-2.5.4-rpcidmapd-nfsopen-failure.patch
Patch029: nfs-utils-2.5.4-mount-writable.patch
Patch030: nfs-utils-2.5.4-mount-v3-retry.patch
Patch100: nfs-utils-1.2.1-statdpath-man.patch
Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
@ -513,6 +514,7 @@ fi
%changelog
* Sun Nov 24 2024 Steve Dickson <steved@redhat.com> 2.5.4-28
- Makefile.am: allow mount.nfs to be writeable by owner (RHEL-68701)
- mount.nfs: retry NFSv3 mount after NFSv4 failure in auto negotiation (RHEL-68574)
* Thu Nov 14 2024 Steve Dickson <steved@redhat.com> 2.5.4-28
- rpc.idmapd: nfsopen() failures should not be fatal (RHEL-65727)