diff --git a/.gitignore b/.gitignore
index 950b496..007ec25 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1 @@
-SOURCES/network-manager-applet-1.26.0.tar.xz
+network-manager-applet-1.36.0.tar.xz
diff --git a/.network-manager-applet.metadata b/.network-manager-applet.metadata
deleted file mode 100644
index d7ae136..0000000
--- a/.network-manager-applet.metadata
+++ /dev/null
@@ -1 +0,0 @@
-c65b00c6b9280a1ad50f656234edcea28afc77cc SOURCES/network-manager-applet-1.26.0.tar.xz
diff --git a/0001-nm-applet-no-notifications.patch b/0001-nm-applet-no-notifications.patch
new file mode 100644
index 0000000..be6b6bf
--- /dev/null
+++ b/0001-nm-applet-no-notifications.patch
@@ -0,0 +1,13 @@
+diff --git a/org.gnome.nm-applet.gschema.xml.in b/org.gnome.nm-applet.gschema.xml.in
+index 9e2887e..4f8c16a 100644
+--- a/org.gnome.nm-applet.gschema.xml.in
++++ b/org.gnome.nm-applet.gschema.xml.in
+@@ -17,7 +17,7 @@
+ Set this to true to disable notifications when connecting to or disconnecting from a VPN.
+
+
+- false
++ true
+ Suppress networks available notifications
+ Set this to true to disable notifications when Wi-Fi networks are available.
+
diff --git a/SPECS/network-manager-applet.spec b/network-manager-applet.spec
similarity index 71%
rename from SPECS/network-manager-applet.spec
rename to network-manager-applet.spec
index ff903e7..1b20b79 100644
--- a/SPECS/network-manager-applet.spec
+++ b/network-manager-applet.spec
@@ -5,13 +5,7 @@
%global libnma_version 1.8.27
%global obsoletes_ver 1:0.9.7
-%global rpm_version 1.26.0
-%global real_version 1.26.0
-%global release_version 1
-
-%global real_version_major %(printf '%s' '%{real_version}' | sed -n 's/^\\([1-9][0-9]*\\.[1-9][0-9]*\\)\\.[1-9][0-9]*$/\\1/p')
-
-%if 0%{?fedora} > 31 || 0%{?rhel} > 7
+%if 0%{?fedora} > 31 || 0%{?rhel} > 8
%bcond_with libnma_gtk4
%else
%bcond_without libnma_gtk4
@@ -25,17 +19,16 @@
Name: network-manager-applet
Summary: A network control and status applet for NetworkManager
-Version: %{rpm_version}
-Release: %{release_version}%{?dist}
-License: GPLv2+
+Version: 1.36.0
+Release: 3%{?dist}
+License: GPL-2.0-or-later
URL: http://www.gnome.org/projects/NetworkManager/
Obsoletes: NetworkManager-gnome < %{obsoletes_ver}
-Source: https://download.gnome.org/sources/network-manager-applet/%{real_version_major}/%{name}-%{real_version}.tar.xz
-# Patch1: 0001-Patch.patch
+Source: https://download.gnome.org/sources/network-manager-applet/1.36/%{name}-%{version}.tar.xz
+Patch1: 0001-nm-applet-no-notifications.patch
Requires: NetworkManager >= %{nm_version}
-Requires: libnotify >= 0.4.3
Requires: nm-connection-editor%{?_isa} = %{version}-%{release}
Requires: libnma%{?_isa} >= %{libnma_version}
@@ -51,13 +44,11 @@ BuildRequires: gobject-introspection-devel >= 0.10.3
BuildRequires: gettext-devel
BuildRequires: /usr/bin/autopoint
BuildRequires: pkgconfig
-BuildRequires: libnotify-devel >= 0.4
BuildRequires: meson
BuildRequires: intltool
BuildRequires: gtk-doc
BuildRequires: desktop-file-utils
BuildRequires: iso-codes-devel
-BuildRequires: libgudev1-devel >= 147
BuildRequires: libsecret-devel >= 0.12
BuildRequires: jansson-devel
BuildRequires: gcr-devel
@@ -83,16 +74,24 @@ This package contains a network configuration editor and Bluetooth modem
utility for use with NetworkManager.
+%package -n nm-connection-editor-desktop
+Summary: The desktop file for nm-connection-editor
+Requires: nm-connection-editor%{?_isa} = %{version}-%{release}
+
+%description -n nm-connection-editor-desktop
+This package contains the desktop file and appdata for nm-connection-editor.
+Without it, the nm-connection-editor cannot be started from the desktop
+environment.
+
+
%prep
-%autosetup -p1 -n "%{name}-%{real_version}"
+%autosetup -p1
%build
%meson \
- -Dgcr=true \
-Dselinux=true \
- -Ddisable-static=true \
%if %{with appindicator}
- -Dappindicator=yes
+ -Dappindicator=auto
%else
-Dappindicator=no
%endif
@@ -117,6 +116,7 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/nm-connection-edit
%{_bindir}/nm-applet
%{_datadir}/applications/nm-applet.desktop
%{_datadir}/icons/hicolor/22x22/apps/nm-adhoc.png
+%{_datadir}/icons/hicolor/22x22/apps/nm-insecure-warn.png
%{_datadir}/icons/hicolor/22x22/apps/nm-mb-roam.png
%{_datadir}/icons/hicolor/22x22/apps/nm-secure-lock.png
%{_datadir}/icons/hicolor/22x22/apps/nm-signal-*.png
@@ -126,7 +126,7 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/nm-connection-edit
%{_datadir}/icons/hicolor/22x22/apps/nm-vpn-connecting*.png
%{_datadir}/icons/hicolor/22x22/apps/nm-wwan-tower.png
%{_datadir}/icons/hicolor/scalable/apps/*.svg
-%{_datadir}/icons/hicolor/22x22/apps/nm-insecure-warn.png
+%{_datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
%{_datadir}/GConf/gsettings/nm-applet.convert
%{_sysconfdir}/xdg/autostart/nm-applet.desktop
%{_mandir}/man1/nm-applet*
@@ -137,57 +137,163 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/nm-connection-edit
# is the RPM that everything else depends on
%files -n nm-connection-editor -f %{name}.lang
%{_bindir}/nm-connection-editor
-%{_datadir}/applications/nm-connection-editor.desktop
%{_datadir}/icons/hicolor/*/apps/nm-device-*.*
%{_datadir}/icons/hicolor/*/apps/nm-no-connection.*
%{_datadir}/icons/hicolor/16x16/apps/nm-vpn-standalone-lock.png
-%{_datadir}/metainfo/nm-connection-editor.appdata.xml
%{_mandir}/man1/nm-connection-editor*
%dir %{_datadir}/gnome-vpn-properties
+%files -n nm-connection-editor-desktop
+%{_datadir}/applications/nm-connection-editor.desktop
+%{_datadir}/metainfo/nm-connection-editor.appdata.xml
+
+
%changelog
-* Tue Mar 22 2022 Ana Cabral - 1.26.0-1
-- Update to 1.26.0 release (rh #2066746)
+* Mon Jun 24 2024 Troy Dawson - 1.36.0-3
+- Bump release for June 2024 mass rebuild
-* Tue Feb 22 2022 Ana Cabral - 1.24.0-4
-- Fix OWE settings disappearing on nm-connection-editor (rh #2023162)
+* Thu Jan 25 2024 Fedora Release Engineering - 1.36.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
-* Mon Nov 22 2021 Ana Cabral - 1.24.0-3
-- Update the spec file
+* Fri Jan 19 2024 Íñigo Huguet - 1.36.0-1
+- Update to 1.36.0 release
-* Tue Sep 14 2021 Ana Cabral - 1.24.0-2
-- Rebuild package
+* Thu Nov 2 2023 Íñigo Huguet - 1.34.0-2
+- migrate to SPDX license
-* Mon Sep 6 2021 Ana Cabral - 1.24.0-1
-- Update to 1.24.0 release (rh #2001638)
+* Mon Oct 16 2023 Beniamino Galvani - 1.34.0-1
+- Update to 1.34.0 release
-* Mon Aug 16 2021 Ana Cabral - 1.18.0-3
-- Fix German translation (rh #1938625, rh #1938627)
+* Thu Jul 20 2023 Fedora Release Engineering - 1.32.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
-* Mon Jul 20 2020 Beniamino Galvani - 1.18.0-2
-- Import translations (rh #1820554)
+* Sun Apr 16 2023 Lubomir Rintel - 1.32.0-1
+- Update to 1.32.0 release
-* Mon Jun 22 2020 Beniamino Galvani - 1.18.0-1
-- Update to 1.18.0 release (rh #1814748)
+* Fri Feb 17 2023 Lubomir Rintel - 1.30.0-3
+- applet: use appindicator if we can outside of X11
-* Mon May 18 2020 Beniamino Galvani - 1.8.22-3
-- Drop gschema XML which conflicts with new libnma package
+* Thu Jan 19 2023 Fedora Release Engineering - 1.30.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
-* Thu Aug 15 2019 Lubomir Rintel - 1.8.22-2
-- Update translations (rh #1690001)
+* Mon Nov 07 2022 Lubomir Rintel - 1.30.0-1
+- Update to 1.30.0 release
-* Thu May 30 2019 Beniamino Galvani - 1.8.22-1
+* Fri Jul 22 2022 Fedora Release Engineering - 1.28.0-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
+
+* Tue Jun 07 2022 Lubomir Rintel - 1.28.0-1
+- Update to 1.28.0 release
+
+* Fri May 13 2022 Thomas Haller - 1.26.0-2
+- Rebuild and spec file cleanup
+
+* Tue Mar 29 2022 Ana Cabral - 1.26.0-1.1
+- Update to 1.26.0 release
+
+* Thu Jan 20 2022 Fedora Release Engineering - 1.24.0-1.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
+
+* Thu Aug 19 2021 Beniamino Galvani - 1.24.0-1.1
+- Update to 1.24.0 release
+
+* Thu Jul 22 2021 Fedora Release Engineering - 1.22.0-1.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
+
+* Mon May 10 2021 Beniamino Galvani - 1.22.0-1
+- Update to 1.22.0 release
+- editor: fix crash evaluating secondary connections (rh #1942905)
+
+* Wed Feb 3 2021 Thomas Haller - 1.20.0-4
+- Update to 1.20.0 release
+- editor: drop NotShowIn=GNOME
+- Use wireless-security code from libnma
+- Add flatpak build configuration
+- applet: hide unmanaged ethernet devices in nm-applet
+- applet: fix Wi-Fi scan requests with appindicator
+- editor: fix drop down list for connection.secondaries
+
+* Tue Feb 2 2021 Thomas Haller - 1.18.0-4
+- Move desktop file to new nm-connection-editor-desktop package (rh #1923262)
+
+* Tue Jan 26 2021 Fedora Release Engineering - 1.18.0-3.2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
+
+* Wed Jan 6 2021 Thomas Haller - 1.18.0-3
+- Build without libdbusmenu-gtk3-devel on RHEL >=9
+
+* Wed Nov 18 2020 Antonio Cardace - 1.18.0-2
+- Build without libappindicator-gtk3-devel on RHEL >=9
+
+* Tue Jul 28 2020 Fedora Release Engineering - 1.18.0-1.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
+
+* Sat Jul 11 2020 Thomas Haller - 1.18.0-1
+- Update to 1.18.0 release
+- Enable build with appindicator by default.
+- Add WireGuard support to the editor.
+- Support OWE (Opportunistic Wireless Encryption) in the editor.
+- Fix crash when disposing VPN secret dialog.
+
+* Thu Apr 30 2020 Ivan Mironov - 1.16.0-2
+- Build with libappindicator which enables Status Notifier Item support
+
+* Sat Mar 7 2020 Thomas Haller - 1.16.0-1
+- Update to 1.16.0 release
+- Move libnma to separate, independent project
+- move org.gnome.nm-applet.gschema.xml to libnma
+
+* Wed Jan 29 2020 Fedora Release Engineering - 1.8.24-1.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
+
+* Wed Oct 09 2019 Lubomir Rintel - 1.8.24-1
+- Update to 1.8.24 release
+- Enable experimental GTK4 build on Rawhide
+
+* Thu Jul 25 2019 Fedora Release Engineering - 1.8.22-1.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
+
+* Wed May 29 2019 Lubomir Rintel - 1.8.22-1
- Update to 1.8.22 release
-* Wed Feb 20 2019 Lubomir Rintel - 1.8.10-5
-- One more translation update (rh #1608325)
+* Wed Feb 27 2019 Beniamino Galvani - 1.8.20-2
+- Fix parsing of hints in wifi secret dialog (rh #1679251)
+- Import other upstream fixes after 1.8.20
-* Tue Oct 16 2018 Lubomir Rintel - 1.8.10-4
-- Update translations (rh #1608325)
+* Fri Feb 08 2019 Beniamino Galvani - 1.8.20-1
+- Update to 1.8.20 release
-* Fri Sep 28 2018 Beniamino Galvani - 1.8.10-3
-- Rebuild with updated annobin (rh #1630604)
+* Fri Feb 01 2019 Fedora Release Engineering - 1.8.18-3.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
+
+* Sat Jan 19 2019 Beniamino Galvani - 1.8.18-3
+- wifi-dialog: fix widget hiding logic (rh #1665653)
+
+* Fri Sep 21 2018 Thomas Haller - 1.8.18-2
+- libnma: fix wrongly showing hidden GUI elements (rh #1626397) (2)
+
+* Fri Sep 7 2018 Thomas Haller - 1.8.18-1
+- Update to 1.8.18 release
+- libnma: fix wrongly showing hidden GUI elements (rh #1626397)
+
+* Sat Aug 11 2018 Lubomir Rintel - 1.8.16-1
+- Update to 1.8.16 release
+
+* Fri Jul 13 2018 Fedora Release Engineering - 1.8.14-1.1
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
+
+* Mon Jun 25 2018 Lubomir Rintel - 1.8.14-1
+- Update to 1.8.14 release
+
+* Mon Jun 4 2018 Thomas Haller - 1.8.12-4
+- applet: fix double-free in ap-menu-item (rh #1585302)
+
+* Fri Jun 01 2018 Adam Williamson - 1.8.12-3
+- Fix GGO #1 (nm-connection-editor --keep-above fails with any other arg)
+
+* Mon May 28 2018 Lubomir Rintel - 1.8.12-2
+- Update to 1.8.12 release
* Fri Feb 09 2018 Igor Gnatenko - 1.8.10-2.2
- Escape macros in %%changelog
diff --git a/sources b/sources
new file mode 100644
index 0000000..d3045d7
--- /dev/null
+++ b/sources
@@ -0,0 +1 @@
+SHA512 (network-manager-applet-1.36.0.tar.xz) = 081cb1f219b0ea44ff15b9ebb3696d976463530317244ce25b18cdc292d453fccd2619cc42ea07798604ed1e5f7c5295bcb7ba148f1ed3312bf8f80d8647e30a