Update to 0.9.5.95 (0.9.6-rc1) snapshot
This commit is contained in:
parent
d30e01e990
commit
b8b06eda40
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@
|
||||
/network-manager-applet-0.9.4.0.git20120328.tar.bz2
|
||||
/network-manager-applet-0.9.4.0.git20120502.tar.bz2
|
||||
/network-manager-applet-0.9.4.1.git20120521.tar.bz2
|
||||
/network-manager-applet-0.9.5.95.git20120713.tar.bz2
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up network-manager-applet-0.9.3.997/configure.ac.foo network-manager-applet-0.9.3.997/configure.ac
|
||||
--- network-manager-applet-0.9.3.997/configure.ac.foo 2011-11-10 15:10:45.268107655 -0600
|
||||
+++ network-manager-applet-0.9.3.997/configure.ac 2011-11-10 15:10:51.902024720 -0600
|
||||
diff -up network-manager-applet-0.9.5.95/configure.ac.foo network-manager-applet-0.9.5.95/configure.ac
|
||||
--- network-manager-applet-0.9.5.95/configure.ac.foo 2011-11-10 15:10:45.268107655 -0600
|
||||
+++ network-manager-applet-0.9.5.95/configure.ac 2011-11-10 15:10:51.902024720 -0600
|
||||
@@ -179,8 +179,6 @@ dnl
|
||||
dnl Compiler flags
|
||||
dnl
|
||||
|
@ -2,16 +2,16 @@
|
||||
%define glib2_version 2.26.0
|
||||
%define dbus_version 1.4
|
||||
%define dbus_glib_version 0.86
|
||||
%define nm_version 1:0.9.4-5
|
||||
%define nm_version 1:0.9.5.95
|
||||
%define obsoletes_ver 1:0.9.3.997-2
|
||||
|
||||
%define snapshot .git20120521
|
||||
%define realversion 0.9.4.1
|
||||
%define snapshot .git20120713
|
||||
%define realversion 0.9.5.95
|
||||
|
||||
Name: network-manager-applet
|
||||
Summary: A network control and status applet for NetworkManager
|
||||
Version: 0.9.4
|
||||
Release: 4%{snapshot}%{?dist}
|
||||
Version: 0.9.5.95
|
||||
Release: 1%{snapshot}%{?dist}
|
||||
Group: Applications/System
|
||||
License: GPLv2+
|
||||
URL: http://www.gnome.org/projects/NetworkManager/
|
||||
@ -139,37 +139,19 @@ desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/nm-connection-edit
|
||||
%post -n libnm-gtk -p /sbin/ldconfig
|
||||
%postun -n libnm-gtk -p /sbin/ldconfig
|
||||
|
||||
%pre
|
||||
if [ "$1" -gt 1 ]; then
|
||||
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||
if [ -f "%{_sysconfdir}/gconf/schemas/nm-applet.schemas" ]; then
|
||||
gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/nm-applet.schemas >/dev/null
|
||||
fi
|
||||
fi
|
||||
|
||||
%preun
|
||||
if [ "$1" -eq 0 ]; then
|
||||
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||
if [ -f "%{_sysconfdir}/gconf/schemas/nm-applet.schemas" ]; then
|
||||
gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/nm-applet.schemas >/dev/null
|
||||
fi
|
||||
fi
|
||||
|
||||
%post
|
||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
|
||||
if [ -f "%{_sysconfdir}/gconf/schemas/nm-applet.schemas" ]; then
|
||||
gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/nm-applet.schemas >/dev/null
|
||||
fi
|
||||
|
||||
%postun
|
||||
if [ $1 -eq 0 ] ; then
|
||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null || :
|
||||
fi
|
||||
|
||||
%posttrans
|
||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas >&/dev/null || :
|
||||
|
||||
|
||||
%post -n nm-connection-editor
|
||||
@ -189,6 +171,7 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%doc COPYING NEWS AUTHORS README CONTRIBUTING
|
||||
%dir %{_datadir}/nm-applet
|
||||
%{_bindir}/nm-applet
|
||||
%{_libexecdir}/nm-applet-migration-tool
|
||||
%{_datadir}/applications/nm-applet.desktop
|
||||
%{_datadir}/nm-applet/wired-8021x.ui
|
||||
%{_datadir}/nm-applet/info.ui
|
||||
@ -203,8 +186,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_datadir}/icons/hicolor/22x22/apps/nm-vpn-active-lock.png
|
||||
%{_datadir}/icons/hicolor/22x22/apps/nm-vpn-connecting*.png
|
||||
%{_datadir}/icons/hicolor/22x22/apps/nm-wwan-tower.png
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
|
||||
%{_datadir}/GConf/gsettings/nm-applet.convert
|
||||
%{_sysconfdir}/xdg/autostart/nm-applet.desktop
|
||||
%{_sysconfdir}/gconf/schemas/nm-applet.schemas
|
||||
|
||||
# Yes, lang files for the applet go in nm-connection-editor RPM since it
|
||||
# is the RPM that everything else depends on
|
||||
@ -239,6 +223,14 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
%{_libdir}/libnm-gtk.so
|
||||
|
||||
%changelog
|
||||
* Fri Jul 13 2012 Jiří Klimeš <jklimes@redhat.com> - 0.9.5.95-1.git20120713
|
||||
- update to 0.9.5.95 (0.9.6-rc1) snapshot
|
||||
- editor: fixed UI mnemonics
|
||||
- editor: fix defaults for PPP echo values
|
||||
- applet: various crash and stability fixes
|
||||
- applet: show IPv6 addressing page for VPN plugins that support it
|
||||
- applet: port to GSettings and split out 0.8 -> 0.9 migration code into standalone tool
|
||||
|
||||
* Mon May 21 2012 Jiří Klimeš <jklimes@redhat.com> - 0.9.4-4
|
||||
- update to git snapshot
|
||||
|
||||
|
@ -1,30 +1,28 @@
|
||||
diff -up network-manager-applet-0.9.3.997/nm-applet.schemas.in.foo network-manager-applet-0.9.3.997/nm-applet.schemas.in
|
||||
--- network-manager-applet-0.9.3.997/nm-applet.schemas.in.foo 2009-10-21 17:23:29.480267635 -0700
|
||||
+++ network-manager-applet-0.9.3.997/nm-applet.schemas.in 2009-10-21 17:39:42.734142996 -0700
|
||||
@@ -6,7 +6,7 @@
|
||||
<applyto>/apps/nm-applet/disable-connected-notifications</applyto>
|
||||
<owner>nm-applet</owner>
|
||||
<type>bool</type>
|
||||
- <default>FALSE</default>
|
||||
+ <default>TRUE</default>
|
||||
<locale name="C">
|
||||
<short>Disable connected notifications</short>
|
||||
<long>
|
||||
@@ -20,7 +20,7 @@
|
||||
<applyto>/apps/nm-applet/disable-disconnected-notifications</applyto>
|
||||
<owner>nm-applet</owner>
|
||||
<type>bool</type>
|
||||
- <default>FALSE</default>
|
||||
+ <default>TRUE</default>
|
||||
<locale name="C">
|
||||
<short>Disable disconnected notifications</short>
|
||||
<long>
|
||||
@@ -34,7 +34,7 @@
|
||||
<applyto>/apps/nm-applet/suppress-wireless-networks-available</applyto>
|
||||
<owner>nm-applet</owner>
|
||||
<type>bool</type>
|
||||
- <default>FALSE</default>
|
||||
+ <default>TRUE</default>
|
||||
<locale name="C">
|
||||
<short>Suppress networks available notifications</short>
|
||||
<long>
|
||||
diff --git a/org.gnome.nm-applet.gschema.xml.in b/org.gnome.nm-applet.gschema.xml.in
|
||||
index 71b6a29..1a41d0e 100644
|
||||
--- network-manager-applet-0.9.5.95/org.gnome.nm-applet.gschema.xml.in
|
||||
+++ network-manager-applet-0.9.5.95/org.gnome.nm-applet.gschema.xml.in
|
||||
@@ -2,12 +2,12 @@
|
||||
<schemalist gettext-domain="nm-applet">
|
||||
<schema id="org.gnome.nm-applet" path="/org/gnome/nm-applet/">
|
||||
<key name="disable-connected-notifications" type="b">
|
||||
- <default>false</default>
|
||||
+ <default>true</default>
|
||||
<_summary>Disable connected notifications</_summary>
|
||||
<_description>Set this to true to disable notifications when connecting to a network.</_description>
|
||||
</key>
|
||||
<key name="disable-disconnected-notifications" type="b">
|
||||
- <default>false</default>
|
||||
+ <default>true</default>
|
||||
<_summary>Disable disconnected notifications</_summary>
|
||||
<_description>Set this to true to disable notifications when disconnecting from a network.</_description>
|
||||
</key>
|
||||
@@ -17,7 +17,7 @@
|
||||
<_description>Set this to true to disable notifications when connecting to or disconnecting from a VPN.</_description>
|
||||
</key>
|
||||
<key name="suppress-wireless-networks-available" type="b">
|
||||
- <default>false</default>
|
||||
+ <default>true</default>
|
||||
<_summary>Suppress networks available notifications</_summary>
|
||||
<_description>Set this to true to disable notifications when wireless networks are available.</_description>
|
||||
</key>
|
||||
|
@ -1,7 +1,7 @@
|
||||
diff --git network-manager-applet-0.9.3.997/src/libnm-gtk/nm-wireless-dialog.c network-manager-applet-0.9.3.997/src/libnm-gtk/nm-wireless-dialog.c
|
||||
diff --git network-manager-applet-0.9.5.95/src/libnm-gtk/nm-wireless-dialog.c network-manager-applet-0.9.5.95/src/libnm-gtk/nm-wireless-dialog.c
|
||||
index 2cd75e0..5ae4764 100644
|
||||
--- network-manager-applet-0.9.3.997/src/libnm-gtk/nm-wireless-dialog.c
|
||||
+++ network-manager-applet-0.9.3.997/src/libnm-gtk/nm-wireless-dialog.c
|
||||
--- network-manager-applet-0.9.5.95/src/libnm-gtk/nm-wireless-dialog.c
|
||||
+++ network-manager-applet-0.9.5.95/src/libnm-gtk/nm-wireless-dialog.c
|
||||
@@ -1151,24 +1151,28 @@ internal_init (NMAWirelessDialog *self,
|
||||
|
||||
tmp = g_strdup_printf (_("Passwords or encryption keys are required to access the wireless network '%s'."),
|
||||
|
Loading…
Reference in New Issue
Block a user