Update to 1.0.6
This commit is contained in:
parent
e32a964200
commit
22781316f9
1
.gitignore
vendored
1
.gitignore
vendored
@ -22,3 +22,4 @@
|
||||
/network-manager-applet-1.0.4.git20160615.28a0e28.tar.bz2
|
||||
/network-manager-applet-1.0.4.git20160702.25368df.tar.bz2
|
||||
/network-manager-applet-1.0.4.tar.xz
|
||||
/network-manager-applet-1.0.6.tar.xz
|
||||
|
@ -1,66 +0,0 @@
|
||||
From b05974ad28404db1c677cf5034c2ae6b06f5baf9 Mon Sep 17 00:00:00 2001
|
||||
From: Lubomir Rintel <lkundrak@v3.sk>
|
||||
Date: Wed, 15 Jul 2015 15:42:15 +0200
|
||||
Subject: [PATCH] libnm-gtk: add symbol versions
|
||||
|
||||
We've added new ABI. Nevertheless, we still want to leave the rest unversioned,
|
||||
so that linking against it won't add a versioned symbol dependency.
|
||||
|
||||
(cherry picked from commit 7ae3f7abd239beac314c75cbd5f2ee8153df0929)
|
||||
---
|
||||
src/libnm-gtk/Makefile.am | 7 ++++---
|
||||
src/libnm-gtk/libnm-gtk.ver | 19 +++++++++++++++++++
|
||||
2 files changed, 23 insertions(+), 3 deletions(-)
|
||||
create mode 100644 src/libnm-gtk/libnm-gtk.ver
|
||||
|
||||
diff --git a/src/libnm-gtk/Makefile.am b/src/libnm-gtk/Makefile.am
|
||||
index 54cb0ac..ea15ebb 100644
|
||||
--- a/src/libnm-gtk/Makefile.am
|
||||
+++ b/src/libnm-gtk/Makefile.am
|
||||
@@ -50,9 +50,10 @@ libnm_gtk_la_LIBADD = \
|
||||
$(top_builddir)/src/marshallers/libmarshallers.la \
|
||||
$(top_builddir)/src/wireless-security/libwireless-security.la
|
||||
|
||||
-libnm_gtk_la_LDFLAGS = -Wl,-no-undefined \
|
||||
- -export-symbols-regex '^nma_.*'
|
||||
+EXTRA_libnm_gtk_la_DEPENDENCIES = $(srcdir)/libnm-gtk.ver
|
||||
|
||||
+libnm_gtk_la_LDFLAGS = -Wl,-no-undefined \
|
||||
+ -Wl,--version-script=$(srcdir)/libnm-gtk.ver
|
||||
|
||||
pkgconfigdir = $(libdir)/pkgconfig
|
||||
pkgconfig_DATA = libnm-gtk.pc
|
||||
@@ -84,4 +85,4 @@ typelib_DATA = $(INTROSPECTION_GIRS:.gir=.typelib)
|
||||
CLEANFILES = $(gir_DATA) $(typelib_DATA)
|
||||
endif
|
||||
|
||||
-EXTRA_DIST = libnm-gtk.pc.in $(ui_DATA)
|
||||
+EXTRA_DIST = libnm-gtk.pc.in libnm-gtk.ver $(ui_DATA)
|
||||
diff --git a/src/libnm-gtk/libnm-gtk.ver b/src/libnm-gtk/libnm-gtk.ver
|
||||
new file mode 100644
|
||||
index 0000000..d80cdc0
|
||||
--- /dev/null
|
||||
+++ b/src/libnm-gtk/libnm-gtk.ver
|
||||
@@ -0,0 +1,19 @@
|
||||
+libnm_gtk_1_0_0 {
|
||||
+local:
|
||||
+ [^n]*;
|
||||
+ n[^m]*;
|
||||
+ nm[^a]*;
|
||||
+ nma[^_]*;
|
||||
+};
|
||||
+
|
||||
+libnm_gtk_1_0_6 {
|
||||
+global:
|
||||
+ nma_utils_menu_to_secret_flags;
|
||||
+ nma_utils_setup_password_storage;
|
||||
+ nma_utils_update_password_storage;
|
||||
+ nma_vpn_password_dialog_focus_password_ternary;
|
||||
+ nma_vpn_password_dialog_get_password_ternary;
|
||||
+ nma_vpn_password_dialog_set_password_ternary;
|
||||
+ nma_vpn_password_dialog_set_password_ternary_label;
|
||||
+ nma_vpn_password_dialog_set_show_password_ternary;
|
||||
+} libnm_gtk_1_0_0;
|
||||
--
|
||||
2.4.3
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up network-manager-applet-0.9.5.96/configure.ac.foo network-manager-applet-0.9.5.96/configure.ac
|
||||
--- network-manager-applet-0.9.5.96/configure.ac.foo 2011-11-10 15:10:45.268107655 -0600
|
||||
+++ network-manager-applet-0.9.5.96/configure.ac 2011-11-10 15:10:51.902024720 -0600
|
||||
@@ -179,8 +179,6 @@ dnl
|
||||
dnl Compiler flags
|
||||
dnl
|
||||
NM_COMPILER_WARNINGS
|
||||
-# Use --enable-maintainer-mode to disabled deprecated symbols
|
||||
-GNOME_MAINTAINER_MODE_DEFINES
|
||||
|
||||
|
||||
AC_CONFIG_FILES([
|
@ -6,23 +6,19 @@
|
||||
%define obsoletes_ver 1:0.9.7
|
||||
|
||||
%define snapshot %{nil}
|
||||
%define git_sha %{nil}
|
||||
%define realversion 1.0.4
|
||||
%define realversion 1.0.6
|
||||
|
||||
Name: network-manager-applet
|
||||
Summary: A network control and status applet for NetworkManager
|
||||
Version: %{realversion}
|
||||
Release: 2%{snapshot}%{git_sha}%{?dist}
|
||||
Release: 1%{snapshot}%{?dist}
|
||||
Group: Applications/System
|
||||
License: GPLv2+
|
||||
URL: http://www.gnome.org/projects/NetworkManager/
|
||||
Obsoletes: NetworkManager-gnome < %{obsoletes_ver}
|
||||
|
||||
Source: https://download.gnome.org/sources/network-manager-applet/1.0/%{name}-%{realversion}%{snapshot}%{git_sha}.tar.xz
|
||||
Source: https://download.gnome.org/sources/network-manager-applet/1.0/%{name}-%{realversion}%{snapshot}.tar.xz
|
||||
Patch0: nm-applet-no-notifications.patch
|
||||
Patch1: nm-applet-wifi-dialog-ui-fixes.patch
|
||||
Patch2: applet-ignore-deprecated.patch
|
||||
Patch3: 0001-libnm-gtk-add-symbol-versions.patch
|
||||
|
||||
Requires: NetworkManager >= %{nm_version}
|
||||
Requires: NetworkManager-glib >= %{nm_version}
|
||||
@ -98,10 +94,7 @@ nm-applet, nm-connection-editor, and the GNOME control center.
|
||||
%prep
|
||||
%setup -q -n network-manager-applet-%{realversion}
|
||||
|
||||
%patch0 -p1 -b .no-notifications
|
||||
%patch1 -p1 -b .applet-wifi-ui
|
||||
%patch2 -p1 -b .no-deprecated
|
||||
%patch3 -p1 -b .libnm-gtk-add-symbol-versions
|
||||
#patch0 -p1 -b .no-notifications
|
||||
|
||||
%build
|
||||
autoreconf -i -f
|
||||
@ -196,6 +189,7 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
|
||||
%{_datadir}/icons/hicolor/*/apps/nm-no-connection.*
|
||||
%{_datadir}/icons/hicolor/16x16/apps/nm-vpn-standalone-lock.png
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
|
||||
%{_datadir}/appdata/org.gnome.nm-connection-editor.appdata.xml
|
||||
%{_mandir}/man1/nm-connection-editor*
|
||||
%dir %{_datadir}/gnome-vpn-properties
|
||||
|
||||
@ -215,6 +209,9 @@ glib-compile-schemas %{_datadir}/glib-2.0/schemas &>/dev/null || :
|
||||
%{_datadir}/gir-1.0/NMGtk-1.0.gir
|
||||
|
||||
%changelog
|
||||
* Thu Aug 27 2015 Lubomir Rintel <lkundrak@v3.sk> - 1:1.0.6
|
||||
- Update to 1.0.6 release
|
||||
|
||||
* Wed Jul 15 2015 Lubomir Rintel <lkundrak@v3.sk> - 1.0.4-2
|
||||
- Version the newly added ABI
|
||||
|
||||
|
@ -1,11 +1,13 @@
|
||||
--- network-manager-applet-0.9.7.0/org.gnome.nm-applet.gschema.xml.in.no-notifications 2012-08-14 08:59:42.000000000 -0400
|
||||
+++ network-manager-applet-0.9.7.0/org.gnome.nm-applet.gschema.xml.in 2012-08-20 14:14:00.148731379 -0400
|
||||
diff --git a/org.gnome.nm-applet.gschema.xml.in b/org.gnome.nm-applet.gschema.xml.in
|
||||
index 9e2887e..4f8c16a 100644
|
||||
--- a/org.gnome.nm-applet.gschema.xml.in
|
||||
+++ b/org.gnome.nm-applet.gschema.xml.in
|
||||
@@ -17,7 +17,7 @@
|
||||
<_description>Set this to true to disable notifications when connecting to or disconnecting from a VPN.</_description>
|
||||
<description>Set this to true to disable notifications when connecting to or disconnecting from a VPN.</description>
|
||||
</key>
|
||||
<key name="suppress-wireless-networks-available" type="b">
|
||||
- <default>false</default>
|
||||
+ <default>true</default>
|
||||
<_summary>Suppress networks available notifications</_summary>
|
||||
<_description>Set this to true to disable notifications when Wi-Fi networks are available.</_description>
|
||||
<summary>Suppress networks available notifications</summary>
|
||||
<description>Set this to true to disable notifications when Wi-Fi networks are available.</description>
|
||||
</key>
|
||||
|
@ -1,35 +0,0 @@
|
||||
--- network-manager-applet-0.9.9.0/src/libnm-gtk/nm-wifi-dialog.c 2014-03-27 12:25:15.000000000 +0100
|
||||
+++ network-manager-applet-0.9.9.0/src/libnm-gtk/nm-wifi-dialog.c.foo 2014-04-24 11:11:26.531662179 +0200
|
||||
@@ -1134,25 +1134,29 @@
|
||||
|
||||
tmp = g_strdup_printf (_("Passwords or encryption keys are required to access the Wi-Fi network '%s'."),
|
||||
esc_ssid ? esc_ssid : "<unknown>");
|
||||
- gtk_window_set_title (GTK_WINDOW (self), _("Wi-Fi Network Authentication Required"));
|
||||
label = g_strdup_printf ("<span size=\"larger\" weight=\"bold\">%s</span>\n\n%s",
|
||||
_("Authentication required by Wi-Fi network"),
|
||||
tmp);
|
||||
g_free (esc_ssid);
|
||||
g_free (tmp);
|
||||
} else if (priv->operation == OP_CREATE_ADHOC) {
|
||||
- gtk_window_set_title (GTK_WINDOW (self), _("Create New Wi-Fi Network"));
|
||||
label = g_strdup_printf ("<span size=\"larger\" weight=\"bold\">%s</span>\n\n%s",
|
||||
_("New Wi-Fi network"),
|
||||
_("Enter a name for the Wi-Fi network you wish to create."));
|
||||
} else if (priv->operation == OP_CONNECT_HIDDEN) {
|
||||
- gtk_window_set_title (GTK_WINDOW (self), _("Connect to Hidden Wi-Fi Network"));
|
||||
label = g_strdup_printf ("<span size=\"larger\" weight=\"bold\">%s</span>\n\n%s",
|
||||
_("Hidden Wi-Fi network"),
|
||||
_("Enter the name and security details of the hidden Wi-Fi network you wish to connect to."));
|
||||
} else
|
||||
g_assert_not_reached ();
|
||||
|
||||
+ /* The primary text should always tell the story, not the title. And since
|
||||
+ * the dialog is always on top, we can skip the taskbar.
|
||||
+ */
|
||||
+ gtk_window_set_title (GTK_WINDOW (self), "");
|
||||
+ gtk_window_set_keep_above (GTK_WINDOW (self), TRUE);
|
||||
+ gtk_window_set_skip_taskbar_hint (GTK_WINDOW (self), TRUE);
|
||||
+
|
||||
widget = GTK_WIDGET (gtk_builder_get_object (priv->builder, "caption_label"));
|
||||
gtk_label_set_markup (GTK_LABEL (widget), label);
|
||||
g_free (label);
|
Loading…
Reference in New Issue
Block a user