Update to nettle 3.7
This commit is contained in:
parent
f1a57b72c6
commit
7f625e1b8d
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@ nettle-1.15.tar.gz
|
||||
/nettle-3.5.1-hobbled.tar.xz
|
||||
/nettle-3.4.1rc1-hobbled.tar.xz
|
||||
/nettle-3.6-hobbled.tar.xz
|
||||
/nettle-3.7-hobbled.tar.xz
|
||||
|
@ -1,11 +1,11 @@
|
||||
Index: nettle-3.6/Makefile.in
|
||||
Index: nettle-3.7/Makefile.in
|
||||
===================================================================
|
||||
--- nettle-3.6.orig/Makefile.in
|
||||
+++ nettle-3.6/Makefile.in
|
||||
@@ -278,7 +278,7 @@ libhogweed.a: $(hogweed_OBJS)
|
||||
--- nettle-3.7.orig/Makefile.in
|
||||
+++ nettle-3.7/Makefile.in
|
||||
@@ -291,7 +291,7 @@ libhogweed.a: $(hogweed_OBJS)
|
||||
|
||||
%.$(OBJEXT): %.asm $(srcdir)/asm.m4 machine.m4 config.m4
|
||||
$(M4) $(srcdir)/asm.m4 machine.m4 config.m4 $< >$*.s
|
||||
%.$(OBJEXT): %.asm $(srcdir)/m4-utils.m4 $(srcdir)/asm.m4 config.m4 machine.m4
|
||||
$(M4) $(srcdir)/m4-utils.m4 $(srcdir)/asm.m4 config.m4 machine.m4 $< >$*.s
|
||||
- $(COMPILE) -c $*.s
|
||||
+ $(COMPILE) -c -Wa,--generate-missing-build-notes=yes $*.s
|
||||
|
||||
|
@ -1,149 +0,0 @@
|
||||
diff --git a/examples/ecc-benchmark.c b/examples/ecc-benchmark.c
|
||||
index ea0be17..6667560 100644
|
||||
--- a/examples/ecc-benchmark.c
|
||||
+++ b/examples/ecc-benchmark.c
|
||||
@@ -330,8 +330,6 @@ bench_curve (const struct ecc_curve *ecc)
|
||||
}
|
||||
|
||||
const struct ecc_curve * const curves[] = {
|
||||
- &_nettle_secp_192r1,
|
||||
- &_nettle_secp_224r1,
|
||||
&_nettle_curve25519,
|
||||
&_nettle_secp_256r1,
|
||||
&_nettle_secp_384r1,
|
||||
diff --git a/examples/hogweed-benchmark.c b/examples/hogweed-benchmark.c
|
||||
index accdf87..0f653cf 100644
|
||||
--- a/examples/hogweed-benchmark.c
|
||||
+++ b/examples/hogweed-benchmark.c
|
||||
@@ -409,23 +409,6 @@ bench_ecdsa_init (unsigned size)
|
||||
|
||||
switch (size)
|
||||
{
|
||||
- case 192:
|
||||
- ecc = &_nettle_secp_192r1;
|
||||
- xs = "8e8e07360350fb6b7ad8370cfd32fa8c6bba785e6e200599";
|
||||
- ys = "7f82ddb58a43d59ff8dc66053002b918b99bd01bd68d6736";
|
||||
- zs = "f2e620e086d658b4b507996988480917640e4dc107808bdd";
|
||||
- ctx->digest = hash_string (&nettle_sha1, "abc");
|
||||
- ctx->digest_size = 20;
|
||||
- break;
|
||||
- case 224:
|
||||
- ecc = &_nettle_secp_224r1;
|
||||
- xs = "993bf363f4f2bc0f255f22563980449164e9c894d9efd088d7b77334";
|
||||
- ys = "b75fff9849997d02d135140e4d0030944589586e22df1fc4b629082a";
|
||||
- zs = "cdfd01838247f5de3cc70b688418046f10a2bfaca6de9ec836d48c27";
|
||||
- ctx->digest = hash_string (&nettle_sha224, "abc");
|
||||
- ctx->digest_size = 28;
|
||||
- break;
|
||||
-
|
||||
/* From RFC 4754 */
|
||||
case 256:
|
||||
ecc = &_nettle_secp_256r1;
|
||||
diff --git a/testsuite/ecdh-test.c b/testsuite/ecdh-test.c
|
||||
index 2bfffd6..bee48a5 100644
|
||||
--- a/testsuite/ecdh-test.c
|
||||
+++ b/testsuite/ecdh-test.c
|
||||
@@ -138,26 +138,6 @@ test_dh (const char *name, const struct ecc_curve *ecc,
|
||||
void
|
||||
test_main(void)
|
||||
{
|
||||
- test_dh ("secp-192r1", &_nettle_secp_192r1,
|
||||
- "3406157206141798348095184987208239421004566462391397236532",
|
||||
- "1050363442265225480786760666329560655512990381040021438562",
|
||||
- "5298249600854377235107392014200406283816103564916230704184",
|
||||
- "738368960171459956677260317271477822683777845013274506165",
|
||||
- "2585840779771604687467445319428618542927556223024046979917",
|
||||
- "293088185788565313717816218507714888251468410990708684573",
|
||||
- "149293809021051532782730990145509724807636529827149481690",
|
||||
- "2891131861147398318714693938158856874319184314120776776192");
|
||||
-
|
||||
- test_dh ("secp-224r1", &_nettle_secp_224r1,
|
||||
- "1321072106881784386340709783538698930880431939595776773514895067682",
|
||||
- "6768311794185371282972144247871764855860666277647541840973645586477",
|
||||
- "2880077809069104378181313860274147139049600284805670362929579614547",
|
||||
- "13934723037778859565852601874354272638301919827851286722006496784914",
|
||||
- "373124771833407982305885866158843810218322878380632071540538232035",
|
||||
- "24223309755162432227459925493224336241652868856405241018762887667883",
|
||||
- "8330362698029245839097779050425944245826040430538860338085968752913",
|
||||
- "24167244512472228715617822000878192535267113543393576038737592837010");
|
||||
-
|
||||
test_dh ("secp-256r1", &_nettle_secp_256r1,
|
||||
"94731533361265297353914491124013058635674217345912524033267198103710636378786",
|
||||
"22441589863306126152768848344973918725077248391248404659242620344938484650846",
|
||||
diff --git a/testsuite/ecdsa-sign-test.c b/testsuite/ecdsa-sign-test.c
|
||||
index 2327535..63ef044 100644
|
||||
--- a/testsuite/ecdsa-sign-test.c
|
||||
+++ b/testsuite/ecdsa-sign-test.c
|
||||
@@ -60,38 +60,6 @@ test_main (void)
|
||||
{
|
||||
/* Test cases for the smaller groups, verified with a
|
||||
proof-of-concept implementation done for Yubico AB. */
|
||||
- test_ecdsa (&_nettle_secp_192r1,
|
||||
- "DC51D3866A15BACDE33D96F992FCA99D"
|
||||
- "A7E6EF0934E70975", /* z */
|
||||
-
|
||||
- "9E56F509196784D963D1C0A401510EE7"
|
||||
- "ADA3DCC5DEE04B15", /* k */
|
||||
-
|
||||
- SHEX("BA7816BF8F01CFEA414140DE5DAE2223"
|
||||
- "B00361A396177A9C"), /* h */
|
||||
-
|
||||
- "8c478db6a5c131540cebc739f9c0a9a8"
|
||||
- "c720c2abdd14a891", /* r */
|
||||
-
|
||||
- "a91fb738f9f175d72f9c98527e881c36"
|
||||
- "8de68cb55ffe589"); /* s */
|
||||
-
|
||||
- test_ecdsa (&_nettle_secp_224r1,
|
||||
- "446df0a771ed58403ca9cb316e617f6b"
|
||||
- "158420465d00a69601e22858", /* z */
|
||||
-
|
||||
- "4c13f1905ad7eb201178bc08e0c9267b"
|
||||
- "4751c15d5e1831ca214c33f4", /* z */
|
||||
-
|
||||
- SHEX("1b28a611fe62ab3649350525d06703ba"
|
||||
- "4b979a1e543566fd5caa85c6"), /* h */
|
||||
-
|
||||
- "2cc280778f3d067df6d3adbe3a6aad63"
|
||||
- "bc75f08f5c5f915411902a99", /* r */
|
||||
-
|
||||
- "d0f069fd0f108eb07b7bbc54c8d6c88d"
|
||||
- "f2715c38a95c31a2b486995f"); /* s */
|
||||
-
|
||||
/* From RFC 4754 */
|
||||
test_ecdsa (&_nettle_secp_256r1,
|
||||
"DC51D386 6A15BACD E33D96F9 92FCA99D"
|
||||
diff --git a/testsuite/testutils.c b/testsuite/testutils.c
|
||||
index 337e4c4..d8f0137 100644
|
||||
--- a/testsuite/testutils.c
|
||||
+++ b/testsuite/testutils.c
|
||||
@@ -1577,8 +1577,6 @@ test_dsa_key(const struct dsa_params *params,
|
||||
}
|
||||
|
||||
const struct ecc_curve * const ecc_curves[] = {
|
||||
- &_nettle_secp_192r1,
|
||||
- &_nettle_secp_224r1,
|
||||
&_nettle_secp_256r1,
|
||||
&_nettle_secp_384r1,
|
||||
&_nettle_secp_521r1,
|
||||
@@ -1635,20 +1633,6 @@ test_ecc_mul_a (unsigned curve, unsigned n, const mp_limb_t *p)
|
||||
{
|
||||
/* For each curve, the points 2 g, 3 g and 4 g */
|
||||
static const struct ecc_ref_point ref[6][3] = {
|
||||
- { { "dafebf5828783f2ad35534631588a3f629a70fb16982a888",
|
||||
- "dd6bda0d993da0fa46b27bbc141b868f59331afa5c7e93ab" },
|
||||
- { "76e32a2557599e6edcd283201fb2b9aadfd0d359cbb263da",
|
||||
- "782c37e372ba4520aa62e0fed121d49ef3b543660cfd05fd" },
|
||||
- { "35433907297cc378b0015703374729d7a4fe46647084e4ba",
|
||||
- "a2649984f2135c301ea3acb0776cd4f125389b311db3be32" }
|
||||
- },
|
||||
- { { "706a46dc76dcb76798e60e6d89474788d16dc18032d268fd1a704fa6",
|
||||
- "1c2b76a7bc25e7702a704fa986892849fca629487acf3709d2e4e8bb" },
|
||||
- { "df1b1d66a551d0d31eff822558b9d2cc75c2180279fe0d08fd896d04",
|
||||
- "a3f7f03cadd0be444c0aa56830130ddf77d317344e1af3591981a925" },
|
||||
- { "ae99feebb5d26945b54892092a8aee02912930fa41cd114e40447301",
|
||||
- "482580a0ec5bc47e88bc8c378632cd196cb3fa058a7114eb03054c9" },
|
||||
- },
|
||||
{ { "7cf27b188d034f7e8a52380304b51ac3c08969e277f21b35a60b48fc47669978",
|
||||
"7775510db8ed040293d9ac69f7430dbba7dade63ce982299e04b79d227873d1" },
|
||||
{ "5ecbe4d1a6330a44c8f7ef951d4bf165e6c6b721efada985fb41661bc6e7fd6c",
|
@ -1,7 +1,7 @@
|
||||
Index: nettle-3.6rc1/examples/ecc-benchmark.c
|
||||
Index: nettle-3.7/examples/ecc-benchmark.c
|
||||
===================================================================
|
||||
--- nettle-3.6rc1.orig/examples/ecc-benchmark.c
|
||||
+++ nettle-3.6rc1/examples/ecc-benchmark.c
|
||||
--- nettle-3.7.orig/examples/ecc-benchmark.c
|
||||
+++ nettle-3.7/examples/ecc-benchmark.c
|
||||
@@ -307,8 +307,6 @@ bench_curve (const struct ecc_curve *ecc
|
||||
}
|
||||
|
||||
@ -11,10 +11,10 @@ Index: nettle-3.6rc1/examples/ecc-benchmark.c
|
||||
&_nettle_curve25519,
|
||||
&_nettle_secp_256r1,
|
||||
&_nettle_secp_384r1,
|
||||
Index: nettle-3.6rc1/examples/hogweed-benchmark.c
|
||||
Index: nettle-3.7/examples/hogweed-benchmark.c
|
||||
===================================================================
|
||||
--- nettle-3.6rc1.orig/examples/hogweed-benchmark.c
|
||||
+++ nettle-3.6rc1/examples/hogweed-benchmark.c
|
||||
--- nettle-3.7.orig/examples/hogweed-benchmark.c
|
||||
+++ nettle-3.7/examples/hogweed-benchmark.c
|
||||
@@ -412,23 +412,6 @@ bench_ecdsa_init (unsigned size)
|
||||
|
||||
switch (size)
|
||||
@ -39,10 +39,10 @@ Index: nettle-3.6rc1/examples/hogweed-benchmark.c
|
||||
/* From RFC 4754 */
|
||||
case 256:
|
||||
ecc = &_nettle_secp_256r1;
|
||||
Index: nettle-3.6rc1/testsuite/ecdh-test.c
|
||||
Index: nettle-3.7/testsuite/ecdh-test.c
|
||||
===================================================================
|
||||
--- nettle-3.6rc1.orig/testsuite/ecdh-test.c
|
||||
+++ nettle-3.6rc1/testsuite/ecdh-test.c
|
||||
--- nettle-3.7.orig/testsuite/ecdh-test.c
|
||||
+++ nettle-3.7/testsuite/ecdh-test.c
|
||||
@@ -159,46 +159,6 @@ test_public_key (const char *label, cons
|
||||
void
|
||||
test_main(void)
|
||||
@ -90,10 +90,10 @@ Index: nettle-3.6rc1/testsuite/ecdh-test.c
|
||||
test_dh ("secp-256r1", &_nettle_secp_256r1,
|
||||
"94731533361265297353914491124013058635674217345912524033267198103710636378786",
|
||||
"22441589863306126152768848344973918725077248391248404659242620344938484650846",
|
||||
Index: nettle-3.6rc1/testsuite/ecdsa-sign-test.c
|
||||
Index: nettle-3.7/testsuite/ecdsa-sign-test.c
|
||||
===================================================================
|
||||
--- nettle-3.6rc1.orig/testsuite/ecdsa-sign-test.c
|
||||
+++ nettle-3.6rc1/testsuite/ecdsa-sign-test.c
|
||||
--- nettle-3.7.orig/testsuite/ecdsa-sign-test.c
|
||||
+++ nettle-3.7/testsuite/ecdsa-sign-test.c
|
||||
@@ -60,38 +60,6 @@ test_main (void)
|
||||
{
|
||||
/* Test cases for the smaller groups, verified with a
|
||||
@ -133,11 +133,11 @@ Index: nettle-3.6rc1/testsuite/ecdsa-sign-test.c
|
||||
/* From RFC 4754 */
|
||||
test_ecdsa (&_nettle_secp_256r1,
|
||||
"DC51D386 6A15BACD E33D96F9 92FCA99D"
|
||||
Index: nettle-3.6rc1/testsuite/testutils.c
|
||||
Index: nettle-3.7/testsuite/testutils.c
|
||||
===================================================================
|
||||
--- nettle-3.6rc1.orig/testsuite/testutils.c
|
||||
+++ nettle-3.6rc1/testsuite/testutils.c
|
||||
@@ -1669,8 +1669,6 @@ test_dsa_key(const struct dsa_params *pa
|
||||
--- nettle-3.7.orig/testsuite/testutils.c
|
||||
+++ nettle-3.7/testsuite/testutils.c
|
||||
@@ -1656,8 +1656,6 @@ test_dsa_key(const struct dsa_params *pa
|
||||
}
|
||||
|
||||
const struct ecc_curve * const ecc_curves[] = {
|
||||
@ -146,7 +146,7 @@ Index: nettle-3.6rc1/testsuite/testutils.c
|
||||
&_nettle_secp_256r1,
|
||||
&_nettle_secp_384r1,
|
||||
&_nettle_secp_521r1,
|
||||
@@ -1727,24 +1725,6 @@ test_ecc_point (const struct ecc_curve *
|
||||
@@ -1714,24 +1712,6 @@ test_ecc_point (const struct ecc_curve *
|
||||
|
||||
/* For each curve, the points g, 2 g, 3 g and 4 g */
|
||||
static const struct ecc_ref_point ecc_ref[9][4] = {
|
||||
|
@ -3,7 +3,7 @@
|
||||
%global hogweed_so_ver 6
|
||||
|
||||
# Set to 1 when building a bootstrap for a bumped so-name.
|
||||
%global bootstrap 1
|
||||
%global bootstrap 0
|
||||
|
||||
%if 0%{?bootstrap}
|
||||
%global version_old 3.5.1
|
||||
@ -14,8 +14,8 @@
|
||||
%bcond_without fips
|
||||
|
||||
Name: nettle
|
||||
Version: 3.6
|
||||
Release: 3%{?dist}
|
||||
Version: 3.7
|
||||
Release: 1%{?dist}
|
||||
Summary: A low-level cryptographic library
|
||||
|
||||
License: LGPLv3+ or GPLv2+
|
||||
@ -171,6 +171,9 @@ make check
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 11 2021 Daiki Ueno <dueno@redhat.com> - 3.7-1
|
||||
- Update to nettle 3.7
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
3
sources
3
sources
@ -1,2 +1 @@
|
||||
SHA512 (nettle-3.5.1-hobbled.tar.xz) = dc67a06e42327bddc10ec303ce49309873aeb6dcd77f2775837d11c2982dcf11c663b712571ebd33862408d1a61c26eca629122ca20a591840777530571aeb9c
|
||||
SHA512 (nettle-3.6-hobbled.tar.xz) = c89d1cae430eb76b6e1d386334b56468b721cd3476882021d150f49b97dbd71992849ecefa67169b50d6aa7fcef8e4386bca71aa8d2e6e92d200d44c9c67267d
|
||||
SHA512 (nettle-3.7-hobbled.tar.xz) = 267ad57aa4fc7791490c94aae5c533489e6bc8080a8275eb7e8c037437b7e981769d7ff771115cd66c57bf4088589780653fd293ff612c233dd00fea0ea94248
|
||||
|
Loading…
Reference in New Issue
Block a user