Retire nettle.
This commit is contained in:
parent
bbd81b4bad
commit
54784c7de2
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
||||
This package was retired due to no active owner on 2010-08-27
|
@ -1,21 +0,0 @@
|
||||
diff -up nettle-1.15/Makefile.in.orig nettle-1.15/Makefile.in
|
||||
--- nettle-1.15/Makefile.in.orig 2008-02-09 21:23:11.000000000 -0600
|
||||
+++ nettle-1.15/Makefile.in 2008-02-09 21:23:28.000000000 -0600
|
||||
@@ -230,7 +230,7 @@ config.m4: config.m4.in config.status
|
||||
|
||||
# Installation
|
||||
# FIXME: Use mkinstalldirs.
|
||||
-install-here: install-info install-headers libnettle.a $(SHLIBINSTALL)
|
||||
+install-here: install-headers libnettle.a $(SHLIBINSTALL)
|
||||
$(MKDIR_P) $(DESTDIR)$(libdir)
|
||||
$(INSTALL_DATA) libnettle.a $(DESTDIR)$(libdir)
|
||||
|
||||
@@ -268,7 +268,7 @@ install-headers: $(INSTALL_HEADERS)
|
||||
fi ; done
|
||||
|
||||
# Uninstall
|
||||
-uninstall-here: uninstall-info uninstall-headers uninstall-shared
|
||||
+uninstall-here: uninstall-headers uninstall-shared
|
||||
rm -f $(DESTDIR)$(libdir)/libnettle.a
|
||||
|
||||
uninstall-headers:
|
137
nettle.spec
137
nettle.spec
@ -1,137 +0,0 @@
|
||||
Name: nettle
|
||||
Version: 1.15
|
||||
Release: 7%{?dist}
|
||||
Summary: A low-level cryptographic library
|
||||
|
||||
Group: Development/Libraries
|
||||
License: LGPLv2+
|
||||
URL: http://www.lysator.liu.se/~nisse/nettle/
|
||||
Source0: http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
|
||||
Patch0: nettle-1.15-Makefile.in.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
BuildRequires: gmp-devel
|
||||
BuildRequires: m4
|
||||
|
||||
Requires(post): /sbin/install-info
|
||||
Requires(preun): /sbin/install-info
|
||||
|
||||
|
||||
%package devel
|
||||
Summary: Development headers for a low-level cryptographic library
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%package static
|
||||
Summary: Static libraries for a low-level cryptographic library
|
||||
Group: Development/Libraries
|
||||
Requires: %{name}-devel = %{version}-%{release}
|
||||
|
||||
%description
|
||||
Nettle is a cryptographic library that is designed to fit easily in more
|
||||
or less any context: In crypto toolkits for object-oriented languages
|
||||
(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
|
||||
kernel space.
|
||||
|
||||
%description devel
|
||||
Nettle is a cryptographic library that is designed to fit easily in more
|
||||
or less any context: In crypto toolkits for object-oriented languages
|
||||
(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
|
||||
kernel space. This package contains kernel headers.
|
||||
|
||||
%description static
|
||||
Nettle is a cryptographic library that is designed to fit easily in more
|
||||
or less any context: In crypto toolkits for object-oriented languages
|
||||
(C++, Python, Pike, ...), in applications like LSH or GNUPG, or even in
|
||||
kernel space. This package contains a static library.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b Makefile.in
|
||||
|
||||
|
||||
%build
|
||||
%configure
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
|
||||
make install-shared DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
|
||||
/usr/bin/iconv -f iso8859-1 -t utf-8 README > README.conv && /bin/mv -f README.conv README
|
||||
/usr/bin/iconv -f iso8859-1 -t utf-8 ChangeLog > ChangeLog.conv && /bin/mv -f ChangeLog.conv ChangeLog
|
||||
/usr/bin/iconv -f iso8859-1 -t utf-8 nettle.info > nettle.info.conv && /bin/mv -f nettle.info.conv nettle.info
|
||||
mkdir -p $RPM_BUILD_ROOT%{_infodir}
|
||||
install -p -m 644 nettle.info $RPM_BUILD_ROOT%{_infodir}/
|
||||
|
||||
|
||||
%check
|
||||
make check
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc AUTHORS ChangeLog COPYING NEWS README TODO
|
||||
%{_infodir}/nettle.info.gz
|
||||
%{_bindir}/nettle-lfib-stream
|
||||
%{_bindir}/pkcs1-conv
|
||||
%{_bindir}/sexp-conv
|
||||
%{_libdir}/libnettle.so.2
|
||||
%{_libdir}/libnettle.so.2.6
|
||||
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root,-)
|
||||
%doc descore.README nettle.html nettle.pdf COPYING
|
||||
%{_includedir}/nettle
|
||||
%{_libdir}/libnettle.so
|
||||
|
||||
%files static
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING
|
||||
%{_libdir}/libnettle.a
|
||||
|
||||
%post
|
||||
/sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir || :
|
||||
/sbin/ldconfig
|
||||
|
||||
%preun
|
||||
if [ $1 = 0 ]; then
|
||||
/sbin/install-info --delete %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
|
||||
fi
|
||||
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.15-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Thu Apr 10 2008 Ian Weller <ianweller@gmail.com> 1.15-5
|
||||
- Moved static lib to -static
|
||||
|
||||
* Mon Mar 24 2008 Ian Weller <ianweller@gmail.com> 1.15-4
|
||||
- Added libraries and ldconfig
|
||||
|
||||
* Mon Feb 18 2008 Ian Weller <ianweller@gmail.com> 1.15-3
|
||||
- Added provides -static to -devel
|
||||
|
||||
* Sun Feb 17 2008 Ian Weller <ianweller@gmail.com> 1.15-2
|
||||
- Removed redundant requires
|
||||
- Removed redundant documentation between packages
|
||||
- Fixed license tag
|
||||
- Fixed -devel description
|
||||
- Added the static library back to -devel
|
||||
- Added make clean
|
||||
|
||||
* Fri Feb 08 2008 Ian Weller <ianweller@gmail.com> 1.15-1
|
||||
- First package build.
|
Loading…
Reference in New Issue
Block a user