Backported a cache silence fix for RSA and DSA from master
This commit is contained in:
parent
95852a3dc8
commit
4ddebebde6
95
nettle-3.2-cache-silence.patch
Normal file
95
nettle-3.2-cache-silence.patch
Normal file
@ -0,0 +1,95 @@
|
||||
diff --git a/bignum.h b/bignum.h
|
||||
index 24158e0..64ed278 100644
|
||||
--- a/bignum.h
|
||||
+++ b/bignum.h
|
||||
@@ -53,6 +53,8 @@
|
||||
# define mpz_combit mpz_combit
|
||||
# define mpz_import mpz_import
|
||||
# define mpz_export mpz_export
|
||||
+/* Side-channel silent powm not available in mini-gmp. */
|
||||
+# define mpz_powm_sec mpz_pwm
|
||||
#else
|
||||
# include <gmp.h>
|
||||
#endif
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index e1ee64c..1e88477 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -236,9 +236,9 @@ fi
|
||||
# Checks for libraries
|
||||
if test "x$enable_public_key" = "xyes" ; then
|
||||
if test "x$enable_mini_gmp" = "xno" ; then
|
||||
- AC_CHECK_LIB(gmp, __gmpz_getlimbn,,
|
||||
+ AC_CHECK_LIB(gmp, __gmpz_powm_sec,,
|
||||
[AC_MSG_WARN(
|
||||
- [GNU MP not found, or not 3.1 or up, see http://gmplib.org/.
|
||||
+ [GNU MP not found, or too old. GMP-5.0 or later is needed, see http://gmplib.org/.
|
||||
Support for public key algorithms will be unavailable.])]
|
||||
enable_public_key=no)
|
||||
|
||||
diff --git a/dsa-sign.c b/dsa-sign.c
|
||||
index 62c7d4a..9d6bb18 100644
|
||||
--- a/dsa-sign.c
|
||||
+++ b/dsa-sign.c
|
||||
@@ -65,7 +65,7 @@ dsa_sign(const struct dsa_params *params,
|
||||
mpz_add_ui(k, k, 1);
|
||||
|
||||
/* Compute r = (g^k (mod p)) (mod q) */
|
||||
- mpz_powm(tmp, params->g, k, params->p);
|
||||
+ mpz_powm_sec(tmp, params->g, k, params->p);
|
||||
mpz_fdiv_r(signature->r, tmp, params->q);
|
||||
|
||||
/* Compute hash */
|
||||
diff --git a/rsa-blind.c b/rsa-blind.c
|
||||
index 7662f50..16b03d7 100644
|
||||
--- a/rsa-blind.c
|
||||
+++ b/rsa-blind.c
|
||||
@@ -61,7 +61,7 @@ _rsa_blind (const struct rsa_public_key *pub,
|
||||
while (!mpz_invert (ri, r, pub->n));
|
||||
|
||||
/* c = c*(r^e) mod n */
|
||||
- mpz_powm(r, r, pub->e, pub->n);
|
||||
+ mpz_powm_sec(r, r, pub->e, pub->n);
|
||||
mpz_mul(c, c, r);
|
||||
mpz_fdiv_r(c, c, pub->n);
|
||||
|
||||
diff --git a/rsa-sign-tr.c b/rsa-sign-tr.c
|
||||
index 3d80ed4..68233a3 100644
|
||||
--- a/rsa-sign-tr.c
|
||||
+++ b/rsa-sign-tr.c
|
||||
@@ -60,7 +60,7 @@ rsa_blind (const struct rsa_public_key *pub,
|
||||
while (!mpz_invert (ri, r, pub->n));
|
||||
|
||||
/* c = c*(r^e) mod n */
|
||||
- mpz_powm(r, r, pub->e, pub->n);
|
||||
+ mpz_powm_sec(r, r, pub->e, pub->n);
|
||||
mpz_mul(c, m, r);
|
||||
mpz_fdiv_r(c, c, pub->n);
|
||||
|
||||
@@ -97,7 +97,7 @@ rsa_compute_root_tr(const struct rsa_public_key *pub,
|
||||
|
||||
rsa_compute_root (key, xb, mb);
|
||||
|
||||
- mpz_powm(t, xb, pub->e, pub->n);
|
||||
+ mpz_powm_sec(t, xb, pub->e, pub->n);
|
||||
res = (mpz_cmp(mb, t) == 0);
|
||||
|
||||
if (res)
|
||||
diff --git a/rsa-sign.c b/rsa-sign.c
|
||||
index eba7388..4832352 100644
|
||||
--- a/rsa-sign.c
|
||||
+++ b/rsa-sign.c
|
||||
@@ -96,11 +96,11 @@ rsa_compute_root(const struct rsa_private_key *key,
|
||||
|
||||
/* Compute xq = m^d % q = (m%q)^b % q */
|
||||
mpz_fdiv_r(xq, m, key->q);
|
||||
- mpz_powm(xq, xq, key->b, key->q);
|
||||
+ mpz_powm_sec(xq, xq, key->b, key->q);
|
||||
|
||||
/* Compute xp = m^d % p = (m%p)^a % p */
|
||||
mpz_fdiv_r(xp, m, key->p);
|
||||
- mpz_powm(xp, xp, key->a, key->p);
|
||||
+ mpz_powm_sec(xp, xp, key->a, key->p);
|
||||
|
||||
/* Set xp' = (xp - xq) c % p. */
|
||||
mpz_sub(xp, xp, xq);
|
@ -1,6 +1,6 @@
|
||||
Name: nettle
|
||||
Version: 3.2
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Summary: A low-level cryptographic library
|
||||
|
||||
Group: Development/Libraries
|
||||
@ -10,8 +10,10 @@ Source0: %{name}-%{version}-hobbled.tar.xz
|
||||
#Source0: http://www.lysator.liu.se/~nisse/archive/%{name}-%{version}.tar.gz
|
||||
Patch0: nettle-3.1.1-remove-ecc-testsuite.patch
|
||||
Patch1: nettle-3.2-version-h.patch
|
||||
Patch2: nettle-3.2-cache-silence.patch
|
||||
|
||||
BuildRequires: gmp-devel m4 texinfo-tex
|
||||
BuildRequires: libtool, automake, autoconf, gettext-devel
|
||||
|
||||
Requires(post): info
|
||||
Requires(preun): info
|
||||
@ -45,8 +47,10 @@ sed 's/ecc-192.c//g' -i Makefile.in
|
||||
sed 's/ecc-224.c//g' -i Makefile.in
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%build
|
||||
autoreconf -ifv
|
||||
%configure --enable-shared --disable-arm-neon --enable-fat
|
||||
make %{?_smp_mflags}
|
||||
|
||||
@ -100,6 +104,9 @@ fi
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Jul 19 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 3.2-3
|
||||
- Backported a fix for more cache silence on RSA and DSA.
|
||||
|
||||
* Thu Feb 18 2016 Nikos Mavrogiannopoulos <nmav@redhat.com> - 3.2-2
|
||||
- Enabled fat builds by default
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user