- update to 10.35.63
- basically new release with some of our patches applied upstream
This commit is contained in:
parent
d0ca71a1a7
commit
ff641e147c
@ -1 +1 @@
|
|||||||
netpbm-10.35.62.tar.bz2
|
netpbm-10.35.63.tar.bz2
|
||||||
|
@ -1,57 +0,0 @@
|
|||||||
diff -up netpbm-10.35.62/converter/pbm/pbmtoepson.c.docfix netpbm-10.35.62/converter/pbm/pbmtoepson.c
|
|
||||||
--- netpbm-10.35.62/converter/pbm/pbmtoepson.c.docfix 2009-04-13 09:14:07.000000000 +0200
|
|
||||||
+++ netpbm-10.35.62/converter/pbm/pbmtoepson.c 2009-04-14 09:26:48.000000000 +0200
|
|
||||||
@@ -74,7 +74,7 @@ parseCommandLine(int arg
|
|
||||||
&dpiSpec, 0);
|
|
||||||
OPTENT3(0, "adjacent", OPT_FLAG, NULL,
|
|
||||||
&adjacentSpec, 0);
|
|
||||||
- OPTENT3(0, "nonadjacent", OPT_FLAG, NULL,
|
|
||||||
+ OPTENT3(0, "noadjacent", OPT_FLAG, NULL,
|
|
||||||
&nonadjacentSpec, 0);
|
|
||||||
|
|
||||||
opt.opt_table = option_def;
|
|
||||||
diff -up netpbm-10.35.62/generator/ppmpat.c.docfix netpbm-10.35.62/generator/ppmpat.c
|
|
||||||
--- netpbm-10.35.62/generator/ppmpat.c.docfix 2009-04-13 09:13:56.000000000 +0200
|
|
||||||
+++ netpbm-10.35.62/generator/ppmpat.c 2009-04-14 09:29:35.000000000 +0200
|
|
||||||
@@ -919,7 +919,7 @@ main(int argc, char ** argv) {
|
|
||||||
#define PAT_CAMO 7
|
|
||||||
#define PAT_ANTICAMO 8
|
|
||||||
#define PAT_TEST 9
|
|
||||||
- const char* const usage = "-gingham|-g2|-gingham3|-g3|-madras|-tartan|-poles|-squig|-camo|-anticamo <width> <height>";
|
|
||||||
+ const char* const usage = "-gingham2|-g2|-gingham3|-g3|-madras|-tartan|-poles|-squig|-camo|-anticamo <width> <height>";
|
|
||||||
|
|
||||||
|
|
||||||
ppm_init(&argc, argv);
|
|
||||||
diff -up netpbm-10.35.62/userguide/pamaddnoise.html.docfix netpbm-10.35.62/userguide/pamaddnoise.html
|
|
||||||
--- netpbm-10.35.62/userguide/pamaddnoise.html.docfix 2009-04-13 09:14:26.000000000 +0200
|
|
||||||
+++ netpbm-10.35.62/userguide/pamaddnoise.html 2009-04-14 09:32:47.000000000 +0200
|
|
||||||
@@ -38,7 +38,7 @@ pamaddnoise - add noise to a Netpbm imag
|
|
||||||
|
|
||||||
<B>pamaddnoise</B> <B>-type </B> <B>multiplicative_gaussian</B>
|
|
||||||
|
|
||||||
-[<B>-msigma</B> <I>value</I>]
|
|
||||||
+[<B>-mgsigma</B> <I>value</I>]
|
|
||||||
|
|
||||||
<BR>
|
|
||||||
|
|
||||||
@@ -102,7 +102,7 @@ a plane of colors in a color space.
|
|
||||||
|
|
||||||
<DD>Used for laplacian noise only. The default value is 10.0.
|
|
||||||
|
|
||||||
-<DT><B>-msigma</b> <i>value</i>
|
|
||||||
+<DT><B>-mgsigma</b> <i>value</i>
|
|
||||||
|
|
||||||
<DD>Used for mutliplicative gaussian noise only. The default value is
|
|
||||||
0.5.
|
|
||||||
diff -up netpbm-10.35.62/userguide/pamperspective.html.docfix netpbm-10.35.62/userguide/pamperspective.html
|
|
||||||
--- netpbm-10.35.62/userguide/pamperspective.html.docfix 2009-04-13 09:14:26.000000000 +0200
|
|
||||||
+++ netpbm-10.35.62/userguide/pamperspective.html 2009-04-14 09:10:32.000000000 +0200
|
|
||||||
@@ -226,7 +226,7 @@ visible part is the smallest possible re
|
|
||||||
parts specified those three ways.
|
|
||||||
|
|
||||||
<p>The visible part must have nonzero size. That means if you specify
|
|
||||||
-<b>--frame-include=no</b> (overriding the default), you'll need to
|
|
||||||
+<b>--frame_include=no</b> (overriding the default), you'll need to
|
|
||||||
specify other frame options in order to have something in the visible
|
|
||||||
part.
|
|
||||||
|
|
@ -11,41 +11,3 @@
|
|||||||
|
|
||||||
while ( rt->in->hasMore( rt->in ) ) {
|
while ( rt->in->hasMore( rt->in ) ) {
|
||||||
if ( (err = rt->in->next( rt->in, &r, &g, &b )) ) goto exit ;
|
if ( (err = rt->in->next( rt->in, &r, &g, &b )) ) goto exit ;
|
||||||
diff -up netpbm-10.35.62/converter/ppm/xvminitoppm.c.glibc netpbm-10.35.62/converter/ppm/xvminitoppm.c
|
|
||||||
--- netpbm-10.35.62/converter/ppm/xvminitoppm.c.glibc 2009-04-13 09:14:06.000000000 +0200
|
|
||||||
+++ netpbm-10.35.62/converter/ppm/xvminitoppm.c 2009-04-14 12:27:48.000000000 +0200
|
|
||||||
@@ -52,7 +52,7 @@ parseCommandLine(int const argc,
|
|
||||||
|
|
||||||
|
|
||||||
static void
|
|
||||||
-getline(FILE * const ifP,
|
|
||||||
+get_line(FILE * const ifP,
|
|
||||||
char * const buf,
|
|
||||||
size_t const size) {
|
|
||||||
|
|
||||||
@@ -105,7 +105,7 @@ readXvHeader(FILE * const ifP,
|
|
||||||
int rc;
|
|
||||||
bool endOfComments;
|
|
||||||
|
|
||||||
- getline(ifP, buf, sizeof(buf));
|
|
||||||
+ get_line(ifP, buf, sizeof(buf));
|
|
||||||
|
|
||||||
if (!STRNEQ(buf, "P7 332", 6))
|
|
||||||
pm_error("Input is not a XV thumbnail picture. It does not "
|
|
||||||
@@ -113,14 +113,14 @@ readXvHeader(FILE * const ifP,
|
|
||||||
|
|
||||||
endOfComments = FALSE;
|
|
||||||
while (!endOfComments) {
|
|
||||||
- getline(ifP, buf, sizeof(buf));
|
|
||||||
+ get_line(ifP, buf, sizeof(buf));
|
|
||||||
if (STRNEQ(buf, "#END_OF_COMMENTS", 16))
|
|
||||||
endOfComments = TRUE;
|
|
||||||
else if (STRNEQ(buf, "#BUILTIN", 8))
|
|
||||||
pm_error("This program does not know how to "
|
|
||||||
"convert builtin XV thumbnail pictures");
|
|
||||||
}
|
|
||||||
- getline(ifP, buf, sizeof(buf));
|
|
||||||
+ get_line(ifP, buf, sizeof(buf));
|
|
||||||
rc = sscanf(buf, "%u %u %u", &cols, &rows, &maxval);
|
|
||||||
if (rc != 3)
|
|
||||||
pm_error("error parsing dimension info '%s'. "
|
|
||||||
|
@ -1,11 +0,0 @@
|
|||||||
diff -up netpbm-10.35.57/converter/other/pamtosvg/fit.c.pamtosvgsegfault netpbm-10.35.57/converter/other/pamtosvg/fit.c
|
|
||||||
--- netpbm-10.35.57/converter/other/pamtosvg/fit.c.pamtosvgsegfault 2008-12-15 10:04:49.000000000 +0100
|
|
||||||
+++ netpbm-10.35.57/converter/other/pamtosvg/fit.c 2008-12-19 09:10:01.000000000 +0100
|
|
||||||
@@ -1852,6 +1852,7 @@ find_error (curve_type curve, spline_typ
|
|
||||||
|
|
||||||
if (*worst_point == CURVE_LENGTH (curve) + 1)
|
|
||||||
{ /* Didn't have any ``worst point''; the error should be zero. */
|
|
||||||
+ *worst_point = 0;
|
|
||||||
if (epsilon_equal (total_error, 0.0))
|
|
||||||
LOG (" Every point fit perfectly.\n");
|
|
||||||
else
|
|
@ -1,22 +0,0 @@
|
|||||||
--- netpbm-10.35/converter/pbm/pbmtomacp.c.pbmtomacp 2007-01-29 10:11:08.000000000 +0100
|
|
||||||
+++ netpbm-10.35/converter/pbm/pbmtomacp.c 2007-02-02 13:55:23.000000000 +0100
|
|
||||||
@@ -38,7 +38,6 @@
|
|
||||||
int argn, rows, cols;
|
|
||||||
int left,bottom,right,top;
|
|
||||||
int lflg, rflg, tflg, bflg;
|
|
||||||
- char name[100];
|
|
||||||
const char * const usage = "[-l left] [-r right] [-b bottom] [-t top] [pbmfile]";
|
|
||||||
|
|
||||||
|
|
||||||
@@ -84,11 +83,9 @@
|
|
||||||
|
|
||||||
if ( argn == argc )
|
|
||||||
{ ifp = stdin;
|
|
||||||
- strcpy( name, "noname" );
|
|
||||||
}
|
|
||||||
else
|
|
||||||
{ ifp = pm_openr( argv[argn] );
|
|
||||||
- strcpy( name, argv[argn] );
|
|
||||||
++argn;
|
|
||||||
}
|
|
||||||
|
|
@ -1,13 +0,0 @@
|
|||||||
diff -up netpbm-10.35.58/lib/ppmdfont.c.ppmdfontfix netpbm-10.35.58/lib/ppmdfont.c
|
|
||||||
--- netpbm-10.35.58/lib/ppmdfont.c.ppmdfontfix 2009-01-19 09:23:54.000000000 +0100
|
|
||||||
+++ netpbm-10.35.58/lib/ppmdfont.c 2009-03-23 13:06:36.000000000 +0100
|
|
||||||
@@ -62,7 +62,8 @@ static void
|
|
||||||
readFontHeader(FILE * const ifP,
|
|
||||||
struct ppmd_fontHeader * const fontHeaderP) {
|
|
||||||
|
|
||||||
- fread(&fontHeaderP->signature, 1, sizeof(fontHeaderP->signature), ifP);
|
|
||||||
+ if (!fread(&fontHeaderP->signature, 1, sizeof(fontHeaderP->signature), ifP))
|
|
||||||
+ pm_error("Error reading font header.");
|
|
||||||
fontHeaderP->format = fgetc(ifP);
|
|
||||||
fontHeaderP->characterCount = fgetc(ifP);
|
|
||||||
fontHeaderP->firstCodePoint = fgetc(ifP);
|
|
@ -1,28 +0,0 @@
|
|||||||
diff -up netpbm-10.35.60/editor/ppmfade.ppmfadeusage netpbm-10.35.60/editor/ppmfade
|
|
||||||
--- netpbm-10.35.60/editor/ppmfade.ppmfadeusage 2009-02-27 12:35:26.000000000 +0100
|
|
||||||
+++ netpbm-10.35.60/editor/ppmfade 2009-02-27 12:39:06.000000000 +0100
|
|
||||||
@@ -36,6 +36,8 @@ my $mode = $SPREAD; # default fading mo
|
|
||||||
#
|
|
||||||
# Check those command line args.
|
|
||||||
#
|
|
||||||
+sub usage();
|
|
||||||
+
|
|
||||||
if (@ARGV == 0) {
|
|
||||||
usage();
|
|
||||||
}
|
|
||||||
@@ -82,7 +84,7 @@ for ($n = 0; $n < @ARGV; $n++) {
|
|
||||||
usage();
|
|
||||||
} else {
|
|
||||||
print "Unknown argument: $ARGV[$n]\n";
|
|
||||||
- exit 100;
|
|
||||||
+ exit 1;
|
|
||||||
}
|
|
||||||
}
|
|
||||||
#
|
|
||||||
@@ -312,5 +314,5 @@ sub usage() {
|
|
||||||
print " [-base basename]\n";
|
|
||||||
print "Notes: Default base: fade\n";
|
|
||||||
print " The resulting image files will be named fade.NNNN.ppm.\n";
|
|
||||||
- exit(100);
|
|
||||||
+ exit 1;
|
|
||||||
}
|
|
@ -1,14 +0,0 @@
|
|||||||
diff -ur netpbm-10.35.orig/editor/ppmquantall netpbm-10.35/editor/ppmquantall
|
|
||||||
--- netpbm-10.35.orig/editor/ppmquantall 2006-09-22 13:47:25.000000000 -0400
|
|
||||||
+++ netpbm-10.35/editor/ppmquantall 2006-09-22 13:48:07.000000000 -0400
|
|
||||||
@@ -62,8 +62,8 @@
|
|
||||||
# To be robust, we need to use Pnmfile to get that information, or
|
|
||||||
# Put this program in C and use ppm_readppminit().
|
|
||||||
|
|
||||||
-set widths=()
|
|
||||||
-set heights=()
|
|
||||||
+widths=()
|
|
||||||
+heights=()
|
|
||||||
|
|
||||||
for i in ${files[@]}; do
|
|
||||||
widths=(${widths[*]} `grep -v '^#' $i | sed '1d; s/ .*//; 2q'`)
|
|
@ -1,31 +0,0 @@
|
|||||||
diff -up netpbm-10.35.60/generator/ppmrainbow.ppmrainbowexit netpbm-10.35.60/generator/ppmrainbow
|
|
||||||
--- netpbm-10.35.60/generator/ppmrainbow.ppmrainbowexit 2009-02-15 13:04:35.000000000 +0100
|
|
||||||
+++ netpbm-10.35.60/generator/ppmrainbow 2009-02-26 18:48:34.000000000 +0100
|
|
||||||
@@ -21,15 +21,16 @@ GetOptions("width=i" => \$Twid,
|
|
||||||
"norepeat!" => \$norepeat,
|
|
||||||
"verbose!" => \$verbose);
|
|
||||||
|
|
||||||
+$! = 1;
|
|
||||||
die "invalid width and/or height\n" unless $Twid >= 1 && $Thgt >= 1;
|
|
||||||
|
|
||||||
my $verboseCommand = $verbose ? "set -x;" : "";
|
|
||||||
|
|
||||||
if (@ARGV < 1) {
|
|
||||||
- die("You must specify at least one color as an argument");
|
|
||||||
+ die("You must specify at least one color as an argument\n");
|
|
||||||
} elsif (@ARGV < 2 && $norepeat) {
|
|
||||||
die("With the -norepeat option, you must specify at least two colors " .
|
|
||||||
- "as arguments.");
|
|
||||||
+ "as arguments.\n");
|
|
||||||
}
|
|
||||||
|
|
||||||
my @colorlist;
|
|
||||||
@@ -57,7 +58,7 @@ while (@colorlist >= 2) {
|
|
||||||
my $rc = system("$verboseCommand pgmramp -lr $w $Thgt | " .
|
|
||||||
"pgmtoppm \"$colorlist[0]-$colorlist[1]\" >$outfile");
|
|
||||||
if ($rc != 0) {
|
|
||||||
- die("pgmramp|pgmtoppm failed.");
|
|
||||||
+ die("pgmramp|pgmtoppm failed.\n");
|
|
||||||
}
|
|
||||||
$widthRemaining -= $w;
|
|
||||||
$n++;
|
|
@ -1,14 +0,0 @@
|
|||||||
diff -up netpbm-10.35.58/converter/ppm/ximtoppm.c.ximtoppmsegfault netpbm-10.35.58/converter/ppm/ximtoppm.c
|
|
||||||
--- netpbm-10.35.58/converter/ppm/ximtoppm.c.ximtoppmsegfault 2009-01-28 18:37:05.000000000 +0100
|
|
||||||
+++ netpbm-10.35.58/converter/ppm/ximtoppm.c 2009-01-28 19:01:14.000000000 +0100
|
|
||||||
@@ -50,6 +50,10 @@ parseCommandLine(int argc, char ** argv,
|
|
||||||
OPTENT3(0, "alphaout", OPT_STRING,
|
|
||||||
&cmdlineP->alpha_filename, &alphaoutSpec, 0);
|
|
||||||
|
|
||||||
+ opt.opt_table = option_def;
|
|
||||||
+ opt.short_allowed = FALSE;
|
|
||||||
+ opt.allowNegNum = FALSE;
|
|
||||||
+
|
|
||||||
optParseOptions3(&argc, argv, opt, sizeof(opt), 0);
|
|
||||||
/* Uses and sets argc, argv, and all of *cmdlineP. */
|
|
||||||
|
|
22
netpbm.spec
22
netpbm.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: A library for handling different graphics file formats
|
Summary: A library for handling different graphics file formats
|
||||||
Name: netpbm
|
Name: netpbm
|
||||||
Version: 10.35.62
|
Version: 10.35.63
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
# See copyright_summary for details
|
# See copyright_summary for details
|
||||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||||
@ -24,21 +24,13 @@ Patch11: netpbm-10.31-xwdfix.patch
|
|||||||
Patch12: netpbm-10.33-ppmtompeg.patch
|
Patch12: netpbm-10.33-ppmtompeg.patch
|
||||||
Patch13: netpbm-10.33-multilib.patch
|
Patch13: netpbm-10.33-multilib.patch
|
||||||
Patch14: netpbm-10.34-pamscale.patch
|
Patch14: netpbm-10.34-pamscale.patch
|
||||||
Patch15: netpbm-10.35-ppmquantall.patch
|
|
||||||
Patch17: netpbm-10.35-pbmtomacp.patch
|
|
||||||
Patch18: netpbm-10.35-glibc.patch
|
Patch18: netpbm-10.35-glibc.patch
|
||||||
Patch19: netpbm-10.35-gcc43.patch
|
Patch19: netpbm-10.35-gcc43.patch
|
||||||
Patch20: netpbm-10.35-rgbtxt.patch
|
Patch20: netpbm-10.35-rgbtxt.patch
|
||||||
Patch21: netpbm-10.35-pamtosvgsegfault.patch
|
|
||||||
Patch22: netpbm-10.35-pnmmontagefix.patch
|
Patch22: netpbm-10.35-pnmmontagefix.patch
|
||||||
Patch23: netpbm-10.35-pnmtofiasco-stdin.patch
|
Patch23: netpbm-10.35-pnmtofiasco-stdin.patch
|
||||||
Patch24: netpbm-10.35-64bitfix.patch
|
Patch24: netpbm-10.35-64bitfix.patch
|
||||||
Patch25: netpbm-10.35-ximtoppmsegfault.patch
|
|
||||||
Patch26: netpbm-10.35-ppmfadeusage.patch
|
|
||||||
Patch27: netpbm-10.35-ppmrainbowexit.patch
|
|
||||||
Patch28: netpbm-10.35-ppmdfontfix.patch
|
|
||||||
Patch29: netpbm-10.35-svgtopam.patch
|
Patch29: netpbm-10.35-svgtopam.patch
|
||||||
Patch30: netpbm-10.35-docfix.patch
|
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
||||||
BuildRequires: libX11-devel, python, jasper-devel
|
BuildRequires: libX11-devel, python, jasper-devel
|
||||||
@ -93,21 +85,13 @@ netpbm-progs. You'll also need to install the netpbm package.
|
|||||||
%patch12 -p1 -b .ppmtompeg
|
%patch12 -p1 -b .ppmtompeg
|
||||||
%patch13 -p1 -b .multilib
|
%patch13 -p1 -b .multilib
|
||||||
%patch14 -p1 -b .pamscale
|
%patch14 -p1 -b .pamscale
|
||||||
%patch15 -p1 -b .pqall
|
|
||||||
%patch17 -p1 -b .pbmtomacp
|
|
||||||
%patch18 -p1 -b .glibc
|
%patch18 -p1 -b .glibc
|
||||||
%patch19 -p1 -b .gcc43
|
%patch19 -p1 -b .gcc43
|
||||||
%patch20 -p1 -b .rgbtxt
|
%patch20 -p1 -b .rgbtxt
|
||||||
%patch21 -p1 -b .pamtosvgsegfault
|
|
||||||
%patch22 -p1 -b .pnmmontagefix
|
%patch22 -p1 -b .pnmmontagefix
|
||||||
%patch23 -p1 -b .pnmtofiasco-stdin
|
%patch23 -p1 -b .pnmtofiasco-stdin
|
||||||
%patch24 -p1 -b .64bitfix
|
%patch24 -p1 -b .64bitfix
|
||||||
%patch25 -p1 -b .ximtoppmsegfault
|
|
||||||
%patch26 -p1 -b .ppmfadeusage
|
|
||||||
%patch27 -p1 -b .ppmrainbowexit
|
|
||||||
%patch28 -p1 -b .ppmdfontfix
|
|
||||||
%patch29 -p1 -b .svgtopam
|
%patch29 -p1 -b .svgtopam
|
||||||
%patch30 -p1 -b .docfix
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./configure <<EOF
|
./configure <<EOF
|
||||||
@ -233,6 +217,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/netpbm/
|
%{_datadir}/netpbm/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 28 2009 Jindrich Novy <jnovy@redhat.com> 10.35.63-1
|
||||||
|
- update to 10.35.63
|
||||||
|
- basically new release with some of our patches applied upstream
|
||||||
|
|
||||||
* Tue Apr 14 2009 Jindrich Novy <jnovy@redhat.com> 10.35.62-1
|
* Tue Apr 14 2009 Jindrich Novy <jnovy@redhat.com> 10.35.62-1
|
||||||
- update to 10.35.62
|
- update to 10.35.62
|
||||||
- upstream fixes pamstereogram
|
- upstream fixes pamstereogram
|
||||||
|
Loading…
Reference in New Issue
Block a user