- update to 10.47.08

This commit is contained in:
Jindrich Novy 2010-01-13 11:31:57 +00:00
parent ca738e4dff
commit ef5891128a
5 changed files with 8 additions and 127 deletions

View File

@ -1 +1 @@
netpbm-10.47.07.tar.xz netpbm-10.47.08.tar.xz

View File

@ -1,105 +0,0 @@
diff -up netpbm-10.35.58/converter/other/fiasco/codec/coder.c.pnmtofiasco-stdin netpbm-10.35.58/converter/other/fiasco/codec/coder.c
--- netpbm-10.35.58/converter/other/fiasco/codec/coder.c.pnmtofiasco-stdin 2009-01-19 09:23:57.000000000 +0100
+++ netpbm-10.35.58/converter/other/fiasco/codec/coder.c 2009-01-21 08:03:00.000000000 +0100
@@ -213,15 +213,14 @@ alloc_coder (char const * const *inputna
*/
{
char *filename;
- int width, w = 0, height, h = 0;
+ int width, w = 0, height, h = 0, format;
bool_t color, c = NO;
+ xelval maxval;
unsigned n;
for (n = 0; (filename = get_input_image_name (inputname, n)); n++)
{
FILE *file;
- xelval maxval;
- int format;
if (filename == NULL)
file = stdin;
else
@@ -251,6 +250,8 @@ alloc_coder (char const * const *inputna
wi->width = w;
wi->height = h;
wi->color = c;
+ wi->format = format;
+ wi->maxval = maxval;
}
/*
@@ -642,7 +643,18 @@ video_coder (char const * const *image_t
*/
future_frame = frame == future_display;
c->mt->number = frame;
- c->mt->original = read_image (image_name);
+ if (strcmp(image_name, "-")) {
+ c->mt->original = read_image (image_name);
+ } else { /* stdin is not seekable - read image contents without rewind */
+ int width = wfa->wfainfo->width;
+ int height = wfa->wfainfo->height;
+ int color = wfa->wfainfo->color;
+ int format = wfa->wfainfo->format;
+ xelval maxval = wfa->wfainfo->maxval;
+
+ c->mt->original = alloc_image(width, height, color, FORMAT_4_4_4);
+ read_image_data(c->mt->original, stdin, color, width, height, maxval, format);
+ }
if (c->tiling->exponent && type == I_FRAME)
perform_tiling (c->mt->original, c->tiling);
diff -up netpbm-10.35.58/converter/other/fiasco/codec/wfa.h.pnmtofiasco-stdin netpbm-10.35.58/converter/other/fiasco/codec/wfa.h
--- netpbm-10.35.58/converter/other/fiasco/codec/wfa.h.pnmtofiasco-stdin 2009-01-19 09:23:57.000000000 +0100
+++ netpbm-10.35.58/converter/other/fiasco/codec/wfa.h 2009-01-21 08:03:28.000000000 +0100
@@ -75,6 +75,7 @@ typedef struct range_info
unsigned level; /* bintree level of range */
} range_info_t;
+#include "pnm.h"
#include "image.h"
#include "rpf.h"
#include "bit-io.h"
@@ -93,6 +94,8 @@ typedef struct wfa_info
unsigned width; /* image width */
unsigned height; /* image height */
unsigned level; /* image level */
+ unsigned format; /* image format */
+ xelval maxval; /* image maximal pixel intensity value */
rpf_t *rpf; /* Standard reduced precision format */
rpf_t *dc_rpf; /* DC reduced precision format */
rpf_t *d_rpf; /* Delta reduced precision format */
diff -up netpbm-10.35.58/converter/other/fiasco/lib/image.c.pnmtofiasco-stdin netpbm-10.35.58/converter/other/fiasco/lib/image.c
--- netpbm-10.35.58/converter/other/fiasco/lib/image.c.pnmtofiasco-stdin 2009-01-19 09:23:57.000000000 +0100
+++ netpbm-10.35.58/converter/other/fiasco/lib/image.c 2009-01-21 08:01:53.000000000 +0100
@@ -273,7 +273,7 @@ free_image (image_t *image)
}
-static void
+void
read_image_data(image_t * const image, FILE *input, const bool_t color,
const int width, const int height, const xelval maxval,
const int format) {
diff -up netpbm-10.35.58/converter/other/fiasco/lib/image.h.pnmtofiasco-stdin netpbm-10.35.58/converter/other/fiasco/lib/image.h
--- netpbm-10.35.58/converter/other/fiasco/lib/image.h.pnmtofiasco-stdin 2009-01-19 09:23:57.000000000 +0100
+++ netpbm-10.35.58/converter/other/fiasco/lib/image.h 2009-01-21 08:02:29.000000000 +0100
@@ -17,6 +17,8 @@
#ifndef _IMAGE_H
#define _IMAGE_H
+#include "pnm.h"
+
#include <stdio.h>
#include "types.h"
#include "fiasco.h"
@@ -51,6 +53,10 @@ read_pnmheader (const char *image_name,
image_t *
read_image (const char *image_name);
void
+read_image_data(image_t * const image, FILE *input, const bool_t color,
+ const int width, const int height, const xelval maxval,
+ const int format);
+void
write_image (const char *image_name, const image_t *image);
bool_t
same_image_type (const image_t *img1, const image_t *img2);

View File

@ -1,13 +0,0 @@
diff -up netpbm-10.47.04/lib/libppmd.c.ppmpat-segfault netpbm-10.47.04/lib/libppmd.c
--- netpbm-10.47.04/lib/libppmd.c.ppmpat-segfault 2009-10-21 13:39:00.000000000 +0200
+++ netpbm-10.47.04/lib/libppmd.c 2009-11-27 06:31:32.000000000 +0100
@@ -1057,8 +1057,8 @@ ppmd_fill_drawprocp(pixel ** const p
if (fh->coords == NULL)
pm_error("out of memory enlarging a fillhandle");
- ocp = &(fh->coords[fh->n - 1]);
}
+ ocp = &(fh->coords[fh->n - 1]);
/* Check for extremum and set the edge number. */
if (fh->n == 0) {

View File

@ -1,6 +1,6 @@
Summary: A library for handling different graphics file formats Summary: A library for handling different graphics file formats
Name: netpbm Name: netpbm
Version: 10.47.07 Version: 10.47.08
Release: 1%{?dist} Release: 1%{?dist}
# See copyright_summary for details # See copyright_summary for details
License: BSD and GPLv2 and IJG and MIT and Public Domain License: BSD and GPLv2 and IJG and MIT and Public Domain
@ -24,9 +24,7 @@ Patch10: netpbm-ppmtompeg.patch
Patch11: netpbm-multilib.patch Patch11: netpbm-multilib.patch
Patch12: netpbm-pamscale.patch Patch12: netpbm-pamscale.patch
Patch13: netpbm-glibc.patch Patch13: netpbm-glibc.patch
Patch14: netpbm-pnmtofiasco-stdin.patch Patch14: netpbm-svgtopam.patch
Patch15: netpbm-svgtopam.patch
Patch16: netpbm-ppmpat-segfault.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
BuildRequires: libX11-devel, python, jasper-devel BuildRequires: libX11-devel, python, jasper-devel
@ -81,9 +79,7 @@ netpbm-progs. You'll also need to install the netpbm package.
%patch11 -p1 -b .multilib %patch11 -p1 -b .multilib
%patch12 -p1 -b .pamscale %patch12 -p1 -b .pamscale
%patch13 -p1 -b .glibc %patch13 -p1 -b .glibc
%patch14 -p1 -b .pnmtofiasco-stdin %patch14 -p1 -b .svgtopam
%patch15 -p1 -b .svgtopam
%patch16 -p1 -b .ppmpat-segfault
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
@ -212,6 +208,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/netpbm/ %{_datadir}/netpbm/
%changelog %changelog
* Wed Jan 13 2010 Jindrich Novy <jnovy@redhat.com> 10.47.08-1
- update to 10.47.08
* Wed Dec 30 2009 Jindrich Novy <jnovy@redhat.com> 10.47.07-1 * Wed Dec 30 2009 Jindrich Novy <jnovy@redhat.com> 10.47.07-1
- update to 10.47.07 - update to 10.47.07

View File

@ -1 +1 @@
46d9573f83715692f9b0dfb84fcd0e7c netpbm-10.47.07.tar.xz 0b382883c1b93f5120da1eaca7b253f8 netpbm-10.47.08.tar.xz