import netpbm-10.82.00-7.el8

This commit is contained in:
CentOS Sources 2022-05-10 03:11:44 -04:00 committed by Stepan Oksanichenko
parent 4bd5ce2e40
commit d44e35d308
2 changed files with 44 additions and 2 deletions

37
SOURCES/netpbm-lib.patch Normal file
View File

@ -0,0 +1,37 @@
diff -urNp a/lib/Makefile b/lib/Makefile
--- a/lib/Makefile 2021-12-06 10:55:43.832967143 +0100
+++ b/lib/Makefile 2021-12-06 10:56:09.862162960 +0100
@@ -220,7 +220,7 @@ libpm.o: compile.h
.PHONY: install.lib
ifeq ($(NETPBMLIBTYPE),unixshared)
# install a Unix-style shared library
-install.lib: $(PKGDIR)/lib $(PKGDIR)/link
+install.lib: $(PKGDIR)/lib
cd $(PKGDIR)/lib ; rm -f libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).*
$(INSTALL) -c -m $(INSTALL_PERM_LIBD) \
libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).$(MIN) $(PKGDIR)/lib/
@@ -262,19 +262,19 @@ $(INTERFACE_HEADERS:%=%_installhdr): $(P
$(SRCDIR)/lib/$(@:%_installhdr=%) $(PKGDIR)/include/netpbm/
.PHONY: install.staticlib
-install.staticlib: $(PKGDIR)/link
+install.staticlib: $(PKGDIR)/lib
$(INSTALL) -c -m $(INSTALL_PERM_LIBS) libnetpbm.$(STATICLIBSUFFIX) \
- $(PKGDIR)/link
+ $(PKGDIR)/lib
# Install a shared library stub -- the ".so" file used at link time to
# prepare a program for dynamically linking a library at run time
.PHONY: install.sharedlibstub
-install.sharedlibstub: $(PKGDIR)/link
+install.sharedlibstub: $(PKGDIR)/lib
ifeq ($(NETPBMLIBTYPE),unixshared)
# install the link-time (.so) links to the runtime libraries
- cd $(PKGDIR)/link ; \
+ cd $(PKGDIR)/lib ; \
rm -f libnetpbm.$(NETPBMLIBSUFFIX); \
- $(SYMLINK) ../lib/libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ) \
+ $(SYMLINK) libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ) \
libnetpbm.$(NETPBMLIBSUFFIX)
endif
ifeq ($(NETPBMLIBTYPE),dll)

View File

@ -1,7 +1,7 @@
Summary: A library for handling different graphics file formats
Name: netpbm
Version: 10.82.00
Release: 6%{?dist}
Release: 7%{?dist}
# See copyright_summary for details
License: BSD and GPLv2 and IJG and MIT and Public Domain
URL: http://netpbm.sourceforge.net/
@ -33,6 +33,7 @@ Patch17: netpbm-manual-pages.patch
Patch18: netpbm-annocheck.patch
Patch19: netpbm-jasper.patch
Patch20: netpbm-covscan.patch
Patch21: netpbm-lib.patch
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex, jbigkit-devel
BuildRequires: libX11-devel, perl-generators, python3, jasper-devel, libxml2-devel
@ -215,12 +216,13 @@ popd
%files
%doc doc/copyright_summary doc/COPYRIGHT.PATENT doc/HISTORY README
%license doc/GPL_LICENSE.txt
%{_libdir}/lib*.so*
%{_libdir}/lib*.so.*
%files devel
%dir %{_includedir}/netpbm
%{_includedir}/netpbm/*.h
%{_mandir}/man3/*
%{_libdir}/lib*.so
%files progs
%{_bindir}/*
@ -232,6 +234,9 @@ popd
%doc userguide/*
%changelog
* Thu Jan 27 2022 Josef Ridky <jridky@redhat.com> - 10.82.00-7
- fix libnetpbm library issue (#2029118)
* Tue Dec 04 2018 Josef Ridky <jridky@redhat.com> - 10.82.00-6
- fix covscan issues (#1602629)