- fix segfault in pbmtolj caused by unchecked assertions caused by
definition of NDEBUG (#160429) - drop hunk from .security patch causing dual inclusion of string.h in pbmtolj.c
This commit is contained in:
parent
897001eb46
commit
cd36fc196d
@ -1441,14 +1441,6 @@
|
|||||||
if ((car >= MAXPKCHAR) || !filename[car]) {
|
if ((car >= MAXPKCHAR) || !filename[car]) {
|
||||||
--- netpbm-10.28/converter/pbm/pbmtolj.c.security 2005-04-23 22:24:05.000000000 +0200
|
--- netpbm-10.28/converter/pbm/pbmtolj.c.security 2005-04-23 22:24:05.000000000 +0200
|
||||||
+++ netpbm-10.28/converter/pbm/pbmtolj.c 2005-06-10 09:44:00.364583648 +0200
|
+++ netpbm-10.28/converter/pbm/pbmtolj.c 2005-06-10 09:44:00.364583648 +0200
|
||||||
@@ -32,6 +32,7 @@
|
|
||||||
#include "mallocvar.h"
|
|
||||||
#include <string.h>
|
|
||||||
#include <assert.h>
|
|
||||||
+#include <string.h>
|
|
||||||
|
|
||||||
static char *rowBuffer, *prevRowBuffer, *packBuffer, *deltaBuffer;
|
|
||||||
static int rowBufferSize, rowBufferIndex, prevRowBufferIndex;
|
|
||||||
@@ -119,7 +120,11 @@ parseCommandLine(int argc, char ** argv,
|
@@ -119,7 +120,11 @@ parseCommandLine(int argc, char ** argv,
|
||||||
static void
|
static void
|
||||||
allocateBuffers(unsigned int const cols) {
|
allocateBuffers(unsigned int const cols) {
|
||||||
|
10
netpbm.spec
10
netpbm.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A library for handling different graphics file formats.
|
Summary: A library for handling different graphics file formats.
|
||||||
Name: netpbm
|
Name: netpbm
|
||||||
Version: 10.28
|
Version: 10.28
|
||||||
Release: 1
|
Release: 2
|
||||||
License: freeware
|
License: freeware
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://netpbm.sourceforge.net/
|
URL: http://netpbm.sourceforge.net/
|
||||||
@ -21,6 +21,7 @@ Patch10: netpbm-10.27-badlink.patch
|
|||||||
Patch11: netpbm-10.27-bmptopnm.patch
|
Patch11: netpbm-10.27-bmptopnm.patch
|
||||||
Patch12: netpbm-10.27-libpm.patch
|
Patch12: netpbm-10.27-libpm.patch
|
||||||
Patch13: netpbm-10.27-pnmtojpeg.patch
|
Patch13: netpbm-10.27-pnmtojpeg.patch
|
||||||
|
Patch14: netpbm-10.28-ndebug.patch
|
||||||
Buildroot: %{_tmppath}/%{name}-root
|
Buildroot: %{_tmppath}/%{name}-root
|
||||||
BuildPrereq: libjpeg-devel, libpng-devel, libtiff-devel, perl
|
BuildPrereq: libjpeg-devel, libpng-devel, libtiff-devel, perl
|
||||||
Obsoletes: libgr
|
Obsoletes: libgr
|
||||||
@ -78,6 +79,7 @@ netpbm-progs. You'll also need to install the netpbm package.
|
|||||||
%patch11 -p1 -b .bmptopnm
|
%patch11 -p1 -b .bmptopnm
|
||||||
%patch12 -p1 -b .libpm
|
%patch12 -p1 -b .libpm
|
||||||
%patch13 -p1 -b .pnmtojpeg
|
%patch13 -p1 -b .pnmtojpeg
|
||||||
|
%patch14 -p1 -b .ndebug
|
||||||
|
|
||||||
##mv shhopt/shhopt.h shhopt/pbmshhopt.h
|
##mv shhopt/shhopt.h shhopt/pbmshhopt.h
|
||||||
##perl -pi -e 's|shhopt.h|pbmshhopt.h|g' `find -name "*.c" -o -name "*.h"` ./GNUmakefile
|
##perl -pi -e 's|shhopt.h|pbmshhopt.h|g' `find -name "*.c" -o -name "*.h"` ./GNUmakefile
|
||||||
@ -175,6 +177,12 @@ rm -rf $RPM_BUILD_ROOT/usr/config_template
|
|||||||
%{_mandir}/man5/*
|
%{_mandir}/man5/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 21 2005 Jindrich Novy <jnovy@redhat.com> 10.28-2
|
||||||
|
- fix segfault in pbmtolj caused by unchecked assertions
|
||||||
|
caused by definition of NDEBUG (#160429)
|
||||||
|
- drop hunk from .security patch causing dual inclusion
|
||||||
|
of string.h in pbmtolj.c
|
||||||
|
|
||||||
* Fri Jun 10 2005 Jindrich Novy <jnovy@redhat.com> 10.28-1
|
* Fri Jun 10 2005 Jindrich Novy <jnovy@redhat.com> 10.28-1
|
||||||
- update to 10.28
|
- update to 10.28
|
||||||
- regenerated man pages
|
- regenerated man pages
|
||||||
|
Loading…
Reference in New Issue
Block a user