- update to 10.47.07

This commit is contained in:
Jindrich Novy 2009-12-30 20:07:49 +00:00
parent 7a46c5cde5
commit ca738e4dff
5 changed files with 6 additions and 83 deletions

View File

@ -1 +1 @@
netpbm-10.47.06.tar.xz
netpbm-10.47.07.tar.xz

View File

@ -1,12 +0,0 @@
--- netpbm-10.32/other/Makefile.pnmdepth 2006-01-03 23:47:15.000000000 +0100
+++ netpbm-10.32/other/Makefile 2006-04-03 14:53:17.000000000 +0200
@@ -66,7 +66,7 @@
$(SYMLINK) pamsplit$(EXE) pnmsplit
# In February 2006, pamdepth replaced pnmdepth
cd $(PKGDIR)/bin ; \
- rm -f pnmsdepth ; \
- $(SYMLINK) pnmsdepth$(EXE) pnmdepth
+ rm -f pnmdepth ; \
+ $(SYMLINK) pamdepth$(EXE) pnmdepth
FORCE:

View File

@ -1,66 +0,0 @@
diff -up netpbm-10.47.04/editor/pnmsmooth.c.pnmsmooth-segfault netpbm-10.47.04/editor/pnmsmooth.c
--- netpbm-10.47.04/editor/pnmsmooth.c.pnmsmooth-segfault 2009-10-21 13:38:57.000000000 +0200
+++ netpbm-10.47.04/editor/pnmsmooth.c 2009-03-23 07:55:01.000000000 +0100
@@ -23,12 +23,12 @@
#include <unistd.h>
#include <string.h>
#include <errno.h>
+#include <sys/wait.h>
#include "pm_c_util.h"
#include "mallocvar.h"
#include "shhopt.h"
#include "nstring.h"
-#include "pm_system.h"
#include "pnm.h"
@@ -176,6 +176,38 @@ writeConvolutionImage(FILE * const
+static void
+runPnmconvol(const char * const inputFilespec,
+ const char * const convolutionImageFilespec) {
+
+ /* fork a Pnmconvol process */
+ pid_t rc;
+
+ rc = fork();
+ if (rc < 0)
+ pm_error("fork() failed. errno=%d (%s)", errno, strerror(errno));
+ else if (rc == 0) {
+ /* child process executes following code */
+
+ execlp("pnmconvol",
+ "pnmconvol", convolutionImageFilespec, inputFilespec,
+ NULL);
+
+ pm_error("error executing pnmconvol command. errno=%d (%s)",
+ errno, strerror(errno));
+ } else {
+ /* This is the parent */
+ pid_t const childPid = rc;
+
+ int status;
+
+ /* wait for child to finish */
+ while (wait(&status) != childPid);
+ }
+}
+
+
+
int
main(int argc, char ** argv) {
@@ -200,8 +232,7 @@ main(int argc, char ** argv) {
if (cmdline.dump) {
/* We're done. Convolution image is in user's file */
} else {
- pm_system_lp("pnmconvol", NULL, NULL, NULL, NULL,
- tempfileName, cmdline.inputFilespec, NULL);
+ runPnmconvol(cmdline.inputFilespec, tempfileName);
unlink(tempfileName);
strfree(tempfileName);

View File

@ -1,6 +1,6 @@
Summary: A library for handling different graphics file formats
Name: netpbm
Version: 10.47.06
Version: 10.47.07
Release: 1%{?dist}
# See copyright_summary for details
License: BSD and GPLv2 and IJG and MIT and Public Domain
@ -27,7 +27,6 @@ Patch13: netpbm-glibc.patch
Patch14: netpbm-pnmtofiasco-stdin.patch
Patch15: netpbm-svgtopam.patch
Patch16: netpbm-ppmpat-segfault.patch
Patch17: netpbm-pnmsmooth-segfault.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
BuildRequires: libX11-devel, python, jasper-devel
@ -85,7 +84,6 @@ netpbm-progs. You'll also need to install the netpbm package.
%patch14 -p1 -b .pnmtofiasco-stdin
%patch15 -p1 -b .svgtopam
%patch16 -p1 -b .ppmpat-segfault
%patch17 -p1 -b .pnmsmooth-segfault
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
@ -214,6 +212,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/netpbm/
%changelog
* Wed Dec 30 2009 Jindrich Novy <jnovy@redhat.com> 10.47.07-1
- update to 10.47.07
* Fri Dec 14 2009 Jindrich Novy <jnovy@redhat.com> 10.47.06-1
- update to 10.47.06 - fixes the dumb pamtosvg mistake in 10.47.05
- pnmmargin won't create leftovers in /tmp (#547888)

View File

@ -1 +1 @@
97501b0316de8257d904d16347ba7730 netpbm-10.47.06.tar.xz
46d9573f83715692f9b0dfb84fcd0e7c netpbm-10.47.07.tar.xz