pnmtops: Multi-page PAM files correction (#833546)
This commit is contained in:
parent
e211666cb2
commit
c51f2c86eb
25
netpbm-multipage-pam.patch
Normal file
25
netpbm-multipage-pam.patch
Normal file
@ -0,0 +1,25 @@
|
||||
diff --git a/converter/other/pnmtops.c b/converter/other/pnmtops.c
|
||||
index 24dc7df..e393931 100644
|
||||
--- a/converter/other/pnmtops.c
|
||||
+++ b/converter/other/pnmtops.c
|
||||
@@ -1909,6 +1909,7 @@ convertPage(FILE * const ifP,
|
||||
/* The file stream which is the head of the filter chain; we write to
|
||||
this and filtered stuff comes out the other end.
|
||||
*/
|
||||
+ FILE * filterChainOfP;
|
||||
|
||||
pnm_readpaminit(ifP, &inpam, PAM_STRUCT_SIZE(tuple_type));
|
||||
|
||||
@@ -1951,7 +1952,11 @@ convertPage(FILE * const ifP,
|
||||
initOutputEncoder(&oe, inpam.width, bitsPerSample,
|
||||
rle, flate, ascii85, psFilter);
|
||||
|
||||
- spawnFilters(stdout, &oe, &feedFileP, filterPidList);
|
||||
+ fflush(stdout);
|
||||
+ filterChainOfP = fdopen(dup(fileno(stdout)), "w");
|
||||
+ /* spawnFilters() closes this. See FILE MANAGEMENT above */
|
||||
+
|
||||
+ spawnFilters(filterChainOfP, &oe, &feedFileP, filterPidList);
|
||||
|
||||
convertRaster(&inpam, bitsPerSample, psFilter, feedFileP);
|
||||
|
@ -1,7 +1,7 @@
|
||||
Summary: A library for handling different graphics file formats
|
||||
Name: netpbm
|
||||
Version: 10.61.02
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
# See copyright_summary for details
|
||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||
Group: System Environment/Libraries
|
||||
@ -34,6 +34,7 @@ Patch23: netpbm-manfix.patch
|
||||
Patch24: netpbm-ppmtopict.patch
|
||||
Patch25: netpbm-pnmtopclxl.patch
|
||||
Patch26: netpbm-man-repeated.patch
|
||||
Patch27: netpbm-multipage-pam.patch
|
||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
||||
BuildRequires: libX11-devel, python, jasper-devel, libxml2-devel
|
||||
|
||||
@ -108,6 +109,7 @@ netpbm-doc. You'll also need to install the netpbm-progs package.
|
||||
%patch24 -p1 -b .ppmtopict
|
||||
%patch25 -p1 -b .pnmtopclxl
|
||||
%patch26 -p1 -b .man-repeated
|
||||
%patch27 -p1 -b .multipage-pam
|
||||
|
||||
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
|
||||
rm -rf converter/other/jpeg2000/libjasper/
|
||||
@ -258,6 +260,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc userguide/*
|
||||
|
||||
%changelog
|
||||
* Tue May 28 2013 Petr Hracek <phracek@redhat.com> - 10.61.02-3
|
||||
- pnmtops: Multi-page PAM files correction (#833546)
|
||||
|
||||
* Mon May 27 2013 Petr Hracek <phracek@redhat.com> 10.61.02-2
|
||||
- Man page corrections (#948531)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user