- update to 10.47.04 (it is now stable) (#529525)

This commit is contained in:
Jindrich Novy 2009-10-21 15:11:20 +00:00
parent 6f800870f4
commit b3d2df7521
24 changed files with 658 additions and 901 deletions

View File

@ -1,11 +0,0 @@
--- netpbm-10.32/converter/other/giftopnm.c.message 2006-02-15 23:53:45.000000000 +0100
+++ netpbm-10.32/converter/other/giftopnm.c 2006-02-27 14:47:32.000000000 +0100
@@ -1401,7 +1401,7 @@ convertImages(FILE * const ifP,
imageSeq, imageSeq>1?"s":"" );
} else {
if (verbose)
- pm_message("Reading Image Sequence %d", imageSeq);
+ pm_message("Reading Image Sequence %d", imageSeq+1);
convertImage(ifP, !allImages && (imageSeq != requestedImageSeq),
imageout_file, alphafile, gifScreen, gif89);
}

View File

@ -1,10 +0,0 @@
--- netpbm-10.33/buildtools/endiangen.c.multilib 2005-04-30 18:36:33.000000000 +0200
+++ netpbm-10.33/buildtools/endiangen.c 2006-06-05 22:21:43.000000000 +0200
@@ -87,7 +87,6 @@
byteOrder() == ENDIAN_LITTLE ? "LITTLE_ENDIAN" : "BIG_ENDIAN");
printf("#endif\n");
printf("\n");
- printf("#define BITS_PER_WORD %u\n", bitsPerWord());
return 0;
}

View File

@ -1,21 +0,0 @@
diff -up netpbm-10.35.58/lib/libpm.c.64bitfix netpbm-10.35.58/lib/libpm.c
--- netpbm-10.35.58/lib/libpm.c.64bitfix 2009-01-22 08:49:25.000000000 +0100
+++ netpbm-10.35.58/lib/libpm.c 2009-01-22 08:50:38.000000000 +0100
@@ -1069,7 +1069,7 @@
pm_readbiglong(FILE * const ifP,
long * const lP) {
- int c;
+ unsigned int c;
unsigned long l;
c = getc(ifP);
@@ -1148,7 +1148,7 @@
int
pm_readlittlelong(FILE * const ifP,
long * const lP) {
- int c;
+ unsigned int c;
unsigned long l;
c = getc(ifP);

View File

@ -1,12 +0,0 @@
diff -up netpbm-10.35.36/lib/libpbm3.c.gcc43 netpbm-10.35.36/lib/libpbm3.c
--- netpbm-10.35.36/lib/libpbm3.c.gcc43 2007-12-31 07:02:07.000000000 +0100
+++ netpbm-10.35.36/lib/libpbm3.c 2008-01-08 13:08:52.000000000 +0100
@@ -105,7 +105,7 @@ packBitsWithMmxSse(FILE * const
) ];
*/
- typedef int v8qi __attribute__ ((mode(V8QI)));
+ typedef int v8qi __attribute__ ((vector_size(8)));
typedef int di __attribute__ ((mode(DI)));
di const zero64 = 0; /* to clear with PXOR */

View File

@ -1,11 +0,0 @@
diff -up netpbm-10.35.57/editor/pnmmontage.c.pnmmontagefix netpbm-10.35.57/editor/pnmmontage.c
--- netpbm-10.35.57/editor/pnmmontage.c.pnmmontagefix 2008-12-15 10:04:29.000000000 +0100
+++ netpbm-10.35.57/editor/pnmmontage.c 2008-12-23 20:09:01.000000000 +0100
@@ -346,6 +346,7 @@ main(int argc, char **argv)
}
pnm_readpaminit(imgs[0].file, &imgs[0], PAM_STRUCT_SIZE(tuple_type));
+ memset(&outimg, 0, sizeof(outimg));
outimg.maxval = imgs[0].maxval;
outimg.format = imgs[0].format;
memcpy(outimg.tuple_type, imgs[0].tuple_type, sizeof(imgs[0].tuple_type));

View File

@ -1,16 +0,0 @@
diff -up netpbm-10.35.40/pm_config.in.h.rgbtxt netpbm-10.35.40/pm_config.in.h
--- netpbm-10.35.40/pm_config.in.h.rgbtxt 2008-03-09 11:28:32.000000000 +0100
+++ netpbm-10.35.40/pm_config.in.h 2008-03-14 12:27:28.000000000 +0100
@@ -67,9 +67,9 @@
#define RGB_DB2 "PBMplus_Dir:RGB.TXT"
#define RGB_DB3 "PBMplus_Dir:RGB.TXT"
#else
-#define RGB_DB1 "/usr/lib/X11/rgb.txt"
-#define RGB_DB2 "/usr/share/X11/rgb.txt"
-#define RGB_DB3 "/usr/X11R6/lib/X11/rgb.txt"
+#define RGB_DB1 "/usr/share/netpbm/rgb.txt"
+#define RGB_DB2 "/usr/lib/X11/rgb.txt"
+#define RGB_DB3 "/usr/share/X11/rgb.txt"
#endif
/* CONFIGURE: This is the name of an environment variable that tells

View File

@ -1,14 +0,0 @@
--- netpbm-9.24/Makefile.config.in.strip Wed Jun 19 16:02:02 2002
+++ netpbm-9.24/Makefile.config.in Wed Jun 19 16:09:25 2002
@@ -56,9 +56,9 @@
# STRIPFLAG is the option you pass to the above install program to make it
# strip unnecessary information out of binaries.
-STRIPFLAG = -s
+# STRIPFLAG = -s
# If you don't want to strip the binaries, just leave it null:
-#STRIPFLAG =
+STRIPFLAG =
SYMLINK = ln -s
# At least some Windows environments don't have any concept of symbolic

12
netpbm-message.patch Normal file
View File

@ -0,0 +1,12 @@
diff -up netpbm-10.47.04/converter/other/giftopnm.c.message netpbm-10.47.04/converter/other/giftopnm.c
--- netpbm-10.47.04/converter/other/giftopnm.c.message 2009-10-21 13:39:06.000000000 +0200
+++ netpbm-10.47.04/converter/other/giftopnm.c 2009-10-21 14:34:42.000000000 +0200
@@ -1676,7 +1676,7 @@ convertImages(FILE * const ifP,
imageSeq, imageSeq > 1 ? "s" : "");
} else {
if (verbose)
- pm_message("Reading Image Sequence %d", imageSeq);
+ pm_message("Reading Image Sequence %d", imageSeq+1);
convertImage(ifP, !allImages && (imageSeq != requestedImageSeq),
imageout_file, alphafile, gifScreen, gif89,
tolerateBadInput);

11
netpbm-multilib.patch Normal file
View File

@ -0,0 +1,11 @@
diff -up netpbm-10.47.04/buildtools/endiangen.c.multilib netpbm-10.47.04/buildtools/endiangen.c
--- netpbm-10.47.04/buildtools/endiangen.c.multilib 2009-10-21 13:38:54.000000000 +0200
+++ netpbm-10.47.04/buildtools/endiangen.c 2009-10-21 14:35:58.000000000 +0200
@@ -87,7 +87,6 @@ main(int argc, char **argv) {
byteOrder() == ENDIAN_LITTLE ? "LITTLE_ENDIAN" : "BIG_ENDIAN");
printf("#endif\n");
printf("\n");
- printf("#define BITS_PER_LONG %u\n", bitsPerLong());
return 0;
}

File diff suppressed because it is too large Load Diff

View File

@ -1,20 +1,19 @@
diff -up netpbm-10.35.48/converter/other/anytopnm.security2 netpbm-10.35.48/converter/other/anytopnm
--- netpbm-10.35.48/converter/other/anytopnm.security2 2008-08-03 22:07:04.000000000 +0200
+++ netpbm-10.35.48/converter/other/anytopnm 2008-08-04 07:11:46.000000000 +0200
@@ -506,11 +506,7 @@ else
diff -up netpbm-10.47.04/converter/other/anytopnm.security2 netpbm-10.47.04/converter/other/anytopnm
--- netpbm-10.47.04/converter/other/anytopnm.security2 2009-10-21 13:39:06.000000000 +0200
+++ netpbm-10.47.04/converter/other/anytopnm 2009-10-21 14:51:49.000000000 +0200
@@ -510,10 +510,7 @@ else
inputFile="-"
fi
-tempdir="${TMPDIR-/tmp}/anytopnm.$$"
-mkdir $tempdir || { echo "Could not create temporary file. Exiting."; exit 1;}
-chmod 700 $tempdir
-
-mkdir -m 0700 $tempdir || \
- { echo "Could not create temporary file. Exiting."; exit 1;}
-trap 'rm -rf $tempdir' 0
+tempdir=$(mktemp -d -t anytopnm.XXXXXXXXXX) || exit 1
# Take out all spaces
# Find the filename extension for last-ditch efforts later
@@ -536,9 +532,17 @@ if [ "$filetype" = "unknown" ]; then
@@ -539,9 +536,17 @@ if [ "$filetype" = "unknown" ]; then
echo "$progname: unknown file type. " \
"'file' says mime type is '$mimeType', " 1>&2
echo "type description is '$typeDescription'" 1>&2
@ -32,32 +31,30 @@ diff -up netpbm-10.35.48/converter/other/anytopnm.security2 netpbm-10.35.48/conv
+fi
+
exit 0
diff -up netpbm-10.35.48/editor/pamstretch-gen.security2 netpbm-10.35.48/editor/pamstretch-gen
--- netpbm-10.35.48/editor/pamstretch-gen.security2 2008-08-03 22:06:45.000000000 +0200
+++ netpbm-10.35.48/editor/pamstretch-gen 2008-08-04 07:11:46.000000000 +0200
@@ -31,10 +31,7 @@ if [ "$1" = "" ]; then
diff -up netpbm-10.47.04/editor/pamstretch-gen.security2 netpbm-10.47.04/editor/pamstretch-gen
--- netpbm-10.47.04/editor/pamstretch-gen.security2 2009-10-21 13:38:57.000000000 +0200
+++ netpbm-10.47.04/editor/pamstretch-gen 2009-10-21 14:53:28.000000000 +0200
@@ -31,9 +31,7 @@ if [ "$1" = "" ]; then
exit 1
fi
-tempdir="${TMPDIR-/tmp}/pamstretch-gen.$$"
-mkdir $tempdir || { echo "Could not create temporary file. Exiting."; exit 1;}
-chmod 700 $tempdir
-tempfile=$tempdir/pnmig
-mkdir -m 0700 $tempdir || \
- { echo "Could not create temporary file. Exiting."; exit 1;}
+tempfile=$(mktemp /tmp/pnmig.XXXXXXXXXX) || exit 1
trap 'rm -rf $tempdir' 0 1 3 15
diff -up netpbm-10.35.48/editor/pnmmargin.security2 netpbm-10.35.48/editor/pnmmargin
--- netpbm-10.35.48/editor/pnmmargin.security2 2008-08-03 22:06:45.000000000 +0200
+++ netpbm-10.35.48/editor/pnmmargin 2008-08-04 07:11:46.000000000 +0200
@@ -11,16 +11,11 @@
tempfile=$tempdir/pnmig
diff -up netpbm-10.47.04/editor/pnmmargin.security2 netpbm-10.47.04/editor/pnmmargin
--- netpbm-10.47.04/editor/pnmmargin.security2 2009-10-21 13:38:57.000000000 +0200
+++ netpbm-10.47.04/editor/pnmmargin 2009-10-21 14:55:40.000000000 +0200
@@ -11,15 +11,11 @@
# documentation. This software is provided "as is" without express or
# implied warranty.
-tempdir="${TMPDIR-/tmp}/pnmmargin.$$"
-mkdir $tempdir || { echo "Could not create temporary file. Exiting."; exit 1;}
-chmod 700 $tempdir
-
-mkdir -m 0700 $tempdir || \
- { echo "Could not create temporary file. Exiting." 1>&2; exit 1;}
-trap 'rm -rf $tempdir' 0 1 3 15
-
-tmp1=$tempdir/pnmm1
@ -71,8 +68,8 @@ diff -up netpbm-10.35.48/editor/pnmmargin.security2 netpbm-10.35.48/editor/pnmma
+tmp4="$tmpdir/tmp4"
color="-gofigure"
@@ -39,6 +34,9 @@ while true ; do
plainopt=""
@@ -43,6 +39,9 @@ while true ; do
shift
if [ ! ${1-""} ] ; then
echo "usage: $0 [-white|-black|-color <colorspec>] <size> [pnmfile]" 1>&2
@ -82,7 +79,7 @@ diff -up netpbm-10.35.48/editor/pnmmargin.security2 netpbm-10.35.48/editor/pnmma
exit 1
fi
color="$1"
@@ -46,6 +44,9 @@ while true ; do
@@ -50,6 +49,9 @@ while true ; do
;;
-* )
echo "usage: $0 [-white|-black|-color <colorspec>] <size> [pnmfile]" 1>&2
@ -92,7 +89,7 @@ diff -up netpbm-10.35.48/editor/pnmmargin.security2 netpbm-10.35.48/editor/pnmma
exit 1
;;
* )
@@ -56,6 +57,9 @@ done
@@ -60,6 +62,9 @@ done
if [ ! ${1-""} ] ; then
echo "usage: $0 [-white|-black|-color <colorspec>] <size> [pnmfile]" 1>&2
@ -102,7 +99,7 @@ diff -up netpbm-10.35.48/editor/pnmmargin.security2 netpbm-10.35.48/editor/pnmma
exit 1
fi
size="$1"
@@ -63,6 +67,9 @@ shift
@@ -67,6 +72,9 @@ shift
if [ ${2-""} ] ; then
echo "usage: $0 [-white|-black|-color <colorspec>] <size> [pnmfile]" 1>&2
@ -112,17 +109,19 @@ diff -up netpbm-10.35.48/editor/pnmmargin.security2 netpbm-10.35.48/editor/pnmma
exit 1
fi
@@ -86,3 +93,7 @@ pamflip -rotate90 $tmp2 > $tmp3
# Cat things together.
pnmcat -lr $tmp2 $tmp1 $tmp2 > $tmp4
pnmcat -tb $tmp3 $tmp4 $tmp3
+
@@ -103,6 +111,6 @@ else
pnmcat -tb $plainopt $tmp3 $tmp4 $tmp3
fi
-
-
-
+if [ -d "$tmpdir" ]; then
+ rm -rf "$tmpdir"
+fi
diff -up netpbm-10.35.48/editor/ppmfade.security2 netpbm-10.35.48/editor/ppmfade
--- netpbm-10.35.48/editor/ppmfade.security2 2008-08-03 22:06:45.000000000 +0200
+++ netpbm-10.35.48/editor/ppmfade 2008-08-04 07:11:46.000000000 +0200
diff -up netpbm-10.47.04/editor/ppmfade.security2 netpbm-10.47.04/editor/ppmfade
--- netpbm-10.47.04/editor/ppmfade.security2 2009-10-21 13:38:57.000000000 +0200
+++ netpbm-10.47.04/editor/ppmfade 2009-10-21 15:03:01.000000000 +0200
@@ -14,6 +14,7 @@
#
#-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
@ -131,7 +130,7 @@ diff -up netpbm-10.35.48/editor/ppmfade.security2 netpbm-10.35.48/editor/ppmfade
my $SPREAD = 1;
my $SHIFT = 2;
@@ -116,20 +117,26 @@ if ($first_file ne "undefined") {
@@ -111,20 +112,26 @@ if ($first_file ne "undefined") {
print("Frames are " . $width . "W x " . $height . "H\n");
@ -162,7 +161,7 @@ diff -up netpbm-10.35.48/editor/ppmfade.security2 netpbm-10.35.48/editor/ppmfade
}
#
@@ -137,14 +144,14 @@ if ($last_file eq "undefined") {
@@ -132,14 +139,14 @@ if ($last_file eq "undefined") {
#
# Here's what our temporary files are:
@ -185,7 +184,7 @@ diff -up netpbm-10.35.48/editor/ppmfade.security2 netpbm-10.35.48/editor/ppmfade
my $i; # Frame number
for ($i = 1; $i <= $nframes; $i++) {
@@ -152,148 +159,148 @@ for ($i = 1; $i <= $nframes; $i++) {
@@ -147,147 +154,147 @@ for ($i = 1; $i <= $nframes; $i++) {
if ($mode eq $SPREAD) {
if ($i <= 10) {
my $n = $spline20[$i] * 100;
@ -386,18 +385,16 @@ diff -up netpbm-10.35.48/editor/ppmfade.security2 netpbm-10.35.48/editor/ppmfade
+system("rm $tmpdir/junk*$$.ppm");
exit(0);
diff -up netpbm-10.35.48/editor/ppmquantall.security2 netpbm-10.35.48/editor/ppmquantall
--- netpbm-10.35.48/editor/ppmquantall.security2 2008-08-03 22:06:45.000000000 +0200
+++ netpbm-10.35.48/editor/ppmquantall 2008-08-04 07:11:46.000000000 +0200
@@ -70,13 +70,8 @@ for i in ${files[@]}; do
diff -up netpbm-10.47.04/editor/ppmquantall.security2 netpbm-10.47.04/editor/ppmquantall
--- netpbm-10.47.04/editor/ppmquantall.security2 2009-10-21 13:38:57.000000000 +0200
+++ netpbm-10.47.04/editor/ppmquantall 2009-10-21 14:52:38.000000000 +0200
@@ -70,12 +70,8 @@ for i in ${files[@]}; do
heights=(${heights[*]} `grep -v '^#' $i | sed '1d; s/.* //; 2q'`)
done
-tempdir="${TMPDIR-/tmp}/ppmquantall.$$"
-mkdir $tempdir || { echo "Could not create temporary file. Exiting."; exit 1;}
-chmod 700 $tempdir
-
-mkdir -m 0700 $tempdir || \
- { echo "Could not create temporary file. Exiting."; exit 1;}
-trap 'rm -rf $tempdir' 0 1 3 15
-
-all=$tempdir/pqa.all.$$
@ -406,9 +403,9 @@ diff -up netpbm-10.35.48/editor/ppmquantall.security2 netpbm-10.35.48/editor/ppm
pnmcat -topbottom -jleft -white ${files[@]} | pnmquant $newcolors > $all
if [ $? != 0 ]; then
diff -up netpbm-10.35.48/editor/ppmshadow.security2 netpbm-10.35.48/editor/ppmshadow
--- netpbm-10.35.48/editor/ppmshadow.security2 2008-08-03 22:06:45.000000000 +0200
+++ netpbm-10.35.48/editor/ppmshadow 2008-08-04 07:11:46.000000000 +0200
diff -up netpbm-10.47.04/editor/ppmshadow.security2 netpbm-10.47.04/editor/ppmshadow
--- netpbm-10.47.04/editor/ppmshadow.security2 2009-10-21 13:38:57.000000000 +0200
+++ netpbm-10.47.04/editor/ppmshadow 2009-10-21 14:51:02.000000000 +0200
@@ -72,9 +72,10 @@ sub makeConvolutionKernel($$) {

View File

@ -1,6 +1,6 @@
Summary: A library for handling different graphics file formats
Name: netpbm
Version: 10.35.68
Version: 10.47.04
Release: 1%{?dist}
# See copyright_summary for details
License: BSD and GPLv2 and IJG and MIT and Public Domain
@ -11,26 +11,21 @@ URL: http://netpbm.sourceforge.net/
# svn checkout https://netpbm.svn.sourceforge.net/svnroot/netpbm/userguide netpbm-%{version}/userguide
# and removing the .svn directories
Source0: netpbm-%{version}.tar.xz
Patch1: netpbm-10.17-time.patch
Patch2: netpbm-9.24-strip.patch
Patch3: netpbm-10.19-message.patch
Patch4: netpbm-10.22-security2.patch
Patch6: netpbm-10.23-security.patch
Patch7: netpbm-10.24-nodoc.patch
Patch8: netpbm-10.28-gcc4.patch
Patch9: netpbm-10.27-bmptopnm.patch
Patch10: netpbm-10.28-CAN-2005-2471.patch
Patch11: netpbm-10.31-xwdfix.patch
Patch12: netpbm-10.33-ppmtompeg.patch
Patch13: netpbm-10.33-multilib.patch
Patch14: netpbm-10.34-pamscale.patch
Patch18: netpbm-10.35-glibc.patch
Patch19: netpbm-10.35-gcc43.patch
Patch20: netpbm-10.35-rgbtxt.patch
Patch22: netpbm-10.35-pnmmontagefix.patch
Patch23: netpbm-10.35-pnmtofiasco-stdin.patch
Patch24: netpbm-10.35-64bitfix.patch
Patch29: netpbm-10.35-svgtopam.patch
Patch1: netpbm-time.patch
Patch2: netpbm-message.patch
Patch3: netpbm-security-scripts.patch
Patch4: netpbm-security-code.patch
Patch5: netpbm-nodoc.patch
Patch6: netpbm-gcc4.patch
Patch7: netpbm-bmptopnm.patch
Patch8: netpbm-CAN-2005-2471.patch
Patch9: netpbm-xwdfix.patch
Patch10: netpbm-ppmtompeg.patch
Patch11: netpbm-multilib.patch
Patch12: netpbm-pamscale.patch
Patch13: netpbm-glibc.patch
Patch14: netpbm-pnmtofiasco-stdin.patch
Patch15: netpbm-svgtopam.patch
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
BuildRequires: libX11-devel, python, jasper-devel
@ -73,25 +68,22 @@ netpbm-progs. You'll also need to install the netpbm package.
%prep
%setup -q
%patch1 -p1 -b .time
%patch2 -p1 -b .strip
%patch3 -p1 -b .message
%patch4 -p1 -b .security2
%patch6 -p1 -b .security
%patch7 -p1 -b .nodoc
%patch8 -p1 -b .gcc4
%patch9 -p1 -b .bmptopnm
%patch10 -p1 -b .CAN-2005-2471
%patch11 -p1 -b .xwdfix
%patch12 -p1 -b .ppmtompeg
%patch13 -p1 -b .multilib
%patch14 -p1 -b .pamscale
%patch18 -p1 -b .glibc
%patch19 -p1 -b .gcc43
%patch20 -p1 -b .rgbtxt
%patch22 -p1 -b .pnmmontagefix
%patch23 -p1 -b .pnmtofiasco-stdin
%patch24 -p1 -b .64bitfix
%patch29 -p1 -b .svgtopam
%patch2 -p1 -b .message
%patch3 -p1 -b .security-scripts
%patch4 -p1 -b .security-code
%patch5 -p1 -b .nodoc
%patch6 -p1 -b .gcc4
%patch7 -p1 -b .bmptopnm
%patch8 -p1 -b .CAN-2005-2471
%patch9 -p1 -b .xwdfix
%patch10 -p1 -b .ppmtompeg
%patch11 -p1 -b .multilib
%patch12 -p1 -b .pamscale
%patch13 -p1 -b .glibc
%patch14 -p1 -b .pnmtofiasco-stdin
%patch15 -p1 -b .svgtopam
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
%build
./configure <<EOF
@ -205,7 +197,8 @@ rm -rf $RPM_BUILD_ROOT
%files devel
%defattr(-,root,root)
%{_includedir}/*.h
%dir %{_includedir}/netpbm
%{_includedir}/netpbm/*.h
%{_libdir}/lib*.so
%{_mandir}/man3/*
@ -217,6 +210,9 @@ rm -rf $RPM_BUILD_ROOT
%{_datadir}/netpbm/
%changelog
* Wed Oct 21 2009 Jindrich Novy <jnovy@redhat.com> 10.47.04-1
- update to 10.47.04 (it is now stable) (#529525)
* Fri Oct 9 2009 Jindrich Novy <jnovy@redhat.com> 10.35.68-1
- update to 10.35.68