update to 10.30
This commit is contained in:
parent
f11f069a4b
commit
acf309e2d1
@ -12,3 +12,5 @@ netpbm-10.28.tar.bz2
|
|||||||
netpbmdoc-10.28.tar.bz2
|
netpbmdoc-10.28.tar.bz2
|
||||||
netpbm-10.29.tar.bz2
|
netpbm-10.29.tar.bz2
|
||||||
netpbmdoc-10.29.tar.bz2
|
netpbmdoc-10.29.tar.bz2
|
||||||
|
netpbmdoc-10.30.tar.bz2
|
||||||
|
netpbm-10.30.tar.bz2
|
||||||
|
File diff suppressed because it is too large
Load Diff
@ -9,15 +9,6 @@
|
|||||||
unsigned int pos;
|
unsigned int pos;
|
||||||
|
|
||||||
/* The following are all information from the BMP headers */
|
/* The following are all information from the BMP headers */
|
||||||
@@ -1081,7 +1081,7 @@ main(int argc, char ** argv) {
|
|
||||||
parse_command_line(argc, argv, &cmdline);
|
|
||||||
|
|
||||||
ifP = pm_openr(cmdline.input_filespec);
|
|
||||||
- if (strcmp(cmdline.input_filespec, "-"))
|
|
||||||
+ if (!strcmp(cmdline.input_filespec, "-"))
|
|
||||||
ifname = "Standard Input";
|
|
||||||
else
|
|
||||||
ifname = cmdline.input_filespec;
|
|
||||||
@@ -1106,7 +1106,7 @@ main(int argc, char ** argv) {
|
@@ -1106,7 +1106,7 @@ main(int argc, char ** argv) {
|
||||||
writeRaster(BMPraster, cols, rows, outputType, cBitCount, pixelformat,
|
writeRaster(BMPraster, cols, rows, outputType, cBitCount, pixelformat,
|
||||||
colormap);
|
colormap);
|
||||||
|
@ -1,26 +1,5 @@
|
|||||||
--- netpbm-10.28/converter/ppm/ppmtowinicon.c.gcc4 2005-06-10 10:34:45.341676768 +0200
|
--- netpbm-10.30/lib/pm.h.gcc4 2005-10-21 12:19:56.000000000 +0200
|
||||||
+++ netpbm-10.28/converter/ppm/ppmtowinicon.c 2005-06-10 10:34:51.749702600 +0200
|
+++ netpbm-10.30/lib/pm.h 2005-10-21 12:20:03.000000000 +0200
|
||||||
@@ -745,7 +745,7 @@ addEntryToIcon(MS_Ico const MSIcon
|
|
||||||
* Perhaps I should use something that allocs a decent amount at start...
|
|
||||||
*/
|
|
||||||
MSIconData->entries =
|
|
||||||
- realloc2 (MSIconData->entries, MSIconData->count * sizeof(IC_Entry *));
|
|
||||||
+ (IC_Entry*)realloc2 (MSIconData->entries, MSIconData->count * sizeof(IC_Entry *));
|
|
||||||
MSIconData->entries[MSIconData->count-1] = entry;
|
|
||||||
}
|
|
||||||
|
|
||||||
--- netpbm-10.28/buildtools/typegen.c.gcc4 2005-04-27 18:24:29.000000000 +0200
|
|
||||||
+++ netpbm-10.28/buildtools/typegen.c 2005-06-10 10:34:51.749702600 +0200
|
|
||||||
@@ -28,6 +28,7 @@
|
|
||||||
We also include the multiple inclusion guard ifdef.
|
|
||||||
-----------------------------------------------------------------------------*/
|
|
||||||
#include <stdio.h>
|
|
||||||
+#include <stdlib.h>
|
|
||||||
#include <unistd.h>
|
|
||||||
|
|
||||||
|
|
||||||
--- netpbm-10.28/lib/pm.h.gcc4 2005-06-10 10:34:45.399667952 +0200
|
|
||||||
+++ netpbm-10.28/lib/pm.h 2005-06-10 10:34:51.750702448 +0200
|
|
||||||
@@ -18,6 +18,7 @@
|
@@ -18,6 +18,7 @@
|
||||||
#include <sys/types.h>
|
#include <sys/types.h>
|
||||||
#include <ctype.h>
|
#include <ctype.h>
|
||||||
@ -29,37 +8,13 @@
|
|||||||
#include <errno.h>
|
#include <errno.h>
|
||||||
#include <setjmp.h>
|
#include <setjmp.h>
|
||||||
#include <sys/stat.h>
|
#include <sys/stat.h>
|
||||||
--- netpbm-10.28/urt/rle_getrow.c.gcc4 2005-06-10 10:34:45.401667648 +0200
|
--- netpbm-10.30/urt/rle.h.gcc4 2005-10-21 12:19:56.000000000 +0200
|
||||||
+++ netpbm-10.28/urt/rle_getrow.c 2005-06-10 10:34:51.751702296 +0200
|
+++ netpbm-10.30/urt/rle.h 2005-10-21 12:21:31.000000000 +0200
|
||||||
@@ -32,7 +32,8 @@
|
|
||||||
* $Id: rle_getrow.c,v 3.0.1.5 1992/03/04 19:33:08 spencer Exp spencer $
|
|
||||||
*/
|
|
||||||
|
|
||||||
-#include "stdio.h"
|
|
||||||
+#include <stdio.h>
|
|
||||||
+#include <string.h>
|
|
||||||
#include "rle.h"
|
|
||||||
#include "rle_code.h"
|
|
||||||
#include "vaxshort.h"
|
|
||||||
--- netpbm-10.28/urt/rle.h.gcc4 2005-06-10 10:34:45.402667496 +0200
|
|
||||||
+++ netpbm-10.28/urt/rle.h 2005-06-10 10:34:51.752702144 +0200
|
|
||||||
@@ -36,6 +36,7 @@
|
@@ -36,6 +36,7 @@
|
||||||
#include "rle_config.h" /* Configuration parameters. */
|
#include "rle_config.h" /* Configuration parameters. */
|
||||||
|
|
||||||
#include <stdio.h> /* Declare FILE. */
|
#include <stdio.h> /* Declare FILE. */
|
||||||
+#include <string.h>
|
+#include <string.h>
|
||||||
|
|
||||||
#ifdef c_plusplus
|
#ifdef c_plusplus
|
||||||
#define USE_PROTOTYPES
|
#define USE_PROTOTYPES
|
||||||
--- netpbm-10.28/urt/Runput.c.gcc4 2005-06-10 10:34:45.400667800 +0200
|
|
||||||
+++ netpbm-10.28/urt/Runput.c 2005-06-10 10:34:51.753701992 +0200
|
|
||||||
@@ -92,7 +92,8 @@
|
|
||||||
* follow the last byte in the run.
|
|
||||||
*/
|
|
||||||
|
|
||||||
-#include "stdio.h"
|
|
||||||
+#include <stdio.h>
|
|
||||||
+#include <string.h>
|
|
||||||
#include "rle_put.h"
|
|
||||||
#include "rle.h"
|
|
||||||
#include "rle_code.h"
|
|
||||||
|
51
netpbm.spec
51
netpbm.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A library for handling different graphics file formats.
|
Summary: A library for handling different graphics file formats.
|
||||||
Name: netpbm
|
Name: netpbm
|
||||||
Version: 10.29
|
Version: 10.30
|
||||||
Release: 2
|
Release: 1
|
||||||
License: freeware
|
License: freeware
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
URL: http://netpbm.sourceforge.net/
|
URL: http://netpbm.sourceforge.net/
|
||||||
@ -10,16 +10,15 @@ Source1: netpbmdoc-%{version}.tar.bz2
|
|||||||
Patch0: netpbm-10.28-legal.patch
|
Patch0: netpbm-10.28-legal.patch
|
||||||
Patch1: netpbm-10.17-time.patch
|
Patch1: netpbm-10.17-time.patch
|
||||||
Patch2: netpbm-9.24-strip.patch
|
Patch2: netpbm-9.24-strip.patch
|
||||||
Patch3: netpbm-10.18-manpath.patch
|
Patch3: netpbm-10.19-message.patch
|
||||||
Patch4: netpbm-10.19-message.patch
|
Patch4: netpbm-10.22-security2.patch
|
||||||
Patch5: netpbm-10.22-security2.patch
|
Patch5: netpbm-10.22-cmapsize.patch
|
||||||
Patch6: netpbm-10.22-cmapsize.patch
|
Patch6: netpbm-10.23-security.patch
|
||||||
Patch7: netpbm-10.23-security.patch
|
Patch7: netpbm-10.24-nodoc.patch
|
||||||
Patch8: netpbm-10.24-nodoc.patch
|
Patch8: netpbm-10.28-gcc4.patch
|
||||||
Patch9: netpbm-10.28-gcc4.patch
|
Patch9: netpbm-10.27-bmptopnm.patch
|
||||||
Patch10: netpbm-10.27-bmptopnm.patch
|
Patch10: netpbm-10.28-CAN-2005-2471.patch
|
||||||
Patch11: netpbm-10.28-CAN-2005-2471.patch
|
Patch11: netpbm-10.29-pnmtopng.patch
|
||||||
Patch12: netpbm-10.29-pnmtopng.patch
|
|
||||||
Buildroot: %{_tmppath}/%{name}-root
|
Buildroot: %{_tmppath}/%{name}-root
|
||||||
BuildPrereq: libjpeg-devel, libpng-devel, libtiff-devel, perl
|
BuildPrereq: libjpeg-devel, libpng-devel, libtiff-devel, perl
|
||||||
Obsoletes: libgr
|
Obsoletes: libgr
|
||||||
@ -66,16 +65,15 @@ netpbm-progs. You'll also need to install the netpbm package.
|
|||||||
%patch0 -p1 -b .legal
|
%patch0 -p1 -b .legal
|
||||||
%patch1 -p1 -b .time
|
%patch1 -p1 -b .time
|
||||||
%patch2 -p1 -b .strip
|
%patch2 -p1 -b .strip
|
||||||
%patch3 -p1 -b .manpath
|
%patch3 -p1 -b .message
|
||||||
%patch4 -p1 -b .message
|
%patch4 -p1 -b .security2
|
||||||
%patch5 -p1 -b .security2
|
%patch5 -p1 -b .cmapsize
|
||||||
%patch6 -p1 -b .cmapsize
|
%patch6 -p1 -b .security
|
||||||
%patch7 -p1 -b .security
|
%patch7 -p1 -b .nodoc
|
||||||
%patch8 -p1 -b .nodoc
|
%patch8 -p1 -b .gcc4
|
||||||
%patch9 -p1 -b .gcc4
|
%patch9 -p1 -b .bmptopnm
|
||||||
%patch10 -p1 -b .bmptopnm
|
%patch10 -p1 -b .CAN-2005-2471
|
||||||
%patch11 -p1 -b .CAN-2005-2471
|
%patch11 -p1 -b .pnmtopng
|
||||||
%patch12 -p1 -b .pnmtopng
|
|
||||||
|
|
||||||
##mv shhopt/shhopt.h shhopt/pbmshhopt.h
|
##mv shhopt/shhopt.h shhopt/pbmshhopt.h
|
||||||
##perl -pi -e 's|shhopt.h|pbmshhopt.h|g' `find -name "*.c" -o -name "*.h"` ./GNUmakefile
|
##perl -pi -e 's|shhopt.h|pbmshhopt.h|g' `find -name "*.c" -o -name "*.h"` ./GNUmakefile
|
||||||
@ -174,6 +172,14 @@ rm -rf $RPM_BUILD_ROOT/usr/config_template
|
|||||||
%{_mandir}/man5/*
|
%{_mandir}/man5/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 21 2005 Jindrich Novy <jnovy@redhat.com> 10.30-1
|
||||||
|
- update to 10.30
|
||||||
|
- update manpath, gcc4 patches
|
||||||
|
- update security patch - fixed length problem in rle_addhist
|
||||||
|
- update partly upstreamed bmptopnm, pnmtopng patches
|
||||||
|
- drop manpath patch
|
||||||
|
- regenerate man pages
|
||||||
|
|
||||||
* Thu Oct 06 2005 Jindrich Novy <jnovy@redhat.com> 10.29-2
|
* Thu Oct 06 2005 Jindrich Novy <jnovy@redhat.com> 10.29-2
|
||||||
- fix segfault in pnmtopng caused by referencing a NULL pointer (#169532)
|
- fix segfault in pnmtopng caused by referencing a NULL pointer (#169532)
|
||||||
|
|
||||||
@ -181,7 +187,6 @@ rm -rf $RPM_BUILD_ROOT/usr/config_template
|
|||||||
- update to 10.29
|
- update to 10.29
|
||||||
- drop upstreamed .libpm, .pnmtojpeg, .pbmtolj patches
|
- drop upstreamed .libpm, .pnmtojpeg, .pbmtolj patches
|
||||||
- update .CAN-2005-2471 patch
|
- update .CAN-2005-2471 patch
|
||||||
- regenerate man pages
|
|
||||||
|
|
||||||
* Mon Aug 15 2005 Jindrich Novy <jnovy@redhat.com> 10.28-6
|
* Mon Aug 15 2005 Jindrich Novy <jnovy@redhat.com> 10.28-6
|
||||||
- link libnetpbm.so against -lm (#165980)
|
- link libnetpbm.so against -lm (#165980)
|
||||||
|
Loading…
Reference in New Issue
Block a user