- fix cmuwtopbm so that magic bytes test actually works
- fix pamtojpeg2k (don't close stdout twice) - fix documentation for pamperspective and pbmtoepson
This commit is contained in:
parent
fd1150b2f6
commit
7d3e28cc83
21
netpbm-cmuwtopbm.patch
Normal file
21
netpbm-cmuwtopbm.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
diff -up netpbm-10.47.12/converter/pbm/cmuwmtopbm.c.cmuwtopbmfix netpbm-10.47.12/converter/pbm/cmuwmtopbm.c
|
||||||
|
--- netpbm-10.47.12/converter/pbm/cmuwmtopbm.c.cmuwtopbmfix 2010-04-27 15:47:14.000000000 +0200
|
||||||
|
+++ netpbm-10.47.12/converter/pbm/cmuwmtopbm.c 2010-05-03 15:17:06.081277896 +0200
|
||||||
|
@@ -18,7 +18,7 @@
|
||||||
|
This program does not check the pad bits at the end of each row.
|
||||||
|
*/
|
||||||
|
|
||||||
|
-
|
||||||
|
+#include <stdint.h>
|
||||||
|
#include "pbm.h"
|
||||||
|
#include "cmuwm.h"
|
||||||
|
|
||||||
|
@@ -33,7 +33,7 @@ readCmuwmHeader(FILE * const ifP
|
||||||
|
const char * const initReadError =
|
||||||
|
"CMU window manager header EOF / read error";
|
||||||
|
|
||||||
|
- long l;
|
||||||
|
+ uint32_t l;
|
||||||
|
short s;
|
||||||
|
int rc;
|
||||||
|
|
@ -89,3 +89,36 @@ diff -up netpbm-10.35.58/userguide/fiascotopnm.html.docfix netpbm-10.35.58/userg
|
|||||||
|
|
||||||
</DL>
|
</DL>
|
||||||
|
|
||||||
|
diff -up netpbm-10.47.12/userguide/pamperspective.html.docfix netpbm-10.47.12/userguide/pamperspective.html
|
||||||
|
--- netpbm-10.47.12/userguide/pamperspective.html.docfix 2010-04-27 15:48:09.000000000 +0200
|
||||||
|
+++ netpbm-10.47.12/userguide/pamperspective.html 2010-05-03 14:16:26.064266675 +0200
|
||||||
|
@@ -220,7 +220,7 @@ default rectangle as the "frame.&qu
|
||||||
|
a rectangle the axes of which are parallel to those of the frame.
|
||||||
|
|
||||||
|
<p>The frame options are additive. All the parts of the image
|
||||||
|
-specified by either margin options, <b>--include_frame</b>, or
|
||||||
|
+specified by either margin options, <b>--frame_include</b>, or
|
||||||
|
<b>--include</b> (or their defaults) are in the visible part. The
|
||||||
|
visible part is the smallest possible rectangle that contains the
|
||||||
|
parts specified those three ways.
|
||||||
|
diff -up netpbm-10.47.12/userguide/pbmtoepson.html.docfix netpbm-10.47.12/userguide/pbmtoepson.html
|
||||||
|
--- netpbm-10.47.12/userguide/pbmtoepson.html.docfix 2010-04-27 15:48:09.000000000 +0200
|
||||||
|
+++ netpbm-10.47.12/userguide/pbmtoepson.html 2010-05-03 14:34:03.571141020 +0200
|
||||||
|
@@ -18,7 +18,7 @@ pbmtoepson - convert a PBM image into Ep
|
||||||
|
[<b>-dpi=</b><i>n</i>]
|
||||||
|
[<b>-protocol=</b>{<b>escp9</b>|<B>escp</B>}]
|
||||||
|
[<b>-adjacent</b>]
|
||||||
|
-[<b>-nonadjacent</b>]
|
||||||
|
+[<b>-noadjacent</b>]
|
||||||
|
|
||||||
|
[<I>pbmfile</I>]
|
||||||
|
|
||||||
|
@@ -74,7 +74,7 @@ print density for you consistent with yo
|
||||||
|
<p>This option was new in Netpbm 10.23 (July 2004).
|
||||||
|
|
||||||
|
<dt><b>-adjacent</b>
|
||||||
|
-<dt><b>-nonadjacent</b>
|
||||||
|
+<dt><b>-noadjacent</b>
|
||||||
|
|
||||||
|
<dd>These options determine whether the output uses "adjacent dot
|
||||||
|
printing" or not, whatever that is.
|
||||||
|
11
netpbm-pamtojpeg2k.patch
Normal file
11
netpbm-pamtojpeg2k.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
diff -up netpbm-10.47.12/converter/other/jpeg2000/pamtojpeg2k.c.pamtojpeg2kfix netpbm-10.47.12/converter/other/jpeg2000/pamtojpeg2k.c
|
||||||
|
--- netpbm-10.47.12/converter/other/jpeg2000/pamtojpeg2k.c.pamtojpeg2kfix 2010-04-27 15:47:10.000000000 +0200
|
||||||
|
+++ netpbm-10.47.12/converter/other/jpeg2000/pamtojpeg2k.c 2010-05-03 15:37:49.934269588 +0200
|
||||||
|
@@ -518,7 +518,5 @@ main(int argc, char **argv)
|
||||||
|
|
||||||
|
pm_close(ifP);
|
||||||
|
|
||||||
|
- pm_close(stdout);
|
||||||
|
-
|
||||||
|
return 0;
|
||||||
|
}
|
11
netpbm.spec
11
netpbm.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A library for handling different graphics file formats
|
Summary: A library for handling different graphics file formats
|
||||||
Name: netpbm
|
Name: netpbm
|
||||||
Version: 10.47.12
|
Version: 10.47.12
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
# See copyright_summary for details
|
# See copyright_summary for details
|
||||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -31,6 +31,8 @@ Patch17: netpbm-fiasco-overflow.patch
|
|||||||
Patch18: netpbm-lz.patch
|
Patch18: netpbm-lz.patch
|
||||||
Patch19: netpbm-pnmmontagefix.patch
|
Patch19: netpbm-pnmmontagefix.patch
|
||||||
Patch20: netpbm-noppmtompeg.patch
|
Patch20: netpbm-noppmtompeg.patch
|
||||||
|
Patch21: netpbm-cmuwtopbm.patch
|
||||||
|
Patch22: netpbm-pamtojpeg2k.patch
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
||||||
BuildRequires: libX11-devel, python, jasper-devel
|
BuildRequires: libX11-devel, python, jasper-devel
|
||||||
@ -104,6 +106,8 @@ netpbm-doc. You'll also need to install the netpbm-progs package.
|
|||||||
%patch18 -p1 -b .lz
|
%patch18 -p1 -b .lz
|
||||||
%patch19 -p1 -b .pnmmmontagefix
|
%patch19 -p1 -b .pnmmmontagefix
|
||||||
%patch20 -p1 -b .noppmtompeg
|
%patch20 -p1 -b .noppmtompeg
|
||||||
|
%patch21 -p1 -b .cmuwtopbmfix
|
||||||
|
%patch22 -p1 -b .pamtojpeg2kfix
|
||||||
|
|
||||||
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
|
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
|
||||||
rm -rf converter/other/jpeg2000/libjasper/
|
rm -rf converter/other/jpeg2000/libjasper/
|
||||||
@ -247,6 +251,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc userguide/*
|
%doc userguide/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon May 3 2010 Jindrich Novy <jnovy@redhat.com> 10.47.12-3
|
||||||
|
- fix cmuwtopbm so that magic bytes test actually works
|
||||||
|
- fix pamtojpeg2k (don't close stdout twice)
|
||||||
|
- fix documentation for pamperspective and pbmtoepson
|
||||||
|
|
||||||
* Wed Apr 28 2010 Jindrich Novy <jnovy@redhat.com> 10.47.12-2
|
* Wed Apr 28 2010 Jindrich Novy <jnovy@redhat.com> 10.47.12-2
|
||||||
- fix CVE-2007-2721 (#501451)
|
- fix CVE-2007-2721 (#501451)
|
||||||
- add missing man pages
|
- add missing man pages
|
||||||
|
Loading…
Reference in New Issue
Block a user