build netpbm with correct LDFLAGS
Resolves: RHEL-70899
This commit is contained in:
parent
990fd763aa
commit
78ed1d2f17
13
netpbm-shlib-ldflags.patch
Normal file
13
netpbm-shlib-ldflags.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/config.mk.in b/config.mk.in
|
||||
index 50687ba..d35c982 100644
|
||||
--- a/config.mk.in
|
||||
+++ b/config.mk.in
|
||||
@@ -250,7 +250,7 @@ EXE =
|
||||
|
||||
# Here, $(SONAME) resolves to the soname for the shared library being created.
|
||||
# The following are gcc options. This works on GNU libc systems.
|
||||
-LDSHLIB = -shared -Wl,-soname,$(SONAME)
|
||||
+LDSHLIB = $(LDFLAGS) -shared -Wl,-soname,$(SONAME)
|
||||
# You need -nostart instead of -shared on BeOS. Though the BeOS compiler is
|
||||
# ostensibly gcc, it has the -nostart option, which is not mentioned in gcc
|
||||
# documentation and doesn't exist in at least one non-BeOS installation.
|
@ -1,7 +1,7 @@
|
||||
Summary: A library for handling different graphics file formats
|
||||
Name: netpbm
|
||||
Version: 11.02.00
|
||||
Release: 9%{?dist}
|
||||
Release: 10%{?dist}
|
||||
# See copyright_summary for details
|
||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||
URL: http://netpbm.sourceforge.net/
|
||||
@ -30,6 +30,7 @@ Patch16: netpbm-jasper.patch
|
||||
Patch17: netpbm-libdir-so.patch
|
||||
Patch18: netpbm-c99.patch
|
||||
Patch19: netpbm-c99-2.patch
|
||||
Patch20: netpbm-shlib-ldflags.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex, gcc, jbigkit-devel
|
||||
@ -120,7 +121,7 @@ TOP=`pwd`
|
||||
|
||||
make \
|
||||
CC="%{__cc}" \
|
||||
LDFLAGS="$LD_FLAGS -L$TOP/pbm -L$TOP/pgm -L$TOP/pnm -L$TOP/ppm" \
|
||||
LDFLAGS="$LDFLAGS -L$TOP/pbm -L$TOP/pgm -L$TOP/pnm -L$TOP/ppm" \
|
||||
CFLAGS="$CFLAGS -fPIC -flax-vector-conversions -fno-strict-aliasing" \
|
||||
CFLAGS_CONFIG="$CFLAGS" \
|
||||
LADD="-lm" \
|
||||
@ -230,6 +231,9 @@ popd
|
||||
%doc userguide/*
|
||||
|
||||
%changelog
|
||||
* Wed Dec 11 2024 Lukáš Zaoral <lzaoral@redhat.com> - 11.02.00-10
|
||||
- build netpbm with correct LDFLAGS (RHEL-70899)
|
||||
|
||||
* Tue Oct 29 2024 Troy Dawson <tdawson@redhat.com> - 11.02.00-9
|
||||
- Bump release for October 2024 mass rebuild:
|
||||
Resolves: RHEL-64018
|
||||
|
Loading…
Reference in New Issue
Block a user