- update to 10.35.34
- sync security patch and fix typos
This commit is contained in:
parent
23577c077e
commit
778363bf6e
@ -1124,20 +1124,6 @@
|
||||
PNM_ASSIGN1( (*colorsP)[1], *maxvalP );
|
||||
+ overflow_add(h10P->pixmap_width, 15);
|
||||
+ if(h10P->pixmap_width < 0)
|
||||
+ pm_error("assert: negative width");
|
||||
*padrightP =
|
||||
( ( h10P->pixmap_width + 15 ) / 16 ) * 16 - h10P->pixmap_width;
|
||||
*bits_per_itemP = 16;
|
||||
@@ -223,9 +226,13 @@
|
||||
*formatP = PGM_TYPE;
|
||||
*visualclassP = StaticGray;
|
||||
*maxvalP = ( 1 << h10P->display_planes ) - 1;
|
||||
+ overflow_add(*maxvalP, 1);
|
||||
*colorsP = pnm_allocrow( *maxvalP + 1 );
|
||||
for ( i = 0; i <= *maxvalP; ++i )
|
||||
PNM_ASSIGN1( (*colorsP)[i], i );
|
||||
+ overflow_add(h10P->pixmap_width, 15);
|
||||
+ if(h10P->pixmap_width < 0)
|
||||
+ pm_error("assert: negative width");
|
||||
*padrightP =
|
||||
( ( h10P->pixmap_width + 15 ) / 16 ) * 16 - h10P->pixmap_width;
|
||||
|
10
netpbm.spec
10
netpbm.spec
@ -1,13 +1,13 @@
|
||||
Summary: A library for handling different graphics file formats
|
||||
Name: netpbm
|
||||
Version: 10.35.33
|
||||
Version: 10.35.34
|
||||
Release: 1%{?dist}
|
||||
License: Assorted licenses, see %{_docdir}/%{name}-%{version}/copyright_summary
|
||||
Group: System Environment/Libraries
|
||||
URL: http://netpbm.sourceforge.net/
|
||||
# Source0 is prepared by
|
||||
# svn checkout https://netpbm.svn.sourceforge.net/svnroot/netpbm/stable netpbm-%{nersion}
|
||||
# svn checkout https://netpbm.svn.sourceforge.net/svnroot/netpbm/userguide netpbm-%{nersion}/userguide
|
||||
# svn checkout https://netpbm.svn.sourceforge.net/svnroot/netpbm/stable netpbm-%{version}
|
||||
# svn checkout https://netpbm.svn.sourceforge.net/svnroot/netpbm/userguide netpbm-%{version}/userguide
|
||||
# and removing the .svn directories
|
||||
Source0: netpbm-%{version}.tar.bz2
|
||||
Patch1: netpbm-10.17-time.patch
|
||||
@ -209,6 +209,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/netpbm/
|
||||
|
||||
%changelog
|
||||
* Wed Nov 26 2007 Jindrich Novy <jnovy@redhat.com> 10.35.34-1
|
||||
- update to 10.35.34
|
||||
- sync security patch and fix typos
|
||||
|
||||
* Wed Nov 14 2007 Jindrich Novy <jnovy@redhat.com> 10.35.33-1
|
||||
- update to 10.35.33
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user