- update to 10.47.05
- fixes pnmtofiasco, fiascotopnm, pamtosvg, pamtouil and ppmrainbow - upstream fix to pamtosvg caused netpbm not to be rebuildable on any arch because of missing semicolon, the fix is now fixed :-/
This commit is contained in:
parent
1b90006cfb
commit
6724979dcc
@ -1 +1 @@
|
|||||||
netpbm-10.47.04.tar.xz
|
netpbm-10.47.05.tar.xz
|
||||||
|
12
netpbm-pamtosvg.patch
Normal file
12
netpbm-pamtosvg.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up netpbm-10.47.05/converter/other/pamtosvg/vector.c.pamtosvg netpbm-10.47.05/converter/other/pamtosvg/vector.c
|
||||||
|
--- netpbm-10.47.05/converter/other/pamtosvg/vector.c.pamtosvg 2009-12-10 08:34:36.000000000 +0100
|
||||||
|
+++ netpbm-10.47.05/converter/other/pamtosvg/vector.c 2009-12-10 09:58:16.000000000 +0100
|
||||||
|
@@ -39,7 +39,7 @@ vector_to_point(vector_type const v) {
|
||||||
|
|
||||||
|
coord.x = v.dx;
|
||||||
|
coord.y = v.dy;
|
||||||
|
- coord.z = v.dz
|
||||||
|
+ coord.z = v.dz;
|
||||||
|
|
||||||
|
return coord;
|
||||||
|
}
|
@ -1,20 +1,21 @@
|
|||||||
--- netpbm-10.17/converter/other/fiasco/config.h.time 2001-05-28 02:43:11.000000000 +0200
|
diff -up netpbm-10.47.05/converter/other/fiasco/config.h.time netpbm-10.47.05/converter/other/fiasco/config.h
|
||||||
+++ netpbm-10.17/converter/other/fiasco/config.h 2003-09-08 15:23:17.000000000 +0200
|
--- netpbm-10.47.05/converter/other/fiasco/config.h.time 2009-12-10 08:34:36.000000000 +0100
|
||||||
|
+++ netpbm-10.47.05/converter/other/fiasco/config.h 2009-12-10 08:43:54.000000000 +0100
|
||||||
@@ -19,7 +19,7 @@
|
@@ -19,7 +19,7 @@
|
||||||
#define STDC_HEADERS 1
|
#define STDC_HEADERS 1
|
||||||
|
|
||||||
/* Define if you can safely include both <sys/time.h> and <time.h>. */
|
/* Define if you can safely include both <sys/time.h> and <time.h>. */
|
||||||
-#define TIME_WITH_SYS_TIME 1
|
-#define TIME_WITH_SYS_TIME 1
|
||||||
+/* #undef TIME_WITH_SYS_TIME 1 */
|
+/* #undef TIME_WITH_SYS_TIME */
|
||||||
|
|
||||||
/* Define if your processor stores words with the most significant
|
/* Define if the X Window System is missing or not being used. */
|
||||||
byte first (like Motorola and SPARC, unlike Intel and VAX). */
|
#define X_DISPLAY_MISSING 1
|
||||||
@@ -79,7 +79,7 @@
|
@@ -75,7 +75,7 @@
|
||||||
#define HAVE_STRING_H 1
|
#define HAVE_STRING_H 1
|
||||||
|
|
||||||
/* Define if you have the <sys/time.h> header file. */
|
/* Define if you have the <sys/time.h> header file. */
|
||||||
-#define HAVE_SYS_TIME_H 1
|
-#define HAVE_SYS_TIME_H 1
|
||||||
+/* #undef HAVE_SYS_TIME_H 1 */
|
+/* #undef HAVE_SYS_TIME_H */
|
||||||
|
|
||||||
/* Define if you have the <unistd.h> header file. */
|
/* Define if you have the <unistd.h> header file. */
|
||||||
#define HAVE_UNISTD_H 1
|
#define HAVE_UNISTD_H 1
|
||||||
|
12
netpbm.spec
12
netpbm.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A library for handling different graphics file formats
|
Summary: A library for handling different graphics file formats
|
||||||
Name: netpbm
|
Name: netpbm
|
||||||
Version: 10.47.04
|
Version: 10.47.05
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
# See copyright_summary for details
|
# See copyright_summary for details
|
||||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
@ -28,6 +28,7 @@ Patch14: netpbm-pnmtofiasco-stdin.patch
|
|||||||
Patch15: netpbm-svgtopam.patch
|
Patch15: netpbm-svgtopam.patch
|
||||||
Patch16: netpbm-ppmpat-segfault.patch
|
Patch16: netpbm-ppmpat-segfault.patch
|
||||||
Patch17: netpbm-pnmsmooth-segfault.patch
|
Patch17: netpbm-pnmsmooth-segfault.patch
|
||||||
|
Patch18: netpbm-pamtosvg.patch
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
||||||
BuildRequires: libX11-devel, python, jasper-devel
|
BuildRequires: libX11-devel, python, jasper-devel
|
||||||
@ -86,6 +87,7 @@ netpbm-progs. You'll also need to install the netpbm package.
|
|||||||
%patch15 -p1 -b .svgtopam
|
%patch15 -p1 -b .svgtopam
|
||||||
%patch16 -p1 -b .ppmpat-segfault
|
%patch16 -p1 -b .ppmpat-segfault
|
||||||
%patch17 -p1 -b .pnmsmooth-segfault
|
%patch17 -p1 -b .pnmsmooth-segfault
|
||||||
|
%patch18 -p1 -b .pamtosvg
|
||||||
|
|
||||||
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
|
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
|
||||||
|
|
||||||
@ -214,6 +216,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/netpbm/
|
%{_datadir}/netpbm/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Dec 10 2009 Jindrich Novy <jnovy@redhat.com> 10.47.05-1
|
||||||
|
- update to 10.47.05
|
||||||
|
- fixes pnmtofiasco, fiascotopnm, pamtosvg, pamtouil and ppmrainbow
|
||||||
|
- upstream fix to pamtosvg caused netpbm not to be rebuildable on
|
||||||
|
any arch because of missing semicolon, the fix is now fixed :-/
|
||||||
|
|
||||||
* Mon Dec 7 2009 Jindrich Novy <jnovy@redhat.com> 10.47.04-3
|
* Mon Dec 7 2009 Jindrich Novy <jnovy@redhat.com> 10.47.04-3
|
||||||
- fix segfault in pnmsmooth (#545089)
|
- fix segfault in pnmsmooth (#545089)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user