New upstream release (#1851753)
This commit is contained in:
parent
2ac4933a6a
commit
6520ba94f7
@ -1,7 +1,21 @@
|
||||
diff -urNp old/userguide/cameratopam.html new/userguide/cameratopam.html
|
||||
--- old/userguide/cameratopam.html 2017-09-05 09:05:16.000000000 +0200
|
||||
+++ new/userguide/cameratopam.html 2017-09-05 13:16:33.622352535 +0200
|
||||
@@ -25,10 +25,10 @@ cameratopam - convert raw camera image t
|
||||
diff --git a/converter/pbm/pbmtoepson.c b/converter/pbm/pbmtoepson.c
|
||||
index 122a438..5d67746 100644
|
||||
--- a/converter/pbm/pbmtoepson.c
|
||||
+++ b/converter/pbm/pbmtoepson.c
|
||||
@@ -75,7 +75,7 @@ parseCommandLine(int argc,
|
||||
&dpiSpec, 0);
|
||||
OPTENT3(0, "adjacent", OPT_FLAG, NULL,
|
||||
&adjacentSpec, 0);
|
||||
- OPTENT3(0, "nonadjacent", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "noadjacent", OPT_FLAG, NULL,
|
||||
&nonadjacentSpec, 0);
|
||||
|
||||
opt.opt_table = option_def;
|
||||
diff --git a/userguide/cameratopam.html b/userguide/cameratopam.html
|
||||
index b50bfeb..3af9008 100644
|
||||
--- a/userguide/cameratopam.html
|
||||
+++ b/userguide/cameratopam.html
|
||||
@@ -24,10 +24,10 @@ cameratopam - convert raw camera image to PAM
|
||||
[<b>-balance_camera</b>]
|
||||
[<b>-red_scale=</b><i>float</i>]
|
||||
[<b>-blue_scale=</b><i>float</i>]
|
||||
@ -14,7 +28,7 @@ diff -urNp old/userguide/cameratopam.html new/userguide/cameratopam.html
|
||||
[<b>-linear</b>]
|
||||
[<b>-verbose</b>]
|
||||
|
||||
@@ -106,7 +106,7 @@ the default.
|
||||
@@ -110,7 +110,7 @@ the default.
|
||||
<dd>Further adjust the color balance by multiplying the red and blue
|
||||
channels by these values. Both default to 1.0.
|
||||
|
||||
@ -23,7 +37,7 @@ diff -urNp old/userguide/cameratopam.html new/userguide/cameratopam.html
|
||||
|
||||
<dd>Change the output brightness. Default is 1.0.
|
||||
|
||||
@@ -114,14 +114,14 @@ channels by these values. Both default
|
||||
@@ -118,14 +118,14 @@ channels by these values. Both default to 1.0.
|
||||
|
||||
<dd>By default, <b>cameratoapm</b> clips all colors to prevent pink
|
||||
hues in the highlights. Combine this option with
|
||||
@ -40,47 +54,49 @@ diff -urNp old/userguide/cameratopam.html new/userguide/cameratopam.html
|
||||
|
||||
<dd>For cameras based on the Fuji Super CCD SR, this option causes
|
||||
<b>cameratopam</b> to use the secondary sensors, in effect
|
||||
diff -urNp old/userguide/fiascotopnm.html new/userguide/fiascotopnm.html
|
||||
--- old/userguide/fiascotopnm.html 2017-09-05 09:05:16.000000000 +0200
|
||||
+++ new/userguide/fiascotopnm.html 2017-09-05 13:32:51.810458154 +0200
|
||||
@@ -51,7 +51,7 @@ the output file(s) are written to the fi
|
||||
diff --git a/userguide/fiascotopnm.html b/userguide/fiascotopnm.html
|
||||
index c33f701..fa84441 100644
|
||||
--- a/userguide/fiascotopnm.html
|
||||
+++ b/userguide/fiascotopnm.html
|
||||
@@ -56,7 +56,7 @@ the output file(s) are written to the first (writable) directory of
|
||||
this list. Otherwise, the current directory is used to store the
|
||||
output file(s).
|
||||
|
||||
-<DT><B>-z</B>, <B>--fast</B>
|
||||
+<DT><B>-r</B>, <B>--fast</B>
|
||||
<DD>
|
||||
-<dt><b>-z</b>, <b>--fast</b>
|
||||
+<dt><b>-r</b>, <b>--fast</b>
|
||||
<dd>
|
||||
Decompress images in the 4:2:0 format; i.e., each chroma channel is
|
||||
decompressed to an image of halved width and height. Use this option
|
||||
@@ -83,7 +83,7 @@ given amount <I>N</I>. <I>N</I> is 1 (mi
|
||||
is 70. When <I>N</I>=0, then the smoothing amount specified in the
|
||||
@@ -88,7 +88,7 @@ given amount <i>N</i>. <i>N</i> is 1 (minimum) to 100 (maximum); default
|
||||
is 70. When <i>N</i>=0, then the smoothing amount specified in the
|
||||
FIASCO file is used (defined by the FIASCO coder).
|
||||
|
||||
-<DT><B>-F</B> <I>N</I>, <B>--fps=</B><I>N</I>
|
||||
+<DT><B>-F</B> <I>N</I>, <B>--framerate=</B><I>N</I>
|
||||
<DD>
|
||||
Set number of frames per second to <I>N</I>. When using this option,
|
||||
-<dt><b>-F</b> <i>N</i>, <b>--fps=</b><i>N</i>
|
||||
+<dt><b>-F</b> <i>N</i>, <b>--framerate=</b><i>N</i>
|
||||
<dd>
|
||||
Set number of frames per second to <i>N</i>. When using this option,
|
||||
the frame rate specified in the FIASCO file is overridden.
|
||||
@@ -113,13 +113,8 @@ following methods (in the specified orde
|
||||
<LI>--config=<I>name</I>
|
||||
</OL>
|
||||
@@ -118,13 +118,8 @@ following methods (in the specified order):
|
||||
<li>--config=<i>name</i>
|
||||
</ol>
|
||||
|
||||
-<DT><B>-h</B>, <B>--info</B>
|
||||
-<DD>
|
||||
-<dt><b>-h</b>, <b>--info</b>
|
||||
-<dd>
|
||||
-Print brief help, then exit.
|
||||
-
|
||||
-<DT><B>-H</B>, <B>--help</B>
|
||||
-<DD>
|
||||
-<dt><b>-H</b>, <b>--help</b>
|
||||
-<dd>
|
||||
-Print detailed help, then exit.
|
||||
+<DT><B>-h</B>, <B>--help</B>
|
||||
+<dt><b>-h</b>, <b>--help</b>
|
||||
+Print help, then exit.
|
||||
|
||||
</DL>
|
||||
</dl>
|
||||
|
||||
diff -urNp old/userguide/pamperspective.html new/userguide/pamperspective.html
|
||||
--- old/userguide/pamperspective.html 2017-09-05 09:05:16.000000000 +0200
|
||||
+++ new/userguide/pamperspective.html 2017-09-05 13:23:15.869997105 +0200
|
||||
@@ -220,7 +220,7 @@ default rectangle as the "frame." The vi
|
||||
diff --git a/userguide/pamperspective.html b/userguide/pamperspective.html
|
||||
index 018f18a..13073d2 100644
|
||||
--- a/userguide/pamperspective.html
|
||||
+++ b/userguide/pamperspective.html
|
||||
@@ -223,7 +223,7 @@ default rectangle as the "frame." The visible part is always
|
||||
a rectangle the axes of which are parallel to those of the frame.
|
||||
|
||||
<p>The frame options are additive. All the parts of the image
|
||||
@ -89,31 +105,20 @@ diff -urNp old/userguide/pamperspective.html new/userguide/pamperspective.html
|
||||
<b>--include</b> (or their defaults) are in the visible part. The
|
||||
visible part is the smallest possible rectangle that contains the
|
||||
parts specified those three ways.
|
||||
diff -urNp old/converter/pbm/pbmtoepson.c new/converter/pbm/pbmtoepson.c
|
||||
--- old/converter/pbm/pbmtoepson.c 2018-01-04 14:26:14.740024843 +0100
|
||||
+++ new/converter/pbm/pbmtoepson.c 2018-01-04 14:28:47.970518766 +0100
|
||||
@@ -75,7 +75,7 @@ parseCommandLine(int ar
|
||||
&dpiSpec, 0);
|
||||
OPTENT3(0, "adjacent", OPT_FLAG, NULL,
|
||||
&adjacentSpec, 0);
|
||||
- OPTENT3(0, "nonadjacent", OPT_FLAG, NULL,
|
||||
+ OPTENT3(0, "noadjacent", OPT_FLAG, NULL,
|
||||
&nonadjacentSpec, 0);
|
||||
|
||||
opt.opt_table = option_def;
|
||||
diff -urNp old/userguide/pbmtoepson.html new/userguide/pbmtoepson.html
|
||||
--- old/userguide/pbmtoepson.html 2018-01-04 14:26:14.586024719 +0100
|
||||
+++ new/userguide/pbmtoepson.html 2018-01-04 14:27:56.466847698 +0100
|
||||
@@ -18,7 +18,7 @@ pbmtoepson - convert a PBM image into Ep
|
||||
diff --git a/userguide/pbmtoepson.html b/userguide/pbmtoepson.html
|
||||
index baacf7b..e74a7fe 100644
|
||||
--- a/userguide/pbmtoepson.html
|
||||
+++ b/userguide/pbmtoepson.html
|
||||
@@ -16,7 +16,7 @@ pbmtoepson - convert a PBM image into Epson printer graphics
|
||||
[<b>-dpi=</b><i>n</i>]
|
||||
[<b>-protocol=</b>{<b>escp9</b>|<B>escp</B>}]
|
||||
[<b>-protocol=</b>{<b>escp9</b>|<b>escp</b>}]
|
||||
[<b>-adjacent</b>]
|
||||
-[<b>-nonadjacent</b>]
|
||||
+[<b>-noadjacent</b>]
|
||||
|
||||
[<I>pbmfile</I>]
|
||||
[<i>pbmfile</i>]
|
||||
|
||||
@@ -74,7 +74,7 @@ print density for you consistent with yo
|
||||
@@ -75,7 +75,7 @@ print density for you consistent with your other options.
|
||||
<p>This option was new in Netpbm 10.23 (July 2004).
|
||||
|
||||
<dt><b>-adjacent</b>
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -up netpbm-10.47.09/converter/other/fiasco/lib/image.h.fiasco-overflow netpbm-10.47.09/converter/other/fiasco/lib/image.h
|
||||
--- netpbm-10.47.09/converter/other/fiasco/lib/image.h.fiasco-overflow 2010-01-25 09:00:48.000000000 +0100
|
||||
+++ netpbm-10.47.09/converter/other/fiasco/lib/image.h 2010-01-27 10:29:48.000000000 +0100
|
||||
@@ -29,7 +29,7 @@ typedef struct image
|
||||
* Image data
|
||||
*/
|
||||
{
|
||||
- char id [7];
|
||||
+ char id [8];
|
||||
unsigned reference_count;
|
||||
unsigned width; /* Width of the image */
|
||||
unsigned height; /* Height of the image */
|
1563
netpbm-manfix.patch
1563
netpbm-manfix.patch
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
File diff suppressed because it is too large
Load Diff
@ -1,9 +1,150 @@
|
||||
diff --git a/userguide/pammixmulti.html b/userguide/pammixmulti.html
|
||||
index c5854c3..a18fa14 100755
|
||||
index 97cf412..d2a2ba0 100755
|
||||
--- a/userguide/pammixmulti.html
|
||||
+++ b/userguide/pammixmulti.html
|
||||
@@ -1,4 +1,3 @@
|
||||
-<?xml version="1.0"?>
|
||||
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN">
|
||||
<html>
|
||||
<head>
|
||||
@@ -2,13 +2,13 @@
|
||||
<html><head><title>Pammixmulti User Manual</title></head>
|
||||
<body>
|
||||
<h1>pammixmulti</h1>
|
||||
-Updated: 18 November 2018<br>
|
||||
-<br>
|
||||
+
|
||||
+Updated: 18 November 2018<br />
|
||||
<a href="#index">Table Of Contents</a>
|
||||
|
||||
|
||||
-<h2>NAME</h2>
|
||||
-<p>pammixmulti - blend together multiple PAM images
|
||||
+<h2 id="name">NAME</h2>
|
||||
+<p>pammixmulti - blend together multiple PAM images</p>
|
||||
|
||||
|
||||
<h2 id="synopsis">SYNOPSIS</h2>
|
||||
@@ -22,11 +22,11 @@ Updated: 18 November 2018<br>
|
||||
<p>Minimum unique abbreviation of an option is acceptable. You can use a
|
||||
single hyphen instead of double hyphens to denote options. You can use white
|
||||
space in place of the equals sign to separate an option name from its
|
||||
-value.
|
||||
+value.</p>
|
||||
|
||||
|
||||
<h2 id="description">DESCRIPTION</h2>
|
||||
-<p>This file is part of <a href="index.html">Netpbm</a>.
|
||||
+<p>This file is part of <a href="index.html">Netpbm</a>.</p>
|
||||
|
||||
<p><b>pammixmulti</b> mixes two or more images to produce a new image. The
|
||||
program provides multiple ways to interpret "mix."
|
||||
@@ -37,7 +37,7 @@ program provides multiple ways to interpret "mix."
|
||||
<p>In addition to the options common to all programs based on libnetpbm
|
||||
(most notably <b>-quiet</b>, see <a href="index.html#commonoptions">
|
||||
Common Options</a>), <b>pammixmulti</b> recognizes the following
|
||||
-command line options:
|
||||
+command line options:</p>
|
||||
|
||||
<dl compact>
|
||||
<dt><b>--blend</b>=average|random|mask</dt>
|
||||
@@ -50,7 +50,7 @@ output is produced by selecting the corresponding pixel from one of the input
|
||||
images, chosen at random on a per-pixel basis. With
|
||||
<b>--blend</b>=<code>mask</code>, each pixel in the output is produced by a
|
||||
weighted average of the corresponding pixels from all the input images based
|
||||
-on the grayscale level of an additional mask image.
|
||||
+on the grayscale level of an additional mask image.</p>
|
||||
</dd>
|
||||
|
||||
<dt><b>--maskfile</b>=<i>filename</i></dt>
|
||||
@@ -60,7 +60,7 @@ grayscale mask file to control the blending of each pixel. (If the file is
|
||||
not grayscale, the first channel is treated as gray). Where the mask file is
|
||||
black, the first image is selected. Where the mask file is white, the last
|
||||
image is selected. Intermediate levels of gray select intermediate
|
||||
-images.
|
||||
+images.</p>
|
||||
</dd>
|
||||
|
||||
<dt><b>--stdev</b>=<i>number</i></dt>
|
||||
@@ -77,7 +77,7 @@ that includes roughly equal amounts of the corresponding pixel from images 1
|
||||
and 2 but less of the corresponding pixel from image 3. As <i>number</i>
|
||||
tends towards the number of input images (going beyond that has diminishing
|
||||
impact), the output tends to look more
|
||||
-like <b>--blend</b>=average. <i>number</i> defaults to 0.25.
|
||||
+like <b>--blend</b>=average. <i>number</i> defaults to 0.25.</p>
|
||||
</dd>
|
||||
|
||||
<dt><b>--randomseed</b> <i>integer</i>
|
||||
@@ -91,39 +91,39 @@ like <b>--blend</b>=average. <i>number</i> defaults to 0.25.
|
||||
|
||||
<h2 id="arguments">ARGUMENTS</h2>
|
||||
|
||||
-<p>You supply the names of the files to mix as non-option arguments.
|
||||
+<p>You supply the names of the files to mix as non-option arguments.</p>
|
||||
|
||||
|
||||
<h2 id="examples">EXAMPLES</h2>
|
||||
|
||||
-<p>Average a bunch of PPM images to produce a new PAM image:
|
||||
+<p>Average a bunch of PPM images to produce a new PAM image:</p>
|
||||
<pre><code>
|
||||
pammixmulti input*.ppm >output.ppm
|
||||
</code></pre>
|
||||
|
||||
<p>Mix these same images by taking each pixel from a randomly selected input
|
||||
-image:
|
||||
+image:</p>
|
||||
|
||||
<pre><code>
|
||||
pammixmulti --blend=random input*.ppm >output.ppm
|
||||
</code></pre>
|
||||
|
||||
<p>Use a mask image to control the fading among input images on a
|
||||
-pixel-by-pixel basis:
|
||||
+pixel-by-pixel basis:</p>
|
||||
|
||||
<pre><code>
|
||||
pammixmulti --blend=mask --maskfile=mask.pgm >output.pam \
|
||||
one.pam two.pam three.pam four.pam
|
||||
</code></pre>
|
||||
|
||||
-<p>Do the same but with more abrupt transitions:
|
||||
+<p>Do the same but with more abrupt transitions:</p>
|
||||
|
||||
<pre><code>
|
||||
pammixmulti --blend=mask --maskfile=mask.pgm --stdev=0.0 >output.pam \
|
||||
one.pam two.pam three.pam four.pam
|
||||
</code></pre>
|
||||
|
||||
-<p>and now with more gradual transitions:
|
||||
+<p>and now with more gradual transitions:</p>
|
||||
|
||||
<pre><code>
|
||||
pammixmulti --blend=mask --maskfile=mask.pgm --stdev=1.0 >output.pam \
|
||||
@@ -138,7 +138,7 @@ pixel-by-pixel basis:
|
||||
|
||||
<h2 id="author">AUTHOR</h2>
|
||||
|
||||
-<p>Copyright 2018 Scott Pakin, scott+pbm@pakin.org.
|
||||
+<p>Copyright 2018 Scott Pakin, scott+pbm@pakin.org.</p>
|
||||
|
||||
<h2 id="seealso">SEE ALSO</h2>
|
||||
|
||||
@@ -152,14 +152,14 @@ pixel-by-pixel basis:
|
||||
<h2 id="index">Table Of Contents</h2>
|
||||
|
||||
<ul>
|
||||
-<li><a href="#synopsis">SYNOPSIS</a>
|
||||
-<li><a href="#description">DESCRIPTION</a>
|
||||
-<li><a href="#options">OPTIONS</a>
|
||||
-<li><a href="#arguments">ARGUMENTS</a>
|
||||
-<li><a href="#examples">EXAMPLES</a>
|
||||
-<li><a href="#history">HISTORY</a>
|
||||
-<li><a href="#author">AUTHOR</a>
|
||||
-<li><a href="#seealso">SEE ALSO</a>
|
||||
+<li><a href="#synopsis">SYNOPSIS</a></li>
|
||||
+<li><a href="#description">DESCRIPTION</a></li>
|
||||
+<li><a href="#options">OPTIONS</a></li>
|
||||
+<li><a href="#arguments">ARGUMENTS</a></li>
|
||||
+<li><a href="#examples">EXAMPLES</a></li>
|
||||
+<li><a href="#history">HISTORY</a></li>
|
||||
+<li><a href="#author">AUTHOR</a></li>
|
||||
+<li><a href="#seealso">SEE ALSO</a></li>
|
||||
</ul>
|
||||
|
||||
</body>
|
||||
|
22
netpbm.spec
22
netpbm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A library for handling different graphics file formats
|
||||
Name: netpbm
|
||||
Version: 10.90.00
|
||||
Release: 2%{?dist}
|
||||
Version: 10.92.00
|
||||
Release: 1%{?dist}
|
||||
# See copyright_summary for details
|
||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||
URL: http://netpbm.sourceforge.net/
|
||||
@ -24,14 +24,13 @@ Patch9: netpbm-xwdfix.patch
|
||||
Patch10: netpbm-multilib.patch
|
||||
Patch11: netpbm-glibc.patch
|
||||
Patch12: netpbm-docfix.patch
|
||||
Patch13: netpbm-fiasco-overflow.patch
|
||||
Patch14: netpbm-cmuwtopbm.patch
|
||||
Patch15: netpbm-pamtojpeg2k.patch
|
||||
Patch16: netpbm-manfix.patch
|
||||
Patch17: netpbm-manual-pages.patch
|
||||
Patch18: netpbm-jasper.patch
|
||||
Patch19: netpbm-userguide.patch
|
||||
Patch20: netpbm-libdir-so.patch
|
||||
Patch13: netpbm-cmuwtopbm.patch
|
||||
Patch14: netpbm-pamtojpeg2k.patch
|
||||
Patch15: netpbm-manfix.patch
|
||||
Patch16: netpbm-manual-pages.patch
|
||||
Patch17: netpbm-jasper.patch
|
||||
Patch18: netpbm-userguide.patch
|
||||
Patch19: netpbm-libdir-so.patch
|
||||
|
||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex, gcc, jbigkit-devel
|
||||
BuildRequires: libX11-devel, perl-generators, python3, jasper-devel, libxml2-devel
|
||||
@ -230,6 +229,9 @@ popd
|
||||
%doc userguide/*
|
||||
|
||||
%changelog
|
||||
* Wed Oct 07 2020 Josef Ridky <jridky@redhat.com> - 10.92.00-1
|
||||
- New upstream release 10.92.00 (#1851753)
|
||||
|
||||
* Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 10.90.00-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user