Resolves: #1466772 - new upstream release 10.79.00
This commit is contained in:
parent
2256bb9d4f
commit
5b1d6df1a0
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@
|
|||||||
/netpbm-10.76.00.tar.xz
|
/netpbm-10.76.00.tar.xz
|
||||||
/netpbm-10.77.00.tar.xz
|
/netpbm-10.77.00.tar.xz
|
||||||
/netpbm-10.78.00.tar.xz
|
/netpbm-10.78.00.tar.xz
|
||||||
|
/netpbm-10.79.00.tar.xz
|
||||||
|
25
netpbm-10.79.00-fprintf.patch
Normal file
25
netpbm-10.79.00-fprintf.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
diff -urNp old/analyzer/pamtable.c new/analyzer/pamtable.c
|
||||||
|
--- old/analyzer/pamtable.c 2017-07-03 12:07:13.979196547 +0200
|
||||||
|
+++ new/analyzer/pamtable.c 2017-07-03 12:09:10.567765434 +0200
|
||||||
|
@@ -131,18 +131,18 @@ printRow(const struct pam * const pamP,
|
||||||
|
unsigned int plane;
|
||||||
|
|
||||||
|
if (col > 0)
|
||||||
|
- fprintf(ofP, format.interTupleGutter);
|
||||||
|
+ fputs(format.interTupleGutter, ofP);
|
||||||
|
|
||||||
|
for (plane = 0; plane < pamP->depth; ++plane) {
|
||||||
|
|
||||||
|
if (plane > 0)
|
||||||
|
- fprintf(ofP, format.interSampleGutter);
|
||||||
|
+ fputs(format.interSampleGutter, ofP);
|
||||||
|
|
||||||
|
fprintf(ofP, format.sampleFmt, tupleRow[col][plane]);
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
- fprintf(ofP, "\n");
|
||||||
|
+ fputs("\n", ofP);
|
||||||
|
}
|
||||||
|
|
||||||
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -urNp old/converter/other/svgtopam.c new/converter/other/svgtopam.c
|
|
||||||
--- old/converter/other/svgtopam.c 2017-02-08 12:11:02.593690917 +0100
|
|
||||||
+++ new/converter/other/svgtopam.c 2017-02-08 12:13:05.192846469 +0100
|
|
||||||
@@ -676,7 +676,7 @@ stringToUint(const char * const string
|
|
||||||
|
|
||||||
/* TODO: move this to nstring.c */
|
|
||||||
|
|
||||||
- if (strlen(string) == 0)
|
|
||||||
+ if (string == NULL || strlen(string) == 0)
|
|
||||||
pm_asprintf(errorP, "Value is a null string");
|
|
||||||
else {
|
|
||||||
char * tailptr;
|
|
13
netpbm.spec
13
netpbm.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: A library for handling different graphics file formats
|
Summary: A library for handling different graphics file formats
|
||||||
Name: netpbm
|
Name: netpbm
|
||||||
Version: 10.78.00
|
Version: 10.79.00
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
# See copyright_summary for details
|
# See copyright_summary for details
|
||||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||||
@ -17,8 +17,8 @@ Patch0: netpbm-security-scripts.patch
|
|||||||
Patch1: netpbm-security-code.patch
|
Patch1: netpbm-security-code.patch
|
||||||
Patch2: netpbm-ppmfadeusage.patch
|
Patch2: netpbm-ppmfadeusage.patch
|
||||||
Patch3: netpbm-noppmtompeg.patch
|
Patch3: netpbm-noppmtompeg.patch
|
||||||
Patch4: netpbm-CVE-2017-2586.patch
|
Patch4: netpbm-CVE-2017-2587.patch
|
||||||
Patch5: netpbm-CVE-2017-2587.patch
|
Patch5: netpbm-10.79.00-fprintf.patch
|
||||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
||||||
BuildRequires: libX11-devel, perl-generators, python, jasper-devel, libxml2-devel
|
BuildRequires: libX11-devel, perl-generators, python, jasper-devel, libxml2-devel
|
||||||
BuildRequires: ghostscript-core
|
BuildRequires: ghostscript-core
|
||||||
@ -78,8 +78,8 @@ netpbm-doc. You'll also need to install the netpbm-progs package.
|
|||||||
%patch1 -p1 -b .security-code
|
%patch1 -p1 -b .security-code
|
||||||
%patch2 -p1 -b .ppmfadeusage
|
%patch2 -p1 -b .ppmfadeusage
|
||||||
%patch3 -p1 -b .noppmtompeg
|
%patch3 -p1 -b .noppmtompeg
|
||||||
%patch4 -p1 -b .CVE-2586
|
%patch4 -p1 -b .CVE-2587
|
||||||
%patch5 -p1 -b .CVE-2587
|
%patch5 -p1 -b .fprintf
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./configure <<EOF
|
./configure <<EOF
|
||||||
@ -225,6 +225,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%doc userguide/*
|
%doc userguide/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 03 2017 Josef Ridky <jridky@redhat.com> - 10.79.00-1
|
||||||
|
- New upstream release 10.79.00 (#1466772)
|
||||||
|
|
||||||
* Wed Mar 29 2017 Josef Ridky <jridky@redhat.com> - 10.78.00-1
|
* Wed Mar 29 2017 Josef Ridky <jridky@redhat.com> - 10.78.00-1
|
||||||
- New upstream release 10.78.00
|
- New upstream release 10.78.00
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (netpbm-10.78.00.tar.xz) = fd5cdea7fdc8ac66589efed509f6e22efee78e35798a8461bccbcc53d0735a0bd242c34f721cda57b77986a82163575736a8acf5841c784c4883b9cc35f86af0
|
SHA512 (netpbm-10.79.00.tar.xz) = 49c21835302bddcaadcde06ff5d25915c5b8a3404f0e91f920af00b79fff2ed354beb6dd5c0abe4be48a52a44b27e97127eee7e3d473ff7f637287208dbabc65
|
||||||
|
Loading…
Reference in New Issue
Block a user