- update to 10.47.06 - fixes the dumb pamtosvg mistake in 10.47.05
- pnmmargin won't create leftovers in /tmp (#547888)
This commit is contained in:
parent
6724979dcc
commit
51ce8e4303
@ -1,12 +0,0 @@
|
||||
diff -up netpbm-10.47.05/converter/other/pamtosvg/vector.c.pamtosvg netpbm-10.47.05/converter/other/pamtosvg/vector.c
|
||||
--- netpbm-10.47.05/converter/other/pamtosvg/vector.c.pamtosvg 2009-12-10 08:34:36.000000000 +0100
|
||||
+++ netpbm-10.47.05/converter/other/pamtosvg/vector.c 2009-12-10 09:58:16.000000000 +0100
|
||||
@@ -39,7 +39,7 @@ vector_to_point(vector_type const v) {
|
||||
|
||||
coord.x = v.dx;
|
||||
coord.y = v.dy;
|
||||
- coord.z = v.dz
|
||||
+ coord.z = v.dz;
|
||||
|
||||
return coord;
|
||||
}
|
@ -1,6 +1,6 @@
|
||||
diff -up netpbm-10.47.04/converter/other/anytopnm.security2 netpbm-10.47.04/converter/other/anytopnm
|
||||
--- netpbm-10.47.04/converter/other/anytopnm.security2 2009-10-21 13:39:06.000000000 +0200
|
||||
+++ netpbm-10.47.04/converter/other/anytopnm 2009-10-21 14:51:49.000000000 +0200
|
||||
diff -up netpbm-10.47.06/converter/other/anytopnm.security-scripts netpbm-10.47.06/converter/other/anytopnm
|
||||
--- netpbm-10.47.06/converter/other/anytopnm.security-scripts 2009-12-13 20:27:05.000000000 +0100
|
||||
+++ netpbm-10.47.06/converter/other/anytopnm 2009-12-16 18:59:17.000000000 +0100
|
||||
@@ -510,10 +510,7 @@ else
|
||||
inputFile="-"
|
||||
fi
|
||||
@ -31,9 +31,9 @@ diff -up netpbm-10.47.04/converter/other/anytopnm.security2 netpbm-10.47.04/conv
|
||||
+fi
|
||||
+
|
||||
exit 0
|
||||
diff -up netpbm-10.47.04/editor/pamstretch-gen.security2 netpbm-10.47.04/editor/pamstretch-gen
|
||||
--- netpbm-10.47.04/editor/pamstretch-gen.security2 2009-10-21 13:38:57.000000000 +0200
|
||||
+++ netpbm-10.47.04/editor/pamstretch-gen 2009-10-21 14:53:28.000000000 +0200
|
||||
diff -up netpbm-10.47.06/editor/pamstretch-gen.security-scripts netpbm-10.47.06/editor/pamstretch-gen
|
||||
--- netpbm-10.47.06/editor/pamstretch-gen.security-scripts 2009-12-13 20:26:58.000000000 +0100
|
||||
+++ netpbm-10.47.06/editor/pamstretch-gen 2009-12-16 18:59:17.000000000 +0100
|
||||
@@ -31,9 +31,7 @@ if [ "$1" = "" ]; then
|
||||
exit 1
|
||||
fi
|
||||
@ -45,9 +45,9 @@ diff -up netpbm-10.47.04/editor/pamstretch-gen.security2 netpbm-10.47.04/editor/
|
||||
trap 'rm -rf $tempdir' 0 1 3 15
|
||||
|
||||
tempfile=$tempdir/pnmig
|
||||
diff -up netpbm-10.47.04/editor/pnmmargin.security2 netpbm-10.47.04/editor/pnmmargin
|
||||
--- netpbm-10.47.04/editor/pnmmargin.security2 2009-10-21 13:38:57.000000000 +0200
|
||||
+++ netpbm-10.47.04/editor/pnmmargin 2009-10-21 14:55:40.000000000 +0200
|
||||
diff -up netpbm-10.47.06/editor/pnmmargin.security-scripts netpbm-10.47.06/editor/pnmmargin
|
||||
--- netpbm-10.47.06/editor/pnmmargin.security-scripts 2009-12-13 20:26:58.000000000 +0100
|
||||
+++ netpbm-10.47.06/editor/pnmmargin 2009-12-16 19:04:05.000000000 +0100
|
||||
@@ -11,15 +11,11 @@
|
||||
# documentation. This software is provided "as is" without express or
|
||||
# implied warranty.
|
||||
@ -69,59 +69,26 @@ diff -up netpbm-10.47.04/editor/pnmmargin.security2 netpbm-10.47.04/editor/pnmma
|
||||
|
||||
color="-gofigure"
|
||||
plainopt=""
|
||||
@@ -43,6 +39,9 @@ while true ; do
|
||||
shift
|
||||
if [ ! ${1-""} ] ; then
|
||||
echo "usage: $0 [-white|-black|-color <colorspec>] <size> [pnmfile]" 1>&2
|
||||
+ if [ -d "$tmpdir" ]; then
|
||||
+ rm -rf "$tmpdir"
|
||||
+ fi
|
||||
exit 1
|
||||
fi
|
||||
color="$1"
|
||||
@@ -50,6 +49,9 @@ while true ; do
|
||||
;;
|
||||
-* )
|
||||
echo "usage: $0 [-white|-black|-color <colorspec>] <size> [pnmfile]" 1>&2
|
||||
+ if [ -d "$tmpdir" ]; then
|
||||
+ rm -rf "$tmpdir"
|
||||
+ fi
|
||||
exit 1
|
||||
;;
|
||||
* )
|
||||
@@ -60,6 +62,9 @@ done
|
||||
|
||||
if [ ! ${1-""} ] ; then
|
||||
echo "usage: $0 [-white|-black|-color <colorspec>] <size> [pnmfile]" 1>&2
|
||||
+ if [ -d "$tmpdir" ]; then
|
||||
+ rm -rf "$tmpdir"
|
||||
+ fi
|
||||
exit 1
|
||||
fi
|
||||
size="$1"
|
||||
@@ -67,6 +72,9 @@ shift
|
||||
|
||||
if [ ${2-""} ] ; then
|
||||
echo "usage: $0 [-white|-black|-color <colorspec>] <size> [pnmfile]" 1>&2
|
||||
+ if [ -d "$tmpdir" ]; then
|
||||
+ rm -rf "$tmpdir"
|
||||
+ fi
|
||||
exit 1
|
||||
fi
|
||||
|
||||
@@ -103,6 +111,6 @@ else
|
||||
@@ -90,6 +86,7 @@ else
|
||||
-white | -black )
|
||||
pnmpad $plainopt $color \
|
||||
-left=$size -right=$size -top=$size -bottom=$size $tmp1
|
||||
+ rm -rf "$tmpdir"
|
||||
exit
|
||||
;;
|
||||
* )
|
||||
@@ -102,7 +99,4 @@ else
|
||||
pnmcat -lr $tmp2 $tmp1 $tmp2 > $tmp4
|
||||
pnmcat -tb $plainopt $tmp3 $tmp4 $tmp3
|
||||
fi
|
||||
|
||||
-
|
||||
-
|
||||
-
|
||||
+if [ -d "$tmpdir" ]; then
|
||||
+ rm -rf "$tmpdir"
|
||||
+fi
|
||||
diff -up netpbm-10.47.04/editor/ppmfade.security2 netpbm-10.47.04/editor/ppmfade
|
||||
--- netpbm-10.47.04/editor/ppmfade.security2 2009-10-21 13:38:57.000000000 +0200
|
||||
+++ netpbm-10.47.04/editor/ppmfade 2009-10-21 15:03:01.000000000 +0200
|
||||
-
|
||||
+rm -rf "$tmpdir"
|
||||
diff -up netpbm-10.47.06/editor/ppmfade.security-scripts netpbm-10.47.06/editor/ppmfade
|
||||
--- netpbm-10.47.06/editor/ppmfade.security-scripts 2009-12-13 20:26:58.000000000 +0100
|
||||
+++ netpbm-10.47.06/editor/ppmfade 2009-12-16 18:59:17.000000000 +0100
|
||||
@@ -14,6 +14,7 @@
|
||||
#
|
||||
#-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
|
||||
@ -385,9 +352,9 @@ diff -up netpbm-10.47.04/editor/ppmfade.security2 netpbm-10.47.04/editor/ppmfade
|
||||
+system("rm $tmpdir/junk*$$.ppm");
|
||||
|
||||
exit(0);
|
||||
diff -up netpbm-10.47.04/editor/ppmquantall.security2 netpbm-10.47.04/editor/ppmquantall
|
||||
--- netpbm-10.47.04/editor/ppmquantall.security2 2009-10-21 13:38:57.000000000 +0200
|
||||
+++ netpbm-10.47.04/editor/ppmquantall 2009-10-21 14:52:38.000000000 +0200
|
||||
diff -up netpbm-10.47.06/editor/ppmquantall.security-scripts netpbm-10.47.06/editor/ppmquantall
|
||||
--- netpbm-10.47.06/editor/ppmquantall.security-scripts 2009-12-13 20:26:58.000000000 +0100
|
||||
+++ netpbm-10.47.06/editor/ppmquantall 2009-12-16 18:59:17.000000000 +0100
|
||||
@@ -70,12 +70,8 @@ for i in ${files[@]}; do
|
||||
heights=(${heights[*]} `grep -v '^#' $i | sed '1d; s/.* //; 2q'`)
|
||||
done
|
||||
@ -403,9 +370,9 @@ diff -up netpbm-10.47.04/editor/ppmquantall.security2 netpbm-10.47.04/editor/ppm
|
||||
|
||||
pnmcat -topbottom -jleft -white ${files[@]} | pnmquant $newcolors > $all
|
||||
if [ $? != 0 ]; then
|
||||
diff -up netpbm-10.47.04/editor/ppmshadow.security2 netpbm-10.47.04/editor/ppmshadow
|
||||
--- netpbm-10.47.04/editor/ppmshadow.security2 2009-10-21 13:38:57.000000000 +0200
|
||||
+++ netpbm-10.47.04/editor/ppmshadow 2009-10-21 14:51:02.000000000 +0200
|
||||
diff -up netpbm-10.47.06/editor/ppmshadow.security-scripts netpbm-10.47.06/editor/ppmshadow
|
||||
--- netpbm-10.47.06/editor/ppmshadow.security-scripts 2009-12-13 20:26:58.000000000 +0100
|
||||
+++ netpbm-10.47.06/editor/ppmshadow 2009-12-16 18:59:17.000000000 +0100
|
||||
@@ -72,9 +72,10 @@ sub makeConvolutionKernel($$) {
|
||||
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
Summary: A library for handling different graphics file formats
|
||||
Name: netpbm
|
||||
Version: 10.47.05
|
||||
Version: 10.47.06
|
||||
Release: 1%{?dist}
|
||||
# See copyright_summary for details
|
||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||
@ -28,7 +28,6 @@ Patch14: netpbm-pnmtofiasco-stdin.patch
|
||||
Patch15: netpbm-svgtopam.patch
|
||||
Patch16: netpbm-ppmpat-segfault.patch
|
||||
Patch17: netpbm-pnmsmooth-segfault.patch
|
||||
Patch18: netpbm-pamtosvg.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
||||
BuildRequires: libX11-devel, python, jasper-devel
|
||||
@ -87,7 +86,6 @@ netpbm-progs. You'll also need to install the netpbm package.
|
||||
%patch15 -p1 -b .svgtopam
|
||||
%patch16 -p1 -b .ppmpat-segfault
|
||||
%patch17 -p1 -b .pnmsmooth-segfault
|
||||
%patch18 -p1 -b .pamtosvg
|
||||
|
||||
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
|
||||
|
||||
@ -216,6 +214,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_datadir}/netpbm/
|
||||
|
||||
%changelog
|
||||
* Fri Dec 14 2009 Jindrich Novy <jnovy@redhat.com> 10.47.06-1
|
||||
- update to 10.47.06 - fixes the dumb pamtosvg mistake in 10.47.05
|
||||
- pnmmargin won't create leftovers in /tmp (#547888)
|
||||
|
||||
* Thu Dec 10 2009 Jindrich Novy <jnovy@redhat.com> 10.47.05-1
|
||||
- update to 10.47.05
|
||||
- fixes pnmtofiasco, fiascotopnm, pamtosvg, pamtouil and ppmrainbow
|
||||
|
Loading…
Reference in New Issue
Block a user