Package %{_libdir}/*.so (RHBZ#1676370).
This commit is contained in:
parent
d9e6b50bf7
commit
4c6e5b409d
37
netpbm-libdir-so.patch
Normal file
37
netpbm-libdir-so.patch
Normal file
@ -0,0 +1,37 @@
|
|||||||
|
diff -Naur netpbm-10.84.03.orig/lib/Makefile netpbm-10.84.03/lib/Makefile
|
||||||
|
--- netpbm-10.84.03.orig/lib/Makefile 2018-11-23 10:36:41.000000000 +0100
|
||||||
|
+++ netpbm-10.84.03/lib/Makefile 2019-02-12 08:22:24.188229574 +0100
|
||||||
|
@@ -221,7 +221,7 @@
|
||||||
|
.PHONY: install.lib
|
||||||
|
ifeq ($(NETPBMLIBTYPE),unixshared)
|
||||||
|
# install a Unix-style shared library
|
||||||
|
-install.lib: $(PKGDIR)/lib $(PKGDIR)/link
|
||||||
|
+install.lib: $(PKGDIR)/lib
|
||||||
|
cd $(PKGDIR)/lib ; rm -f libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).*
|
||||||
|
$(INSTALL) -c -m $(INSTALL_PERM_LIBD) \
|
||||||
|
libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ).$(MIN) $(PKGDIR)/lib/
|
||||||
|
@@ -263,19 +263,19 @@
|
||||||
|
$(SRCDIR)/lib/$(@:%_installhdr=%) $(PKGDIR)/include/netpbm/
|
||||||
|
|
||||||
|
.PHONY: install.staticlib
|
||||||
|
-install.staticlib: $(PKGDIR)/link
|
||||||
|
+install.staticlib: $(PKGDIR)/lib
|
||||||
|
$(INSTALL) -c -m $(INSTALL_PERM_LIBS) libnetpbm.$(STATICLIBSUFFIX) \
|
||||||
|
- $(PKGDIR)/link
|
||||||
|
+ $(PKGDIR)/lib
|
||||||
|
|
||||||
|
# Install a shared library stub -- the ".so" file used at link time to
|
||||||
|
# prepare a program for dynamically linking a library at run time
|
||||||
|
.PHONY: install.sharedlibstub
|
||||||
|
-install.sharedlibstub: $(PKGDIR)/link
|
||||||
|
+install.sharedlibstub: $(PKGDIR)/lib
|
||||||
|
ifeq ($(NETPBMLIBTYPE),unixshared)
|
||||||
|
# install the link-time (.so) links to the runtime libraries
|
||||||
|
- cd $(PKGDIR)/link ; \
|
||||||
|
+ cd $(PKGDIR)/lib ; \
|
||||||
|
rm -f libnetpbm.$(NETPBMLIBSUFFIX); \
|
||||||
|
- $(SYMLINK) ../lib/libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ) \
|
||||||
|
+ $(SYMLINK) libnetpbm.$(NETPBMLIBSUFFIX).$(MAJ) \
|
||||||
|
libnetpbm.$(NETPBMLIBSUFFIX)
|
||||||
|
endif
|
||||||
|
ifeq ($(NETPBMLIBTYPE),dll)
|
@ -1,7 +1,7 @@
|
|||||||
Summary: A library for handling different graphics file formats
|
Summary: A library for handling different graphics file formats
|
||||||
Name: netpbm
|
Name: netpbm
|
||||||
Version: 10.84.03
|
Version: 10.84.03
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
# See copyright_summary for details
|
# See copyright_summary for details
|
||||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||||
URL: http://netpbm.sourceforge.net/
|
URL: http://netpbm.sourceforge.net/
|
||||||
@ -33,6 +33,7 @@ Patch17: netpbm-manfix.patch
|
|||||||
Patch18: netpbm-manual-pages.patch
|
Patch18: netpbm-manual-pages.patch
|
||||||
Patch19: netpbm-jasper.patch
|
Patch19: netpbm-jasper.patch
|
||||||
Patch20: netpbm-userguide.patch
|
Patch20: netpbm-userguide.patch
|
||||||
|
Patch21: netpbm-libdir-so.patch
|
||||||
|
|
||||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex, gcc, jbigkit-devel
|
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex, gcc, jbigkit-devel
|
||||||
BuildRequires: libX11-devel, perl-generators, python3, jasper-devel, libxml2-devel
|
BuildRequires: libX11-devel, perl-generators, python3, jasper-devel, libxml2-devel
|
||||||
@ -212,12 +213,13 @@ popd
|
|||||||
%files
|
%files
|
||||||
%doc doc/copyright_summary doc/COPYRIGHT.PATENT doc/HISTORY README
|
%doc doc/copyright_summary doc/COPYRIGHT.PATENT doc/HISTORY README
|
||||||
%license doc/GPL_LICENSE.txt
|
%license doc/GPL_LICENSE.txt
|
||||||
%{_libdir}/lib*.so*
|
%{_libdir}/lib*.so.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%dir %{_includedir}/netpbm
|
%dir %{_includedir}/netpbm
|
||||||
%{_includedir}/netpbm/*.h
|
%{_includedir}/netpbm/*.h
|
||||||
%{_mandir}/man3/*
|
%{_mandir}/man3/*
|
||||||
|
%{_libdir}/lib*.so
|
||||||
|
|
||||||
%files progs
|
%files progs
|
||||||
%{_bindir}/*
|
%{_bindir}/*
|
||||||
@ -229,6 +231,9 @@ popd
|
|||||||
%doc userguide/*
|
%doc userguide/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 12 2019 Ralf Corsépius <corsepiu@fedoraproject.org> - 10.84.03-3
|
||||||
|
- Package %%{_libdir}/*.so (RHBZ#1676370).
|
||||||
|
|
||||||
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 10.84.03-2
|
* Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 10.84.03-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user