Resolves: #1651965 - use system version of jasper and jbigkit
This commit is contained in:
parent
e59c8cc27e
commit
4754916413
62
netpbm-jasper.patch
Normal file
62
netpbm-jasper.patch
Normal file
@ -0,0 +1,62 @@
|
||||
diff -urNp a/config.mk.in b/config.mk.in
|
||||
--- a/config.mk.in 2018-11-21 12:46:22.044790058 +0100
|
||||
+++ b/config.mk.in 2018-11-22 13:13:10.260123268 +0100
|
||||
@@ -128,7 +128,7 @@ INSTALL = $(SRCDIR)/buildtools/install.s
|
||||
|
||||
# STRIPFLAG is the option you pass to the above install program to make it
|
||||
# strip unnecessary information out of binaries.
|
||||
-STRIPFLAG = -s
|
||||
+STRIPFLAG =
|
||||
# If you don't want to strip the binaries, just leave it null:
|
||||
#STRIPFLAG =
|
||||
|
||||
@@ -482,12 +482,12 @@ JBIGLIB = $(INTERNAL_JBIGLIB)
|
||||
JBIGHDR_DIR = $(INTERNAL_JBIGHDR_DIR)
|
||||
|
||||
# The Jasper JPEG-2000 image compression library (aka JasPer):
|
||||
-JASPERLIB = $(INTERNAL_JASPERLIB)
|
||||
-JASPERHDR_DIR = $(INTERNAL_JASPERHDR_DIR)
|
||||
+JASPERLIB = ""
|
||||
+JASPERHDR_DIR = "/usr/include/jasper"
|
||||
# JASPERDEPLIBS is the libraries (-l options or file names) on which
|
||||
# The Jasper library depends -- i.e. what you have to link into any
|
||||
# executable that links in the Jasper library.
|
||||
-JASPERDEPLIBS =
|
||||
+JASPERDEPLIBS = -ljasper
|
||||
#JASPERDEPLIBS = -ljpeg
|
||||
|
||||
# And the Utah Raster Toolkit (aka URT aka RLE) library:
|
||||
diff -urNp a/converter/other/jbig/Makefile b/converter/other/jbig/Makefile
|
||||
--- a/converter/other/jbig/Makefile 2018-11-21 12:46:22.075789920 +0100
|
||||
+++ b/converter/other/jbig/Makefile 2018-11-22 13:13:40.837969056 +0100
|
||||
@@ -11,8 +11,9 @@ include $(BUILDDIR)/config.mk
|
||||
|
||||
# INTERNAL_JBIGLIB must be relative to the current directory, because it
|
||||
# may end up in MERGE_OBJECTS, which must be relative.
|
||||
-INTERNAL_JBIGLIB = libjbig/libjbig.a
|
||||
-INTERNAL_JBIGHDR_DIR = $(SRCDIR)/$(SUBDIR)/libjbig/include
|
||||
+INTERNAL_JBIGLIB =
|
||||
+INTERNAL_JBIGHDR_DIR = /usr/include
|
||||
+#INTERNAL_JBIGHDR_DIR = $(SRCDIR)/$(SUBDIR)/libjbig/include
|
||||
|
||||
EXTERN_INCLUDES =
|
||||
ifneq ($(JBIGHDR_DIR),NONE)
|
||||
@@ -35,7 +36,6 @@ SCRIPTS =
|
||||
|
||||
ifeq ($(JBIGLIB),$(INTERNAL_JBIGLIB))
|
||||
JBIGLIB_DEP = $(JBIGLIB)
|
||||
- SUBDIRS += libjbig
|
||||
else
|
||||
# It's not our internal version; user's on his own to make sure it's built
|
||||
endif
|
||||
@@ -49,10 +49,3 @@ include $(SRCDIR)/common.mk
|
||||
|
||||
$(BINARIES): %: %.o $(JBIGLIB_DEP) $(LIBOPT)
|
||||
$(BINARIES): LDFLAGS_TARGET = $(shell $(LIBOPT) $(JBIGLIB))
|
||||
-
|
||||
-$(INTERNAL_JBIGLIB): $(BUILDDIR)/$(SUBDIR)/libjbig FORCE
|
||||
- $(MAKE) -f $(SRCDIR)/$(SUBDIR)/libjbig/Makefile \
|
||||
- -C $(dir $@) $(notdir $@)
|
||||
-
|
||||
-.PHONY: FORCE
|
||||
-FORCE:
|
13
netpbm.spec
13
netpbm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A library for handling different graphics file formats
|
||||
Name: netpbm
|
||||
Version: 10.83.01
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
# See copyright_summary for details
|
||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||
URL: http://netpbm.sourceforge.net/
|
||||
@ -31,15 +31,15 @@ Patch15: netpbm-cmuwtopbm.patch
|
||||
Patch16: netpbm-pamtojpeg2k.patch
|
||||
Patch17: netpbm-manfix.patch
|
||||
Patch18: netpbm-manual-pages.patch
|
||||
Patch19: netpbm-jasper.patch
|
||||
|
||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex, gcc
|
||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex, gcc, jbigkit-devel
|
||||
BuildRequires: libX11-devel, perl-generators, python3, jasper-devel, libxml2-devel
|
||||
%if (0%{?fedora} && 0%{?fedora} < 28) || (0%{?rhel} || 0%{?rhel} <= 7)
|
||||
BuildRequires: ghostscript-core
|
||||
%else
|
||||
BuildRequires: ghostscript
|
||||
%endif
|
||||
Provides: bundled(jasper), bundled(jbigkit)
|
||||
|
||||
%description
|
||||
The netpbm package contains a library of functions which support
|
||||
@ -88,6 +88,8 @@ netpbm-doc. You'll also need to install the netpbm-progs package.
|
||||
|
||||
%prep
|
||||
%autosetup -p1
|
||||
rm -rf converter/other/jpeg2000/libjasper/
|
||||
rm -rf converter/other/jbig/libjbig/
|
||||
|
||||
%build
|
||||
./configure <<EOF
|
||||
@ -124,6 +126,7 @@ make \
|
||||
PNGINC_DIR=%{_includedir} \
|
||||
TIFFINC_DIR=%{_includedir} \
|
||||
JPEGLIB_DIR=%{_libdir} \
|
||||
JBIGLIB=%{_libdir}/libjbig.so.2.1 \
|
||||
PNGLIB_DIR=%{_libdir} \
|
||||
TIFFLIB_DIR=%{_libdir} \
|
||||
LINUXSVGALIB="NONE" \
|
||||
@ -155,7 +158,6 @@ if [ "%{_libdir}" != "/usr/lib" ]; then
|
||||
fi
|
||||
|
||||
cp -af lib/libnetpbm.a %{buildroot}%{_libdir}/libnetpbm.a
|
||||
cp -l %{buildroot}%{_libdir}/libnetpbm.so.?? %{buildroot}%{_libdir}/libnetpbm.so
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}
|
||||
mv userguide/man %{buildroot}%{_mandir}
|
||||
@ -226,6 +228,9 @@ popd
|
||||
%doc userguide/*
|
||||
|
||||
%changelog
|
||||
* Wed Nov 21 2018 Josef Ridky <jridky@redhat.com> - 10.83.01-2
|
||||
- Use system version of jasper and jbigkit library (#1651965)
|
||||
|
||||
* Mon Jul 23 2018 Josef Ridky <jridky@redhat.com> - 10.83.01-1
|
||||
- New upstream release 10.83.01 (#1596970)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user