- update to 10.35.60
- update .security patch, minor cleanup - fixes xwdtopnm for at least some direct color 24/32 images - fixes memory leak and out of memory crash in libpammap
This commit is contained in:
parent
203492f115
commit
336e8a8e29
@ -1 +1 @@
|
|||||||
netpbm-10.35.59.tar.bz2
|
netpbm-10.35.60.tar.bz2
|
||||||
|
@ -303,27 +303,6 @@ diff -up netpbm-10.35.46/converter/other/tifftopnm.c.security netpbm-10.35.46/co
|
|||||||
if (samplebuf == NULL)
|
if (samplebuf == NULL)
|
||||||
pm_error ("can't allocate memory for row buffer");
|
pm_error ("can't allocate memory for row buffer");
|
||||||
|
|
||||||
diff -up netpbm-10.35.46/converter/other/xwdtopnm.c.security netpbm-10.35.46/converter/other/xwdtopnm.c
|
|
||||||
--- netpbm-10.35.46/converter/other/xwdtopnm.c.security 2008-06-24 08:59:13.000000000 +0200
|
|
||||||
+++ netpbm-10.35.46/converter/other/xwdtopnm.c 2008-06-24 09:04:21.000000000 +0200
|
|
||||||
@@ -214,6 +214,9 @@ processX10Header(X10WDFileHeader * cons
|
|
||||||
*colorsP = pnm_allocrow( 2 );
|
|
||||||
PNM_ASSIGN1( (*colorsP)[0], 0 );
|
|
||||||
PNM_ASSIGN1( (*colorsP)[1], *maxvalP );
|
|
||||||
+ overflow_add(h10P->pixmap_width, 15);
|
|
||||||
+ if(h10P->pixmap_width < 0)
|
|
||||||
+ pm_error("assert: negative width");
|
|
||||||
*padrightP =
|
|
||||||
( ( h10P->pixmap_width + 15 ) / 16 ) * 16 - h10P->pixmap_width;
|
|
||||||
*bits_per_itemP = 16;
|
|
||||||
@@ -560,6 +563,7 @@ processX11Header(X11WDFileHeader * cons
|
|
||||||
|
|
||||||
*colsP = h11FixedP->pixmap_width;
|
|
||||||
*rowsP = h11FixedP->pixmap_height;
|
|
||||||
+ overflow2(h11FixedP->bytes_per_line, 8);
|
|
||||||
*padrightP =
|
|
||||||
h11FixedP->bytes_per_line * 8 / h11FixedP->bits_per_pixel -
|
|
||||||
h11FixedP->pixmap_width;
|
|
||||||
diff -up netpbm-10.35.46/converter/pbm/icontopbm.c.security netpbm-10.35.46/converter/pbm/icontopbm.c
|
diff -up netpbm-10.35.46/converter/pbm/icontopbm.c.security netpbm-10.35.46/converter/pbm/icontopbm.c
|
||||||
--- netpbm-10.35.46/converter/pbm/icontopbm.c.security 2008-06-24 08:59:23.000000000 +0200
|
--- netpbm-10.35.46/converter/pbm/icontopbm.c.security 2008-06-24 08:59:23.000000000 +0200
|
||||||
+++ netpbm-10.35.46/converter/pbm/icontopbm.c 2008-06-24 09:04:21.000000000 +0200
|
+++ netpbm-10.35.46/converter/pbm/icontopbm.c 2008-06-24 09:04:21.000000000 +0200
|
||||||
@ -2098,3 +2077,25 @@ diff -up netpbm-10.35.46/urt/scanargs.c.security netpbm-10.35.46/urt/scanargs.c
|
|||||||
|
|
||||||
#if defined(c_plusplus) && !defined(USE_PROTOTYPES)
|
#if defined(c_plusplus) && !defined(USE_PROTOTYPES)
|
||||||
#define USE_PROTOTYPES
|
#define USE_PROTOTYPES
|
||||||
|
diff -up netpbm-10.35.60/converter/other/xwdtopnm.c.security netpbm-10.35.60/converter/other/xwdtopnm.c
|
||||||
|
--- netpbm-10.35.60/converter/other/xwdtopnm.c.security 2009-02-15 13:04:43.000000000 +0100
|
||||||
|
+++ netpbm-10.35.60/converter/other/xwdtopnm.c 2009-02-16 12:15:50.000000000 +0100
|
||||||
|
@@ -214,6 +214,10 @@ processX10Header(X10WDFileHeader * cons
|
||||||
|
*colorsP = pnm_allocrow( 2 );
|
||||||
|
PNM_ASSIGN1( (*colorsP)[0], 0 );
|
||||||
|
PNM_ASSIGN1( (*colorsP)[1], *maxvalP );
|
||||||
|
+ overflow_add(h10P->pixmap_width, 15);
|
||||||
|
+ if(h10P->pixmap_width < 0)
|
||||||
|
+ pm_error("assert: negative width");
|
||||||
|
+ overflow2((((h10P->pixmap_width + 15) / 16) * 16 - h10P->pixmap_width), 8);
|
||||||
|
*padrightP =
|
||||||
|
(((h10P->pixmap_width + 15) / 16) * 16 - h10P->pixmap_width) * 8;
|
||||||
|
*bits_per_itemP = 16;
|
||||||
|
@@ -608,6 +612,7 @@ processX11Header(X11WDFileHeader * cons
|
||||||
|
|
||||||
|
*colsP = h11FixedP->pixmap_width;
|
||||||
|
*rowsP = h11FixedP->pixmap_height;
|
||||||
|
+ overflow2(h11FixedP->bytes_per_line, 8);
|
||||||
|
*padrightP =
|
||||||
|
h11FixedP->bytes_per_line * 8 -
|
||||||
|
h11FixedP->pixmap_width * h11FixedP->bits_per_pixel;
|
||||||
|
11
netpbm.spec
11
netpbm.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: A library for handling different graphics file formats
|
Summary: A library for handling different graphics file formats
|
||||||
Name: netpbm
|
Name: netpbm
|
||||||
Version: 10.35.59
|
Version: 10.35.60
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
# See copyright_summary for details
|
# See copyright_summary for details
|
||||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||||
@ -101,9 +101,6 @@ netpbm-progs. You'll also need to install the netpbm package.
|
|||||||
%patch24 -p1 -b .64bitfix
|
%patch24 -p1 -b .64bitfix
|
||||||
%patch25 -p1 -b .ximtoppmsegfault
|
%patch25 -p1 -b .ximtoppmsegfault
|
||||||
|
|
||||||
##mv shhopt/shhopt.h shhopt/pbmshhopt.h
|
|
||||||
##perl -pi -e 's|shhopt.h|pbmshhopt.h|g' `find -name "*.c" -o -name "*.h"` ./GNUmakefile
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
./configure <<EOF
|
./configure <<EOF
|
||||||
|
|
||||||
@ -227,6 +224,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/netpbm/
|
%{_datadir}/netpbm/
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 16 2009 Jindrich Novy <jnovy@redhat.com> 10.35.60-1
|
||||||
|
- update to 10.35.60
|
||||||
|
- update .security patch, minor cleanup
|
||||||
|
- fixes xwdtopnm for at least some direct color 24/32 images
|
||||||
|
- fixes memory leak and out of memory crash in libpammap
|
||||||
|
|
||||||
* Thu Jan 29 2009 Jindrich Novy <jnovy@redhat.com> 10.35.59-1
|
* Thu Jan 29 2009 Jindrich Novy <jnovy@redhat.com> 10.35.59-1
|
||||||
- update to 10.35.59
|
- update to 10.35.59
|
||||||
- fixes array bound violation in ilbmtoppm
|
- fixes array bound violation in ilbmtoppm
|
||||||
|
Loading…
Reference in New Issue
Block a user