remove ppmtompeg
This commit is contained in:
parent
abafd87444
commit
0673c2136f
@ -1 +1 @@
|
||||
netpbm-10.47.10.tar.xz
|
||||
netpbm-10.47.12.tar.xz
|
||||
|
23
netpbm-noppmtompeg.patch
Normal file
23
netpbm-noppmtompeg.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -up netpbm-10.47.12/buildtools/manpage.mk.noppmtompeg netpbm-10.47.12/buildtools/manpage.mk
|
||||
--- netpbm-10.47.12/buildtools/manpage.mk.noppmtompeg 2010-04-27 09:54:52.121522491 -0400
|
||||
+++ netpbm-10.47.12/buildtools/manpage.mk 2010-04-27 09:55:10.337642487 -0400
|
||||
@@ -251,7 +251,6 @@ MAN1 = \
|
||||
ppmtolj.1 \
|
||||
ppmtomap.1 \
|
||||
ppmtomitsu.1 \
|
||||
- ppmtompeg.1 \
|
||||
ppmtoneo.1 \
|
||||
ppmtopcx.1 \
|
||||
ppmtopgm.1 \
|
||||
diff -up netpbm-10.47.12/converter/ppm/Makefile.noppmtompeg netpbm-10.47.12/converter/ppm/Makefile
|
||||
--- netpbm-10.47.12/converter/ppm/Makefile.noppmtompeg 2010-04-27 09:55:20.293517254 -0400
|
||||
+++ netpbm-10.47.12/converter/ppm/Makefile 2010-04-27 09:55:41.534642567 -0400
|
||||
@@ -7,7 +7,7 @@ VPATH=.:$(SRCDIR)/$(SUBDIR)
|
||||
|
||||
include $(BUILDDIR)/config.mk
|
||||
|
||||
-SUBDIRS = hpcdtoppm ppmtompeg
|
||||
+SUBDIRS = hpcdtoppm
|
||||
|
||||
PORTBINARIES = 411toppm eyuvtoppm gouldtoppm ilbmtoppm imgtoppm \
|
||||
leaftoppm mtvtoppm neotoppm \
|
@ -1,23 +0,0 @@
|
||||
--- netpbm-10.35/converter/ppm/ppmtompeg/fsize.c.ppmtompeg 2006-09-18 12:20:24.000000000 +0200
|
||||
+++ netpbm-10.35/converter/ppm/ppmtompeg/fsize.c 2006-09-18 13:35:53.000000000 +0200
|
||||
@@ -115,8 +115,7 @@ Fsize_Note(int const id,
|
||||
Fsize_Validate(&Fsize_x, &Fsize_y);
|
||||
|
||||
if ((Fsize_x == 0) || (Fsize_y == 0)) {
|
||||
- fprintf(stderr,"Frame %d: size is less than the minimum: %d x %d!\n",
|
||||
- id, DCTSIZE*2, DCTSIZE*2);
|
||||
+ fprintf(stderr,"Frame %d: image dimensions need to be integer multiples of 16 for ppmtompeg!\n",id);
|
||||
exit(1);
|
||||
}
|
||||
|
||||
--- netpbm-10.35/converter/ppm/ppmtompeg/parallel.c.ppmtompeg 2006-09-18 13:30:49.000000000 +0200
|
||||
+++ netpbm-10.35/converter/ppm/ppmtompeg/parallel.c 2006-09-18 13:32:24.000000000 +0200
|
||||
@@ -1316,8 +1316,6 @@ CombineServer(int const numFram
|
||||
TransmitPortNum(masterHostName, masterPortNum, combinePortNum);
|
||||
|
||||
close(outputServerSocket);
|
||||
-
|
||||
- fclose(ofP);
|
||||
}
|
||||
|
||||
|
@ -878,102 +878,6 @@ diff -up netpbm-10.47.04/converter/ppm/ppmtomitsu.c.security netpbm-10.47.04/con
|
||||
medias.maxcols *= 2;
|
||||
medias.maxrows *= 2;
|
||||
}
|
||||
diff -up netpbm-10.47.04/converter/ppm/ppmtompeg/iframe.c.security netpbm-10.47.04/converter/ppm/ppmtompeg/iframe.c
|
||||
--- netpbm-10.47.04/converter/ppm/ppmtompeg/iframe.c.security 2009-10-21 13:39:09.000000000 +0200
|
||||
+++ netpbm-10.47.04/converter/ppm/ppmtompeg/iframe.c 2009-10-21 15:09:33.000000000 +0200
|
||||
@@ -800,7 +800,8 @@ BlockComputeSNR(MpegFrame * const curren
|
||||
if (needs_init) {
|
||||
int ysz = (Fsize_y>>3) * sizeof(int32 *);
|
||||
int xsz = (Fsize_x>>3);
|
||||
-
|
||||
+
|
||||
+ overflow2((Fsize_y>>3), sizeof(int32 *));
|
||||
needs_init = FALSE;
|
||||
for (y=0; y<3; y++) {
|
||||
varDiff[y] = ratio[y] = total[y] = 0.0;
|
||||
@@ -819,6 +820,7 @@ BlockComputeSNR(MpegFrame * const curren
|
||||
fprintf(stderr, "Out of memory in BlockComputeSNR\n");
|
||||
exit(-1);
|
||||
}
|
||||
+ overflow2(xsz,4);
|
||||
for (y = 0; y < ySize[0]>>3; y++) {
|
||||
SignalY[y] = (int32 *) calloc(xsz,4);
|
||||
SignalCr[y] = (int32 *) calloc(xsz,4);
|
||||
diff -up netpbm-10.47.04/converter/ppm/ppmtompeg/parallel.c.security netpbm-10.47.04/converter/ppm/ppmtompeg/parallel.c
|
||||
--- netpbm-10.47.04/converter/ppm/ppmtompeg/parallel.c.security 2009-10-21 13:39:10.000000000 +0200
|
||||
+++ netpbm-10.47.04/converter/ppm/ppmtompeg/parallel.c 2009-10-21 15:09:33.000000000 +0200
|
||||
@@ -2161,7 +2161,9 @@ DecodeServer(int const numInput
|
||||
const char * error;
|
||||
|
||||
/* should keep list of port numbers to notify when frames become ready */
|
||||
-
|
||||
+
|
||||
+ overflow2(numInputFiles, sizeof(int));
|
||||
+ overflow2(numInputFiles, sizeof(boolean));
|
||||
ready = (boolean *) calloc(numInputFiles, sizeof(boolean));
|
||||
waitMachine = (int *) calloc(numInputFiles, sizeof(int));
|
||||
waitPort = (int *) malloc(numMachines*sizeof(int));
|
||||
diff -up netpbm-10.47.04/converter/ppm/ppmtompeg/psearch.c.security netpbm-10.47.04/converter/ppm/ppmtompeg/psearch.c
|
||||
--- netpbm-10.47.04/converter/ppm/ppmtompeg/psearch.c.security 2009-10-21 13:39:10.000000000 +0200
|
||||
+++ netpbm-10.47.04/converter/ppm/ppmtompeg/psearch.c 2009-10-21 15:09:33.000000000 +0200
|
||||
@@ -216,7 +216,14 @@ SetSearchRange(int const pixelsP, int co
|
||||
int const max_search = max(searchRangeP, searchRangeB);
|
||||
|
||||
int index;
|
||||
-
|
||||
+
|
||||
+ overflow2(searchRangeP, 2);
|
||||
+ overflow2(searchRangeB, 2);
|
||||
+ overflow_add(searchRangeP*2, 3);
|
||||
+ overflow_add(searchRangeB*2, 3);
|
||||
+ overflow2(2*searchRangeB+3, sizeof(int));
|
||||
+ overflow2(2*searchRangeP+3, sizeof(int));
|
||||
+
|
||||
pmvHistogram = (int **) malloc((2*searchRangeP+3)*sizeof(int *));
|
||||
bbmvHistogram = (int **) malloc((2*searchRangeB+3)*sizeof(int *));
|
||||
bfmvHistogram = (int **) malloc((2*searchRangeB+3)*sizeof(int *));
|
||||
@@ -800,6 +807,9 @@ ShowPMVHistogram(fpointer)
|
||||
int *columnTotals;
|
||||
int rowTotal;
|
||||
|
||||
+ overflow2(searchRangeP, 2);
|
||||
+ overflow_add(searchRangeP*2, 3);
|
||||
+ overflow2(searchRangeP*2+3, sizeof(int));
|
||||
columnTotals = (int *) calloc(2*searchRangeP+3, sizeof(int));
|
||||
|
||||
#ifdef COMPLETE_DISPLAY
|
||||
@@ -847,6 +857,9 @@ ShowBBMVHistogram(fpointer)
|
||||
|
||||
fprintf(fpointer, "B-frame Backwards:\n");
|
||||
|
||||
+ overflow2(searchRangeB, 2);
|
||||
+ overflow_add(searchRangeB*2, 3);
|
||||
+ overflow2(searchRangeB*2+3, sizeof(int));
|
||||
columnTotals = (int *) calloc(2*searchRangeB+3, sizeof(int));
|
||||
|
||||
#ifdef COMPLETE_DISPLAY
|
||||
@@ -894,6 +907,9 @@ ShowBFMVHistogram(fpointer)
|
||||
|
||||
fprintf(fpointer, "B-frame Forwards:\n");
|
||||
|
||||
+ overflow2(searchRangeB, 2);
|
||||
+ overflow_add(searchRangeB*2, 3);
|
||||
+ overflow2(searchRangeB*2+3, sizeof(int));
|
||||
columnTotals = (int *) calloc(2*searchRangeB+3, sizeof(int));
|
||||
|
||||
#ifdef COMPLETE_DISPLAY
|
||||
diff -up netpbm-10.47.04/converter/ppm/ppmtompeg/rgbtoycc.c.security netpbm-10.47.04/converter/ppm/ppmtompeg/rgbtoycc.c
|
||||
--- netpbm-10.47.04/converter/ppm/ppmtompeg/rgbtoycc.c.security 2009-10-21 13:39:10.000000000 +0200
|
||||
+++ netpbm-10.47.04/converter/ppm/ppmtompeg/rgbtoycc.c 2009-10-21 15:09:33.000000000 +0200
|
||||
@@ -72,6 +72,8 @@ compute_mult_tables(const pixval maxval)
|
||||
}
|
||||
table_maxval = maxval;
|
||||
|
||||
+ overflow_add(table_maxval, 1);
|
||||
+ overflow2(table_maxval+1, sizeof(float));
|
||||
mult299 = malloc((table_maxval+1)*sizeof(float));
|
||||
mult587 = malloc((table_maxval+1)*sizeof(float));
|
||||
mult114 = malloc((table_maxval+1)*sizeof(float));
|
||||
diff -up netpbm-10.47.04/converter/ppm/ppmtopcx.c.security netpbm-10.47.04/converter/ppm/ppmtopcx.c
|
||||
--- netpbm-10.47.04/converter/ppm/ppmtopcx.c.security 2009-10-21 13:39:10.000000000 +0200
|
||||
+++ netpbm-10.47.04/converter/ppm/ppmtopcx.c 2009-10-21 15:09:33.000000000 +0200
|
||||
|
15
netpbm.spec
15
netpbm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A library for handling different graphics file formats
|
||||
Name: netpbm
|
||||
Version: 10.47.10
|
||||
Release: 3%{?dist}
|
||||
Version: 10.47.12
|
||||
Release: 1%{?dist}
|
||||
# See copyright_summary for details
|
||||
License: BSD and GPLv2 and IJG and MIT and Public Domain
|
||||
Group: System Environment/Libraries
|
||||
@ -9,7 +9,8 @@ URL: http://netpbm.sourceforge.net/
|
||||
# Source0 is prepared by
|
||||
# svn checkout https://netpbm.svn.sourceforge.net/svnroot/netpbm/stable netpbm-%{version}
|
||||
# svn checkout https://netpbm.svn.sourceforge.net/svnroot/netpbm/userguide netpbm-%{version}/userguide
|
||||
# and removing the .svn directories
|
||||
# and removing the .svn directories ( find -name "\.svn" -type d -print0 | xargs -0 rm -rf )
|
||||
# and removing the ppmtompeg code, due to patents ( rm -rf netpbm-%{version}/converter/ppm/ppmtompeg/ )
|
||||
Source0: netpbm-%{version}.tar.xz
|
||||
Patch1: netpbm-time.patch
|
||||
Patch2: netpbm-message.patch
|
||||
@ -20,7 +21,6 @@ Patch6: netpbm-gcc4.patch
|
||||
Patch7: netpbm-bmptopnm.patch
|
||||
Patch8: netpbm-CAN-2005-2471.patch
|
||||
Patch9: netpbm-xwdfix.patch
|
||||
Patch10: netpbm-ppmtompeg.patch
|
||||
Patch11: netpbm-multilib.patch
|
||||
Patch12: netpbm-pamscale.patch
|
||||
Patch13: netpbm-glibc.patch
|
||||
@ -30,6 +30,7 @@ Patch16: netpbm-ppmfadeusage.patch
|
||||
Patch17: netpbm-fiasco-overflow.patch
|
||||
Patch18: netpbm-lz.patch
|
||||
Patch19: netpbm-pnmmontagefix.patch
|
||||
Patch20: netpbm-noppmtompeg.patch
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, flex
|
||||
BuildRequires: libX11-devel, python, jasper-devel
|
||||
@ -93,7 +94,6 @@ netpbm-doc. You'll also need to install the netpbm-progs package.
|
||||
%patch7 -p1 -b .bmptopnm
|
||||
%patch8 -p1 -b .CAN-2005-2471
|
||||
%patch9 -p1 -b .xwdfix
|
||||
%patch10 -p1 -b .ppmtompeg
|
||||
%patch11 -p1 -b .multilib
|
||||
%patch12 -p1 -b .pamscale
|
||||
%patch13 -p1 -b .glibc
|
||||
@ -103,6 +103,7 @@ netpbm-doc. You'll also need to install the netpbm-progs package.
|
||||
%patch17 -p1 -b .fiasco-overflow
|
||||
%patch18 -p1 -b .lz
|
||||
%patch19 -p1 -b .pnmmmontagefix
|
||||
%patch20 -p1 -b .noppmtompeg
|
||||
|
||||
sed -i 's/STRIPFLAG = -s/STRIPFLAG =/g' config.mk.in
|
||||
|
||||
@ -243,6 +244,10 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%doc userguide/*
|
||||
|
||||
%changelog
|
||||
* Tue Apr 27 2010 Tom "spot" Callaway <tcallawa@redhat.com> 10.47.12-1
|
||||
- update to 10.47.12
|
||||
- remove ppmtompeg, due to legal issues
|
||||
|
||||
* Thu Mar 18 2010 Jindrich Novy <jnovy@redhat.com> 10.47.10-3
|
||||
- package docs in separate netpbm-doc package (#492437)
|
||||
- don't package patch backups in documentation
|
||||
|
Loading…
Reference in New Issue
Block a user