- update to 10.35
- drop .pnmtopng, .rgbtxt patches, fixed upstream - sync .xwidfix, .ppmtompeg patches - regenerate man pages
This commit is contained in:
parent
cff40ff07c
commit
01e6ac20e0
@ -24,3 +24,5 @@ netpbmdoc-10.34.tar.bz2
|
||||
netpbm-10.34.tar.bz2
|
||||
netpbm-10.34.l1.tar.bz2
|
||||
netpbmdoc-10.34.l1.tar.bz2
|
||||
netpbm-10.35.l1.tar.bz2
|
||||
netpbmdoc-10.35.l1.tar.bz2
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- netpbm-10.31/converter/other/xwdtopnm.c.xwdfix 2006-02-14 15:13:58.000000000 +0100
|
||||
+++ netpbm-10.31/converter/other/xwdtopnm.c 2006-02-14 15:15:37.000000000 +0100
|
||||
@@ -985,7 +985,7 @@ getpix(pixelReader * const rdrP) {
|
||||
--- netpbm-10.35/converter/other/xwdtopnm.c.xwdfix 2006-09-18 13:24:50.000000000 +0200
|
||||
+++ netpbm-10.35/converter/other/xwdtopnm.c 2006-09-18 13:27:26.000000000 +0200
|
||||
@@ -945,7 +945,7 @@ getpix(pixelReader * const rdrP) {
|
||||
unsigned long const bitsToTakeMask = lsbmask[nBitsToTake];
|
||||
/* E.g. if nbitsToTake is 4, this is 0x0000000F */
|
||||
|
||||
- unsigned long bitsToTake;
|
||||
+ unsigned int bitsToTake;
|
||||
/* The actual bits we take, in the 'nBitsToTake' low bits */
|
||||
|
||||
assert(nBitsToTake <= 32);
|
||||
|
||||
|
@ -1,22 +1,23 @@
|
||||
--- netpbm-10.33/converter/ppm/ppmtompeg/fsize.c.ppmtompeg 1995-07-03 23:57:05.000000000 +0200
|
||||
+++ netpbm-10.33/converter/ppm/ppmtompeg/fsize.c 2006-04-05 12:44:04.000000000 +0200
|
||||
@@ -117,8 +117,8 @@
|
||||
--- netpbm-10.35/converter/ppm/ppmtompeg/fsize.c.ppmtompeg 2006-09-18 12:20:24.000000000 +0200
|
||||
+++ netpbm-10.35/converter/ppm/ppmtompeg/fsize.c 2006-09-18 13:35:53.000000000 +0200
|
||||
@@ -115,8 +115,7 @@ Fsize_Note(int const id,
|
||||
Fsize_Validate(&Fsize_x, &Fsize_y);
|
||||
|
||||
if ((Fsize_x==0) || (Fsize_y==0)) {
|
||||
- fprintf(stderr,"Frame %d: size is zero!\n",id);
|
||||
-/* exit(1); */
|
||||
+ fprintf(stderr,"Frame %d: image dimensions need to be integer multiples of 16 for ppmtompeg!\n",id);
|
||||
+ exit(1);
|
||||
if ((Fsize_x == 0) || (Fsize_y == 0)) {
|
||||
- fprintf(stderr,"Frame %d: size is less than the minimum: %d x %d!\n",
|
||||
- id, DCTSIZE*2, DCTSIZE*2);
|
||||
+ fprintf(stderr,"Frame %d: image dimensions need to be integer multiples of 16 for ppmtompeg!\n",id);
|
||||
exit(1);
|
||||
}
|
||||
|
||||
#ifdef BLEAH
|
||||
--- netpbm-10.34/converter/ppm/ppmtompeg/parallel.c.ppmtompeg 2006-07-19 14:53:27.000000000 +0200
|
||||
+++ netpbm-10.34/converter/ppm/ppmtompeg/parallel.c 2006-07-19 15:11:42.000000000 +0200
|
||||
@@ -1315,8 +1315,6 @@
|
||||
--- netpbm-10.35/converter/ppm/ppmtompeg/parallel.c.ppmtompeg 2006-09-18 13:30:49.000000000 +0200
|
||||
+++ netpbm-10.35/converter/ppm/ppmtompeg/parallel.c 2006-09-18 13:32:24.000000000 +0200
|
||||
@@ -1316,8 +1316,6 @@ CombineServer(int const numFram
|
||||
TransmitPortNum(masterHostName, masterPortNum, combinePortNum);
|
||||
|
||||
|
||||
close(outputServerSocket);
|
||||
-
|
||||
- fclose(ofp);
|
||||
- fclose(ofP);
|
||||
}
|
||||
|
||||
|
||||
|
30
netpbm.spec
30
netpbm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A library for handling different graphics file formats.
|
||||
Name: netpbm
|
||||
Version: 10.34
|
||||
Release: 8%{?dist}
|
||||
Version: 10.35
|
||||
Release: 1%{?dist}
|
||||
License: freeware
|
||||
Group: System Environment/Libraries
|
||||
URL: http://netpbm.sourceforge.net/
|
||||
@ -17,12 +17,10 @@ Patch7: netpbm-10.24-nodoc.patch
|
||||
Patch8: netpbm-10.28-gcc4.patch
|
||||
Patch9: netpbm-10.27-bmptopnm.patch
|
||||
Patch10: netpbm-10.28-CAN-2005-2471.patch
|
||||
Patch11: netpbm-10.29-pnmtopng.patch
|
||||
Patch12: netpbm-10.30-rgbtxt.patch
|
||||
Patch13: netpbm-10.31-xwdfix.patch
|
||||
Patch14: netpbm-10.33-ppmtompeg.patch
|
||||
Patch15: netpbm-10.33-multilib.patch
|
||||
Patch16: netpbm-10.34-pamscale.patch
|
||||
Patch11: netpbm-10.31-xwdfix.patch
|
||||
Patch12: netpbm-10.33-ppmtompeg.patch
|
||||
Patch13: netpbm-10.33-multilib.patch
|
||||
Patch14: netpbm-10.34-pamscale.patch
|
||||
Buildroot: %{_tmppath}/%{name}-root
|
||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, perl, flex
|
||||
BuildRequires: libX11-devel
|
||||
@ -77,12 +75,10 @@ netpbm-progs. You'll also need to install the netpbm package.
|
||||
%patch8 -p1 -b .gcc4
|
||||
%patch9 -p1 -b .bmptopnm
|
||||
%patch10 -p1 -b .CAN-2005-2471
|
||||
%patch11 -p1 -b .pnmtopng
|
||||
%patch12 -p1 -b .rgbtxt
|
||||
%patch13 -p1 -b .xwdfix
|
||||
%patch14 -p1 -b .ppmtompeg
|
||||
%patch15 -p1 -b .multilib
|
||||
%patch16 -p1 -b .pamscale
|
||||
%patch11 -p1 -b .xwdfix
|
||||
%patch12 -p1 -b .ppmtompeg
|
||||
%patch13 -p1 -b .multilib
|
||||
%patch14 -p1 -b .pamscale
|
||||
|
||||
##mv shhopt/shhopt.h shhopt/pbmshhopt.h
|
||||
##perl -pi -e 's|shhopt.h|pbmshhopt.h|g' `find -name "*.c" -o -name "*.h"` ./GNUmakefile
|
||||
@ -187,6 +183,12 @@ rm -rf $RPM_BUILD_ROOT/usr/config_template
|
||||
%{_mandir}/man5/*
|
||||
|
||||
%changelog
|
||||
* Mon Sep 18 2006 Jindrich Novy <jnovy@redhat.com> 10.35-1
|
||||
- update to 10.35
|
||||
- drop .pnmtopng, .rgbtxt patches, fixed upstream
|
||||
- sync .xwidfix, .ppmtompeg patches
|
||||
- regenerate man pages
|
||||
|
||||
* Thu Sep 14 2006 Jindrich Novy <jnovy@redhat.com> 10.34-8
|
||||
- readd pbmtols, author claims it's LGPL (#202519)
|
||||
- add .l1 suffixes to tarball names to reflect legal fixes
|
||||
|
Loading…
Reference in New Issue
Block a user