- update to 10.32
- drop .msbmp patch, aplied upstream - sync the rest of the patches - regenerate man pages
This commit is contained in:
parent
9761fe0d3b
commit
001711f02e
@ -1,11 +1,10 @@
|
||||
--- netpbm-10.19/converter/other/giftopnm.c.message 2003-10-30 02:46:12.000000000 +0100
|
||||
+++ netpbm-10.19/converter/other/giftopnm.c 2004-02-09 17:02:56.964219996 +0100
|
||||
@@ -1255,7 +1255,8 @@
|
||||
requestedImageSeq+1,
|
||||
--- netpbm-10.32/converter/other/giftopnm.c.message 2006-02-15 23:53:45.000000000 +0100
|
||||
+++ netpbm-10.32/converter/other/giftopnm.c 2006-02-27 14:47:32.000000000 +0100
|
||||
@@ -1401,7 +1401,7 @@ convertImages(FILE * const ifP,
|
||||
imageSeq, imageSeq>1?"s":"" );
|
||||
} else {
|
||||
- pm_message("Reading Image Sequence %d", imageSeq);
|
||||
+ if (verbose)
|
||||
if (verbose)
|
||||
- pm_message("Reading Image Sequence %d", imageSeq);
|
||||
+ pm_message("Reading Image Sequence %d", imageSeq+1);
|
||||
convertImage(ifP, !allImages && (imageSeq != requestedImageSeq),
|
||||
imageout_file, alphafile, gifScreen, gif89);
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,20 +1,20 @@
|
||||
--- netpbm-10.27/converter/other/bmptopnm.c.bmptopnm 2005-05-09 10:06:05.707795976 +0200
|
||||
+++ netpbm-10.27/converter/other/bmptopnm.c 2005-05-09 10:29:30.498235368 +0200
|
||||
@@ -932,7 +932,7 @@ readBmp(FILE * const ifP,
|
||||
--- netpbm-10.32/converter/other/bmptopnm.c.bmptopnm 2006-02-27 15:02:02.000000000 +0100
|
||||
+++ netpbm-10.32/converter/other/bmptopnm.c 2006-02-27 15:07:31.000000000 +0100
|
||||
@@ -1248,7 +1248,7 @@ readBmp(FILE * const ifP,
|
||||
xel ** const colormapP,
|
||||
bool const verbose) {
|
||||
|
||||
- xel * colormap; /* malloc'ed */
|
||||
+ xel * colormap = NULL; /* malloc'ed */
|
||||
unsigned int pos;
|
||||
/* Current byte position in the BMP file */
|
||||
|
||||
/* The following are all information from the BMP headers */
|
||||
@@ -1106,7 +1106,7 @@ main(int argc, char ** argv) {
|
||||
writeRaster(BMPraster, cols, rows, outputType, cBitCount, pixelformat,
|
||||
colormap);
|
||||
|
||||
@@ -1455,7 +1455,7 @@ main(int argc, char ** argv) {
|
||||
writeRasterGen(BMPraster, cols, rows, outputType, cBitCount,
|
||||
pixelformat, colormap);
|
||||
}
|
||||
- free(colormap);
|
||||
+ if (colormap) free(colormap);
|
||||
free(BMPraster);
|
||||
|
||||
exit(0);
|
||||
return 0;
|
||||
|
12
netpbm.spec
12
netpbm.spec
@ -1,7 +1,7 @@
|
||||
Summary: A library for handling different graphics file formats.
|
||||
Name: netpbm
|
||||
Version: 10.31
|
||||
Release: 5
|
||||
Version: 10.32
|
||||
Release: 1
|
||||
License: freeware
|
||||
Group: System Environment/Libraries
|
||||
URL: http://netpbm.sourceforge.net/
|
||||
@ -21,7 +21,6 @@ Patch10: netpbm-10.28-CAN-2005-2471.patch
|
||||
Patch11: netpbm-10.29-pnmtopng.patch
|
||||
Patch12: netpbm-10.30-rgbtxt.patch
|
||||
Patch13: netpbm-10.31-xwdfix.patch
|
||||
Patch14: netpbm-10.31-msbmp.patch
|
||||
Buildroot: %{_tmppath}/%{name}-root
|
||||
BuildRequires: libjpeg-devel, libpng-devel, libtiff-devel, perl, flex
|
||||
Obsoletes: libgr
|
||||
@ -79,7 +78,6 @@ netpbm-progs. You'll also need to install the netpbm package.
|
||||
%patch11 -p1 -b .pnmtopng
|
||||
%patch12 -p1 -b .rgbtxt
|
||||
%patch13 -p1 -b .xwdfix
|
||||
%patch14 -p1 -b .msbmp
|
||||
|
||||
##mv shhopt/shhopt.h shhopt/pbmshhopt.h
|
||||
##perl -pi -e 's|shhopt.h|pbmshhopt.h|g' `find -name "*.c" -o -name "*.h"` ./GNUmakefile
|
||||
@ -178,6 +176,12 @@ rm -rf $RPM_BUILD_ROOT/usr/config_template
|
||||
%{_mandir}/man5/*
|
||||
|
||||
%changelog
|
||||
* Tue Feb 28 2006 Jindrich Novy <jnovy@redhat.com> 10.32-1
|
||||
- update to 10.32
|
||||
- drop .msbmp patch, aplied upstream
|
||||
- sync the rest of the patches
|
||||
- regenerate man pages
|
||||
|
||||
* Mon Feb 20 2006 Jindrich Novy <jnovy@redhat.com> 10.31-5
|
||||
- add missing flex BuildRequires
|
||||
- fix anytopnm to recognize ms-bmp files (#182060)
|
||||
|
Loading…
Reference in New Issue
Block a user