Patche are applicable with --fuz=0
This commit is contained in:
parent
967816f6f9
commit
9634070fca
@ -2,7 +2,7 @@
|
|||||||
+++ net-tools-1.60/netplug-1.2.9/Makefile 2005-01-10 11:38:01.796744224 +0100
|
+++ net-tools-1.60/netplug-1.2.9/Makefile 2005-01-10 11:38:01.796744224 +0100
|
||||||
@@ -24,10 +24,12 @@
|
@@ -24,10 +24,12 @@
|
||||||
install $(install_opts) -m 755 scripts/rc.netplugd $(initdir)/netplugd
|
install $(install_opts) -m 755 scripts/rc.netplugd $(initdir)/netplugd
|
||||||
install -C $(install_opts) -m 444 man/man8/netplugd.8 $(mandir)/man8
|
install $(install_opts) -m 444 man/man8/netplugd.8 $(mandir)/man8
|
||||||
|
|
||||||
-bk_root := $(shell bk root)
|
-bk_root := $(shell bk root)
|
||||||
+#bk_root := $(shell bk root)
|
+#bk_root := $(shell bk root)
|
||||||
|
@ -184,9 +184,9 @@
|
|||||||
if (state == TCP_LISTEN) {
|
if (state == TCP_LISTEN) {
|
||||||
time_len = 0;
|
time_len = 0;
|
||||||
retr = 0L;
|
retr = 0L;
|
||||||
@@ -1849,6 +2014,7 @@
|
@@ -1880,6 +2045,7 @@
|
||||||
break;
|
break;
|
||||||
sleep(1);
|
sleep(reptimer);
|
||||||
prg_cache_clear();
|
prg_cache_clear();
|
||||||
+ tcp_node_hash_clear();
|
+ tcp_node_hash_clear();
|
||||||
}
|
}
|
||||||
|
@ -3,13 +3,13 @@ diff -Naurp net-tools-1.60-ifconfig-new/lib/interface.c net-tools-1.60-ifconfig/
|
|||||||
+++ net-tools-1.60-ifconfig/lib/interface.c 2006-03-23 09:58:45.000000000 +0100
|
+++ net-tools-1.60-ifconfig/lib/interface.c 2006-03-23 09:58:45.000000000 +0100
|
||||||
@@ -203,6 +203,7 @@ out:
|
@@ -203,6 +203,7 @@ out:
|
||||||
|
|
||||||
static char *get_name(char *name, char *p)
|
static char *get_name(char **namep, char *p)
|
||||||
{
|
{
|
||||||
+ int count = 0;
|
+ int count = 0;
|
||||||
while (isspace(*p))
|
while (isspace(*p))
|
||||||
p++;
|
p++;
|
||||||
while (*p) {
|
char *name = *namep = p;
|
||||||
@@ -211,8 +212,13 @@ static char *get_name(char *name, char *
|
@@ -211,8 +212,13 @@ static char *get_name(char **namep, char
|
||||||
if (*p == ':') { /* could be an alias */
|
if (*p == ':') { /* could be an alias */
|
||||||
char *dot = p, *dotname = name;
|
char *dot = p, *dotname = name;
|
||||||
*name++ = *p++;
|
*name++ = *p++;
|
||||||
@ -24,7 +24,7 @@ diff -Naurp net-tools-1.60-ifconfig-new/lib/interface.c net-tools-1.60-ifconfig/
|
|||||||
if (*p != ':') { /* it wasn't, backup */
|
if (*p != ':') { /* it wasn't, backup */
|
||||||
p = dot;
|
p = dot;
|
||||||
name = dotname;
|
name = dotname;
|
||||||
@@ -223,6 +229,9 @@ static char *get_name(char *name, char *
|
@@ -223,6 +229,9 @@ static char *get_name(char **namep, char
|
||||||
break;
|
break;
|
||||||
}
|
}
|
||||||
*name++ = *p++;
|
*name++ = *p++;
|
||||||
|
Loading…
Reference in New Issue
Block a user