2.0 pre-release

This commit is contained in:
Jiri Popelka 2012-10-04 11:54:40 +02:00
parent cbb4fe95ac
commit 95ca85a4b4
18 changed files with 183 additions and 143 deletions

1
.gitignore vendored
View File

@ -8,3 +8,4 @@ net-tools-1.60.tar.bz2
/net-tools-1.60.20120509git.tar.xz
/net-tools-1.60.20120702git.tar.xz
/net-tools-1.60.20120917git.tar.xz
/net-tools-2.0.20121004git.tar.xz

View File

@ -1,16 +0,0 @@
diff -up net-tools-1.60/lib/interface.c.statalias net-tools-1.60/lib/interface.c
--- net-tools-1.60/lib/interface.c.statalias 2011-12-02 16:37:32.258671807 +0100
+++ net-tools-1.60/lib/interface.c 2011-12-02 16:37:33.193660117 +0100
@@ -403,9 +403,11 @@ static int if_readlist_rep(char *target,
char *s, name[IFNAMSIZ];
s = get_name(name, buf);
get_dev_fields(s, ife);
- ife->statistics_valid = 1;
if (target && !strcmp(target,name))
+ {
+ ife->statistics_valid = 1;
break;
+ }
}
if (ferror(fh)) {
perror(_PATH_PROCNET_DEV);

View File

@ -1,6 +1,6 @@
diff -up net-tools-1.60/lib/interface.c.cycle net-tools-1.60/lib/interface.c
--- net-tools-1.60/lib/interface.c.cycle 2012-01-16 15:34:09.000000000 +0100
+++ net-tools-1.60/lib/interface.c 2012-01-19 11:42:51.207536052 +0100
diff -up net-tools-2.0/lib/interface.c.cycle net-tools-2.0/lib/interface.c
--- net-tools-2.0/lib/interface.c.cycle 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/lib/interface.c 2012-10-04 11:26:37.982693893 +0200
@@ -93,6 +93,7 @@ int if_list_all = 0; /* do we have reque
static struct interface *int_list, *int_last;
@ -67,9 +67,9 @@ diff -up net-tools-1.60/lib/interface.c.cycle net-tools-1.60/lib/interface.c
int if_readlist(void)
{
diff -up net-tools-1.60/man/en_US/netstat.8.cycle net-tools-1.60/man/en_US/netstat.8
--- net-tools-1.60/man/en_US/netstat.8.cycle 2012-01-16 15:34:09.000000000 +0100
+++ net-tools-1.60/man/en_US/netstat.8 2012-01-19 11:42:51.208536039 +0100
diff -up net-tools-2.0/man/en_US/netstat.8.cycle net-tools-2.0/man/en_US/netstat.8
--- net-tools-2.0/man/en_US/netstat.8.cycle 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/man/en_US/netstat.8 2012-10-04 11:26:37.983693882 +0200
@@ -33,6 +33,7 @@ netstat \- Print network connections, ro
.RB [ \-\-verbose | \-v ]
.RB [ \-\-continuous | \-c]
@ -117,7 +117,7 @@ diff -up net-tools-1.60/man/en_US/netstat.8.cycle net-tools-1.60/man/en_US/netst
.P
.B netstat
.RB { \-\-version | \-V }
@@ -188,6 +194,10 @@ option, show interfaces that are not up
@@ -197,6 +203,10 @@ option, show interfaces that are not up
Print routing information from the FIB. (This is the default.)
.SS "\-C"
Print routing information from the route cache.
@ -128,10 +128,10 @@ diff -up net-tools-1.60/man/en_US/netstat.8.cycle net-tools-1.60/man/en_US/netst
.P
.SH OUTPUT
.P
diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
--- net-tools-1.60/netstat.c.cycle 2012-01-16 15:34:09.000000000 +0100
+++ net-tools-1.60/netstat.c 2012-01-19 11:49:59.836177456 +0100
@@ -116,9 +116,9 @@
diff -up net-tools-2.0/netstat.c.cycle net-tools-2.0/netstat.c
--- net-tools-2.0/netstat.c.cycle 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/netstat.c 2012-10-04 11:26:37.983693882 +0200
@@ -114,9 +114,9 @@
#endif
/* prototypes for statistics.c */
@ -143,7 +143,7 @@ diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
void inittab6(void);
typedef enum {
@@ -344,10 +344,10 @@ static void prg_cache_clear(void)
@@ -342,10 +342,10 @@ static void prg_cache_clear(void)
prg_cache_loaded = 0;
}
@ -199,7 +199,7 @@ diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
fprintf(stderr, _(" -r, --route display routing table\n"));
fprintf(stderr, _(" -i, --interfaces display interface table\n"));
@@ -1861,6 +1864,7 @@ int main
@@ -1865,6 +1868,7 @@ int main
(int argc, char *argv[]) {
int i;
int lop;
@ -207,7 +207,7 @@ diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
static struct option longopts[] =
{
AFTRANS_OPTS,
@@ -2043,6 +2047,12 @@ int main
@@ -2047,6 +2051,12 @@ int main
flag_sta++;
}
@ -220,7 +220,7 @@ diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
if (flag_int + flag_rou + flag_mas + flag_sta > 1)
usage();
@@ -2072,7 +2082,7 @@ int main
@@ -2076,7 +2086,7 @@ int main
flag_not & FLAG_NUM_PORT, flag_exp);
if (i || !flag_cnt)
break;
@ -229,7 +229,7 @@ diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
}
#else
ENOSUPP("netstat", "FW_MASQUERADE");
@@ -2084,18 +2094,18 @@ int main
@@ -2088,18 +2098,18 @@ int main
if (flag_sta) {
if (!afname[0])
strcpy(afname, DFLT_AF);
@ -251,7 +251,7 @@ diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
#else
ENOSUPP("netstat", "AF INET6");
#endif
@@ -2103,7 +2113,11 @@ int main
@@ -2107,7 +2117,11 @@ int main
printf(_("netstat: No statistics support for specified address family: %s\n"), afname);
exit(1);
}
@ -264,7 +264,7 @@ diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
}
if (flag_rou) {
@@ -2125,7 +2139,7 @@ int main
@@ -2129,7 +2143,7 @@ int main
i = route_info(afname, options);
if (i || !flag_cnt)
break;
@ -273,7 +273,7 @@ diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
}
return (i);
}
@@ -2134,7 +2148,7 @@ int main
@@ -2138,7 +2152,7 @@ int main
i = iface_info();
if (!flag_cnt || i)
break;
@ -282,7 +282,7 @@ diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
}
return (i);
}
@@ -2321,7 +2335,7 @@ int main
@@ -2325,7 +2339,7 @@ int main
if (!flag_cnt || i)
break;
@ -291,9 +291,9 @@ diff -up net-tools-1.60/netstat.c.cycle net-tools-1.60/netstat.c
prg_cache_clear();
}
return (i);
diff -up net-tools-1.60/statistics.c.cycle net-tools-1.60/statistics.c
--- net-tools-1.60/statistics.c.cycle 2012-01-16 15:34:09.000000000 +0100
+++ net-tools-1.60/statistics.c 2012-01-19 11:42:51.220535890 +0100
diff -up net-tools-2.0/statistics.c.cycle net-tools-2.0/statistics.c
--- net-tools-2.0/statistics.c.cycle 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/statistics.c 2012-10-04 11:26:37.984693871 +0200
@@ -502,7 +502,7 @@ void process6_fd(FILE *f)
}

View File

@ -1,7 +1,7 @@
diff -up net-tools-1.60/netstat.c.dup-tcp net-tools-1.60/netstat.c
--- net-tools-1.60/netstat.c.dup-tcp 2011-12-07 19:17:24.162425150 +0100
+++ net-tools-1.60/netstat.c 2011-12-07 19:18:02.161950091 +0100
@@ -449,6 +449,121 @@ static void prg_cache_load(void)
diff -up net-tools-2.0/netstat.c.dup-tcp net-tools-2.0/netstat.c
--- net-tools-2.0/netstat.c.dup-tcp 2012-10-04 11:32:01.437729086 +0200
+++ net-tools-2.0/netstat.c 2012-10-04 11:32:01.441729032 +0200
@@ -502,6 +502,121 @@ static void prg_cache_load(void)
" will not be shown, you would have to be root to see it all.)\n"));
}
@ -123,7 +123,7 @@ diff -up net-tools-1.60/netstat.c.dup-tcp net-tools-1.60/netstat.c
#if HAVE_AFNETROM
static const char *netrom_state[] =
{
@@ -960,6 +1075,12 @@ static void tcp_do_one(int lnr, const ch
@@ -1018,6 +1133,12 @@ static void tcp_do_one(int lnr, const ch
return;
}
@ -136,7 +136,7 @@ diff -up net-tools-1.60/netstat.c.dup-tcp net-tools-1.60/netstat.c
addr_do_one(local_addr, sizeof(local_addr), 22, ap, &localaddr, local_port, "tcp");
addr_do_one(rem_addr, sizeof(rem_addr), 22, ap, &remaddr, rem_port, "tcp");
@@ -2114,6 +2235,7 @@ int main
@@ -2355,6 +2476,7 @@ int main
break;
wait_continous(reptimer);
prg_cache_clear();

View File

@ -1,6 +1,6 @@
diff -up net-tools-1.60/lib/interface.c.long_iface net-tools-1.60/lib/interface.c
--- net-tools-1.60/lib/interface.c.long_iface 2011-12-05 18:16:38.000000000 +0100
+++ net-tools-1.60/lib/interface.c 2011-12-05 19:13:17.343530194 +0100
diff -up net-tools-2.0/lib/interface.c.long_iface net-tools-2.0/lib/interface.c
--- net-tools-2.0/lib/interface.c.long_iface 2012-10-04 11:35:27.983694933 +0200
+++ net-tools-2.0/lib/interface.c 2012-10-04 11:35:27.991694805 +0200
@@ -216,6 +216,7 @@ out:
char *get_name(char **namep, char *p)

View File

@ -1,6 +1,6 @@
diff -up net-tools-1.60/lib/inet6.c.inet6-lookup net-tools-1.60/lib/inet6.c
--- net-tools-1.60/lib/inet6.c.inet6-lookup 2011-11-21 02:31:57.000000000 +0100
+++ net-tools-1.60/lib/inet6.c 2011-12-01 17:10:40.057969536 +0100
diff -up net-tools-2.0/lib/inet6.c.inet6-lookup net-tools-2.0/lib/inet6.c
--- net-tools-2.0/lib/inet6.c.inet6-lookup 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/lib/inet6.c 2012-10-04 11:29:22.686750407 +0200
@@ -149,33 +149,9 @@ static const char *INET6_sprint(struct s
}
@ -36,9 +36,9 @@ diff -up net-tools-1.60/lib/inet6.c.inet6-lookup net-tools-1.60/lib/inet6.c
}
diff -up net-tools-1.60/lib/inet6_gr.c.inet6-lookup net-tools-1.60/lib/inet6_gr.c
--- net-tools-1.60/lib/inet6_gr.c.inet6-lookup 2011-11-21 02:31:57.000000000 +0100
+++ net-tools-1.60/lib/inet6_gr.c 2011-12-01 17:11:21.958445708 +0100
diff -up net-tools-2.0/lib/inet6_gr.c.inet6-lookup net-tools-2.0/lib/inet6_gr.c
--- net-tools-2.0/lib/inet6_gr.c.inet6-lookup 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/lib/inet6_gr.c 2012-10-04 11:29:22.687750395 +0200
@@ -108,7 +108,7 @@ int rprint_fib6(int ext, int numeric)
addr6p[4], addr6p[5], addr6p[6], addr6p[7]);
inet6_aftype.input(1, addr6, (struct sockaddr *) &saddr6);
@ -57,9 +57,9 @@ diff -up net-tools-1.60/lib/inet6_gr.c.inet6-lookup net-tools-1.60/lib/inet6_gr.
/* Decode the flags. */
diff -up net-tools-1.60/lib/inet6_sr.c.inet6-lookup net-tools-1.60/lib/inet6_sr.c
--- net-tools-1.60/lib/inet6_sr.c.inet6-lookup 2011-11-21 02:31:57.000000000 +0100
+++ net-tools-1.60/lib/inet6_sr.c 2011-12-01 17:14:32.707061021 +0100
diff -up net-tools-2.0/lib/inet6_sr.c.inet6-lookup net-tools-2.0/lib/inet6_sr.c
--- net-tools-2.0/lib/inet6_sr.c.inet6-lookup 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/lib/inet6_sr.c 2012-10-04 11:29:22.687750395 +0200
@@ -32,6 +32,7 @@
#include "net-support.h"
#include "pathnames.h"

View File

@ -1,6 +1,6 @@
diff -up net-tools-1.60/man/en_US/netstat.8.interface net-tools-1.60/man/en_US/netstat.8
--- net-tools-1.60/man/en_US/netstat.8.interface 2012-01-19 15:11:22.176127422 +0100
+++ net-tools-1.60/man/en_US/netstat.8 2012-01-19 15:11:22.182127345 +0100
diff -up net-tools-2.0/man/en_US/netstat.8.interface net-tools-2.0/man/en_US/netstat.8
--- net-tools-2.0/man/en_US/netstat.8.interface 2012-10-04 11:31:00.753513633 +0200
+++ net-tools-2.0/man/en_US/netstat.8 2012-10-04 11:31:00.755513607 +0200
@@ -46,9 +46,9 @@ netstat \- Print network connections, ro
.RB [delay]
.P
@ -13,7 +13,7 @@ diff -up net-tools-1.60/man/en_US/netstat.8.interface net-tools-1.60/man/en_US/n
.RB [ \-\-verbose | \-v ]
.RB [ \-\-program | \-p ]
.RB [ \-\-numeric | \-n ]
@@ -130,8 +130,8 @@ and
@@ -129,8 +129,8 @@ and
produce the same output.
.SS "\-\-groups , \-g"
Display multicast group membership information for IPv4 and IPv6.
@ -24,10 +24,10 @@ diff -up net-tools-1.60/man/en_US/netstat.8.interface net-tools-1.60/man/en_US/n
.SS "\-\-masquerade , \-M"
Display a list of masqueraded connections.
.SS "\-\-statistics , \-s"
diff -up net-tools-1.60/netstat.c.interface net-tools-1.60/netstat.c
--- net-tools-1.60/netstat.c.interface 2012-01-19 15:11:22.163127584 +0100
+++ net-tools-1.60/netstat.c 2012-01-19 15:12:16.094453349 +0100
@@ -145,6 +145,7 @@ char *Release = RELEASE, *Version = "net
diff -up net-tools-2.0/netstat.c.interface net-tools-2.0/netstat.c
--- net-tools-2.0/netstat.c.interface 2012-10-04 11:31:00.745513734 +0200
+++ net-tools-2.0/netstat.c 2012-10-04 11:31:00.756513594 +0200
@@ -143,6 +143,7 @@ char *Release = RELEASE, *Version = "net
#define E_IOCTL -3
int flag_int = 0;
@ -68,7 +68,7 @@ diff -up net-tools-1.60/netstat.c.interface net-tools-1.60/netstat.c
fprintf(stderr, _(" -i, --interfaces display interface table\n"));
fprintf(stderr, _(" -g, --groups display multicast group memberships\n"));
fprintf(stderr, _(" -s, --statistics display networking statistics (like SNMP)\n"));
@@ -1869,7 +1876,7 @@ int main
@@ -1873,7 +1880,7 @@ int main
{
AFTRANS_OPTS,
{"version", 0, 0, 'V'},
@ -77,7 +77,7 @@ diff -up net-tools-1.60/netstat.c.interface net-tools-1.60/netstat.c
{"help", 0, 0, 'h'},
{"route", 0, 0, 'r'},
#if HAVE_FW_MASQUERADE
@@ -1913,7 +1920,7 @@ int main
@@ -1917,7 +1924,7 @@ int main
getroute_init(); /* Set up AF routing support */
afname[0] = '\0';
@ -86,7 +86,7 @@ diff -up net-tools-1.60/netstat.c.interface net-tools-1.60/netstat.c
switch (i) {
case -1:
break;
@@ -1954,6 +1961,13 @@ int main
@@ -1958,6 +1965,13 @@ int main
case 'p':
flag_prg++;
break;

View File

@ -1,7 +1,7 @@
diff -up net-tools-1.60/include/interface.h.stack net-tools-1.60/include/interface.h
--- net-tools-1.60/include/interface.h.stack 2012-01-05 12:22:43.000000000 +0100
+++ net-tools-1.60/include/interface.h 2012-01-05 13:00:10.564699085 +0100
@@ -73,7 +73,7 @@ extern int do_if_print(struct interface
diff -up net-tools-2.0/include/interface.h.stack net-tools-2.0/include/interface.h
--- net-tools-2.0/include/interface.h.stack 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/include/interface.h 2012-10-04 11:33:44.294371323 +0200
@@ -72,7 +72,7 @@ extern int do_if_print(struct interface
extern int procnetdev_version(char *buf);
extern int get_dev_fields(char *bp, struct interface *ife);
@ -10,9 +10,9 @@ diff -up net-tools-1.60/include/interface.h.stack net-tools-1.60/include/interfa
extern void ife_print(struct interface *ptr);
diff -up net-tools-1.60/lib/interface.c.stack net-tools-1.60/lib/interface.c
--- net-tools-1.60/lib/interface.c.stack 2012-01-05 13:00:10.561699123 +0100
+++ net-tools-1.60/lib/interface.c 2012-01-05 13:03:19.522336790 +0100
diff -up net-tools-2.0/lib/interface.c.stack net-tools-2.0/lib/interface.c
--- net-tools-2.0/lib/interface.c.stack 2012-10-04 11:33:44.292371355 +0200
+++ net-tools-2.0/lib/interface.c 2012-10-04 11:33:44.295371307 +0200
@@ -214,10 +214,11 @@ out:
return err;
}

View File

@ -1,7 +1,7 @@
diff -up net-tools-1.60/lib/ipx_gr.c.ipx net-tools-1.60/lib/ipx_gr.c
--- net-tools-1.60/lib/ipx_gr.c.ipx 2011-11-21 02:31:57.000000000 +0100
+++ net-tools-1.60/lib/ipx_gr.c 2011-12-01 17:02:53.261805292 +0100
@@ -70,7 +70,7 @@ int IPX_rprint(int options)
diff -up net-tools-2.0/lib/ipx_gr.c.ipx net-tools-2.0/lib/ipx_gr.c
--- net-tools-2.0/lib/ipx_gr.c.ipx 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/lib/ipx_gr.c 2012-10-04 11:27:39.011998824 +0200
@@ -71,7 +71,7 @@ int IPX_rprint(int options)
continue;
/* Fetch and resolve the Destination */
@ -10,10 +10,10 @@ diff -up net-tools-1.60/lib/ipx_gr.c.ipx net-tools-1.60/lib/ipx_gr.c
strcpy(net, ap->sprint(&sa, numeric));
/* Fetch and resolve the Router Net */
diff -up net-tools-1.60/netstat.c.ipx net-tools-1.60/netstat.c
--- net-tools-1.60/netstat.c.ipx 2011-12-01 17:02:53.000000000 +0100
+++ net-tools-1.60/netstat.c 2011-12-01 17:06:26.071144809 +0100
@@ -1582,13 +1582,13 @@ static int ipx_info(void)
diff -up net-tools-2.0/netstat.c.ipx net-tools-2.0/netstat.c
--- net-tools-2.0/netstat.c.ipx 2012-10-04 11:27:39.008998860 +0200
+++ net-tools-2.0/netstat.c 2012-10-04 11:27:39.012998812 +0200
@@ -1647,13 +1647,13 @@ static int ipx_info(void)
}
/* Fetch and resolve the Source */

View File

@ -1,6 +1,6 @@
diff -up net-tools-1.60/man/en_US/arp.8.man net-tools-1.60/man/en_US/arp.8
--- net-tools-1.60/man/en_US/arp.8.man 2012-01-16 15:34:09.000000000 +0100
+++ net-tools-1.60/man/en_US/arp.8 2012-01-19 15:15:09.086290653 +0100
diff -up net-tools-2.0/man/en_US/arp.8.man net-tools-2.0/man/en_US/arp.8
--- net-tools-2.0/man/en_US/arp.8.man 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/man/en_US/arp.8 2012-10-04 11:30:07.668188620 +0200
@@ -63,6 +63,10 @@ arp \- manipulate the system ARP cache
.B \-f
.RI [ filename ]
@ -20,9 +20,9 @@ diff -up net-tools-1.60/man/en_US/arp.8.man net-tools-1.60/man/en_US/arp.8
+.BR ip(8)
.SH AUTHORS
Fred N. van Kempen <waltje@uwalt.nl.mugnet.org>, Bernd Eckenfels <net\-tools@lina.inka.de>.
diff -up net-tools-1.60/man/en_US/ethers.5.man net-tools-1.60/man/en_US/ethers.5
--- net-tools-1.60/man/en_US/ethers.5.man 2012-01-16 15:34:09.000000000 +0100
+++ net-tools-1.60/man/en_US/ethers.5 2012-01-19 15:15:09.087290640 +0100
diff -up net-tools-2.0/man/en_US/ethers.5.man net-tools-2.0/man/en_US/ethers.5
--- net-tools-2.0/man/en_US/ethers.5.man 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/man/en_US/ethers.5 2012-10-04 11:30:07.669188608 +0200
@@ -26,6 +26,3 @@ can be resolved by DNS or a dot separate
.SH FILES \"{{{
/etc/ethers
@ -30,9 +30,9 @@ diff -up net-tools-1.60/man/en_US/ethers.5.man net-tools-1.60/man/en_US/ethers.5
-.SH "SEE ALSO" \"{{{
-rarp(8)
-.\"}}}
diff -up net-tools-1.60/man/en_US/ifconfig.8.man net-tools-1.60/man/en_US/ifconfig.8
--- net-tools-1.60/man/en_US/ifconfig.8.man 2012-01-16 15:34:09.000000000 +0100
+++ net-tools-1.60/man/en_US/ifconfig.8 2012-01-19 15:15:09.087290640 +0100
diff -up net-tools-2.0/man/en_US/ifconfig.8.man net-tools-2.0/man/en_US/ifconfig.8
--- net-tools-2.0/man/en_US/ifconfig.8.man 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/man/en_US/ifconfig.8 2012-10-04 11:30:07.669188608 +0200
@@ -5,6 +5,13 @@ ifconfig \- configure a network interfac
.B "ifconfig [-v] [-a] [-s] [interface]"
.br
@ -47,7 +47,7 @@ diff -up net-tools-1.60/man/en_US/ifconfig.8.man net-tools-1.60/man/en_US/ifconf
.SH DESCRIPTION
.B Ifconfig
is used to configure the kernel-resident network interfaces. It is
@@ -225,7 +232,8 @@ package to display link layer informatio
@@ -222,7 +229,8 @@ package to display link layer informatio
While appletalk DDP and IPX addresses will be displayed they cannot be
altered by this command.
.SH SEE ALSO
@ -57,9 +57,9 @@ diff -up net-tools-1.60/man/en_US/ifconfig.8.man net-tools-1.60/man/en_US/ifconf
.br
http://physics.nist.gov/cuu/Units/binary.html - Prefixes for binary multiples
.SH AUTHORS
diff -up net-tools-1.60/man/en_US/mii-tool.8.man net-tools-1.60/man/en_US/mii-tool.8
--- net-tools-1.60/man/en_US/mii-tool.8.man 2012-01-16 15:34:09.000000000 +0100
+++ net-tools-1.60/man/en_US/mii-tool.8 2012-01-19 15:15:09.087290640 +0100
diff -up net-tools-2.0/man/en_US/mii-tool.8.man net-tools-2.0/man/en_US/mii-tool.8
--- net-tools-2.0/man/en_US/mii-tool.8.man 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/man/en_US/mii-tool.8 2012-10-04 11:30:07.669188608 +0200
@@ -18,6 +18,10 @@ mii\-tool \- view, manipulate media-inde
[\fB\-F\fR, \fB\-\-force=\fImedia\fR]
.RI "interface\ ..."
@ -81,9 +81,9 @@ diff -up net-tools-1.60/man/en_US/mii-tool.8.man net-tools-1.60/man/en_US/mii-to
.SH AUTHORS
David Hinds \- dhinds@pcmcia.sourceforge.org
.br
diff -up net-tools-1.60/man/en_US/nameif.8.man net-tools-1.60/man/en_US/nameif.8
--- net-tools-1.60/man/en_US/nameif.8.man 2012-01-16 15:34:09.000000000 +0100
+++ net-tools-1.60/man/en_US/nameif.8 2012-01-19 15:15:09.088290628 +0100
diff -up net-tools-2.0/man/en_US/nameif.8.man net-tools-2.0/man/en_US/nameif.8
--- net-tools-2.0/man/en_US/nameif.8.man 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/man/en_US/nameif.8 2012-10-04 11:30:07.670188596 +0200
@@ -5,6 +5,12 @@ nameif \- name network interfaces based
.B "nameif [\-c configfile] [\-s]"
.br
@ -108,10 +108,10 @@ diff -up net-tools-1.60/man/en_US/nameif.8.man net-tools-1.60/man/en_US/nameif.8
+
.SH BUGS
Only works for Ethernet currently.
diff -up net-tools-1.60/man/en_US/netstat.8.man net-tools-1.60/man/en_US/netstat.8
--- net-tools-1.60/man/en_US/netstat.8.man 2012-01-19 15:15:09.066290903 +0100
+++ net-tools-1.60/man/en_US/netstat.8 2012-01-19 15:15:09.088290628 +0100
@@ -187,7 +195,8 @@ Show the PID and name of the program to
diff -up net-tools-2.0/man/en_US/netstat.8.man net-tools-2.0/man/en_US/netstat.8
--- net-tools-2.0/man/en_US/netstat.8.man 2012-10-04 11:30:07.659188734 +0200
+++ net-tools-2.0/man/en_US/netstat.8 2012-10-04 11:30:07.670188596 +0200
@@ -196,7 +196,8 @@ Show the PID and name of the program to
.SS "\-l, \-\-listening"
Show only listening sockets. (These are omitted by default.)
.SS "\-a, \-\-all"
@ -121,9 +121,9 @@ diff -up net-tools-1.60/man/en_US/netstat.8.man net-tools-1.60/man/en_US/netstat
.B \-\-interfaces
option, show interfaces that are not up
.SS "\-F"
diff -up net-tools-1.60/man/en_US/route.8.man net-tools-1.60/man/en_US/route.8
--- net-tools-1.60/man/en_US/route.8.man 2012-01-16 15:34:09.000000000 +0100
+++ net-tools-1.60/man/en_US/route.8 2012-01-19 15:15:09.089290616 +0100
diff -up net-tools-2.0/man/en_US/route.8.man net-tools-2.0/man/en_US/route.8
--- net-tools-2.0/man/en_US/route.8.man 2012-10-01 07:40:47.000000000 +0200
+++ net-tools-2.0/man/en_US/route.8 2012-10-04 11:30:07.670188596 +0200
@@ -52,6 +52,11 @@ If]
.RB [ \-\-version ]
.RB [ \-h ]

View File

@ -1,7 +1,7 @@
diff -up net-tools-1.60/netstat.c.probe net-tools-1.60/netstat.c
--- net-tools-1.60/netstat.c.probe 2011-12-06 13:06:40.626378359 +0100
+++ net-tools-1.60/netstat.c 2011-12-06 13:06:40.650378062 +0100
@@ -1150,6 +1150,11 @@ static void tcp_do_one(int lnr, const ch
diff -up net-tools-2.0/netstat.c.probe net-tools-2.0/netstat.c
--- net-tools-2.0/netstat.c.probe 2012-10-04 11:36:15.085940621 +0200
+++ net-tools-2.0/netstat.c 2012-10-04 11:36:15.092940511 +0200
@@ -1267,6 +1267,11 @@ static void tcp_do_one(int lnr, const ch
(double) time_len / HZ, retr, timeout);
break;

View File

@ -1,6 +1,6 @@
diff -up net-tools-1.60/netstat.c.sctp net-tools-1.60/netstat.c
--- net-tools-1.60/netstat.c.sctp 2012-06-19 17:22:46.424153397 +0200
+++ net-tools-1.60/netstat.c 2012-06-19 17:30:32.395825888 +0200
diff -up net-tools-2.0/netstat.c.sctp net-tools-2.0/netstat.c
--- net-tools-2.0/netstat.c.sctp 2012-10-04 11:34:36.645522120 +0200
+++ net-tools-2.0/netstat.c 2012-10-04 11:34:36.655521958 +0200
@@ -114,7 +114,7 @@
#endif
@ -234,12 +234,6 @@ diff -up net-tools-1.60/netstat.c.sctp net-tools-1.60/netstat.c
- return;
- err:
- fprintf(stderr, "SCTP error in line: %d\n", lnr);
-}
-
-static int sctp_info_epts(void) {
- INFO_GUTS6(_PATH_PROCNET_SCTPEPTS, _PATH_PROCNET_SCTP6EPTS, "AF INET (sctp)",
- sctp_do_ept, "sctp", "sctp6");
-}
+ {
+ char local_addr[64];
+ ap = process_sctp_addr_str(this_local_addr, (struct sockaddr*)&localaddr);
@ -390,11 +384,14 @@ diff -up net-tools-1.60/netstat.c.sctp net-tools-1.60/netstat.c
+ this_remote_addr=strtok_r(0," \t\n",&ss2);
+ }
+ finish_this_one(uid,inode,"");
+}
+
}
-static int sctp_info_epts(void) {
+static int sctp_info_eps(void)
+{
+ INFO_GUTS6(_PATH_PROCNET_SCTPEPTS, _PATH_PROCNET_SCTP6EPTS, "AF INET (sctp)",
INFO_GUTS6(_PATH_PROCNET_SCTPEPTS, _PATH_PROCNET_SCTP6EPTS, "AF INET (sctp)",
- sctp_do_ept, "sctp", "sctp6");
-}
+ sctp_eps_do_one, "sctp", "sctp6");
+ }
@ -417,7 +414,7 @@ diff -up net-tools-1.60/netstat.c.sctp net-tools-1.60/netstat.c
}
static void addr_do_one(char *buf, size_t buf_len, size_t short_len, struct aftype *ap,
@@ -2235,7 +2338,7 @@ int main
@@ -2237,7 +2340,7 @@ int main
if (!strcmp(afname, "inet")) {
#if HAVE_AFINET
inittab();
@ -426,9 +423,9 @@ diff -up net-tools-1.60/netstat.c.sctp net-tools-1.60/netstat.c
#else
ENOSUPP("netstat", "AF INET");
#endif
diff -up net-tools-1.60/statistics.c.sctp net-tools-1.60/statistics.c
--- net-tools-1.60/statistics.c.sctp 2012-06-19 17:22:46.401153708 +0200
+++ net-tools-1.60/statistics.c 2012-06-19 17:22:46.432153287 +0200
diff -up net-tools-2.0/statistics.c.sctp net-tools-2.0/statistics.c
--- net-tools-2.0/statistics.c.sctp 2012-10-04 11:34:36.623522476 +0200
+++ net-tools-2.0/statistics.c 2012-10-04 11:34:36.655521958 +0200
@@ -21,7 +21,7 @@
#define UFWARN(x)
#endif

16
net-tools-statalias.patch Normal file
View File

@ -0,0 +1,16 @@
diff -up net-tools-2.0/lib/interface.c.statalias net-tools-2.0/lib/interface.c
--- net-tools-2.0/lib/interface.c.statalias 2012-10-04 11:33:05.490889090 +0200
+++ net-tools-2.0/lib/interface.c 2012-10-04 11:33:05.513888785 +0200
@@ -405,9 +405,11 @@ static int if_readlist_rep(char *target,
char *s, name[IFNAMSIZ];
s = get_name(name, buf);
get_dev_fields(s, ife);
- ife->statistics_valid = 1;
if (target && !strcmp(target,name))
+ {
+ ife->statistics_valid = 1;
break;
+ }
}
if (ferror(fh)) {
perror(_PATH_PROCNET_DEV);

View File

@ -0,0 +1,33 @@
From c14bac4f216c452d1e82cb73e4b53c2ccdd77987 Mon Sep 17 00:00:00 2001
From: Mike Frysinger <vapier@gentoo.org>
Date: Tue, 2 Oct 2012 22:19:58 -0400
Subject: [PATCH] version bump to 2.0
This is somewhat redundant as most distros are rolling snapshots
themselves, but maybe we should celebrate by throwing a 2.0 release
out there. It's been over 10 years since the last release after all.
Note: We'll need Bernd to actually run `make dist` and post the tarball
to sf.net.
Signed-off-by: Mike Frysinger <vapier@gentoo.org>
---
Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
index b2ea629..155e249 100644
--- a/Makefile
+++ b/Makefile
@@ -102,7 +102,7 @@ endif
# -------- end of user definitions --------
MAINTAINER = Philip.Blundell@pobox.com
-RELEASE = 1.60
+RELEASE = 2.0
.EXPORT_ALL_VARIABLES:
--
1.7.11.4

View File

@ -1,17 +1,17 @@
%global checkout 20120917git
%global checkout 20121004git
Summary: Basic networking tools
Name: net-tools
Version: 1.60
Release: 145.%{checkout}%{?dist}
Version: 2.0
Release: 0.1.%{checkout}%{?dist}
License: GPL+
Group: System Environment/Base
URL: http://net-tools.sourceforge.net
# git archive --format=tar --remote=git://net-tools.git.sourceforge.net/gitroot/net-tools/net-tools master | xz > net-tools-%%{version}.%%{checkout}.tar.xz
Source0: net-tools-%{version}.%{checkout}.tar.xz
Source1: net-tools-%{version}-config.h
Source2: net-tools-%{version}-config.make
Source1: net-tools-config.h
Source2: net-tools-config.make
Source3: ether-wake.c
Source4: ether-wake.8
Source5: mii-diag.c
@ -21,37 +21,41 @@ Source8: ipmaddr.8
Source9: arp-ethers.service
# adds <delay> option that allows netstat to cycle printing through statistics every delay seconds.
Patch1: net-tools-1.60-cycle.patch
Patch1: net-tools-cycle.patch
# Fixed incorrect address display for ipx (#46434)
Patch2: net-tools-1.60-ipx.patch
Patch2: net-tools-ipx.patch
# hostname lookup problems with route --inet6 (#84108)
Patch3: net-tools-1.60-inet6-lookup.patch
Patch3: net-tools-inet6-lookup.patch
# various man page fixes merged into one patch
Patch4: net-tools-1.60-man.patch
Patch4: net-tools-man.patch
# netstat: interface option now works as described in the man page (#61113, #115987)
Patch5: net-tools-1.60-interface.patch
Patch5: net-tools-interface.patch
# filter out duplicate tcp entries (#139407)
Patch6: net-tools-1.60-duplicate-tcp.patch
Patch6: net-tools-duplicate-tcp.patch
# don't report statistics for virtual devices (#143981)
Patch7: net-tools-1.60-statalias.patch
Patch7: net-tools-statalias.patch
# clear static buffers in interface.c by Ulrich Drepper (#176714)
Patch8: net-tools-1.60-interface_stack.patch
Patch8: net-tools-interface_stack.patch
# statistics for SCTP
Patch9: net-tools-1.60-sctp-statistics.patch
Patch9: net-tools-sctp-statistics.patch
# ifconfig crash when interface name is too long (#190703)
Patch10: net-tools-1.60-ifconfig-long-iface-crasher.patch
Patch10: net-tools-ifconfig-long-iface-crasher.patch
# fixed tcp timers info in netstat (#466845)
Patch11: net-tools-1.60-netstat-probe.patch
Patch11: net-tools-netstat-probe.patch
# the git snapshot we ship is actually much more a
# 2.0 pre-release then 1.60 post-release
Patch12: net-tools-version-bump-to-2.0.patch
BuildRequires: gettext, libselinux
BuildRequires: libselinux-devel
@ -76,6 +80,7 @@ Most of them are obsolete. For replacement check iproute package.
%patch9 -p1 -b .sctp
%patch10 -p1 -b .long_iface
%patch11 -p1 -b .probe
%patch12 -p1 -b .bump
cp %SOURCE1 ./config.h
cp %SOURCE2 ./config.make
@ -163,6 +168,10 @@ install -m 644 %{SOURCE9} %{buildroot}%{_unitdir}
%attr(0644,root,root) %{_unitdir}/arp-ethers.service
%changelog
* Thu Oct 04 2012 Jiri Popelka <jpopelka@redhat.com> - 2.0-0.1.20121004git
- the git snapshot we ship is actually much more a
2.0 pre-release then 1.60 post-release
* Mon Oct 01 2012 Jiri Popelka <jpopelka@redhat.com> - 1.60-145.20120917git
- compile without STRIP (Metricom radio) support

View File

@ -1 +1 @@
12cc7ebd0c9a941d090103da873fb1fd net-tools-1.60.20120917git.tar.xz
bf47e8d5a98ba4245cb87b7282fa636d net-tools-2.0.20121004git.tar.xz