latest snapshot (#1021109)
This commit is contained in:
parent
7fbe9cf7b6
commit
6d9777aae9
1
.gitignore
vendored
1
.gitignore
vendored
@ -15,3 +15,4 @@ net-tools-1.60.tar.bz2
|
||||
/net-tools-2.0.20130607git.tar.xz
|
||||
/net-tools-2.0.20130910git.tar.xz
|
||||
/net-tools-2.0.20131004git.tar.xz
|
||||
/net-tools-2.0.20131119git.tar.xz
|
||||
|
@ -1,78 +0,0 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 0574841..8d42f9d 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -26,6 +26,8 @@
|
||||
# set the base of the Installation
|
||||
# BASEDIR = /mnt
|
||||
BASEDIR ?= $(DESTDIR)
|
||||
+BINDIR ?= /bin
|
||||
+SBINDIR ?= /sbin
|
||||
|
||||
# path to the net-lib support library. Default: lib
|
||||
NET_LIB_PATH = lib
|
||||
@@ -199,39 +201,39 @@ installbin:
|
||||
@echo "Notice: ifconfig and route are now installed into /bin"
|
||||
@echo "######################################################"
|
||||
@echo
|
||||
- install -m 0755 -d ${BASEDIR}/sbin
|
||||
- install -m 0755 -d ${BASEDIR}/bin
|
||||
- install -m 0755 arp ${BASEDIR}/sbin
|
||||
- install -m 0755 hostname ${BASEDIR}/bin
|
||||
- install -m 0755 ifconfig ${BASEDIR}/bin
|
||||
- install -m 0755 nameif ${BASEDIR}/sbin
|
||||
- install -m 0755 netstat ${BASEDIR}/bin
|
||||
- install -m 0755 plipconfig $(BASEDIR)/sbin
|
||||
- install -m 0755 rarp ${BASEDIR}/sbin
|
||||
- install -m 0755 route ${BASEDIR}/bin
|
||||
- install -m 0755 slattach $(BASEDIR)/sbin
|
||||
+ install -m 0755 -d ${BASEDIR}${SBINDIR}
|
||||
+ install -m 0755 -d ${BASEDIR}${BINDIR}
|
||||
+ install -m 0755 arp ${BASEDIR}${SBINDIR}
|
||||
+ install -m 0755 hostname ${BASEDIR}${BINDIR}
|
||||
+ install -m 0755 ifconfig ${BASEDIR}${BINDIR}
|
||||
+ install -m 0755 nameif ${BASEDIR}${SBINDIR}
|
||||
+ install -m 0755 netstat ${BASEDIR}${BINDIR}
|
||||
+ install -m 0755 plipconfig $(BASEDIR)${SBINDIR}
|
||||
+ install -m 0755 rarp ${BASEDIR}${SBINDIR}
|
||||
+ install -m 0755 route ${BASEDIR}${BINDIR}
|
||||
+ install -m 0755 slattach $(BASEDIR)${SBINDIR}
|
||||
ifeq ($(HAVE_IP_TOOLS),1)
|
||||
- install -m 0755 ipmaddr $(BASEDIR)/sbin
|
||||
- install -m 0755 iptunnel $(BASEDIR)/sbin
|
||||
+ install -m 0755 ipmaddr $(BASEDIR)${SBINDIR}
|
||||
+ install -m 0755 iptunnel $(BASEDIR)${SBINDIR}
|
||||
endif
|
||||
ifeq ($(HAVE_MII),1)
|
||||
- install -m 0755 mii-tool $(BASEDIR)/sbin
|
||||
+ install -m 0755 mii-tool $(BASEDIR)${SBINDIR}
|
||||
endif
|
||||
- ln -fs hostname $(BASEDIR)/bin/dnsdomainname
|
||||
- ln -fs hostname $(BASEDIR)/bin/ypdomainname
|
||||
- ln -fs hostname $(BASEDIR)/bin/nisdomainname
|
||||
- ln -fs hostname $(BASEDIR)/bin/domainname
|
||||
+ ln -fs hostname $(BASEDIR)${BINDIR}/dnsdomainname
|
||||
+ ln -fs hostname $(BASEDIR)${BINDIR}/ypdomainname
|
||||
+ ln -fs hostname $(BASEDIR)${BINDIR}/nisdomainname
|
||||
+ ln -fs hostname $(BASEDIR)${BINDIR}/domainname
|
||||
ifeq ($(HAVE_AFDECnet),1)
|
||||
- ln -fs hostname $(BASEDIR)/bin/nodename
|
||||
+ ln -fs hostname $(BASEDIR)${BINDIR}/nodename
|
||||
endif
|
||||
|
||||
savebin:
|
||||
- @for i in ${BASEDIR}/sbin/arp ${BASEDIR}/sbin/ifconfig \
|
||||
- ${BASEDIR}/bin/netstat \
|
||||
- ${BASEDIR}/sbin/rarp ${BASEDIR}/sbin/route \
|
||||
- ${BASEDIR}/bin/hostname ${BASEDIR}/bin/ypdomainname \
|
||||
- ${BASEDIR}/bin/dnsdomainname ${BASEDIR}/bin/nisdomainname \
|
||||
- ${BASEDIR}/bin/domainname ; do \
|
||||
+ @for i in ${BASEDIR}${SBINDIR}/arp ${BASEDIR}${SBINDIR}/ifconfig \
|
||||
+ ${BASEDIR}${BINDIR}/netstat \
|
||||
+ ${BASEDIR}${SBINDIR}/rarp ${BASEDIR}${SBINDIR}/route \
|
||||
+ ${BASEDIR}${BINDIR}/hostname ${BASEDIR}${BINDIR}/ypdomainname \
|
||||
+ ${BASEDIR}${BINDIR}/dnsdomainname ${BASEDIR}${BINDIR}/nisdomainname \
|
||||
+ ${BASEDIR}${BINDIR}/domainname ; do \
|
||||
[ -f $$i ] && cp -f $$i $$i.old ; done ; echo Saved.
|
||||
|
||||
installdata:
|
@ -1,9 +1,9 @@
|
||||
%global checkout 20131004git
|
||||
%global checkout 20131119git
|
||||
|
||||
Summary: Basic networking tools
|
||||
Name: net-tools
|
||||
Version: 2.0
|
||||
Release: 0.16.%{checkout}%{?dist}
|
||||
Release: 0.17.%{checkout}%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
URL: http://sourceforge.net/projects/net-tools/
|
||||
@ -53,9 +53,6 @@ Patch10: net-tools-netstat-probe.patch
|
||||
# use all interfaces instead of default (#1003875)
|
||||
Patch20: ether-wake-interfaces.patch
|
||||
|
||||
# install binaries into /usr/bin and /usr/sbin (#1016674)
|
||||
Patch21: net-tools-install-to-usr-bin.patch
|
||||
|
||||
BuildRequires: gettext, libselinux
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: systemd-units
|
||||
@ -89,7 +86,6 @@ cp %SOURCE7 ./man/en_US
|
||||
cp %SOURCE8 ./man/en_US
|
||||
|
||||
%patch20 -p1 -b .interfaces
|
||||
%patch21 -p1 -b .usr_bin
|
||||
|
||||
touch ./config.h
|
||||
|
||||
@ -161,6 +157,9 @@ install -m 644 %{SOURCE9} %{buildroot}%{_unitdir}
|
||||
%attr(0644,root,root) %{_unitdir}/arp-ethers.service
|
||||
|
||||
%changelog
|
||||
* Tue Nov 19 2013 Jiri Popelka <jpopelka@redhat.com> - 2.0-0.17.20131119git
|
||||
- latest snapshot (#1021109)
|
||||
|
||||
* Fri Nov 01 2013 Jiri Popelka <jpopelka@redhat.com> - 2.0-0.16.20131004git
|
||||
- use different compiler/linker flags macros
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user