- don't report statistics for virtual devices (#143981) <kzak@redhat.com>

- fixing translation headers - content type format
- kill bitkeeper warning messages
This commit is contained in:
Radek Vokál 2005-01-10 13:13:19 +00:00
parent 287e357513
commit 3e6663adc0
4 changed files with 102 additions and 16 deletions

View File

@ -0,0 +1,17 @@
--- net-tools-1.60/netplug-1.2.7/Makefile.kill_bitkeeper 2005-01-10 11:36:32.000000000 +0100
+++ net-tools-1.60/netplug-1.2.7/Makefile 2005-01-10 11:38:01.796744224 +0100
@@ -24,10 +24,12 @@
install $(install_opts) -m 755 scripts/rc.netplugd $(initdir)/netplugd
install -C $(install_opts) -m 444 man/man8/netplugd.8 $(mandir)/man8
-bk_root := $(shell bk root)
+#bk_root := $(shell bk root)
+bk_root := $(shell)
tar_root := netplug-$(version)
tar_file := $(bk_root)/$(tar_root).tar.bz2
-files := $(shell bk sfiles -Ug)
+#files := $(shell bk sfiles -Ug)
+file := $(shell)
tarball: $(tar_file)

View File

@ -0,0 +1,33 @@
--- net-tools-1.60/po/de.po.isofix 2000-10-28 12:59:43.000000000 +0200
+++ net-tools-1.60/po/de.po 2005-01-10 11:29:29.407639208 +0100
@@ -9,7 +9,7 @@
"Last-Translator: Ralf Bächle <ralf@gnu.org>\n"
"Language-Team:\n"
"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=iso8859-1\n"
+"Content-Type: text/plain; charset=iso-8859-1\n"
"Content-Transfer-Encoding: 8bit\n"
#: ../arp.c:110 ../arp.c:269
--- net-tools-1.60/po/fr.po.isofix 2000-02-20 22:47:00.000000000 +0100
+++ net-tools-1.60/po/fr.po 2005-01-10 11:29:23.613520048 +0100
@@ -9,7 +9,7 @@
"Last-Translator: J.M.Vansteene <vanstee@worldnet.fr>\n"
"Language-Team:\n"
"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=iso8859-1\n"
+"Content-Type: text/plain; charset=iso-8859-1\n"
"Content-Transfer-Encoding: 8bit\n"
#: ../arp.c:110 ../arp.c:269
--- net-tools-1.60/po/pt_BR.po.isofix 2000-02-20 22:47:06.000000000 +0100
+++ net-tools-1.60/po/pt_BR.po 2005-01-10 11:29:16.294632688 +0100
@@ -14,7 +14,7 @@
"PO-Revision-Date: 1999-03-01 02:38+0100\n"
"Last-Translator: Arnaldo Carvalho de Melo <acme@conectiva.com.br>\n"
"MIME-Version: 1.0\n"
-"Content-Type: text/plain; charset=ISO8859-9\n"
+"Content-Type: text/plain; charset=iso-8859-9\n"
"Content-Transfer-Encoding: 8bit\n"
#: ../arp.c:110 ../arp.c:269

View File

@ -0,0 +1,15 @@
--- net-tools-1.60/lib/interface.c.statalias 2005-01-07 12:49:14.084104032 +0100
+++ net-tools-1.60/lib/interface.c 2005-01-07 12:49:38.527388088 +0100
@@ -395,9 +395,11 @@
char *s, name[IFNAMSIZ];
s = get_name(name, buf);
get_dev_fields(s, ife);
- ife->statistics_valid = 1;
if (target && !strcmp(target,name))
+ {
+ ife->statistics_valid = 1;
break;
+ }
}
if (ferror(fh)) {
perror(_PATH_PROCNET_DEV);

View File

@ -3,7 +3,7 @@
Summary: Basic networking tools. Summary: Basic networking tools.
Name: net-tools Name: net-tools
Version: 1.60 Version: 1.60
Release: 42 Release: 43
License: GPL License: GPL
Group: System Environment/Base Group: System Environment/Base
Source0: http://www.tazenda.demon.co.uk/phil/net-tools/net-tools-%{version}.tar.bz2 Source0: http://www.tazenda.demon.co.uk/phil/net-tools/net-tools-%{version}.tar.bz2
@ -41,6 +41,9 @@ Patch27: net-tools-1.60-netstat_ulong.patch
Patch28: net-tools-1.60-note.patch Patch28: net-tools-1.60-note.patch
Patch29: net-tools-1.60-num-ports.patch Patch29: net-tools-1.60-num-ports.patch
Patch30: net-tools-1.60-duplicate-tcp.patch Patch30: net-tools-1.60-duplicate-tcp.patch
Patch31: net-tools-1.60-statalias.patch
Patch32: net-tools-1.60-isofix.patch
Patch33: net-tools-1.60-bitkeeper.patch
BuildRoot: %{_tmppath}/%{name}-root BuildRoot: %{_tmppath}/%{name}-root
Requires(post,preun): chkconfig Requires(post,preun): chkconfig
BuildRequires: gettext BuildRequires: gettext
@ -81,6 +84,9 @@ ifconfig, netstat, route, and others.
%patch28 -p1 -b .note %patch28 -p1 -b .note
%patch29 -p1 -b .num-ports %patch29 -p1 -b .num-ports
%patch30 -p1 -b .dup-tcp %patch30 -p1 -b .dup-tcp
%patch31 -p1 -b .statalias
%patch32 -p1 -b .isofix
%patch33 -p1 -b .bitkeeper
cp %SOURCE2 ./config.h cp %SOURCE2 ./config.h
cp %SOURCE3 ./config.make cp %SOURCE3 ./config.make
@ -92,22 +98,32 @@ perl -pi -e "s|-O2||" Makefile
#man pages conversion #man pages conversion
#french #french
iconv -f iso8859-1 -t utf-8 -o arp.tmp man/fr_FR/arp.8 && mv arp.tmp man/fr_FR/arp.8 iconv -f iso-8859-1 -t utf-8 -o arp.tmp man/fr_FR/arp.8 && mv arp.tmp man/fr_FR/arp.8
iconv -f iso8859-1 -t utf-8 -o ethers.tmp man/fr_FR/ethers.5 && mv ethers.tmp man/fr_FR/ethers.5 iconv -f iso-8859-1 -t utf-8 -o ethers.tmp man/fr_FR/ethers.5 && mv ethers.tmp man/fr_FR/ethers.5
iconv -f iso8859-1 -t utf-8 -o hostname.tmp man/fr_FR/hostname.1 && mv hostname.tmp man/fr_FR/hostname.1 iconv -f iso-8859-1 -t utf-8 -o hostname.tmp man/fr_FR/hostname.1 && mv hostname.tmp man/fr_FR/hostname.1
iconv -f iso8859-1 -t utf-8 -o ifconfig.tmp man/fr_FR/ifconfig.8 && mv ifconfig.tmp man/fr_FR/ifconfig.8 iconv -f iso-8859-1 -t utf-8 -o ifconfig.tmp man/fr_FR/ifconfig.8 && mv ifconfig.tmp man/fr_FR/ifconfig.8
iconv -f iso8859-1 -t utf-8 -o netstat.tmp man/fr_FR/netstat.8 && mv netstat.tmp man/fr_FR/netstat.8 iconv -f iso-8859-1 -t utf-8 -o netstat.tmp man/fr_FR/netstat.8 && mv netstat.tmp man/fr_FR/netstat.8
iconv -f iso8859-1 -t utf-8 -o plipconfig.tmp man/fr_FR/plipconfig.8 && mv plipconfig.tmp man/fr_FR/plipconfig.8 iconv -f iso-8859-1 -t utf-8 -o plipconfig.tmp man/fr_FR/plipconfig.8 && mv plipconfig.tmp man/fr_FR/plipconfig.8
iconv -f iso8859-1 -t utf-8 -o rarp.tmp man/fr_FR/rarp.8 && mv rarp.tmp man/fr_FR/rarp.8 iconv -f iso-8859-1 -t utf-8 -o rarp.tmp man/fr_FR/rarp.8 && mv rarp.tmp man/fr_FR/rarp.8
iconv -f iso8859-1 -t utf-8 -o route.tmp man/fr_FR/route.8 && mv route.tmp man/fr_FR/route.8 iconv -f iso-8859-1 -t utf-8 -o route.tmp man/fr_FR/route.8 && mv route.tmp man/fr_FR/route.8
iconv -f iso8859-1 -t utf-8 -o slattach.tmp man/fr_FR/slattach.8 && mv slattach.tmp man/fr_FR/slattach.8 iconv -f iso-8859-1 -t utf-8 -o slattach.tmp man/fr_FR/slattach.8 && mv slattach.tmp man/fr_FR/slattach.8
#portugal #portugal
iconv -f iso8859-1 -t utf-8 -o arp.tmp man/pt_BR/arp.8 && mv arp.tmp man/pt_BR/arp.8 iconv -f iso-8859-1 -t utf-8 -o arp.tmp man/pt_BR/arp.8 && mv arp.tmp man/pt_BR/arp.8
iconv -f iso8859-1 -t utf-8 -o hostname.tmp man/pt_BR/hostname.1 && mv hostname.tmp man/pt_BR/hostname.1 iconv -f iso-8859-1 -t utf-8 -o hostname.tmp man/pt_BR/hostname.1 && mv hostname.tmp man/pt_BR/hostname.1
iconv -f iso8859-1 -t utf-8 -o ifconfig.tmp man/pt_BR/ifconfig.8 && mv ifconfig.tmp man/pt_BR/ifconfig.8 iconv -f iso-8859-1 -t utf-8 -o ifconfig.tmp man/pt_BR/ifconfig.8 && mv ifconfig.tmp man/pt_BR/ifconfig.8
iconv -f iso8859-1 -t utf-8 -o netstat.tmp man/pt_BR/netstat.8 && mv netstat.tmp man/pt_BR/netstat.8 iconv -f iso-8859-1 -t utf-8 -o netstat.tmp man/pt_BR/netstat.8 && mv netstat.tmp man/pt_BR/netstat.8
iconv -f iso8859-1 -t utf-8 -o rarp.tmp man/pt_BR/rarp.8 && mv rarp.tmp man/pt_BR/rarp.8 iconv -f iso-8859-1 -t utf-8 -o rarp.tmp man/pt_BR/rarp.8 && mv rarp.tmp man/pt_BR/rarp.8
iconv -f iso8859-1 -t utf-8 -o route.tmp man/pt_BR/route.8 && mv route.tmp man/pt_BR/route.8 iconv -f iso-8859-1 -t utf-8 -o route.tmp man/pt_BR/route.8 && mv route.tmp man/pt_BR/route.8
#german
iconv -f iso-8859-1 -t utf-8 -o arp.tmp man/de_DE/arp.8 && mv arp.tmp man/fr_FR/arp.8
iconv -f iso-8859-1 -t utf-8 -o ethers.tmp man/de_DE/ethers.5 && mv ethers.tmp man/fr_FR/ethers.5
iconv -f iso-8859-1 -t utf-8 -o hostname.tmp man/de_DE/hostname.1 && mv hostname.tmp man/fr_FR/hostname.1
iconv -f iso-8859-1 -t utf-8 -o ifconfig.tmp man/de_DE/ifconfig.8 && mv ifconfig.tmp man/fr_FR/ifconfig.8
iconv -f iso-8859-1 -t utf-8 -o netstat.tmp man/de_DE/netstat.8 && mv netstat.tmp man/fr_FR/netstat.8
iconv -f iso-8859-1 -t utf-8 -o plipconfig.tmp man/de_DE/plipconfig.8 && mv plipconfig.tmp man/fr_FR/plipconfig.8
iconv -f iso-8859-1 -t utf-8 -o rarp.tmp man/de_DE/rarp.8 && mv rarp.tmp man/fr_FR/rarp.8
iconv -f iso-8859-1 -t utf-8 -o route.tmp man/de_DE/route.8 && mv route.tmp man/fr_FR/route.8
iconv -f iso-8859-1 -t utf-8 -o slattach.tmp man/de_DE/slattach.8 && mv slattach.tmp man/fr_FR/slattach.8
%build %build
make make
@ -172,6 +188,11 @@ exit 0
%{_sysconfdir}/rc.d/init.d/netplugd %{_sysconfdir}/rc.d/init.d/netplugd
%changelog %changelog
* Mon Jan 10 2005 Radek Vokal <rvokal@redhat.com> 1.60-43
- don't report statistics for virtual devices (#143981) <kzak@redhat.com>
- fixing translation headers - content type format
- kill bitkeeper warning messages
* Fri Dec 03 2004 Radek Vokal <rvokal@redhat.com> 1.60-42 * Fri Dec 03 2004 Radek Vokal <rvokal@redhat.com> 1.60-42
- filter out duplicate tcp entries (#139407) - filter out duplicate tcp entries (#139407)