2c91dc1bcd
This includes support for the CXL commands, and adds the following packages: cxl-cli, cxl-devel, cxl-libs. Resolves: rhbz#2132167
148 lines
4.6 KiB
Diff
148 lines
4.6 KiB
Diff
From 57b1484fa427228afd52cdfa4fa3916a7a5878bf Mon Sep 17 00:00:00 2001
|
|
From: Ira Weiny <ira.weiny@intel.com>
|
|
Date: Thu, 7 Oct 2021 02:21:37 -0600
|
|
Subject: [PATCH 044/217] ndctl: Add CXL packages to the RPM spec
|
|
|
|
Add CXL related packages - the cxl-cli utility, the libcxl library, and
|
|
development headers to respective RPM packages in the main spec file.
|
|
|
|
Reviewed-by: Dan Williams <dan.j.williams@intel.com>
|
|
Signed-off-by: Ira Weiny <ira.weiny@intel.com>
|
|
Signed-off-by: Vishal Verma <vishal.l.verma@intel.com>
|
|
---
|
|
Makefile.am | 4 ++++
|
|
ndctl.spec.in | 49 +++++++++++++++++++++++++++++++++++++++++++++++++
|
|
2 files changed, 53 insertions(+)
|
|
|
|
diff --git a/Makefile.am b/Makefile.am
|
|
index e2f6bef..fa2010a 100644
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -23,17 +23,21 @@ CLEANFILES += $(noinst_SCRIPTS)
|
|
|
|
do_rhel_subst = sed -e 's,VERSION,$(VERSION),g' \
|
|
-e 's,DAX_DNAME,daxctl-devel,g' \
|
|
+ -e 's,CXL_DNAME,cxl-devel,g' \
|
|
-e 's,DNAME,ndctl-devel,g' \
|
|
-e '/^%defattr.*/d' \
|
|
-e 's,DAX_LNAME,daxctl-libs,g' \
|
|
+ -e 's,CXL_LNAME,cxl-libs,g' \
|
|
-e 's,LNAME,ndctl-libs,g'
|
|
|
|
do_sles_subst = sed -e 's,VERSION,$(VERSION),g' \
|
|
-e 's,DAX_DNAME,libdaxctl-devel,g' \
|
|
+ -e 's,CXL_DNAME,libcxl-devel,g' \
|
|
-e 's,DNAME,libndctl-devel,g' \
|
|
-e 's,%license,%doc,g' \
|
|
-e 's,\(^License:.*GPL\)v2,\1-2.0,g' \
|
|
-e "s,DAX_LNAME,libdaxctl$$(($(LIBDAXCTL_CURRENT) - $(LIBDAXCTL_AGE))),g" \
|
|
+ -e "s,CXL_LNAME,libcxl$$(($(LIBCXL_CURRENT) - $(LIBCXL_AGE))),g" \
|
|
-e "s,LNAME,libndctl$$(($(LIBNDCTL_CURRENT) - $(LIBNDCTL_AGE))),g"
|
|
|
|
rhel/ndctl.spec: ndctl.spec.in Makefile.am version.m4
|
|
diff --git a/ndctl.spec.in b/ndctl.spec.in
|
|
index 0563b2d..4b08c05 100644
|
|
--- a/ndctl.spec.in
|
|
+++ b/ndctl.spec.in
|
|
@@ -8,6 +8,7 @@ Source0: https://github.com/pmem/%{name}/archive/v%{version}.tar.gz#/%{name}-%{v
|
|
|
|
Requires: LNAME%{?_isa} = %{version}-%{release}
|
|
Requires: DAX_LNAME%{?_isa} = %{version}-%{release}
|
|
+Requires: CXL_LNAME%{?_isa} = %{version}-%{release}
|
|
BuildRequires: autoconf
|
|
%if 0%{?rhel} < 9
|
|
BuildRequires: asciidoc
|
|
@@ -54,6 +55,24 @@ the Linux kernel Device-DAX facility. This facility enables DAX mappings
|
|
of performance / feature differentiated memory without need of a
|
|
filesystem.
|
|
|
|
+%package -n cxl-cli
|
|
+Summary: Manage CXL devices
|
|
+License: GPLv2
|
|
+Requires: CXL_LNAME%{?_isa} = %{version}-%{release}
|
|
+
|
|
+%description -n cxl-cli
|
|
+The cxl utility provides enumeration and provisioning commands for
|
|
+the Linux kernel CXL devices.
|
|
+
|
|
+%package -n CXL_DNAME
|
|
+Summary: Development files for libcxl
|
|
+License: LGPLv2
|
|
+Requires: CXL_LNAME%{?_isa} = %{version}-%{release}
|
|
+
|
|
+%description -n CXL_DNAME
|
|
+This package contains libraries and header files for developing applications
|
|
+that use libcxl, a library for enumerating and communicating with CXL devices.
|
|
+
|
|
%package -n DAX_DNAME
|
|
Summary: Development files for libdaxctl
|
|
License: LGPLv2
|
|
@@ -84,6 +103,13 @@ Device DAX is a facility for establishing DAX mappings of performance /
|
|
feature-differentiated memory. DAX_LNAME provides an enumeration /
|
|
control API for these devices.
|
|
|
|
+%package -n CXL_LNAME
|
|
+Summary: Management library for CXL devices
|
|
+License: LGPLv2
|
|
+
|
|
+%description -n CXL_LNAME
|
|
+libcxl is a library for enumerating and communicating with CXL devices.
|
|
+
|
|
|
|
%prep
|
|
%setup -q ndctl-%{version}
|
|
@@ -105,6 +131,8 @@ make check
|
|
|
|
%ldconfig_scriptlets -n DAX_LNAME
|
|
|
|
+%ldconfig_scriptlets -n CXL_LNAME
|
|
+
|
|
%define bashcompdir %(pkg-config --variable=completionsdir bash-completion)
|
|
|
|
%files
|
|
@@ -126,6 +154,12 @@ make check
|
|
%{_mandir}/man1/daxctl*
|
|
%{_datadir}/daxctl/daxctl.conf
|
|
|
|
+%files -n cxl-cli
|
|
+%defattr(-,root,root)
|
|
+%license LICENSES/preferred/GPL-2.0 LICENSES/other/MIT LICENSES/other/CC0-1.0
|
|
+%{_bindir}/cxl
|
|
+%{_mandir}/man1/cxl*
|
|
+
|
|
%files -n LNAME
|
|
%defattr(-,root,root)
|
|
%doc README.md
|
|
@@ -138,6 +172,12 @@ make check
|
|
%license LICENSES/preferred/LGPL-2.1 LICENSES/other/MIT LICENSES/other/CC0-1.0
|
|
%{_libdir}/libdaxctl.so.*
|
|
|
|
+%files -n CXL_LNAME
|
|
+%defattr(-,root,root)
|
|
+%doc README.md
|
|
+%license LICENSES/preferred/LGPL-2.1 LICENSES/other/MIT LICENSES/other/CC0-1.0
|
|
+%{_libdir}/libcxl.so.*
|
|
+
|
|
%files -n DNAME
|
|
%defattr(-,root,root)
|
|
%license LICENSES/preferred/LGPL-2.1
|
|
@@ -152,6 +192,15 @@ make check
|
|
%{_libdir}/libdaxctl.so
|
|
%{_libdir}/pkgconfig/libdaxctl.pc
|
|
|
|
+%files -n CXL_DNAME
|
|
+%defattr(-,root,root)
|
|
+%license LICENSES/preferred/LGPL-2.1
|
|
+%{_includedir}/cxl/
|
|
+%{_libdir}/libcxl.so
|
|
+%{_libdir}/pkgconfig/libcxl.pc
|
|
+%{_mandir}/man3/cxl*
|
|
+%{_mandir}/man3/libcxl.3.gz
|
|
+
|
|
|
|
%changelog
|
|
* Fri May 27 2016 Dan Williams <dan.j.williams@intel.com> - 53-1
|
|
--
|
|
2.27.0
|
|
|