- update to patch 20100116
- don't require -ltinfo when linking with --no-add-needed
This commit is contained in:
parent
7e522ec5a6
commit
fcf8ecd167
@ -1,2 +1,3 @@
|
||||
ncurses-5.7.tar.gz
|
||||
ncurses-5.7-20081115-20090207.patch.bz2
|
||||
ncurses-5.7-20091107-patch.sh.bz2
|
||||
ncurses-5.7-20091114-20100116.patch.bz2
|
||||
|
@ -1,6 +1,6 @@
|
||||
diff -up ncurses-5.7/misc/ncurses-config.in.config ncurses-5.7/misc/ncurses-config.in
|
||||
--- ncurses-5.7/misc/ncurses-config.in.config 2009-01-23 13:44:17.000000000 +0100
|
||||
+++ ncurses-5.7/misc/ncurses-config.in 2009-01-23 14:00:38.000000000 +0100
|
||||
--- ncurses-5.7/misc/ncurses-config.in.config 2010-01-18 14:35:20.000000000 +0100
|
||||
+++ ncurses-5.7/misc/ncurses-config.in 2010-01-18 14:37:01.000000000 +0100
|
||||
@@ -35,7 +35,6 @@ exec_prefix="@exec_prefix@"
|
||||
|
||||
bindir="@bindir@"
|
||||
@ -9,16 +9,21 @@ diff -up ncurses-5.7/misc/ncurses-config.in.config ncurses-5.7/misc/ncurses-conf
|
||||
datadir="@datadir@"
|
||||
mandir="@mandir@"
|
||||
|
||||
@@ -83,7 +82,7 @@ ENDECHO
|
||||
;;
|
||||
@@ -85,11 +84,11 @@ ENDECHO
|
||||
--libs)
|
||||
if test @TINFO_NAME@ = @LIB_NAME@ ; then
|
||||
sed -e 's,^[ ]*,,' -e 's, [ ]*, ,g' -e 's,[ ]*$,,' <<-ENDECHO
|
||||
- -L$libdir @EXTRA_LDFLAGS@ -l${THIS} @LIBS@
|
||||
+ @EXTRA_LDFLAGS@ -l${THIS} @LIBS@
|
||||
ENDECHO
|
||||
else
|
||||
sed -e 's,^[ ]*,,' -e 's, [ ]*, ,g' -e 's,[ ]*$,,' <<-ENDECHO
|
||||
- -L$libdir @EXTRA_LDFLAGS@ -l${THIS} -l${TINFO_LIB} @LIBS@
|
||||
+ @EXTRA_LDFLAGS@ -l${THIS} -l${TINFO_LIB} @LIBS@
|
||||
ENDECHO
|
||||
fi
|
||||
;;
|
||||
# identification
|
||||
@@ -107,7 +106,6 @@ ENDECHO
|
||||
@@ -114,7 +113,6 @@ ENDECHO
|
||||
echo "${includedir}"
|
||||
;;
|
||||
--libdir)
|
23
ncurses.spec
23
ncurses.spec
@ -1,15 +1,16 @@
|
||||
Summary: Ncurses support utilities
|
||||
Name: ncurses
|
||||
Version: 5.7
|
||||
Release: 3.20090207%{?dist}
|
||||
Release: 4.20100116%{?dist}
|
||||
License: MIT
|
||||
Group: System Environment/Base
|
||||
URL: http://invisible-island.net/ncurses/ncurses.html
|
||||
Source0: ftp://invisible-island.net/ncurses/ncurses-%{version}.tar.gz
|
||||
|
||||
Patch1: ncurses-5.7-20081115-20090207.patch.bz2
|
||||
Patch1: ncurses-5.7-20091107-patch.sh.bz2
|
||||
Patch2: ncurses-5.7-20091114-20100116.patch.bz2
|
||||
|
||||
Patch8: ncurses-5.7-20090124-config.patch
|
||||
Patch8: ncurses-5.7-20100116-config.patch
|
||||
Patch9: ncurses-5.6-20070612-libs.patch
|
||||
Patch11: ncurses-5.6-20080112-urxvt.patch
|
||||
Patch12: ncurses-5.6-20080628-kbs.patch
|
||||
@ -90,6 +91,7 @@ The ncurses-static package includes static libraries of the ncurses library.
|
||||
%setup -q
|
||||
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
|
||||
%patch8 -p1 -b .config
|
||||
%patch9 -p1 -b .libs
|
||||
@ -173,10 +175,10 @@ done
|
||||
|
||||
# prepare -base and -term file lists
|
||||
for termname in \
|
||||
Eterm\* aterm cons25 cygwin eterm\* gnome gnome-256color hurd jfbterm \
|
||||
Eterm\* aterm bterm cons25 cygwin eterm\* gnome gnome-256color hurd jfbterm \
|
||||
konsole konsole-256color mach\* mlterm mrxvt nsterm putty\* pcansi \
|
||||
rxvt rxvt-\* screen screen-\* screen.\* sun teraterm teraterm2.3 \
|
||||
wsvt25\* xfce xterm xterm-\*
|
||||
vwmterm wsvt25\* xfce xterm xterm-\*
|
||||
do
|
||||
for i in $RPM_BUILD_ROOT%{_datadir}/terminfo/?/$termname; do
|
||||
for t in $(find $RPM_BUILD_ROOT%{_datadir}/terminfo -samefile $i); do
|
||||
@ -202,6 +204,13 @@ for l in $RPM_BUILD_ROOT%{_includedir}/*.h; do
|
||||
ln -s ../$(basename $l) $RPM_BUILD_ROOT%{_includedir}/ncursesw
|
||||
done
|
||||
|
||||
# don't require -ltinfo when linking with --no-add-needed
|
||||
for l in $RPM_BUILD_ROOT%{_libdir}/libncurses{,w}.so; do
|
||||
soname=$(basename $(readlink $l))
|
||||
rm -f $l
|
||||
echo "INPUT(AS_NEEDED($soname -ltinfo))" > $l
|
||||
done
|
||||
|
||||
rm -f $RPM_BUILD_ROOT%{_libdir}/libcurses{,w}.so
|
||||
echo "INPUT(-lncurses)" > $RPM_BUILD_ROOT%{_libdir}/libcurses.so
|
||||
echo "INPUT(-lncursesw)" > $RPM_BUILD_ROOT%{_libdir}/libcursesw.so
|
||||
@ -265,6 +274,10 @@ bzip2 NEWS
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%changelog
|
||||
* Mon Jan 18 2010 Miroslav Lichvar <mlichvar@redhat.com> 5.7-4.20100116
|
||||
- update to patch 20100116
|
||||
- don't require -ltinfo when linking with --no-add-needed
|
||||
|
||||
* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.7-3.20090207
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user